丰儿 / 股票 / 通达信 江恩24节气图 - 指标公式

分享

   

通达信 江恩24节气图 - 指标公式

2009-03-12  丰儿
FZ24节气
a:=LSOLARTERM(date);
DRAWTEXT(a=1,high*1.02,'●小寒'),colorblue;
DRAWTEXT(a=2,high*1.02,'●大寒'),colorblue;
DRAWTEXT(a=3,high*1.02,'●立春'),colorblue;
DRAWTEXT(a=4,high*1.02,'●雨水'),colorblue;
DRAWTEXT(a=5,high*1.02,'●惊蛰'),colorblue;
DRAWTEXT(a=6,high*1.02,'●春分'),colorblue;
DRAWTEXT(a=7,high*1.02,'●清明'),colorblue;
DRAWTEXT(a=8,high*1.02,'●谷雨'),colorblue;
DRAWTEXT(a=9,high*1.02,'●立夏'),colorblue;
DRAWTEXT(a=10,high*1.02,'●小满'),colorblue;
DRAWTEXT(a=11,high*1.02,'●芒种'),colorblue;
DRAWTEXT(a=12,high*1.02,'●夏至'),colorblue;
DRAWTEXT(a=13,high*1.02,'●小暑'),colorblue;
DRAWTEXT(a=14,high*1.02,'●大暑'),colorblue;
DRAWTEXT(a=15,high*1.02,'●立秋'),colorblue;
DRAWTEXT(a=16,high*1.02,'●处暑'),colorblue;
DRAWTEXT(a=17,high*1.02,'●白露'),colorblue;
DRAWTEXT(a=18,high*1.02,'●秋分'),colorblue;
DRAWTEXT(a=19,high*1.02,'●寒露'),colorblue;
DRAWTEXT(a=20,high*1.02,'●霜降'),colorblue;
DRAWTEXT(a=21,high*1.02,'●立冬'),colorblue;
DRAWTEXT(a=22,high*1.02,'●小雪'),colorblue;
DRAWTEXT(a=23,high*1.02,'●大雪'),colorblue;
DRAWTEXT(a=24,high*1.02,'●冬至'),colorblue;
ma5:ma(c,5);
ma10:ma(c,10);
ma20:ma(c,20);
ma30:ma(c,30);
ma60:ma(c,60);
ma120:ma(c,120);
ma250:ma(c,250);
DRAWYITEXT(a=1 or a=2 or a=3 or a=4 or a=5 or a=6 or a=7 or
a=8 or a=9 or a=10 or a=11 or a=12 or a=13 or a=14 or a=15 or
a=16 or a=17 or a=18 or a=19 or a=20 or a=21 or a=22 or a=23 or
a=24,high*1.04,kgua(1, 1),1),colorred;{显示正K象卦名};
DRAWYITEXT(a=1 or a=2 or a=3 or a=4 or a=5 or a=6 or a=7 or
a=8 or a=9 or a=10 or a=11 or a=12 or a=13 or a=14 or a=15 or
a=16 or a=17 or a=18 or a=19 or a=20 or a=21 or a=22 or a=23 or
a=24,low*0.98,99-kgua(1, 1),1),colorblue;{显示反K象卦名};
STICKLINE(open>=close ,close ,open,9,0 ),COLORaaaaaa;
STICKLINE(open>=close ,close ,open,6,0 ),COLORbbbbbb;
STICKLINE(open>=close ,close ,open,2.4,0 ),COLORcccccc;
STICKLINE(open>=close ,close ,open,1.1,0 ),COLORdddddd;
STICKLINE(close>open,close,open,9,0 ),COLOr6666cc;
STICKLINE(close>open,close,open,6 ,0 ),COLOR7777dd;
STICKLINE(close>open,close,open,2.4 ,0 ),COLOR8888ee;
STICKLINE(close>open,close,open,1.1 ,0 ),COLOR9999ff;
STICKLINE(close>open,open,low,0.5,0 ),COLOR1199ff;
STICKLINE(close>open,close,HIGH,0.5 ,0 ),COLOR1199ff;
STICKLINE(open>=close,close,low,0.5 ,0 ),COLORcccccc;
STICKLINE(open>=close,open,HIGH,0.5 ,0 ),COLORcccccc;
FZKDJ指示
RSV:=(CLOSE-LLV(LOW, 27))/(HHV(HIGH, 27)-LLV(LOW, 27))*100;
K1:=SMA(RSV,9, 1);
D1:=SMA(K1, 5, 1);
J1:=3*K1-2*D1;
RSV1:=(CLOSE-LLV(LOW, 27))/(HHV(HIGH, 27)-LLV(LOW, 27))*100;
K:=SMA(RSV1,9, 1);
D:=SMA(K,5, 1);
J:=3*K-2*D;
低位提示:CROSS(K,D)*60,COLORRED;
A1:=REF(CLOSE, 1);
A2:=IF(CROSS(J1, J) AND J<13, -1, 0)+IF(CROSS(J, J1) AND J>105, 1, 0);
A3:=(HIGH+LOW+CLOSE)/3;
A4:=(A3-MA(A3, 15))/(0.015*AVEDEV(A3, 12))/2;
A5:=SMA(MAX(CLOSE-A1, 0), 6, 1)/SMA(ABS(CLOSE-A1), 6, 1)*100;
A6:=LLV(LOW, 35);
A7:=HHV(HIGH, 35);
A8:=EMA((CLOSE-A6)/(A7-A6)*100, 9);
A9:=IF(A4>100 AND A8>50 AND CLOSE>OPEN, 0.5, 0)+IF(A5>95 AND A8>50 AND CLOSE>OPEN, 0.5, 0);
A10:=(CLOSE-LLV(LOW, 27))/(HHV(HIGH, 27)-LLV(LOW, 27))*100;
K2:=SMA(A10, 27, 1);
D2:=SMA(K2, 9, 1);
J2:=3*K2-2*D2;
A12:=IF(J2>95 AND A5>95, 0.5, 0);
高位提示:IF(A2+A9+A12>0, 61.80, 0),COLORYELLOW;
FZK-KDJ
nn=20   n=2
{nn=20;n=2;}
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV12:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=3*K12-2*D12;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
支撑位:IF(CROSS(j,j24),L,REF(L,BARSLAST(CROSS(j,j24)))),COLORYELLOW,,LINETHICK2;
压力位:IF(CROSS(j24,j),H,REF(H,BARSLAST(CROSS(j24,j)))),COLORred,LINETHICK2;
U2L:=IF(C>=MA(C,NN),80,50);
L2L:=IF(C>=MA(C,NN),50,20);
RH1:=IF(j< U2L AND REF(j,1)>=U2L,HHV(REF(H,1),BARSLAST(j>=U2L AND REF(j,1)< U2L)-1),
       REF(HHV(REF(H,1),BARSLAST(j>=U2L AND REF(j,1)< U2L)-1),BARSLAST(j< U2L AND REF(j,1))));
RH4:=IF(H>RH1,L,REF(L,BARSLAST(H>RH1)));
RH42:=IF(H>RH1,j,REF(j,BARSLAST(H>RH1)));
RH5:IF(H>RH4 AND j< RH42 AND j< j24,H,REF(H,BARSLAST(H>RH4 AND j< RH42 AND j< j24))),COLORgreen;
RL1:=IF(j>L2L AND REF(j,1)<=L2L,LLV(REF(L,1),BARSLAST(j<=L2L AND REF(j,1)>L2L)-1),
       REF(LLV(REF(L,1),BARSLAST(j<=L2L AND REF(j,1)>L2L)-1),BARSLAST(j>L2L AND REF(j,1))));
RL4:=IF(L< RL1,H,REF(H,BARSLAST(L< RL1)));
RL42:=IF(L< RL1,j,REF(j,BARSLAST(L< RL1)));
RL5:IF(L< RL4 AND j>RL42 AND j>j24,L,REF(L,BARSLAST(L< RL4 AND j>RL42 AND j>j24))),COLORMAGENTA;
cb:=amount/v/100;
cd:=cb>h or cb< l;
STICKLINE(cd<1,cb-0.002,cb+0.002,8,1),COLORYELLOW;
导航:ma(c,3);
FZK-RSI
nn=20   n=6
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7,0);
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,4,0);
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,2,0);
STICKLINE(CLOSE>=OPEN,HIGH,LOW,0,0);
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,7,0);
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,4,0);
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,2,0);
STICKLINE(CLOSE<=OPEN,HIGH,LOW,0,0);
Var1:=REF(CLOSE,1);
MA20: MA(CLOSE,NN);
Var2:=MA(CLOSE,5);
Var3:=SMA(MAX(CLOSE-Var1,0),N,1)/SMA(ABS(CLOSE-Var1),N,1)*100;
Var4:=SMA(MAX(CLOSE-Var1,0),12,1)/SMA(ABS(CLOSE-Var1),12,1)*100;
Var5:=SMA(MAX(CLOSE-Var1,0),24,1)/SMA(ABS(CLOSE-Var1),24,1)*100;
Var6:=IF(CROSS(Var3,Var5),LOW,REF(LOW,BARSLAST(CROSS(Var3,Var5))));
Var7:=IF(CROSS(Var5,Var3),HIGH,REF(HIGH,BARSLAST(CROSS(Var5,Var3))));
Var8:=IF(CLOSE>=MA(CLOSE,NN),80,50);
Var9:=IF(CLOSE>=MA(CLOSE,NN),50,20);
VarA:=IF(Var3<Var8 AND REF(Var3,1)>=Var8,HHV(REF(HIGH,1),BARSLAST(Var3>=Var8 AND REF(Var3,1)<Var8)-1),REF(HHV(REF(HIGH,1),BARSLAST(Var3>=Var8 AND REF(Var3,1)<Var8)-1),BARSLAST(Var3<Var8 AND REF(Var3,1))));
VarB:=IF(HIGH>VarA,LOW,REF(LOW,BARSLAST(HIGH>VarA)));
VarC:=IF(HIGH>VarA,Var3,REF(Var3,BARSLAST(HIGH>VarA)));
VarD:=IF(HIGH>VarB AND Var3<VarC AND Var3<Var5,HIGH,REF(HIGH,BARSLAST(HIGH>VarB AND Var3<VarC AND Var3<Var5)));
VarE:=IF(Var3>Var9 AND REF(Var3,1)<=Var9,LLV(REF(LOW,1),BARSLAST(Var3<=Var9 AND REF(Var3,1)>Var9)-1),REF(LLV(REF(LOW,1),BARSLAST(Var3<=Var9 AND REF(Var3,1)>Var9)-1),BARSLAST(Var3>Var9 AND REF(Var3,1))));
VarF:=IF(LOW<VarE,HIGH,REF(HIGH,BARSLAST(LOW<VarE)));
Var10:=IF(LOW<VarE,Var3,REF(Var3,BARSLAST(LOW<VarE)));
Var11:=IF(LOW<VarF AND Var3>Var10 AND Var3>Var5,LOW,REF(LOW,BARSLAST(LOW<VarF AND Var3>Var10 AND Var3>Var5)));
多防线: Var11;
空防线: VarD;
Var12:=AMOUNT/VOL/100;
Var13:=Var12>HIGH OR Var12<LOW;
STICKLINE(Var13<1,Var12-0.002,Var12+0.002,8,1);
SAR(10,2,20),CIRCLEDOT
FZMSD
n=34,k=3
股MSD:EMA(100*(C-LLV(LOW,N))/(HHV(H,N)-LLV(LOW,N)),K), COLOR9900ff;
大盘MSD:EMA(100*(INDEXC-LLV(INDEXL,N))/(HHV(INDEXH,N)-LLV(INDEXL,N)),K),COLORcccc66;
100,pointdot;
0,pointdot;
差值:股MSD-大盘MSD,pointdot color00cc33;
STICKLINE( 差值>=0,0 ,差值*1.0,4 ,0 )COLOR0000ff;
STICKLINE( 差值>=0,0 ,差值*0.8,4 ,0 )COLOR0066ff;
STICKLINE( 差值>=0,0 ,差值*0.6,4 ,0 )COLOR0099ff;
STICKLINE( 差值>=0,0 ,差值*0.4,4 ,0 )COLOR00ccff;
STICKLINE( 差值>=0,0 ,差值*0.2,4 ,0 )COLOR00ffff;
STICKLINE( 差值<0,0 ,差值*1.0,4 ,0 )COLOR00ff00;
STICKLINE( 差值<0,0 ,差值*0.8,4 ,0 )COLOR00cc33;
STICKLINE( 差值<0,0 ,差值*0.6,4 ,0 )COLOR009933;
STICKLINE( 差值<0,0 ,差值*0.4,4 ,0 )COLOR007733;
STICKLINE( 差值<0,0 ,差值*0.2,4 ,0 )COLOR005500;
FZOSC
n=10,m=10,
OSC: (CLOSE-REF(CLOSE,N))*100;
OSC1: MA(OSC,M);
FZOSCMACD
LONG=34   SHORT=5
OSC: (MA(CLOSE,SHORT)-MA(CLOSE,LONG))/MA(CLOSE,SHORT)*100, COLORSTICK;
OSCMACD: MA(OSC,5);
stickline(OSC>0,0,OSC,8,0),colorRED;
stickline(OSC<0,0,OSC,8,0),colorgreen;
FZSAR
n=10,STEP=2,MAXP=20
SAR(N,STEP,MAXP),CIRCLEDOT
FZ波段KD
Var1:=MA(CLOSE,5);
Var2:=MA(CLOSE,10);
Var3:=MA(CLOSE,30);
Var4:=MA(CLOSE,60);
Var5:=EMA(COST(85),7);
Var6:=EMA(COST(15),7);
Var7:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);
Var8:=INTPART(Var7*100)/100;
Var9:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);
VarA:=INTPART(Var9*100)/100;
VarB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VarC:=INTPART(VarB*100)/100;
VarD:=EMA(CLOSE,5)-EMA(CLOSE,10);
VarE:=EMA(CLOSE,5)-EMA(CLOSE,10);
VarF:=EMA(VarD,9);
放空段: IF(VarD>VarF,VarF,VarE), , COLORGREEN;
持股段: IF(VarD< VarF,VarF,VarE), , COLORRED;
VarF, , COLORYELLOW;
Var10:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
Var11:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
Var12:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
Var13:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
Var14:=REF(VarF,1);
Var15:=VarF;
Var16:=Var15-Var14;
Var17:=REF(VarD,1);
Var18:=VarD;
Var19:=Var18-Var17;
Var1A:=OPEN;
Var1B:=CLOSE;
变盘点: IF(Var1A<=Var1 AND Var1A<=Var2 AND Var1A<=Var3 AND Var1B>=Var1 AND Var1B>=VarC AND Var16>0 AND Var19>0,0.5,0), STICK;
DRAWICON(变盘点,0.4,2), ,COLORRED;
DRAWTEXT(变盘点,0.4,'变盘点'), , COLORWHITE;
DRAWTEXT(变盘点,-0.25,'上下,自己分析'), ,COLORWHITE;
Var1C:=IF(CROSS(VarD,VarF) AND VarD<0 AND VarF<-0.2 AND Var11>45 AND Var16>0,0.3,0);
买进1: IF(Var1C,0.5,0), ,COLORYELLOW;
DRAWICON(买进1,0.5,1), , COLORRED;
Var1D:=(2*CLOSE+HIGH+LOW)/4;
Var1E:=LLV(LOW,34);
Var1F:=HHV(HIGH,34);
Var20:=EMA((Var1D-Var1E)/(Var1F-Var1E)*100,13);
Var21:=EMA(0.667*REF(Var20,1)+0.333*Var20,2);
持仓: STICKLINE(Var20>Var21,0,-0.02,10,1), , COLORMAGENTA;
空仓: STICKLINE(Var20< Var21,0,-0.02,10,1), , ;
Var22:=REF(CLOSE,1);
Var23:=SMA(MAX(CLOSE-Var22,0),6,1)/SMA(ABS(CLOSE-Var22),6,1)*100;
卖出: IF(CROSS(84,Var23),0.5,0), ,COLORGREEN;
DRAWICON(卖出,0.5,2), , COLORGREEN;
FZ步步高
中线: 1-100*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40)), , ;
短线: 1-100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10)), ,;
!警戒线!: -15;
↓逃顶线↓: -5;
↑抄底线↑: -90, , ;
FZ超跌反弹
Var1:=REF(HIGH,1)*1.1;
Var2:=HIGH*1.1;
Var3:=(Var2*VOL+Var1*(CAPITAL-VOL))/CAPITAL;
Var4:=REF(LOW,1)*0.9;
Var5:=LOW*0.9;
Var6:=(Var5*VOL+Var4*(CAPITAL-VOL))/CAPITAL;
Var7:=EMA(Var6,30);
Var8:=EMA(Var3,30);
Var9:=Var8-2;
VarA:=IF(CLOSE<=Var7,Var9,Var8);
别样: VarA;
红: Var9;
FZ出手就赢
n=9,m1=3,m2=3,
RSV:=(CLOSE-LLV(LOW,n))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
Var2:=REF(LOW,1);
Var3:=SMA(ABS(LOW-Var2),3,1)/SMA(MAX(LOW-Var2,0),3,1)*100;
Var4:=EMA(IF(CLOSE*1.3,Var3*10,Var3/10),3);
Var5:=LLV(LOW,30);
Var6:=HHV(Var4,30);
Var7:=IF(MA(CLOSE,58),1,0);
Var8:=EMA(IF(LOW<=Var5,(Var4+Var6*2)/2,0),3)/618*Var7;
Var9:=IF(Var8>100,100,Var8);
STICKLINE(Var9>-150,0,Var9,3,0), , colorff00ff;
底部吸筹指标: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, , color00ff00;
STICKLINE(CROSS(底部吸筹指标,-24),100,0,6,0), , colorffffff;
先知: (CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100, , colorff00ff;
可能放量拉升: IF(CROSS(底部吸筹指标,-24),1,0), , colorblue;
短线获利:STICKLINE(REF(J,1)<0 AND J>0,60,0,2,0),color0000ff;
Vark1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
Vark2:=REVERSE(Vark1);
Vark3:=SMA(Vark1,3,1);
波段王:=SMA(Vark3,3,1), , COLORRED,linethick2;
波段鬼:=SMA(波段王,2.5,1),coloryellow,linethick2;
趋势线: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1), ,COLORff6666,linethick2;
卖:IF((CROSS(波段鬼,波段王) or CROSS(波段鬼,趋势线) or CROSS(波段王,趋势线) ) AND 波段鬼>65,90,0),stick, ,colorffff00 ,linethick3;
RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K1:=SMA(RSV9,3,1);
DK1:=K1-REF(K1,1),COLORSTICK;
出手就赢:IF(DK1>7 AND REF(DK1,1)<0 AND (DK1-REF(DK1,1))>9,50,0), STICK,COLORyellow;
DRAWICON(出手就赢>0,50 ,1);
买点准备:IF(趋势线<=10,0,10), colorff9933,linethick3;
STICKLINE( CROSS(趋势线,10),0,73,6,0), COLOR3366ff,;
DRAWTEXT(IF(CROSS(趋势线,10),100,0),68,'抄底'),COLORblue ;
DRAWTEXT(IF(CROSS(10,趋势线),1,0), 10,'$备钱'),COLOR33ffcc,;
DRAWTEXT(REF(J,1)<0 AND J>0,50,'短买'),,,,colorred ,;
DRAWTEXT(CROSS(底部吸筹指标,-24),80,'抄底'),colorblue ,;
FZ顶底极限
Var1:=MA(CLOSE,20);
布林极限: 100*(CLOSE-Var1)/STD(CLOSE,20);
布林K值: EMA(布林极限,10);
Var2:=EMA(布林极限,5);
Var3:=EMA(布林K值,5);
Var4:=EMA(HHV(HIGH,500),21);
Var5:=EMA(HHV(HIGH,250),21);
Var6:=EMA(HHV(HIGH,90),21);
Var7:=EMA(LLV(LOW,500),21);
Var8:=EMA(LLV(LOW,250),21);
Var9:=EMA(LLV(LOW,90),21);
VarA:=EMA((Var7*0.96+Var8*0.96+Var9*0.96+Var4*0.558+Var5*0.558+Var6*0.558)/6,21);
VarB:=EMA((Var7*1.25+Var8*1.23+Var9*1.2+Var4*0.55+Var5*0.55+Var6*0.65)/6,21);
VarC:=EMA((Var7*1.3+Var8*1.3+Var9*1.3+Var4*0.68+Var5*0.68+Var6*0.68)/6,21);
VarD:=EMA((VarA*3+VarB*2+VarC)/6*1.738,21);
VarE:=REF(LOW,1);
VarF:=SMA(ABS(LOW-VarE),3,1)/SMA(MAX(LOW-VarE,0),3,1)*100;
Var10:=IF(CLOSE*1.35<=VarD,VarF*10,VarF/10);
Var11:=EMA(Var10,3);
Var12:=LLV(LOW,30);
Var13:=HHV(Var11,30);
Var14:=IF(LOW<=Var12,(Var11+Var13*2)/2,0);
Var15:=EMA(Var14,3)/500-100;
Var16:=0.2*Var15;
Var17:=1.2*Var15;
Var18:=(2*CLOSE+HIGH+LOW)/4;
Var19:=LLV(LOW,34);
Var1A:=HHV(HIGH,34);
Var1B:=(Var18-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
Var1C:=EMA(Var1B,3);
Var1D:=EMA(Var1C,3);
Var1E:=EMA((Var18-Var19)/(Var1A-Var19)*100,9);
Var1F:=EMA(0.667*REF(Var1E,1)+0.333*Var1E,3);
Var20:=LLV(HIGH,240);
Var21:=100*(CLOSE-Var20)/Var20;
Var22:=HHV(HIGH,240);
Var23:=100*(Var22-CLOSE)/CLOSE;
Var24:=REF(HHV(CLOSE,60),1);
Var25:=REF(LLV(CLOSE,60),1);
Var26:=100*(CLOSE-Var25)/(Var24-Var25);
可以考虑出击了: IF(Var16<REF(Var16,1) AND REF(Var16,1)>REF(Var16,2) AND REF(Var16,2)>REF(Var16,3) AND Var17<REF(Var17,1) AND REF(Var17,1)>REF(Var17,2) AND REF(Var17,2)>REF(Var17,3) AND REF(Var17,1)>0,200,0);
IF(CROSS(Var26,Var21) AND CROSS(布林极限,布林K值) AND CLOSE>=OPEN AND Var1E<=50 AND Var1F<=50 AND Var1C>=Var1E AND Var1D>=Var1F,200,0);
IF(CROSS(REF(Var26,1),REF(Var21,1)) AND CROSS(布林极限,布林K值) AND CLOSE>=OPEN AND Var1E<=50 AND Var1F<=50 AND Var1C>=Var1E AND Var1D>=Var1F,200,0);
IF(CROSS(REF(Var21,1),REF(Var23,1)) AND CROSS(布林极限,布林K值) AND CLOSE>=OPEN AND Var1E<=50 AND Var1F<=50 AND Var1C>=Var1E AND Var1D>=Var1F,200,0);
100;
-100;
170;
-170;
STICKLINE(布林极限>=布林K值,布林极限,布林K值,6,0);
STICKLINE(布林极限<布林K值,布林K值,布林极限,6,0);
STICKLINE(Var2>=Var3,Var2,Var3,6,0);
STICKLINE(Var2<Var3,Var3,Var2,6,0);
STICKLINE(CROSS(布林极限,布林K值),布林极限,布林K值,6,0);
STICKLINE(布林极限>=170,布林极限,布林K值,6,0);
FZ动力波浪线
DATA=5,WARN=0,MV=6,SM=6
Var1:=1340601;
W1: IF(DATE<Var1,MA(CLOSE-REF(CLOSE,MV*2),MV),4.5)*6*MV;
W2: IF(DATE<Var1,MA(LOW-REF(LOW,MV*2),MV),1.5)*5*MV;
W3: IF(DATE<Var1,MA(HIGH-REF(HIGH,MV*2),MV),0.5)*4*MV;
W4: IF(DATE<Var1,MA(OPEN-REF(OPEN,MV*2),MV),-1.5)*3*MV;
买: IF(CLOSE>90,-500,-3)*SM;
卖: IF(CLOSE>90,500,3)*SM;
Var2:=IF(W4<0,W4-W1,W1-W4);
Var3:=IF(W4>0,W4-0,0-W4);
Var4:=IF(Var2/Var3>1,1,0);
IF(Var4=IF(W4<0,0,1),W1,0);
0;
DRAWTEXT(DATE>Var1,100,'');
DRAWTEXT(DATE>Var1,50,'');
DRAWTEXT(DATE>Var1,0,'');
DRAWTEXT(DATE>Var1,-50,'');
DRAWTEXT(DATE>Var1,-100,'');
DRAWTEXT(DATE>Var1,-150,'');
FZ动向流
n=5
动向流:(ma(close,3)-ref(ma(close,3),n))/ref(ma(close,3),n),colorFFff00;
polyline(1,ma(动向流,2)) colorFFff00;
polyline(1,ma(动向流,3)) colorFFff00;
polyline(1,ma(动向流,4)) colorFFff00;
polyline(1,ma(动向流,5)) colorFFff00;
polyline(1,ma(动向流,6)) colorFFff00;
polyline(1,ma(动向流,7)) colorFFff00;
polyline(1,ma(动向流,8)) colorFFff00;
polyline(1,ma(动向流,9)) colorFFff00;
polyline(1,ma(动向流,10)) colorFFff00;
polyline(1,ma(动向流,11)) colorFFff00;
polyline(1,ma(动向流,12)) colorFFff00;
polyline(1,ma(动向流,13)) colorFFff00;
polyline(1,ma(动向流,14)) colorFFff00;
polyline(1,ma(动向流,15)) colorFFff00;
polyline(1,ma(动向流,16)) colorFFff00;
polyline(1,ma(动向流,17)) colorFFff00;
polyline(1,ma(动向流,18)) colorFFff00;
polyline(1,ma(动向流,19)) colorFFff00;
polyline(1,ma(动向流,20)) colorFFff00;
polyline(1,ma(动向流,21)) colorFFff00;
polyline(1,ma(动向流,22)) colorFFff00;
polyline(1,ma(动向流,23)) colorFFff00;
polyline(1,ma(动向流,24)) colorFFff00;
polyline(1,ma(动向流,25)) colorFFff00;
polyline(1,ma(动向流,26)) colorFFff00;
polyline(1,ma(动向流,27)) colorFFff00;
polyline(1,ma(动向流,28)) colorFFff00;
polyline(1,ma(动向流,29)) colorFFff00;
polyline(1,ma(动向流,30)) colorFFff00;
FZ多空动力线
mv=6,SM=12,LM=65
Var1:=CLOSE-REF(CLOSE,34);
Var2:=(MA(VOL,5)-MA(VOL,15))/MA(VOL,10)/MV;
Var3:=(MA(INDEXV,5)-MA(INDEXV,15))/MA(INDEXV,10);
Var4:=Var1+Var2;
Var5:=MA(Var1,SM);
Var6:=MA(Var1,LM);
Var7:=1340601;
Var8:=(MV+2)*30;
M: IF(DATE<Var7,Var4,1.1)*Var8;
SJ: IF(DATE<Var7,Var5,-1.1)*Var8;
LJ: IF(DATE<Var7,Var6,0)*Var8;
Var9:=MA(Var1,MV/2+1);
VarA:=MA(Var1,MV/2+3);
ENE: IF(DATE<Var7,Var9-VarA-(Var9-Var4),0)*Var8*2, COLORSTICK;
VarB:=IF(DATE<Var7,INDEXC-REF(INDEXC,34)+Var3,1.1);
IND: IF(CLOSE<90,VarB,0);
DRAWTEXT(DATE>Var7,100,'试');
DRAWTEXT(DATE>Var7,50,'用');
DRAWTEXT(DATE>Var7,0,'期');
DRAWTEXT(DATE>Var7,-50,'已');
DRAWTEXT(DATE>Var7,-100,'过');
DRAWTEXT(DATE>Var7,-150,'!');
FZ多空箱体
n=21,m=3,p=2,
a:=(3*c+l+o+h)/6;
多:(20*a+19*ref(a,1)+18*ref(a,2)+17*ref(a,3)+16*ref(a,4)+15*ref(a,5)+14*ref(a,6)
+13*ref(a,7)+12*ref(a,8)+11*ref(a,9)+10*ref(a,10)+9*ref(a,11)+8*ref(a,12)
+7*ref(a,13)+6*ref(a,14)+5*ref(a,15)+4*ref(a,16)+3*ref(a,17)+2*ref(a,18)+
ref(a,20))/210;
空:ma(多,m);
MID : MA(CLOSE,N);
UPPER: MID + P*STD(CLOSE,N);
LOWER: MID - P*STD(CLOSE,N);
aa:=if(c>=o,(c-o)/4,0);
STICKLINE(c>=o,o,o+aa,7,0),colorred;
STICKLINE(c>=o,o+aa,o+2*aa,7,0),colorred;
STICKLINE(c>=o,o+2*aa,o+3*aa,7,0),colorred;
STICKLINE(c>=o,o+3*aa,c,7,0),colorred;
VarA:=IF(CLOSE>150,91.3,0.913);
箱体下沿:INTPART(CLOSE/VarA )*VarA,pointdot,linethick2,colorgreen;
箱体上沿:箱体下沿+VarA,pointdot,linethick2,coloryellow ;
箱体中线:(箱体下沿+箱体上沿)/2,pointdot,colorwhite,linethick2;
FZ鳄鱼线
Y:=(H+L)/2;
BLUE:=SMA(Y,13,1),SHIFT8,COLORBLUE;
RED:=SMA(Y,8,1),SHIFT5,COLORRED;
GREEN:=SMA(Y,5,1),SHIFT3,COLORGREEN;
B2:=REF(BLUE,8);
R2:=REF(RED,5);
G2:=REF(GREEN,3);
KU1:=IF(H=HHV(H,3),1,0);
KD1:=IF(L=LLV(L,3),1,0);
UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0,REF(H,2),REF(H,2+BARSLAST(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0)));
DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0,REF(L,2),REF(L,2+BARSLAST(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0)));
KU:=IF(C>B2 AND C>R2 AND C>G2,1,0);
KD:=IF(C<B2 AND C<R2 AND C<G2,-1,0);
KK:=IF(BARSLAST(KU=1 AND REF(KU,1)=0)<BARSLAST(KD=-1 AND REF(KD,1)=0),1,-1);
AO:=MA(Y ,5 )-MA(Y ,34 );
AC:=AO-MA( AO,5);
ac1:=ref(AC,1);
ao1:=ref(ao,1);
AO转:(170*MA(Y,5)-170*MA(Y,34)+165*MA(Y,33)-136*MA(Y,4))/29,linethick0;
AO零:(165*ma(Y,33)-136*ma(Y,4))/29,linethick0;
AC转:(5*34*5*AO-5*34*5*MA(AO,5)+5*34*4*MA(AO,4)+5*4*33*MA(Y,33)-4*34*4*MA(Y,4))/116,linethick0;
AC零:(5*34*MA(AO,4)-34*4*MA(Y,4)+5*33*MA(Y,33))/29,linethick0;
KAC:=IF(AC>ac1 AND Ao>ao1,1,0);
KAO:=IF(AC<ac1 AND Ao<ao1,-1,0);
蓝:SMA(Y,13,1),SHIFT8,COLORBLUE;
红:SMA(Y,8,1),SHIFT5,COLORRED;
绿:SMA(Y,5,1),SHIFT3,COLORGREEN;
上碎型:IF(H>=R2,UL,REF(UL,BARSLAST(H>R2))),COLORMAGENTA,linethick0;
下碎型:IF(L<=R2,DL,REF(DL,BARSLAST(L<=R2))),COLORYELLOW,linethick0;
STICKLINE(BARSLAST(ABS(上碎型-REF(上碎型,1)))<BARSLAST(c>上碎型 AND REF(c,1)<REF(上碎型,1)),上碎型,上碎型,3,1),COLORMAGENTA;
STICKLINE(BARSLAST(ABS(下碎型-REF(下碎型,1)))<BARSLAST(c<下碎型 AND REF(c,1)>REF(下碎型,1)),下碎型,下碎型,3,1),COLORYELLOW;
OL:=(170*MA(Y,5)-170*MA(Y,34)+165*MA(Y,33)-136*MA(Y,4))/29,shift1,color000033;
CL:=(165*ma(y,33)-136*ma(y,4)+170*(4*MA(AO,4)+5*(REF(AO,4)-MA(REF(AO,4),5)))/4)/29,shift1,color000033;
H1:=REF(H,4);
H2:=REF(H,3);
H3:=REF(H,2);
H4:=REF(H,1);
H5:=H;
L1:=REF(L,4);
L2:=REF(L,3);
L3:=REF(L,2);
L4:=REF(L,1);
L5:=L;
∥:=(H3>H2) And (H3>H1) And (H3>H4) And (H3>H5);
∥Fractal:=IF(∥,1,0);
∥Var1:=BackSet(∥Fractal,3);
∥Var2:=Filter(∥Var1,2);
∥Var3:=BackSet(∥Fractal,5);
∣:=(L3<L2) And (L3<L1) And (L3<L4) And (L3<L5);
∣Fractal:=IF(∣,1,0);
∣Var1:=BackSet(∣Fractal,3);
∣Var2:=Filter(∣Var1,2);
∣Var3:=BackSet(∣Fractal,5);
DrawIcon(∥Var2,H*1.001,'S14');
DrawIcon(∣Var2,L,'S14');
DRAWICON(c>上碎型 AND REF(c,1)<REF(上碎型,1),H*1.015,4);
DRAWICON(c<下碎型 AND REF(c,1)>REF(下碎型,1),L*0.99,5);
DRAWICON(KU=1 AND REF(KU,1)=0 and c<0,L,4);
DRAWICON(KD=-1 AND REF(KD,1)=0 and c<0,H*1.01,5);
DRAWICON(KU=0 AND REF(KU,1)=1 and c<0,H*1.01,7);
DRAWICON(KD=0 AND REF(KD,1)=-1 and c<0,L,6);
STICKLINE(KAC=1 AND C>=O,O,C,8,1),COLORRED;
STICKLINE(KAO=-1 AND C>=O,O,C,8,1),COLORGREEN;
STICKLINE(KAO=0 AND KAC=0 AND C>=O,O,C,8,1),COLORGRAY;
STICKLINE(C>=O,H,C,0.4,1),COLORRED;
STICKLINE(C>=O,O,L,0.4,1),COLORRED;
STICKLINE(KAC=1 AND C<O,O,C,8,0),COLORRED;
STICKLINE(KAO=-1 AND C<O,O,C,8,0),COLORGREEN;
STICKLINE(KAO=0 AND KAC=0 AND C<O,O,C,8,0),COLORGRAY;
STICKLINE(O>C,H,O,0.4,1),COLORCYAN;
STICKLINE(O>C,C,L,0.4,1),COLORCYAN;
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:IF(TDU3<TUD3,REF(HHV(H,2),TDU3),REF(LLV(L,2),TUD3)),COLORYELLOW;
JDU0:=REF(C,1)<=REF(UDGLINE,1) AND C>UDGLINE AND TDU0<TUD0;
JUD0:=REF(C,1)>=REF(UDGLINE,1) AND C<UDGLINE AND TUD0<TDU0;
JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
DRAWTEXT(JDU2,L*0.98,'\n空\n转\n多'),align4;
DRAWTEXT(JUD2,H*1.03,'\n多\n转\n空'),align5;
DRAWTEXT(JDU3,L*0.98,'\n多\n续\n多'),align4;
DRAWTEXT(JUD3,H*1.03,'\n空\n续\n空'),align5;
BSLINE:=IF(BARSLAST(JDU2)<BARSLAST(JUD2),IF(REF(CROSS(0,AC),1) OR REF(CROSS(0,AO),1),LLV(L,2),REF(LLV(L,2),BARSLAST(REF(CROSS(0,AC),1) OR REF(CROSS(0,AO),1)))),IF(REF(CROSS(AC,0) OR REF(CROSS(AO,0),1),1),HHV(H,2),REF(HHV(H,2),BARSLAST(REF(CROSS(AC,0),1) OR REF(CROSS(AO,0),1))))),COLORyellow;
DRAWICON(JDU1 OR BARSLAST(JDU1)<BARSLAST(JUD1),C,10),ALIGN4;
DRAWICON(JUD1 OR BARSLAST(JDU1)>BARSLAST(JUD1),C,11),ALIGN5;
FZ分割
Var1:=IF(C>200,91.3,0.913);
a:INTPART(c/Var1 )*Var1,pointdot,linethick2,colorgreen;
a+(Var1),pointdot,linethick2,colorgreen ;
Var2:=IF(C>200,182.6,1.826);
b:INTPART(c/Var2 )*Var2,pointdot,linethick2,colorred;
b+(Var2),pointdot,linethick2,colorred;
STICKLINE(open>=close ,close ,open,9,0 ),COLORaaaaaa;
STICKLINE(open>=close ,close ,open,6,0 ),COLORbbbbbb;
STICKLINE(open>=close ,close ,open,2.4,0 ),COLORcccccc;
STICKLINE(open>=close ,close ,open,1.1,0 ),COLORdddddd;
STICKLINE(close>open,close,open,9,0 ),COLOr6666cc;
STICKLINE(close>open,close,open,6 ,0 ),COLOR7777dd;
STICKLINE(close>open,close,open,2.4 ,0 ),COLOR8888ee;
STICKLINE(close>open,close,open,1.1 ,0 ),COLOR9999ff;
STICKLINE(close>open,open,low,0.5,0 ),COLOR1199ff;
STICKLINE(close>open,close,HIGH,0.5 ,0 ),COLOR1199ff;
STICKLINE(open>=close,close,low,0.5 ,0 ),COLORcccccc;
STICKLINE(open>=close,open,HIGH,0.5 ,0 ),COLORcccccc;
FZ古今
a1:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
a2:=SMA(a1,3,1);
a3:=SMA(a2,3,1);
a4:=3*a2-2*a3;
短线:ema(a4,5) coloryellow linethick2;
a5:= (HHV(HIGH,35)-CLOSE)/(HHV(HIGH,35)-LLV(LOW,35))*100;
空方:ma((eMA(a5,2)),2) colorblue linethick2;
浮筹:ma(a4,30) colorgreen pointdot;
庄家生命:MA(WINNER(CLOSE)*100,6)COLORmagenta;
BY1:=MA(庄家生命,12);
BY2:=CROSS(庄家生命,BY1) AND CROSS(短线,浮筹) OR CROSS(REF(短线,1),REF(浮筹,1));
压力线:ema(a4,120);
STICKLINE( 浮筹,浮筹+1 ,浮筹-1,5 ,0 )COLORGREEN;
STICKLINE( 短线>浮筹,110 ,115,7 ,1 )COLORmagenta;
STICKLINE( 短线<浮筹,-10 ,-15,7 ,1 )coloryellow;
STICKLINE( 短线>浮筹,-10 ,-15,7 ,1 )COLORCYAN;
STICKLINE( 短线<浮筹,110 ,115,7 ,1 )COLORGREEN;
STICKLINE( (CROSS(短线,浮筹) AND 浮筹<50 ) ,-10 ,-15,7 ,0 )COLORred;
STICKLINE( (CROSS(短线,浮筹) AND 浮筹<40 and 压力线<80 ) ,浮筹+10 ,浮筹-10,4 ,0 )COLOR0000ff;
DRAWTEXT((CROSS(浮筹,短线) and 浮筹>50) ,浮筹+10 ,'反弹结束' )COLORGREEN;
DRAWTEXT((CROSS(浮筹,空方) and 浮筹<50) ,浮筹+10 ,'还有一波' )COLORblue;
STICKLINE((CROSS(庄家生命,BY1) and 压力线<80 AND (CROSS(短线,浮筹) OR CROSS(REF(短线,1),REF(浮筹,1)))),30 ,0,7 ,1 )COLORred;
STICKLINE( 庄家生命,庄家生命 ,0,0.1 ,0 )COLORmagenta;
FZ鬼RSI
nn=20   n=6
Var1:=REF(CLOSE,1);
Var2:=MAX(REF(CLOSE,1),REF(Var1,1));
Var3:=MIN(REF(CLOSE,1),REF(Var1,1));
Var4:=STICKLINE(CLOSE>Var2,CLOSE,Var2,8,0);
Var5:=STICKLINE(CLOSE<Var2 AND CLOSE>Var3 AND REF(CLOSE,1)>=REF(CLOSE,2),CLOSE,Var2,8,0);
Var6:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)>=REF(Var3,1),Var1,Var3,8,0);
Var7:=STICKLINE(CLOSE>Var1 AND REF(CLOSE,1)>=REF(Var3,1),Var1,CLOSE,8,0);
Var8:=STICKLINE(CLOSE=Var1 AND REF(CLOSE,1)>=REF(Var3,1),Var1,CLOSE,8,0);
Var9:=STICKLINE(CLOSE>Var2 AND REF(CLOSE,1)<REF(Var3,1),Var2,CLOSE,8,0);
STICKLINE(Var1>=REF(CLOSE,2) AND CLOSE<Var1 AND CLOSE>=REF(CLOSE,2),Var1,CLOSE,8,0);
VarA:=STICKLINE(REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE>=Var1 AND CLOSE<REF(CLOSE,2),Var1,CLOSE,8,0);
VarB:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)>=REF(Var3,1),CLOSE,Var3,8,0);
VarC:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)<REF(Var3,1),Var1,CLOSE,8,0);
VarD:=STICKLINE(CLOSE>Var2 AND REF(CLOSE,1)<REF(Var3,1),Var1,Var2,8,0);
VarE:=STICKLINE(CLOSE>Var3 AND CLOSE<Var2 AND REF(CLOSE,1)<REF(Var3,1),Var1,CLOSE,8,0);
VarF:=STICKLINE(CLOSE<Var1 AND REF(CLOSE,1)<REF(Var2,1),Var1,CLOSE,8,0);
STICKLINE(CLOSE=Var1 AND REF(CLOSE,1)<REF(Var2,1),Var1,CLOSE,8,0);
Var10:=STICKLINE(CLOSE>Var2,CLOSE,Var2,6,0);
Var11:=STICKLINE(CLOSE<Var2 AND CLOSE>Var3 AND REF(CLOSE,1)>=REF(CLOSE,2),CLOSE,Var2,6,0);
Var12:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)>=REF(Var3,1),Var1,Var3,6,0);
Var13:=STICKLINE(CLOSE>Var1 AND REF(CLOSE,1)>=REF(Var3,1),Var1,CLOSE,6,0);
Var14:=STICKLINE(CLOSE=Var1 AND REF(CLOSE,1)>=REF(Var3,1),Var1,CLOSE,6,0);
Var15:=STICKLINE(CLOSE>Var2 AND REF(CLOSE,1)<REF(Var3,1),Var2,CLOSE,6,0);
STICKLINE(Var1>=REF(CLOSE,2) AND CLOSE<Var1 AND CLOSE>=REF(CLOSE,2),Var1,CLOSE,6,0);
Var16:=STICKLINE(REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE>=Var1 AND CLOSE<REF(CLOSE,2),Var1,CLOSE,6,0);
Var17:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)>=REF(Var3,1),CLOSE,Var3,6,0);
Var18:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)<REF(Var3,1),Var1,CLOSE,6,0);
Var19:=STICKLINE(CLOSE>Var2 AND REF(CLOSE,1)<REF(Var3,1),Var1,Var2,6,0);
Var1A:=STICKLINE(CLOSE>Var3 AND CLOSE<Var2 AND REF(CLOSE,1)<REF(Var3,1),Var1,CLOSE,6,0);
Var1B:=STICKLINE(CLOSE<Var1 AND REF(CLOSE,1)<REF(Var2,1),Var1,CLOSE,6,0);
STICKLINE(CLOSE=Var1 AND REF(CLOSE,1)<REF(Var2,1),Var1,CLOSE,6,0);
Var1C:=STICKLINE(CLOSE>Var2,CLOSE,Var2,4,0);
Var1D:=STICKLINE(CLOSE<Var2 AND CLOSE>Var3 AND REF(CLOSE,1)>=REF(CLOSE,2),CLOSE,Var2,4,0);
Var1E:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)>=REF(Var3,1),Var1,Var3,4,0);
Var1F:=STICKLINE(CLOSE>Var1 AND REF(CLOSE,1)>=REF(Var3,1),Var1,CLOSE,4,0);
Var20:=STICKLINE(CLOSE=Var1 AND REF(CLOSE,1)>=REF(Var3,1),Var1,CLOSE,4,0);
Var21:=STICKLINE(CLOSE>Var2 AND REF(CLOSE,1)<REF(Var3,1),Var2,CLOSE,4,0);
STICKLINE(Var1>=REF(CLOSE,2) AND CLOSE<Var1 AND CLOSE>=REF(CLOSE,2),Var1,CLOSE,4,0);
Var22:=STICKLINE(REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE>=Var1 AND CLOSE<REF(CLOSE,2),Var1,CLOSE,4,0);
Var23:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)>=REF(Var3,1),CLOSE,Var3,4,0);
Var24:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)<REF(Var3,1),Var1,CLOSE,4,0);
Var25:=STICKLINE(CLOSE>Var2 AND REF(CLOSE,1)<REF(Var3,1),Var1,Var2,4,0);
Var26:=STICKLINE(CLOSE>Var3 AND CLOSE<Var2 AND REF(CLOSE,1)<REF(Var3,1),Var1,CLOSE,4,0);
Var27:=STICKLINE(CLOSE<Var1 AND REF(CLOSE,1)<REF(Var2,1),Var1,CLOSE,4,0);
STICKLINE(CLOSE=Var1 AND REF(CLOSE,1)<REF(Var2,1),Var1,CLOSE,4,0);
Var28:=STICKLINE(CLOSE>Var2,CLOSE,Var2,2,0);
Var29:=STICKLINE(CLOSE<Var2 AND CLOSE>Var3 AND REF(CLOSE,1)>=REF(CLOSE,2),CLOSE,Var2,2,0);
Var2A:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)>=REF(Var3,1),Var1,Var3,2,0);
Var2B:=STICKLINE(CLOSE>Var1 AND REF(CLOSE,1)>=REF(Var3,1),Var1,CLOSE,2,0);
Var2C:=STICKLINE(CLOSE=Var1 AND REF(CLOSE,1)>=REF(Var3,1),Var1,CLOSE,2,0);
Var2D:=STICKLINE(CLOSE>Var2 AND REF(CLOSE,1)<REF(Var3,1),Var2,CLOSE,2,0);
STICKLINE(Var1>=REF(CLOSE,2) AND CLOSE<Var1 AND CLOSE>=REF(CLOSE,2),Var1,CLOSE,2,0);
Var2E:=STICKLINE(REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE>=Var1 AND CLOSE<REF(CLOSE,2),Var1,CLOSE,2,0);
Var2F:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)>=REF(Var3,1),CLOSE,Var3,2,0);
Var30:=STICKLINE(CLOSE<Var3 AND REF(CLOSE,1)<REF(Var3,1),Var1,CLOSE,2,0);
Var31:=STICKLINE(CLOSE>Var2 AND REF(CLOSE,1)<REF(Var3,1),Var1,Var2,2,0);
Var32:=STICKLINE(CLOSE>Var3 AND CLOSE<Var2 AND REF(CLOSE,1)<REF(Var3,1),Var1,CLOSE,2,0);
Var33:=STICKLINE(CLOSE<Var1 AND REF(CLOSE,1)<REF(Var2,1),Var1,CLOSE,2,0);
STICKLINE(CLOSE=Var1 AND REF(CLOSE,1)<REF(Var2,1),Var1,CLOSE,2,0);
Var34:=REF(CLOSE,1);
MA20: MA(CLOSE,NN);
Var35:=MA(CLOSE,5);
Var36:=SMA(MAX(CLOSE-Var34,0),N,1)/SMA(ABS(CLOSE-Var34),N,1)*100;
Var37:=SMA(MAX(CLOSE-Var34,0),12,1)/SMA(ABS(CLOSE-Var34),12,1)*100;
Var38:=SMA(MAX(CLOSE-Var34,0),24,1)/SMA(ABS(CLOSE-Var34),24,1)*100;
Var39:=IF(CROSS(Var36,Var38),LOW,REF(LOW,BARSLAST(CROSS(Var36,Var38))));
Var3A:=IF(CROSS(Var38,Var36),HIGH,REF(HIGH,BARSLAST(CROSS(Var38,Var36))));
Var3B:=IF(CLOSE>=MA(CLOSE,NN),80,50);
Var3C:=IF(CLOSE>=MA(CLOSE,NN),50,20);
Var3D:=IF(Var36<Var3B AND REF(Var36,1)>=Var3B,HHV(REF(HIGH,1),BARSLAST(Var36>=Var3B AND REF(Var36,1)<Var3B)-1),REF(HHV(REF(HIGH,1),BARSLAST(Var36>=Var3B AND REF(Var36,1)<Var3B)-1),BARSLAST(Var36<Var3B AND REF(Var36,1))));
Var3E:=IF(HIGH>Var3D,LOW,REF(LOW,BARSLAST(HIGH>Var3D)));
Var3F:=IF(HIGH>Var3D,Var36,REF(Var36,BARSLAST(HIGH>Var3D)));
Var40:=IF(HIGH>Var3E AND Var36<Var3F AND Var36<Var38,HIGH,REF(HIGH,BARSLAST(HIGH>Var3E AND Var36<Var3F AND Var36<Var38)));
Var41:=IF(Var36>Var3C AND REF(Var36,1)<=Var3C,LLV(REF(LOW,1),BARSLAST(Var36<=Var3C AND REF(Var36,1)>Var3C)-1),REF(LLV(REF(LOW,1),BARSLAST(Var36<=Var3C AND REF(Var36,1)>Var3C)-1),BARSLAST(Var36>Var3C AND REF(Var36,1))));
Var42:=IF(LOW<Var41,HIGH,REF(HIGH,BARSLAST(LOW<Var41)));
Var43:=IF(LOW<Var41,Var36,REF(Var36,BARSLAST(LOW<Var41)));
Var44:=IF(LOW<Var42 AND Var36>Var43 AND Var36>Var38,LOW,REF(LOW,BARSLAST(LOW<Var42 AND Var36>Var43 AND Var36>Var38)));
多防线: Var44;
空防线: Var40;
Var45:=AMOUNT/VOL/100;
Var46:=Var45>HIGH OR Var45<LOW;
STICKLINE(Var46<1,Var45-0.002,Var45+0.002,8,1);
FZ黑马发现
n1=1000
Var3:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);
Var4:=(CLOSE-LLV(CLOSE,N1))/(HHV(CLOSE,N1)-LLV(CLOSE,N1))*100;
Var5:=EMA(CLOSE,2)-EMA(CLOSE,150);
Var6:=EMA(Var5,100);
Var7:=2*(Var5-Var6);
Var8:=POW(Var7,3)*0.1+POW(Var7,1);
Var9:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VarA:=EMA(Var9*0.97,3);
VarB:=(HIGH+LOW+CLOSE)/3;
VarC:=(VarB-MA(VarB,14))/(0.015*AVEDEV(VarB,14));
黑马线: IF(Var7>0.1,Var8,0)*5,stick ,COLORGREEN,linethick4;
VarD:=LLV(HIGH,240);
VarE:=100*(CLOSE-VarD)/VarD;
VarF:=AMOUNT/VOL;
Var10:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
Var11:=INDEXC;
Var12:=MA(Var11,5);
Var13:=MA(Var11,20);
Var14:=MA(Var11,30);
Var15:=Var14>Var12*1.08 AND Var13>Var12*1.055;
Var16:=Var12>Var11*1.03 AND Var13>Var11*1.13;
Var17:=Var16;
Var18:=IF(FILTER(Var10<6,5)=1,1,0);
发现: (Var18 AND VarE<-2.5 AND Var3<5 AND Var4=0)*60, LINETHICK3,COLORMAGENTA;
Var19:=Var10<6 AND Var17;
黑马: IF(FILTER(Var19,1)=1,1,0)*80,STICK ,  COLORFF6666,LINETHICK3;
大黑马: Var19 AND Var18*80,STICK ,LINETHICK2, COLORFF9966;
操盘手: Var4,colorff99ff,LINETHICK3;
Var1A:=CROSS(黑马线,2);
Var1B:=CROSS(黑马线,4);
庄拉: IF(FILTER((Var1A OR Var1B) AND Var4<40 AND Var3<40,5)=1,35,0),COLORRED ,LINETHICK4;
Var1C:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
Var1D:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
Var1E:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
Var1F:=REF(CLOSE,1);
Var20:=SMA(MAX(CLOSE-Var1F,0),5,1)/SMA(ABS(CLOSE-Var1F),5,1)*100;
Var21:=(HIGH+LOW+CLOSE)/3;
Var22:=(Var21-MA(Var21,14))/(0.015*AVEDEV(Var21,14));
Var23:=(Var1C>=-15.8 AND Var1C<=-12.2 AND Var1D<=-20.8 AND Var1E<=-27.5 AND Var20<=11.7 AND Var22<=-145)*100;
Var24:=Var4=0;
Var25:=Var4=100;
STICKLINE(Var23>0,90,100,5,0),linethick3 ,COLORRED;
DRAWTEXT(Var23>0,90,'发现大黑马加把安全锁,全部亏损问它要'), , COLORMAGENTA;
STICKLINE(Var24>0,-3,-9,1,0),linethick3, COLORRED;
STICKLINE(Var25>0,101,105,1,0),COLORGREEN;
DRAWTEXT(发现>0,25,'短线黑马2.5%')COLORCC99FF;
DRAWTEXT(黑马>0,52,'黑马发现10%'), COLORYELLOW;
DRAWTEXT(大黑马,70,'★日线专用大黑马获利10%以上'),COLORRED;
0,LINETHICK3,COLORFF9966;
100, COLORFF9966;
FZ火焰山增强版
ll=250,mm=120,ss=60,n=10,
Var1:=EMA(HHV(HIGH,LL),N);
Var2:=EMA(HHV(HIGH,MM),N);{}
Var3:=EMA(HHV(HIGH,SS),N); { }
Var4:=EMA(LLV(LOW,LL),N); {}
Var5:=EMA(LLV(LOW,MM),N); {}
Var6:=EMA(LLV(LOW,SS),N);  {}
Var7:=EMA((Var4*0.96+Var5*0.96+Var6*0.96+Var1*0.558+Var2*0.558+Var3*0.558)/6,21);{线}
Var8:=EMA((Var4*1.25+Var5*1.23+Var6*1.2+Var1*0.55+Var2*0.55+Var3*0.65)/6,21);
Var9:=EMA((Var4*1.3+Var5*1.3+Var6*1.3+Var1*0.68+Var2*0.68+Var3*0.68)/6,21);
Var11:=IF(date>=1030926,0,1);{公1日}
VarA:=EMA((Var7*3+Var8*2+Var9)/6*1.738,N);
VarB:=REF(LOW,1);
VarC:=SMA(ABS(LOW-VarB),3,1)/SMA(MAX(LOW-VarB,0),3,1)*100;
VarD:=EMA(IF(CLOSE*1.35<=VarA,VarC*10,VarC*var11/10),3);
VarE:=LLV(LOW,30)*var11;
VarF:=HHV(VarD,30);
VV:=V/CAPITAL*50;
火焰山:EMA(IF(LOW<=VarE,(VarD+VarF*2)/2,0),3)/618,STICK,coloryellow,linethick2,;
火焰山*VV,STICK,linethick2,COLORRED;
FZ极品趋势
安全区: -70;
风险区: -30;
Var1:=1;
Var2:=LLV(LOW,33)*Var1;
Var3:=HHV(HIGH,21)*Var1;
Var4:=EMA((CLOSE-Var2)/(Var3-Var2)*100,20)*0.998*Var1;
极品K线趋势: -100+EMA(0.667*REF(Var4,1)+0.333*Var4,1)*Var1;
Var5:=-100+EMA(0.667*REF(Var4,1)+0.333*Var4,1)*Var1;
STICKLINE(Var5>=-70 AND Var5<=-30,Var5,Var5+3,20,0), ,COLORGREEN;
STICKLINE(Var5>-30,Var5,Var5+3,20,0), , colorred;
STICKLINE(Var5<-70,Var5,Var5+3,20,0), , ;
FZ江恩八分图
n=232,m=100
VERTLINE(FILTER(BACKSET(ISLASTBAR,N),N-1)),COLORRED;
VERTLINE(FILTER(BACKSET(ISLASTBAR,M),M-1)),COLORRED;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)/8),N-(N-M)/8-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)/8*2),N-(N-M)/8*2-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)/8*3),N-(N-M)/8*3-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)/8*4),N-(N-M)/8*4-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)/8*5),N-(N-M)/8*5-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)/8*6),N-(N-M)/8*6-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)/8*7),N-(N-M)/8*7-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)/8*8),N-(N-M)/8*8-1)),COLORRED;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*9/8),N-(N-M)*9/8-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*10/8),N-(N-M)*10/8-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*9/8),N-(N-M)*9/8-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*10/8),N-(N-M)*10/8-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*11/8),N-(N-M)*11/8-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*12/8),N-(N-M)*12/8-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*13/8),N-(N-M)*13/8-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*14/8),N-(N-M)*14/8-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*15/8),N-(N-M)*15/8-1)),COLORYELLOW;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*16/8),N-(N-M)*16/8-1)),COLORYELLOW;

VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*2/3),N-(N-M)*2/3-1)),COLORWHITE;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*4/3),N-(N-M)*4/3-1)),COLORWHITE;
VERTLINE(FILTER(BACKSET(ISLASTBAR,N-(N-M)*5/3),N-(N-M)*5/3-1)),COLORWHITE;
FZ江恩轮
n=7
Var1:=BARSCOUNT(CLOSE)*3.142/180;
A2: SIN(Var1*N);
A3: COS(Var1*N);
X1: 0;
X3: 0.236;
X2: -0.236;
FZ快枪
VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
快枪:-EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10,COLORSTICK;
快枪1:(快枪>0);0;快枪;4;1;
FZ烈火
n=5,n1=5,m=666,
Var1:=MA(HHV(HIGH,485),17);
Var2:=MA(HHV(HIGH,222),17);
Var3:=MA(HHV(HIGH,96),17);
Var4:=MA(LLV(LOW,485),17);
Var5:=MA(LLV(LOW,222),17);
Var6:=MA(LLV(LOW,96),17);
Var7:=MA((Var4*0.96+Var5*0.96+Var6*0.96+Var1*0.558+Var2*0.558+Var3*0.558)/6,17);
Var8:=MA((Var4*1.25+Var5*1.23+Var6*1.2+Var1*0.55+Var2*0.55+Var3*0.65)/6,17);
Var9:=MA((Var4*1.3+Var5*1.3+Var6*1.3+Var1*0.68+Var2*0.68+Var3*0.68)/6,17);
VarA:=MA((Var7*3+Var8*2+Var9)/6*1.738,17);
VarB:=LOW;
VarC:=REF(LOW,1);
VarD:=SMA(ABS(VarB-VarC),3,1)/SMA(MAX(VarB-VarC,0),N,1)*100;
VarE:=MA(IF(CLOSE*1.35<=VarA,VarD*10,VarD/10),N);
VarF:=LLV(LOW,30);
Var10:=HHV(VarE,30);
大火: MA(IF(LOW<=VarF,(VarE+Var10*2)/2,0),N), , COLORRED;
STICKLINE(大火,0,大火,8,0), , COLORRED;
Var11:=WINNER(CLOSE);
Var12:=VOL/CAPITAL;
Var13:=Var12/Var11;
火芯: M*IF(Var11<N1/100,Var13,0), , COLORYELLOW;
STICKLINE(火芯,0,火芯,8,0), , COLORYELLOW;
FZ轮中之轮
DATE1=1000218   800101    1301231
WD=120
0;
CD:=BARSLAST(DATE=DATE1)+20;
AD:=MOD(CD,WD);
S24:=IF(AD=0,1,0);
S24A:=IF(MOD(CD+1,WD)=0,1,0);
S24B:=IF(REF(S24,1)=1,1,0);
S3:=IF(AD=FLOOR(WD*3/24) OR AD=CEILING(WD*3/24) OR AD=FLOOR(WD*9/24) OR AD=CEILING(WD*9/24) OR AD=FLOOR(WD*15/24) OR AD=CEILING(WD*15/24) OR AD=FLOOR(WD*21/24) OR AD=CEILING(WD*21/24),1,0);
S3A:=IF(AD+1=FLOOR(WD*3/24) OR AD+1=CEILING(WD*3/24) OR AD+1=FLOOR(WD*9/24) OR AD+1=CEILING(WD*9/24) OR AD+1=FLOOR(WD*15/24) OR AD+1=CEILING(WD*15/24) OR AD+1=FLOOR(WD*21/24) OR AD+1=CEILING(WD*21/24),1,0);
S3B:=IF(REF(S3,1)=1,1,0);
S6:=IF(AD=FLOOR(WD*6/24) OR AD=CEILING(WD*6/24) OR AD=FLOOR(WD*12/24) OR AD=CEILING(WD*12/24) OR AD=FLOOR(WD*18/24) OR AD=CEILING(WD*18/24),1,0);
S6A:=IF(AD+1=FLOOR(WD*6/24) OR AD+1=CEILING(WD*6/24) OR AD+1=FLOOR(WD*12/24) OR AD+1=CEILING(WD*12/24) OR AD+1=FLOOR(WD*18/24) OR AD+1=CEILING(WD*18/24),1,0);
S6B:=IF(REF(S6,1)=1,1,0);
S8:=IF(AD=FLOOR(WD*8/24) OR AD=CEILING(WD*8/24) OR AD=FLOOR(WD*16/24) OR AD=CEILING(WD*16/24),1,0);
S8A:=IF(AD+1=FLOOR(WD*8/24) OR AD+1=CEILING(WD*8/24) OR AD+1=FLOOR(WD*16/24) OR AD+1=CEILING(WD*16/24),1,0);
S8B:=IF(REF(S8,1)=1,1,0);
A24:STICKLINE(S24=1,0,3,8,0),COLORRED,shift20;
A24B:STICKLINE(S24A=1 OR S24B=1,0,1,8,0),COLORRED,shift20;
A3:STICKLINE(S3=1,0,3,8,0),COLORGREEN,shift20;
A3B:STICKLINE(S3A=1 OR S3B=1,0,1,8,0),COLORGREEN,shift20;
A6:STICKLINE(S6=1,0,3,8,0),COLORCYAN,shift20;
A6B:STICKLINE(S6A=1 OR S6B=1,0,1,8,0),COLORCYAN,shift20;
A8:STICKLINE(S8=1,0,3,8,0),COLORYELLOW,shift20;
A8B:STICKLINE(S8A=1 OR S8B=1,0,1,8,0),COLORYELLOW,shift20;
DRAWNUMBER(ISLASTBAR,2,0,0),shift1;
DRAWNUMBER(ISLASTBAR,2,1,0),shift2;
DRAWNUMBER(ISLASTBAR,2,2,0),shift3;
DRAWNUMBER(ISLASTBAR,2,3,0),shift4;
DRAWNUMBER(ISLASTBAR,2,4,0),shift5;
DRAWNUMBER(ISLASTBAR,2,5,0),shift6;
DRAWNUMBER(ISLASTBAR,2,6,0),shift7;
DRAWNUMBER(ISLASTBAR,2,7,0),shift8;
DRAWNUMBER(ISLASTBAR,2,8,0),shift9;
FZ矛盾论
Var02:=LLV(LOW,5);
Var03:=HHV(HIGH,10);
动力线:EMA((CLOSE-Var02)/(Var03-Var02)*4,13)*30,colorwhite,linethick2;
Var1:=CLOSE-REF(CLOSE,1);
Var2:=IF(CLOSE-REF(CLOSE,1)>=0,Var1,0);
Var3:=REF(CLOSE,1)-CLOSE;
Var4:=IF(CLOSE-REF(CLOSE,1)<=0,Var3,0);
Var5:=SUM(Var2,8)/SUM(Var4,8);
Var6:=(1-1/(1+Var5))*100;
Var7:=LLV(LOW,50);
Var8:=HHV(HIGH,50);
Var9:=EMA(CLOSE,2);
VARB: EMA((Var9-Var7)/(Var8-Var7)*100,13),colorred,linethick3;
天线: 70, POINTDOT,linethick2,color0099ff;
地线: 20, POINTDOT,linethick2,colorcc9966;
中线:45,pointdot,linethick2,colorgreen;
Var13:=(REF(HIGH,1)+REF(LOW,1))/2;
Var14:=MA(CLOSE,20)+2*STD(CLOSE,20);
Var15:=FILTER(CROSS(Var13,Var14),4)*200;
DRAWTEXT(Var15,65,'短逃'),colorgreen;
Var16:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
Var17:=FILTER(CROSS(Var16,13),4);
Var18:=IF(Var16>90,50,100);
Var19:=FILTER(CROSS(Var18,Var16),4)*235;
DRAWTEXT(Var19,80,'见顶'),colorcyan;
PARTLINE(varb>ref(varb,1) and varb>20,varb),colorred,linethick3;
PARTLINE(varb<20,varb),coloryellow,linethick3;
PARTLINE(varb<ref(varb,1) and varb>20,varb),colorff9900,linethick3;
FZ牛*马*熊
{C牛*马*熊}
a1: (SMA(CLOSE,21,1)-SMA(CLOSE,89,1))*5;
强度系数: (SMA(CLOSE,10,1)-SMA(CLOSE,50,1))*5, COLORSTICK;
【牛】: a1*2.129;
【马】: 强度系数*2.75;
b1:=(SMA(CLOSE,55,1)-SMA(CLOSE,13,1))*5;
【熊】: b1*1.236
FZ牛马熊
Var1:=WINNER(CLOSE)*100;
Var2:=100-Var1;
Var3:=ABS(Var1-Var2);
TD:=Backset(ISLASTBAR,1);
DRAWTEXT(TD AND Var1,Var1*0.9,'  【牛】'),COLORRED;
DRAWTEXT(TD AND Var2,Var2*0.9,'  【熊】'),COLORYELLOW;
DRAWTEXT(TD AND Var3,Var3*0.9,'  【马】'),COLORMAGENTA;
STICKLINE(TD,Var1,0,30,0 ),COLORRED;
STICKLINE(TD,Var2,0,15,0 ),COLORYELLOW;
STICKLINE(TD,Var3,0,8, 0),COLORMAGENTA;
FZ盘后分析
Var1:=EMA(CLOSE,8);
Var2:=EMA(Var1,21);
Var3:=CROSS(Var1,Var2);
Var4:=Var1<EMA(CLOSE,120);
Var5:=EMA(SMA((CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100,8,1),3);
趋势指示 : STICKLINE(Var5>20 AND Var5<80,Var5,Var5,20,1),COLORRED;
白色高位:STICKLINE(Var5>80,Var5,Var5,20,1);
黄色低位:STICKLINE(Var5<20,Var5,Var5,20,1);
FZ飘
a1:=HHV(h ,2 ) ; {HHV(X,N),求N周期内X最高值}
a2:=HHV(h ,4 ) ;
a3:=HHV(h ,6 ) ;
a4:=HHV(h, 8 ) ;
b1:FORCAST(a1,2) COLORYELLOW; {FORCAST(X,N)为X的N周期线性回归预测值}
b2:FORCAST(a2,2) COLORMAGENTA;
b3:FORCAST(a3,2) COLORffbb00;
b4:FORCAST(a4,2) COLOR00cc00;
【发财】:IF(a4>=a1 ,a1 ,a4) COLOR666666;
PARTLINE(a4<ref(a4,1),a1),COLORYELLOW;
FZ七彩桥
n=13,m=5
DY1:=(2*CLOSE+HIGH+LOW)/4;
DY2:=LLV(LOW,34);
DY3:=HHV(HIGH,34);
DYA:EMA((DY1-DY2)/(DY3-DY2),30),COLORWHITE;
PARTLINE(DYA>=REF(DYA,1),DYA),COLORRED;
DYB:MA(DYA,N),COLORCYAN;
PARTLINE(DYB>=REF(DYB,1),DYB),COLORMAGENTA;
Var1:=WINNER((CLOSE+HIGH+LOW+OPEN)/4);
a1:=MA(Var1,M);
STICKLINE(a1<0.05,0,a1,6,0),COLORFFFFFF;
STICKLINE(a1>0.05 and a1<=0.10,0.05,a1,6,0),COLORFF33CC;
STICKLINE(a1>0.10 and a1<=0.20,0.10,a1,6,0),COLORFF9900;
STICKLINE(a1>0.20 and a1<=0.30,0.20,a1,6,0),COLOR00FF00;
STICKLINE(a1>0.30 and a1<=0.40,0.30,a1,6,0),COLOR3366FF;
STICKLINE(a1>0.40 and a1<=0.50,0.40,a1,6,0),COLORFFFF00;
STICKLINE(a1>0.50 and a1<=0.60,0.50,a1,6,0),COLORFF00FF;
STICKLINE(a1>0.60 and a1<=0.70,0.60,a1,6,0),COLOR00FFFF;
STICKLINE(a1>0.70 and a1<=0.80,0.70,a1,6,0),COLORFF9900;
STICKLINE(a1>0.80 and a1<=0.90,0.80,a1,6,0),COLOR00FF00;
STICKLINE(a1>0.90 and a1<=0.95,0.90,a1,6,0),COLOR0000FF;
顶部:STICKLINE(a1>0.95,0.95,a1,4,0),COLORFF33FF;
STICKLINE(a1<=0.02,0,a1,4,0),COLOR6633FF;
底部:STICKLINE(a1<=0.005,0,a1,4,0),COLOR66FF99;
STICKLINE(CLOSE<MA(CLOSE,13),-0.05,-0.03,8,1),COLORCYAN;
STICKLINE(CLOSE>=MA(CLOSE,13),-0.05,-0.03,8,1),COLOR0000FF;
大底:STICKLINE(a1<=0.005,-0.05,-0.03,8,0),COLORYELLOW;
FZ强市股
天数=5,
aa:=ma((INDEXC-ref(INDEXC,1))/INDEXC,天数);
bb:=ma((CLOSE-REF(CLOSE,1))/C,天数 );
【5日比较涨幅】:(bb-aa)*1000,colorstick;
【大盘涨幅】:100*(INDEXC-ref(INDEXC,1))/INDEXC,pointdot;
【个股涨幅】:100*(CLOSE-REF(CLOSE,1))/C,pointdot;
STICKLINE( 【5日比较涨幅】>=0,0 ,【5日比较涨幅】*1.0,4 ,0 )COLOR11ccff;
STICKLINE( 【5日比较涨幅】>=0,0 ,【5日比较涨幅】*0.8,4 ,0 )COLOR1199ff;
STICKLINE( 【5日比较涨幅】>=0,0 ,【5日比较涨幅】*0.6,4 ,0 )COLOR1166ff;
STICKLINE( 【5日比较涨幅】>=0,0 ,【5日比较涨幅】*0.4,4 ,0 )COLOR1133ff;
STICKLINE( 【5日比较涨幅】>=0,0 ,【5日比较涨幅】*0.2,4 ,0 )COLOR1100ff;
STICKLINE( 【5日比较涨幅】<0,0 ,【5日比较涨幅】*1.0,4 ,0 )COLORffff00;
STICKLINE( 【5日比较涨幅】<0,0 ,【5日比较涨幅】*0.8,4 ,0 )COLORffcc33;
STICKLINE( 【5日比较涨幅】<0,0 ,【5日比较涨幅】*0.6,4 ,0 )COLORff9933;
STICKLINE( 【5日比较涨幅】<0,0 ,【5日比较涨幅】*0.4,4 ,0 )COLORff7733;
STICKLINE( 【5日比较涨幅】<0,0 ,【5日比较涨幅】*0.2,4 ,0 )COLORff5500;
【日比较涨幅】:100*((((CLOSE-REF(CLOSE,1))/C)-(INDEXC-ref(INDEXC,1))/INDEXC) ),pointdot,colorff00aa;
FZ散户操盘S
n=9,m1=3,m2=3
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
Var1:=EMA(HHV(HIGH,500),21);
Var2:=EMA(HHV(HIGH,250),21);
Var3:=EMA(HHV(HIGH,90),21);
Var4:=EMA(LLV(LOW,500),21);
Var5:=EMA(LLV(LOW,250),21);
Var6:=EMA(LLV(LOW,90),21);
Var7:=EMA((Var4*0.96+Var5*0.96+Var6*0.96+Var1*0.558+Var2*0.558+Var3*0.558)/6,21);
Var8:=EMA((Var4*1.25+Var5*1.23+Var6*1.2+Var1*0.55+Var2*0.55+Var3*0.65)/6,21);
Var9:=EMA((Var4*1.3+Var5*1.3+Var6*1.3+Var1*0.68+Var2*0.68+Var3*0.68)/6,21);
osc:=c/ma(c,6);
短线:= EMA(SLOPE(osc,8)*11+osc,55)*2,;
散户2:= EMA(osc,8)*2, ;
VarA:=EMA((Var7*3+Var8*2+Var9)/6*1.738,21);
VarB:=REF(LOW,1);
VarC:=SMA(ABS(LOW-VarB),3,1)/SMA(MAX(LOW-VarB,0),3,1)*100;
VarD:=EMA(IF(CLOSE*1.35<=VarA,VarC*10,VarC/10),3);
VarE:=LLV(LOW,30);
VarF:=HHV(VarD,30);
Var10:=IF(MA(CLOSE,58),1,0);
Var11:=EMA(IF(LOW<=VarE,(VarD+VarF*2)/2,0),3)/618*Var10;
Var12:=IF(Var11>40,10,Var11);
Var13:=HHV(HIGH,30);
Var14:=LLV(LOW,30);
Var15:=CLOSE/MA(CLOSE,40)*100<78;
Var16:=CLOSE/MA(CLOSE,60)*100<74;
Var17:=HIGH>LOW*1.051 AND J<55
;
Var18:=Var17 AND COUNT(Var17,5)>=3;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
散户操盘: EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3)/4*5,;
强势:105;
生命线: 50;
地平线:0;
散户: EMA((CLOSE-Var14)/(Var13-Var14)*100,5) ;
同盟: EMA((CLOSE-Var14)/(Var13-Var14)*100,20) ;
DRAWTEXT(CROSS(90,散户),散户操盘,'↓'),colorred,linethick4;
DRAWTEXT(CROSS(同盟,散户) and 散户>50 ,散户操盘,'↓'),colorred,linethick4;
DRAWTEXT((CROSS(散户,同盟) and 散户<30 and count(c>ref(c,1),3)>=1  and (hhv(h,8)/ref(c,1)>=1.10 and ref(c,6)/ref(c,1)<=1.45) ) ,散户,'↑'),colorgreen,linethick4;
0, , ;
DRAWTEXT(IF(散户操盘>108 and h/l>1.07 and (h/c>1.03 or c/v>1.05) ,散户操盘,0) ,散户操盘,'↓'),coloryellow,linethick4;
DRAWTEXT(IF(散户操盘>115 and h/l>1.07 and (h/c>1.03 or c/v>1.05),散户操盘,0) ,散户操盘,'↓'),colorred,linethick4;
DRAWTEXT(CROSS(散户操盘,生命线)and 同盟 < 45,散户操盘,'↑'),colorgreen,linethick4;
DRAWTEXT(CROSS(84,RSI),散户操盘,'↓'),coloryellow,linethick4;
DRAWTEXT(散户2<=短线 and Var18 AND (Var15 OR Var16) and hhv(h,8)/ref(c,1)>=1.18 and ref(c,6)/ref(c,1)<=1.45,散户,'↑'),coloryellow,linethick4;

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    来自: 丰儿 > 《股票》

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>