弓长74 / 通达信指标 / 【精进叁号主图】--在原1号和2号的基础上...

0 0

   

【精进叁号主图】--在原1号和2号的基础上优化 - 指标公式 - 创幻论坛 - 中国最好的...

2009-12-23  弓长74

【精进叁号主图】--在原1号和2号的基础上优化


在大家的关注和建议下,近来对原精进1号和2号主图作了进一步的优化,献给大家。
用于通达信,因没用其它股软,无法提供其它版本,请谅![41楼zw8166024兄将之改为了飞狐版,加分并在此致谢!]
基本用法与源码如下:
1、出现红色立体K线,在均价下出击;
2、出现绿色立体K线,在均价上逃遁;
3、注意均线颜色变化,(红色为持股区、蓝色为变盘区、绿色为持币区)
4、白虚线为出击线基础上10%递加,止盈时可以适当参考。
其余请参考精进1号和2号主图。严格止损,灵活止盈!
注意:出击线和逃遁线较立体K线慢一天出现!之所以慢一天出现,只是为了解决线的粘连问题!其数值为买卖参考价格!因为慢一天出现,在实战中要多加注意红色立体K线当天出现后,当天买的价格越低越好,其余可以回抽时买入。绿色立体K线出现后,风险就在眼前,不问原因,先逃遁再说。

 


A0:=(L+H+C*2)/4;
A1:EMA(A0,14)COLORBLUE,LINETHICK2;
A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
出击:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA,LINETHICK2;
逃遁:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORGREEN,LINETHICK2;
盈10%:IF(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.1,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.1,DRAWNULL),COLORWHITE,POINTDOT;
盈20%:IF(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.2,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.2,DRAWNULL),COLORWHITE,POINTDOT;
盈30%:IF(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.3,DRAWNULL),COLORWHITE,POINTDOT;
盈40%:IF(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.4,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.4,DRAWNULL),COLORWHITE,POINTDOT;
盈50%:IF(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.5,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.5,DRAWNULL),COLORWHITE,POINTDOT;
铁:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK2;
律:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK2;
STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC;
STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF;
STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;
STICKLINE(CROSS(0,A1X),C,O,3,0),COLOR00CC00;
STICKLINE(CROSS(0,A1X),C,O,1,0),COLOR66FF00;
不喜欢止盈比例的可用如下改进版作主图,用法如下:
M表示MACD底背离,
K表示KDJ底背离,
R表示RSI底背离,
MM-G表示日线MACD与周线MACD金叉共振,
MK-G表示MACD与KDJ金叉共振。

A0:=(L+H+C*2)/4;
A1:EMA(A0,14)COLORBLUE,LINETHICK2;
A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
出击:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA,LINETHICK2;
逃遁:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORGREEN,LINETHICK2;
铁:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK2;
律:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK2;
STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC;
STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF;
STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;
STICKLINE(CROSS(0,A1X),C,O,3,0),COLOR00CC00;
STICKLINE(CROSS(0,A1X),C,O,1,0),COLOR66FF00;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26),COLORRED;
DEA:=EMA(DIFF,9),COLORYELLOW;
MACD:=2*(DIFF-DEA),COLORSTICK;
周DIF:="MACD.DIF#WEEK"(12,26,9);
周DEA:="MACD.DEA#WEEK"(12,26,9);
周MACD:="MACD.MACD#WEEK"(12,26,9);
DRAWTEXT(CROSS(DIFF,DEA)AND CROSS(周DIF,周DEA),L*0.91,'MM-G');
A3:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A3+1)>C AND REF(DIFF,A3+1)<DIFF AND CROSS(DIFF,DEA);
A4:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A4+1)>C AND REF("KDJ.K"(9,3,3),A4+1)<"KDJ.K"(9,3,3) AND CROSS ("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A5:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A5+1)>C AND REF("RSI.RSI1"(6,12,24),A5+1)<"RSI.RSI1"(6,12,24) AND CROSS ("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
B4:=CROSS(DIFF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
DRAWTEXT(B1,L*0.99,'M'),COLORWHITE;
DRAWTEXT(B2,L*0.97,'K'),COLORFF00FF;
DRAWTEXT(B3,L*0.95,'R'),COLORYELLOW;
DRAWTEXT(B4,L*0.93,'MK-G'),COLOR0099FF;

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多