分享

实用小公式——万能叠加

2010-02-07   紫气东来

实用小公式——万能叠加


原文:/viewthread.php?tid=3137169
    看到有些学友求助要将多个指标叠加在一起。加来加去的不是你大就是他小 !究竟要怎样才能使配对成功呢?
    很多股软主图都有一个功能:叠加品种。当你使用叠加大盘时都会提示你:更换百分比坐标。
   按此思路:
一、
主图叠加线性指标:
分:=CONST(LLV(指标,90));  百:=CONST(HHV(指标,90))-分;
基点:=CONST(LLV(L,90));   基:=CONST(HHV(H,90))-基点;
CC比:=(指标-分)/百;  XCX:=CC比*基+基点;
QW:XCX,LINETHICK3;

副图叠加线性指标:
分:=CONST(LLV(指标,90));  百:=CONST(HHV(指标,90))-分;
点:=CONST(LLV(主指标,90));   基:=CONST(HHV(主指标,90))-点;
CC比:=(主指标-分)/百;  XCX:=CC比*基+点;
QW:XCX,LINETHICK3;


主图叠加K线:
分:=CONST(LLV(INDEXL,90));  百:=CONST(HHV(INDEXH,90))-分;
点:=CONST(LLV(L,90));   基:=CONST(HHV(H,90))-点;
CC比:=(INDEXC-分)/百;  HH比:=(INDEXH-分)/百;

LL比:=(INDEXL-分)/百;  OO比:=(INDEXO-分)/百;
CX:=CC比*基+点;  HX:=HH比*基+点;  LX:=LL比*基+点;  OX:=OO比*基+点;
STICKLINE(OX>=CX,HX,LX,0,0),COLOR8E0000;
STICKLINE(OX<=CX,HX,LX,0,0),COLORAA00AA;
STICKLINE(OX>=CX,OX,CX,3,0),COLOR8E0000;
STICKLINE(OX<=CX,OX,CX,3,1),COLORAA00AA;


副图叠加K线:
分:=CONST(LLV(L,90));  百:=CONST(HHV(H,90))-分;
基点:=CONST(LLV(主指标,90));   基:=CONST(HHV(主指标,90))-基点;
C比:=(C-分)/百;  H比:=(H-分)/百;  L比:=(L-分)/百;  O比:=(O-分)/百;
CX:=C比*基+基点;  HX:=H比*基+基点;  LX:=L比*基+基点;  OX:=O比*基+基点;
DRAWKLINE(HX,OX,LX,CX);
 



飞狐版:
主图叠加线性指标:

x:=LLV(指标,90);  x:=HHV(指标,90);
L
:=LLV(LOW,90);  H
:=HHV(HIGH,90);
:=x[DATACOUNT];  :=x
[DATACOUNT];
价高:=H[DATACOUNT];  价低:=L
[DATACOUNT];
:=;    :=-;      基点:=价低;      :=价高-基点
;
CC
:=(指标-)/;  XCX:=CC*+基点
;
QW:XCX,LINETHICK3;

副图叠加线性指标:
x
:=LLV(指标,90);  x:=HHV(指标,90);
L
:=LLV(主指标,90);  H:=HHV(主指标,90);
:=x[DATACOUNT];  :=x[DATACOUNT];
主高:=H[DATACOUNT];  主低:=L[DATACOUNT];
:=;    :=-;     :=主低;      :=主高-;
CC
:=(指标-)/;  XCX:=CC*+
;
QW:XCX,LINETHICK3;
 
主图叠加K线:
x
:=LLV(L,90);  x:=HHV(H,90);
L
:=LLV(INDEXL,90);  H:=HHV(INDEXH,90);
:=X[DATACOUNT];  :=X[DATACOUNT];
价高:=H[DATACOUNT];  价低:= L[DATACOUNT];
:=价低;  :=价高-;
:=;   :=-;
CC
:=(INDEXC-)/;  HH:=(INDEXH-)/;
LL
:=(INDEXL-)/;  OO:=(INDEXO-)/;
CX:=CC
*+;  HX:=HH*+;  LX:=LL*+;  OX:=OO*+;
STICKLINE(OX>=CX,HX,LX,0,0),COLOR8E0000;
STICKLINE(OX<=CX,HX,LX,0,0),COLORAA00AA;
STICKLINE(OX>=CX,OX,CX,3,0),COLOR8E0000;
STICKLINE(OX<=CX,OX,CX,3,1),COLORAA00AA;

副图叠加K线:
KLINE(O,H,L,C,1);

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。
    转藏 全屏 打印 分享 献花(0

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多