beiquan / 我的图书馆 / 炒股指标公式集锦B

分享

   

炒股指标公式集锦B

2010-02-18  beiquan
炒股指标公式集锦 B【转百度:张喜亮】
2009-08-10 13:22

太准了

var1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
var2:=HIGH-REF(HIGH,1);
var3:=REF(LOW,1)-LOW;
var4:=SUM(IF(var2>0 AND var2>var3,var2,0),25);
var5:=SUM(IF(var3>0 AND var3>var2,var3,0),25);
var6:=var4*100/var1;
var7:=var5*100/var1;
var8:=MA(ABS(var7-var6)/(var7+var6)*100,15);
var9:=(var8+REF(var8,15))/2;
A:=(var7>var6 AND var7>25 AND var6<25);
B:ZIG(3,50/5)*100,colorwhite;
g:MA(B,2),coloryellow;
D:=CROSS(B,g)*1000,colorred;
W:=cross(g,B)*1000,colorblue;
E:=REF(INDEXC,1);
F:=SMA(MAX(INDEXC-E,0),3,1)/SMA(ABS(INDEXC-E),3,1);
var10:=F AND F<8;
var11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
var12:=SMA(var11,3,1);
var13:=SMA(var12,3,1);
var14:=var13 AND var13<20;
mm:=A AND D AND var10 AND var14 ;
DRAWTEXT(W=1000,b*1.05,'卖' ),COLOR00ff00;
DRAWTEXT(D=1000,b*1.05,'买'),COLORred;


预警权证盘中
VAR1D:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR1E:=EMA(VAR1D,30);
VAR1F:=2*(VAR1D-VAR1E)*10;
VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2);
VAR25:=IF(VAR1F>0.015,VAR20,0)/45;
拉升资金: VAR25,COLORRED;
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
主力资金: IF(VAR28>0.1,VAR29,0)*5;
趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV

(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2;

顶警: 90;
卖警: IF(趋势>=85,50,0),STICK,LINETHICK3,COLORRED;
卖出: IF(CROSS(趋势,顶警),100,0),STICK,LINETHICK3,COLORRED;
DRAWTEXT(卖出,80,'快逃!'),COLORRED;


底警: 10,COLORGREEN;
买警: IF(趋势<=10,50,0),STICK,LINETHICK3,COLORYELLOW;
买入: IF(CROSS(趋势,底警),100,0),STICK,LINETHICK3,COLORFF66FF;
DRAWTEXT(买入,40,'关注!'),COLORYELLOW;
TT:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4/C*100>126;
AA:=REF(LLV(LOW,20),30);
BB:=LLV(CLOSE,30);
CC:=LOW<BB;
DD:=CLOSE<AA;
EE:=CC AND DD AND CLOSE<OPEN;
XG:REF(EE,1)>0 AND CLOSE<OPEN;
TT:MA(C,3)/L*100>111;
TJ1:MA(C,3)/L>=1.17;

 

 

实用权证公式
权证五一
VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21)
;
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
VAR11:=EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10;
VAR12:=IF(VAR11>40,10,VAR11);
STICKLINE(VAR12>8,0,VAR12,3,1),COLORMAGENTA;
VAR13:=HHV(HIGH,30);
VAR14:=LLV(LOW,30);
D: EMA((CLOSE-VAR14)/(VAR13-VAR14)*100,5), , COLORRED LINETHICK2;
K: EMA((CLOSE-VAR14)/(VAR13-VAR14)*100,20), , LINETHICK2 COLORFF9933;
K1:=BACKSET(K>REF(K,1),2);
强K:IF(K1,K,DRAWNULL),COLOR33FFFF,LINETHICK2;
底: 5, ,POINTDOT LINETHICK2 COLORMAGENTA;
DRAWTEXT(CROSS(底,D),D+10,'机会'),COLORWHITE;
强弱分界: 50 ,POINTDOT ;
DRAWTEXT(FILTER(D>90,13),D-10,'风险'), COLORWHITE;
DRAWTEXT(CROSS(K,D) AND D>55,D-10,'死叉'), COLORWHITE ;
DRAWTEXT(CROSS(D,K) AND D<34,D+10,'金叉'), COLORYELLOW;
0, POINTDOT LINETHICK2 COLORMAGENTA;

稳赢权证
财:EMA(CLOSE,S) - EMA(CLOSE,P),COLORRED,LINETHICK2;
神:EMA(财,M),COLORGREEN,LINETHICK1;
强弱分水岭:0, COLORFF00FF,LINETHICK5,POINTDOT;
STICKLINE(财>神,财,神,2,0),COLORYELLOW;

 

1.BDZJ波段真准
N:=21;
V1:=MA(CLOSE,N);
波段: ((20)*(CLOSE-V1))/(STD(CLOSE,N)),Linethick3,CoLor00FFFF;
XY1:=((CLOSE-MA(CLOSE,34))/(MA(CLOSE,34)))*(100);
XY2A:=((CLOSE-MA(CLOSE,42))/(MA(CLOSE,42)))*(100);
XY3:=((CLOSE-MA(CLOSE,67))/(MA(CLOSE,67)))*(100);
XY:=(XY1+XY2A)/(2)-XY3;
XX1:=((0-100)*(HHV(HIGH,34)-CLOSE))/(HHV(HIGH,34)-LLV(LOW,34));
XX2:=((0-100)*(HHV(HIGH,42)-CLOSE))/(HHV(HIGH,42)-LLV(LOW,42));
XX2B:=((0-100)*(HHV(HIGH,72)-CLOSE))/(HHV(HIGH,72)-LLV(LOW,72));
XX:=EMA((XX1+XX2B)/(2)-XX2B,6);
XZ1:=((SMA(MAX(CLOSE-REF(CLOSE,1),0),19,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),19,1)))*(100);
XZ2:=((SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),34,1)))*(100);
XZ3:=((SMA(MAX(CLOSE-REF(CLOSE,1),0),72,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),72,1)))*(100);
XD:=EMA(((XZ1+XZ2)/(2)-XZ3)*(5),6);
XK:=(((0-1)*(XY+XX+XD))/(3))*(1.5);
多头:XD,Linethick2,CoLor0000FF;
空头:XK,Linethick2,CoLor00FF00;
中线: (多头+空头)/(2),CoLorFFFFFF;
STICKLINE((多头>=REF(多头,1)),多头,中线,3,0),CoLor0000FF;
多空差:=多头-空头;
DRAWICON(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),中线,1),CoLor0000FF;
DRAWICON(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),中线,2),CoLor008000;

2.BOLLBBI权证公式
BBI: (MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/(4),Linethick2,CoLorFF99FF;
M3:EMA(CLOSE,3),CoLorFF9900;
M5:EMA(CLOSE,5),CoLorFFFFFF;
M10:=EMA(CLOSE,10);
M26:EMA(CLOSE,26),CoLor0000FF;
M60:EMA(CLOSE,60),Linethick2,CoLor00FF00;
M120:EMA(CLOSE,120),CoLorAAAAAA;
M250:EMA(CLOSE,250),CoLor00FFFF;
UU:BBI+(3)*(STD(BBI,10)),POINTDOT,Linethick3,CoLorFF9900;
LL:BBI-(3)*(STD(BBI,10)),POINTDOT,Linethick3,CoLorFF5500;
N:=13;
AA:BBI,CoLor800080;
IF((AA>=REF(AA,1)),AA,0),circledot,Linethick2,CoLor00FFFF;
IF((AA<REF(AA,1)),AA,0),circledot,Linethick2,CoLorFF9900;
STICKLINE((CLOSE>AA),LOW,HIGH,0.1,1),CoLor0000FF;
STICKLINE((CLOSE>AA),CLOSE,OPEN,4,1),CoLor0000FF;
STICKLINE((CLOSE>AA),CLOSE,OPEN,4,1),CoLor0000FF;
STICKLINE((CLOSE<AA),CLOSE,OPEN,4,1),CoLorFFFF00;
STICKLINE((CLOSE<AA),CLOSE,OPEN,4,1),CoLor00FF00;
STICKLINE((CLOSE<AA),LOW,HIGH,0.1,1),CoLor00FF00;

3.KDJVV权证公式
短J:"KDJ.J"(3,3,3),CoLorAAAAAA;
MA短J:EMA(短J,3),CoLorAAAADD;
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA(((VAR6-VAR7)/(VAR8-VAR7))*(100),13);
VARA:=EMA((0.667)*(REF(VAR9,1))+(0.333)*(VAR9),2);
中多:VAR9,CoLorFFFFFF;
中空:EMA((0.382)*(REF(VAR9,2))+(0.618)*(VAR9),12),CoLorFFFF00;
STICKLINE((VAR9>VARA),VAR9,VARA,6,0),CoLorFFFFFF;
STICKLINE((VAR9<=VARA),VAR9,VARA,6,0),CoLorFFCC66;
RSV:=((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89)))*(100);
K89:=SMA(RSV,30,1);
长K89:K89,CoLor0000FF;
D89:=SMA(K89,3,1);
长D89:D89,CoLorFF00FF;
D89A:=(D89)*(0.998);
STICKLINE((D89>=REF(D89,1)),D89,REF(D89,1),5,0),Linethick2,CoLorFF99FF;
STICKLINE((D89<REF(D89,1)),D89,REF(D89,1),5,0),Linethick2,CoLor0000FF;
STICKLINE((D89A>=REF(D89A,1)),D89A,REF(D89A,1),5,0),Linethick2,CoLorFF99FF;
STICKLINE((D89A<REF(D89A,1)),D89A,REF(D89A,1),5,0),Linethick2,CoLor0000FF;
0,CoLorFFFFFF;
20,POINTDOT,CoLorFFFFFF;
50,CoLorFFFFFF;
80,POINTDOT,CoLorFFFFFF;
100,CoLorFFFFFF;
MV3:=EMA(VOL,3);
MV60:=EMA(VOL,60);
量乖离率360: ((MV3-MV60)/(MV60))*(20),Linethick2,CoLor00FF00;
DRAWICON(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),20,1),CoLor000080;
DRAWICON(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),90,2),CoLor800080;
BIAS20:=((CLOSE-MA(CLOSE,20))/(MA(CLOSE,20)))*(100);
起航天数:=BARSLAST((BARSLAST((BIAS20>0) AND (REF(BIAS20,1)>0))>0));
休整天数:=BARSLAST((BARSLAST((BIAS20<0) AND (REF(BIAS20,1)<0))>0));
STICKLINE(起航天数,100,120,3,0),CoLor0000FF;
STICKLINE(休整天数,100,120,3,0),CoLor00FFFF;
DRAWTEXT((起航天数=1),(-5),'起'),CoLor0000FF;
DRAWTEXT((起航天数=1),(-10),'航'),CoLor0000FF;
DRAWTEXT((休整天数=1),(-5),'休'),CoLor00FFFF;
DRAWTEXT((休整天数=1),(-10),'整'),CoLor00FFFF;

4.MACD521权证公式(未来)
DIFF: (EMA(CLOSE,5)-EMA(CLOSE,21))*(4),Linethick3,CoLor00FFFF;
DEA:EMA(DIFF,5),Linethick3,CoLorFF99FF;
MACD: (2)*(DIFF-DEA),ColorStick,CoLor00FF00;
MACDA:MACD,CoLor0000FF;
0,CoLorFFA2AF;
MV3:=EMA(VOL,3);
MV60:=EMA(VOL,60);
量乖离率360: ((MV3-MV60)/(MV60))*(0.5),Linethick2,CoLor00FF00;
DRAWICON(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),(-0.05),1),CoLor008000;
DRAWICON(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),0.5,2),CoLorFF0000;
标签: 股票   公式   .

 

涨停先锋

{操盘线42}
MA5:MA(CLOSE,5),ColorFFFfff,linethick1;
MA10:MA(CLOSE,10),Color00Ffff,linethicK1;
MA21:MA(CLOSE,21),Color00ff00,linethick1;
MA30:MA(CLOSE,30),ColorFF00ff,linethick1;
MA60:MA(CLOSE,60),Color0000ff,linethick1;
MA120:MA(CLOSE,120),ColorFFff00,linethick1;
买线:EMA(C,2),color000000;
卖线:EMA(SLOPE(C,21)*20+C,42),pointdot,color000000;
BUY:=cross(买线,卖线);
SEL:=cross(卖线,买线);
drawtext(buy,LOW*0.99,'B'),colorf00ff0,linethick5;
drawtext(sel,HIGH*1.01,'S'),colorwhite,linethick5;
stickline(买线>=卖线,low,high,0.1,0),colorred;
stickline(买线>=卖线,close,open,4.5,0),color0000AA;
stickline(买线>=卖线,close,open,3,0),color0000CC;
stickline(买线>=卖线,close,open,2,0),color0000DD;
stickline(买线>=卖线,close,open,1,0),color0000FF;
stickline(买线<卖线,close,open,1,0),colorEEEE00;
stickline(买线<卖线,close,open,2,0),colorDDDD00;
stickline(买线<卖线,close,open,3,0),colorCCCC00;
stickline(买线<卖线,close,open,4.5,0),colorAAAA00;
stickline(买线<卖线,low,high,0.1,0),colorFFff00;
stickline(cross(买线,卖线) or cross(卖线,买线),open,close,3.5,0),coloryellow

 


突破即涨

动态止损度:=5;
黑:=0;{下跌通道黑色K线开关}
离L:=0;{乖离提示开关}
提示:=0;{买卖文字提示开关}
布林M:=0;{开关}

MMA:=0;
五:MA(CLOSE,5),COLORWHITE;
十:MA(CLOSE,10),COLOR00FFFF;
M18:=MA(CLOSE,18),COLORRED;
离基:=五;
离O:=离基*1.20,COLOR555555;
离A:离基*1.15,COLOR555555;
离B:离基*1.10,COLOR555555;
离C:离基*0.90,COLOR555555;
离D:=离基*0.85,COLOR333333;
EXP50:=EXPMA(CLOSE,50),COLORGREEN;
MA30:MA(CLOSE,30),LINETHICK1,COLORRED;
MA60:MA(CLOSE,60),COLORGREEN;


β0:=(H-L)/2+L,LINETHICK0;
α:=β0,LINETHICK0;
β:=REF(β0,1),LINETHICK0,COLORGREEN;
γ:=REF(β0,2),LINETHICK0,COLORMAGENTA;
{涨:PLOYLINE(C>REF(C,1),CONST(C)),COLOR0000AA,LINETHICK1;
跌:PLOYLINE(C<REF(C,1),CONST(C)),COLOR00AA00,LINETHICK1;}

高:PLOYLINE(1,CONST(HHV(H,50))),COLOR770077,LINETHICK1;
低:=PLOYLINE(1,CONST(LLV(L,50))),COLOR777700,LINETHICK1;
中:=PLOYLINE(1,(高-低)/2+低),COLOR005555,LINETHICK4;
止损价:=CONST(HHV(C,5)*(100-动态止损度)/100);
止:PLOYLINE(CONST(C)<=止损价,止损价),COLOR888800,LINETHICK4;

DRAWTEXT(DYNAINFO(7)<=止损价 AND ISLASTBAR,止损价*1.05,'止损');


AA:=CLOSE/REF(C,1)>=1.09;
BA:=CLOSE/REF(C,1)>=1.09;
DRAWKLINE(H,O,L,C);
STICKLINE(AA,O,C,2.5,1),COLORYELLOW;
MA1:=MA(CLOSE,5),COLORRED;
MA2:=MA(CLOSE,10),COLORYELLOW;
MA3:=MA(CLOSE,20),COLOR770077;
E50:=EXPMA(CLOSE,50),LINETHICK1,POINTDOT,COLORLIGREEN;
E100:=EXPMA(CLOSE,100),POINTDOT,COLORGRAY;
MA181:MA(C,181),COLORGRAY;
{MA60:=MA(C,60),COLOR007700;}
{周:IF( MMA=1 ,MA2,DRAWNULL),COLORYELLOW,LINETHICK1;
月:IF( MMA=1 ,MA3,DRAWNULL),COLORWHITE,LINETHICK1;
季:IF( MMA=1 ,MA4,DRAWNULL),COLORGREEN,LINETHICK1;}

{IF(C>E50 ,E50,DRAWNULL),COLOR00FF00,LINETHICK1;}

IF(CONST(α>β) AND DYNAINFO(7)>0,DYNAINFO(7),DRAWNULL),COLOR000088,LINETHICK1;
IF(CONST(α<=β)AND DYNAINFO(7)>0 ,DYNAINFO(7),DRAWNULL),COLOR008800,LINETHICK1;
IF(CONST(α>β) AND DYNAINFO(7)>0 AND DYNAINFO(7)>=高*0.99,DYNAINFO

(7),DRAWNULL),COLOR000088,LINETHICK1;
IF(CONST(α<=β)AND DYNAINFO(7)>0 AND DYNAINFO(7)<=低*1.01 ,DYNAINFO

(7),DRAWNULL),COLOR008800,LINETHICK1;


N1:=12;
N2:=26;
N3:=9;


DIFF:=(EMA(CLOSE,N1) - EMA(CLOSE,N2));
DEA:=EMA(DIFF,N3);
MACD:=(2 * (DIFF - DEA));
MACD2:=MACD;

SARH:=CLOSE>SAR(4,2,20);

 

 

 

 

{IF(C<MA3 ,MA1,DRAWNULL),COLOR555555,LINETHICK1;}
{IF(C<MA3 ,MA2,DRAWNULL),COLOR222222,LINETHICK1;}

{IF(五>=REF(五,1) ,离A,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五>=REF(五,1) ,离B,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五<=REF(五,1) ,离C,DRAWNULL),COLOR00FF00,LINETHICK1;
IF(五<=REF(五,1) ,离D,DRAWNULL),COLOR00FF00,LINETHICK1;}

五V:=MA(V,5);

{IF(五V>=REF(五V,1) ,离A,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五V>=REF(五V,1) ,离B,DRAWNULL),COLOR0000FF,LINETHICK1;
IF(五V<=REF(五V,1) ,离C,DRAWNULL),COLOR00FF00,LINETHICK1;
IF(五V<=REF(五V,1) ,离D,DRAWNULL),COLOR00FF00,LINETHICK1;}


{IF(五<REF(五,2) AND 离L=0,离A,DRAWNULL),COLOR555555,LINETHICK1;
IF(五<REF(五,2) AND 离L=0,离D,DRAWNULL),COLOR555555,LINETHICK1;}

TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

 

 


STICKLINE(C<MA3 AND 黑=1,H,L,0,0),COLOR555555;
STICKLINE(MA1<MA3 AND 黑=1,O,C,2.5,1),COLOR555555;

STICKLINE(BA AND C<MA3,O,C,2.7,1),COLORWHITE;
{DRAWICON(MACD>REF(MACD,1) AND CROSS(C,MA3) AND 提示=0 ,L,1);}

{DRAWICON(REF(C>MA3 AND 提示,1) AND CROSS(MA(C,5),C),H,2);}

N:=14;
M:=6;
TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/TR;
MDI:=DMM*100/TR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=EXPMEMA(ADX,M);
DMIJX:=CROSS(PDI,MDI) AND C>O ;
{STICKLINE(DMIJX,H,L,0,1),COLORYELLOW;
STICKLINE(DMIJX,O,C,2.7,0),COLORYELLOW;}

{DRAWICON(DMIJX AND 提示=0,L,1);}

 


{DRAWTEXT(H>离A,离A/0.99,'★'),COLORYELLOW;}

头上边:=MAX(O,C),NODRAW;
头下边:=MIN(O,C),NODRAW;
垂头:=ABS(O-C),NODRAW;{垂头}
长针:=(头下边-L),NODRAW;{长针}
垂:=长针/垂头>2 AND (H-头上边)<=长针 AND L<REF(L,1) AND O<REF(C,1),NODRAW;


DRAWTEXT(垂 AND L<=LLV(L,3) AND L<离C AND 提示,L/1.01,'针') AND 提示,COLORGREEN,LINETHICK4;
DRAWTEXT(H>MA(CLOSE,5)*1.07 AND ISLASTBAR AND 提示,H*1.01,'离!'),COLORGREEN,LINETHICK2;
DRAWTEXT(L<MA(CLOSE,5)*1.005 AND L>MA(CLOSE,5) AND 提示=0 AND H<MA(CLOSE,5)*1.07 AND

ISLASTBAR,L/1.02,'低吸'),COLORGREEN,LINETHICK2;

 

{////MACD反身向上////}
{MACD红缩:=REF(MACD,1)>MACD AND MACD>0;
DRAWTEXT(REF(EVERY(MACD红缩,3),1)
AND MACD>REF(MACD,1) AND C>MA(C,22) AND 提示=0,L/1.02,'启动'),COLORWHITE;
}
{////MACD反身向上2////}
{MACD红缩2:=REF(MACD,1)>MACD AND MACD>0;
DRAWTEXT(REF(EVERY(MACD红缩2,2),1)
AND MACD>REF(MACD,1) AND C>MA(C,22) AND EVERY(DIFF>0,3) AND 提示=0,L/1.02,'起

动'),COLORWHITE;
}

{突破买进(源码)}

{DRAWTEXT(DYNAINFO(7)>0 AND ISLASTBAR ,HIGH,'("DYNAINFO(7)")');}
上5日:=REF(EVERY(C<MA1,2),1) AND CROSS(C,MA1);
STICKLINE(上5日,H,L,0,0),COLORFF00FF;
{STICKLINE(上5日,O,C,2.7,0),COLOR3366FF;}
STICKLINE(上5日,O,C,2.7,0),COLORFF00FF;
DRAWICON(上5日,L,1);
破5日:=REF(EVERY(C>MA1,4),1) AND CROSS(MA1,C);
DRAWICON(破5日,H,2);


DT:=REF(CLOSE/REF(C,1),1)<=0.95;
DRAWTEXT(AA AND DT AND CURRBARSCOUNT<60 ,H,'急挖坑'),COLORGREEN;

SC1:=MACD.MACD<0;
SC2:=CROSS(十,五);
SC3:=MA(V,5)<MA(V,10);
SC:=SC1 AND SC2 AND SC3 ;
DRAWTEXT(SC AND CURRBARSCOUNT<10 ,HHV(H,5),'三死叉'),COLORWHITE;

JC1:=MACD.MACD>0;
JC2:=CROSS(五,十);
JC3:=MA(V,5)>MA(V,10);
JC:=JC1 AND JC2 AND JC3 ;
DRAWTEXT(JC AND CURRBARSCOUNT<20 ,LLV(L,5),'后金叉'),COLORYELLOW;

{ZS:=CROSS(DMI.ADXR,DMI.ADX);
DRAWTEXT(ZS AND CURRBARSCOUNT<10 ,HHV(H,5),'转势'),COLORRED;}

{IF(五<REF(五,1),五,DRAWNULL),COLOR888888,LINETHICK1;};

{XQK:=H<REF(L,1) ;
DRAWTEXT(XQK AND CURRBARSCOUNT<20 ,H,'□□□□□□□□□□□□'),COLOR999999;
SQK:= L>REF(H,1);
DRAWTEXT(SQK AND CURRBARSCOUNT<20 ,L,'□□□□□□□□□□□□'),COLORRED;};


DRAWTEXT(CROSS(H,离B) AND CURRBARSCOUNT<10 ,HHV(H,3),'超乖离'),COLORYELLOW;
DRAWTEXT(CROSS(H,离A)   AND CURRBARSCOUNT<10 ,HHV(H,3),'超乖离'),COLORYELLOW;
DRAWTEXT(CROSS(离C,L) AND CURRBARSCOUNT<10 ,LLV(L,3),'负乖离'),COLORWHITE;
DRAWTEXT((C<MA(C,5) OR MA(C,5)<MA(C,10)) AND CURRBARSCOUNT<2,HHV(H,5)*1.04,'MA5

下'),COLORRED;
DRAWTEXT((C<MA(C,5) OR MA(C,5)<MA(C,10)) AND CURRBARSCOUNT<2 ,HHV(H,5)*1.01,'不持

股'),COLORRED;

 

非常棒

EMA13:=EMA(C,13),COLORWHITE;
EMA21:=EMA(C,21),COLORYELLOW;
EMA34:=EMA(C,34),COLORFF00FF;
EMA60:=MA(C,60),COLORFFCC66;
VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLORLIRED;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),COLORGREEN;
DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1);
DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2);
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;
S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA

(CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
A0:=(L+H+C*2)/4;
A1:EMA(A0,14)COLORBLUE,LINETHICK2;
A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS

(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2};
逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS

(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2};
买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK3;
卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK3;
STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC;
STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF;
STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;

 

百战百胜


七天线:MA(C,7),COLORGRAY;
工作线:(EMA(C,17)) ,POINTDOT,LINETHICK4,COLORYELLOW;
生命线:(MA(C,25)) ,LINETHICK2,COLORMAGENTA;
不惑线:=(MA(C,43)) ,COLORCYAN;
姊妹线:=(EMA(C,50)) ,CIRCLEDOT,COLORWHITE;
九号线:=(MA(C,99)) ,LINETHICK1,COLOR0099FF;
卖线:EMA(SLOPE(C,21)*21+C,42),COLORRED,LINETHICK2;
A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
A4:=EMA(C,10);
A5:=REF(C,2);
A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C - A5)),6,1))) * 100;
A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
DRAWTEXT((CROSS(A4,A3)),L,'△'),COLORYELLOW;
DRAWTEXT(A7,H,'○'),LINETHICK3,COLORGREEN;
A8:=LLV(L,21);
A9:=HHV(H,21);
A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
A13:=LLV(L,55);
A14:=HHV(H,34);
A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
A16:=(A11 + A15) / 2;
A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
A18:=EMA(A16,5);
A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
A20:=CROSS(A10,A11);
A21:=(CROSS(A10,A19)) AND (A19 < 30);
A22:=A21 * 0.6;
DRAWTEXT((A22 = 0.6),L,'◇'),COLORYELLOW;
DRAWTEXT((A20 = 1),L,'◇'),COLORWHITE;
A23:=((C + L) + H) / 3;
A24:=EMA(A23,6);
A25:=EMA(A24,5);
A26:=CROSS(A24,A25);
DRAWICON(A26,(LOW*0.98),5),COLORMAGENTA;
DRAWICON(CROSS(卖线,C),(H*1.02),4);
STICKLINE(((C >= 工作线) AND (C >= O)),O,C,3,1),COLORRED;
STICKLINE(((C >= 工作线) AND (C <= O)),O,C,3,0),COLORRED;
STICKLINE(((C < 工作线) AND (C >= O)),O,C,3,1),COLORGREEN;
STICKLINE(((C < 工作线) AND (C <= O)),O,C,3,0),COLORGREEN;

 

出紫色买

A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV

(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)

-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
{FILLRGN(趋势,80,趋势>80);}
DRAWICON(CROSS(趋势,0),0,1);
{FILLRGN(0,A09,(A09 > 0 AND (趋势<20 OR 趋势>REF(趋势,1)AND 趋势<50))),COLORFFFF00;}
机构建仓区:0,LINETHICK0,COLORFFFF00;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
{STICKLINE(趋势<=13,0,20,5,0),COLORCC9900;
DRAWTEXT(FILTER(趋势<=13,15),30,'准备现金'),COLORCC9900;
STICKLINE(趋势<=13 AND VAR4>13,0,50,5,0),COLOR0099FF;}
VAR5:=FILTER((趋势<=13 AND VAR4>13),10);
DRAWTEXT(VAR5,60,'买入'),COLOR0099FF;
STICKLINE(趋势>=90 AND VAR4,0,30,5,0),COLORGRAY;
VAR6:=FILTER((趋势>=90 AND VAR4),10);
DRAWTEXT(VAR6,40,'清仓'),COLORGRAY;
VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;
STICKLINE(VAR9>90,100,105,10,2),COLORRED;
VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;
DRAWTEXT(IF(CROSS(VAR9,VAR10) AND VAR9>87,95,0),88,'险'),COLOR00FF00;
DRAWICON(CROSS(90,VAR9),95,5);
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
火焰山:EMA(IF(LOW<=VAR7 AND 趋势<40,(VAR11+VAR12),0),3)/618,COLORRED,LINETHICK2;
STICKLINE(火焰山>0,0 ,火焰山*1.2,8,0 ),COLORRED;
VAR13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
VAR14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趋势线: 趋势,COLORYELLOW,LINETHICK2;
VAR16:=MAX(EMA(VAR13,2)-EMA(VAR14,5),0)*200;
VAR17:=EMA(VAR16,5);
波浪峰:VAR17,STICK,COLORFF00FF;
STICKLINE(VAR17<REF(VAR17,1),0,VAR17,1,0),COLOR00FF00;
VAR18:=MA(趋势线,8);
IF(CROSS(VAR2,VAR18) AND VAR2<15,50,0),COLORRED;
DRAWTEXT(CROSS(趋势线,VAR2)AND 趋势线>REF(趋势线,1)AND 趋势线<50,50,'追涨'),COLORFF0000;


指标跟踪

平衡:EMA(C,20)COLORYELLOW;
上轨:平衡 + 2*STD(C,20),LINETHICK2,COLORMAGENTA;
下轨:平衡 - 2*STD(C,20),LINETHICK2,COLORGREEN;
IF(平衡>REF(平衡,1),平衡,DRAWNULL),COLORRED;
IF(平衡=REF(平衡,1),平衡,DRAWNULL),COLORYELLOW;
IF(平衡<REF(平衡,1),平衡,DRAWNULL),COLORGREEN;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORFF7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORFFBB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORFFDD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0.5,0 ),COLORFFFF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0) ,COLOR0000FF;
VAR9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND

CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV

(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
红持:=VAR9Q;
    STICKLINE(VAR9Q,C,(O+C)/2,3,0),COLOR000055;
    STICKLINE(VAR9Q,C,(O+C)/2,2,0),COLOR000077;
    STICKLINE(VAR9Q,C,(O+C)/2,1,0),COLOR0000BB;
    STICKLINE(VAR9Q,C,(O+C)/2,0.5,0),COLOR0000FF;
VARAQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
粉变:=VARAQ;
    STICKLINE(VARAQ,C,(O+C)/2,3,0),COLORFF11FF;
    STICKLINE(VARAQ,C,(O+C)/2,2,0),COLORFF55FF;
    STICKLINE(VARAQ,C,(O+C)/2,1,0),COLORFF99FF;
    STICKLINE(VARAQ,C,(O+C)/2,0.5,0),COLORFFDDFF;
VARBQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND

C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)!=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4)

AND C<REF(C,1) AND C<REF(C,2);
灰跌:=VARBQ;
    STICKLINE(VARBQ,C,(O+C)/2,3,0),COLOR333333;
    STICKLINE(VARBQ,C,(O+C)/2,2,0),COLOR777777;
    STICKLINE(VARBQ,C,(O+C)/2,1,0),COLORBBBBBB;
    STICKLINE(VARBQ,C,(O+C)/2,0.5,0),COLORFFFFFF;
VARCQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND

REF(C,2)<REF(C,4) AND C>=REF(C,1);
绿买:=VARCQ;
    STICKLINE(VARCQ,O,(O+C)/2,3,0),COLOR003300;
    STICKLINE(VARCQ,O,(O+C)/2,2,0),COLOR007700;
    STICKLINE(VARCQ,O,(O+C)/2,1,0),COLOR00BB00;
    STICKLINE(VARCQ,O,(O+C)/2,0.5,0),COLOR00FF00;
VARDQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF

(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
蓝抛:=VARDQ;
STICKLINE(VARDQ,O,(O+C)/2,3,0),COLORFF1100;
STICKLINE(VARDQ,O,(O+C)/2,2,0),COLORFF5500;
STICKLINE(VARDQ,O,(O+C)/2,1,0),COLORFF9900;
STICKLINE(VARDQ,O,(O+C)/2,0.5,0),COLORFFDD00;
Y1:=REF(EMA(DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9),3),1);
DRAWTEXT(CROSS(CLOSE,Y1),LOW,'[买进]'),COLORYELLOW;
STICKLINE(CROSS(Y1,CLOSE),H*1.05,H,0,0),COLORWHITE;
DRAWTEXT(CROSS(Y1,CLOSE),HIGH*1.05,'[卖出]'),COLORWHITE;
VAR1W:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2W:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3W:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWTEXT(CROSS(VAR2W,MA(VAR3W,6)),LOW -0.6,'(买)'),COLORFF99FF;
DRAWTEXT(CROSS(MA(VAR3W,6),VAR1W),HIGH +0.9,'(卖)'),COLORCCFF13;
VAR3P:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0,

91, 0);
STICKLINE(VAR3P>90,L,L*0.92,0,0),COLORFF00FF;
DRAWTEXT(VAR3P>90,LOW*0.92,'追涨'),COLORFF00FF;
SS:=MA((LOW+HIGH+CLOSE)/3,5)>REF(MA((LOW+HIGH+CLOSE)/3,5),1) AND REF(MA

((LOW+HIGH+CLOSE)/3,5),1)<REF(MA((LOW+HIGH+CLOSE)/3,5),2);
SC:=L<HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND H>HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND C>REF(C,1)

AND C>O;
MR:=SC AND COUNT(SS,2);
买:=MR AND NOT(REF(MR,1));
STICKLINE(买,L,L*0.95,0,0),COLORRED;
DRAWTEXT(买,L*0.95, '必涨'),COLORRED;
多方:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1);
STICKLINE(CROSS(78.89,多方),H+1.5,H,0,0),COLOR00FF00;
DRAWTEXT(CROSS(78.89,多方),H+1.5,'(逃顶)'),COLOR00FF00;
A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV

(L,55))*1,5,1);
A2:=(EMA(A1,5)-REF(EMA(A1,5),1))/REF(EMA(A1,5),1)*1;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;
DRAWTEXT(CROSS(A1,EMA(A1,5))AND EMA(A1,5)<A5,L*0.98,'(黑马)'),COLORYELLOW;
VAR1:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*1;
VAR2:=SMA(VAR1,3,1)*100;
趋势线:=SMA((SMA(VAR2,3,1)*VAR1),3,1)*1;
VAR9:=CROSS(趋势线,(SMA(VAR2,3,1)*VAR1)) AND (SMA(VAR2,3,1)*VAR1)>8;
DRAWTEXT(VAR9 AND COUNT(VAR9,1)=1,H+0.6,'逃'), LINETHICK2,COLORYELLOW;
DRAWICON(FILTER(CROSS(-"WR.WR1"(14,14),(0 - 81)),10),L-0.2,1);
DRAWICON(FILTER(CROSS((0 -19),-"WR.WR1"(14,14)),10),H,2);

 

保驾护航

MID := MA(CLOSE,7);
HH:=MID + 2*AVEDEV(CLOSE,10);
LL:=MID - 2*AVEDEV(CLOSE,10);
RSV:= (CLOSE-MID)/AVEDEV(CLOSE,20)*7;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D;
STICKLINE(K>D,K,D,2,1),COLORYELLOW;
STICKLINE(K<D,K,D,2,0),COLORBLUE;
VAR77:=HHV(HIGH,5);
VAR88:=LLV(LOW,5);
趋势:=EMA((CLOSE-VAR88)/(VAR77-VAR88)*7,5);
VAR99:=EMA(CLOSE,6)-EMA(CLOSE,12);
VAR100:=5*EMA(VAR99,9);
VAR110:=1*(VAR99-VAR100);
VAR120:=IF(VAR110>0,6*VAR110,0);
买:=FILTER(趋势<VAR120 AND 趋势<REF(趋势,3) AND 趋势>REF(趋势,1) AND
趋势<3,1);
DRAWICON(买>0,K*1.1,1);
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),2,1),COLORRED;{红1}
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),2,0),COLORFFCC66;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,1),COLORYELLOW;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2,2),COLOR00FF00{98FD};
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00FFFF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR00C8FF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR10ECFF;
{STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR10FFFF;}
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00D900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR93FFD1;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR93FF22;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR24FF22;
DRAWICON((CROSS(K,MID) AND VAR1>0),0,1);
XG:(K>D) AND VAR19>0,COLOR0095FF,LINETHICK3;
XG2:CROSS(K,MID) AND VAR1>0,COLORLIGREEN,LINETHICK3;

 

三线合一

FL:MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1)),COLOR009900,LINETHICK2;
FS:MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1),COLOR00FF00,LINETHICK2;
CG:IF(MA(CLOSE,17)<FS,FS,MA(CLOSE,17)),COLORCCFF66,LINETHICK2;


FL:MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1)),COLOR009900,LINETHICK2;
FS:MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1),COLOR00FF00,LINETHICK2;
CG:IF(MA(CLOSE,17)<FS,FS,MA(CLOSE,17)),COLORCCFF66,LINETHICK2;
年线:=EMA(C,250);
A:CG-(EMA(C,3)-CG),COLORFF8080;
QQ:年线-(EMA(C,3)-年线),COLORFF80FF,LINETHICK2;
K1:=BACKSET(CG>REF(CG,1),2);
IF(K1,CG,DRAWNULL),COLOR00FFFF,LINETHICK2;


通达信主图公式:垂帘听股
MA5:=MA(C,5);
A:=(3*C+L+O+H)/6;
垂帘:(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)
+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)
+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)
+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210,COLORRED,POINTDOT;
听股:MA(垂帘,13),COLORFFCCCC,CIRCLEDOT;
ZAR1:=SLOPE(EMA(CLOSE,2),5)*15+C;
ZAR2:=EMA(ZAR1,5);
ZARA:=EMA(EMA(EMA(EMA(EMA(EMA(EMA(EMA(ZAR2,5),5),5),5),5),5),5),5);
ZARB:=BARSLAST(CROSS(CLOSE,ZARA));
ZARC:=BARSLAST(CROSS(ZARA,CLOSE));
STICKLINE(CLOSE<ZARA,REF(CLOSE,ZARC),REF(CLOSE,ZARC),12,0),LINETHICK2,COLORFFCCCC;
STICKLINE(CLOSE>ZARA AND CLOSE>REF(CLOSE,ZARB),REF(CLOSE,ZARB),垂帘,0.2,0),COLORFFC8FF;
STICKLINE(CLOSE>ZARA AND CLOSE>REF(CLOSE,ZARB),REF(CLOSE,ZARB),REF

(CLOSE,ZARB),12,0),COLORFFC8FF,LINETHICK2;
{上涨:=0,COLORFFC8FF;}
STICKLINE(CLOSE<ZARA AND CLOSE<REF(CLOSE,ZARC),REF(CLOSE,ZARC),垂帘,0.2,0),COLOR00FF00;
{止盈止损:0,COLOR00FF00;}
VAR41:= EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
VAR42:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
VAR4A:=REF(VAR41,1)>92 AND VAR41<92;
DRAWTEXT(VAR4A,H+0.12,'●短卖'),COLOR00FF00;

STICKLINE(C>=O,H,L,0,0),COLORRED;
STICKLINE(C<O,H,L,0,0),COLORFFFF52;
STICKLINE(C>=O,C,O,4,1),COLORRED;
STICKLINE(C<O,C,O,4,0),COLORFFFF52;
MA13:MA(C,13),COLORWHITE,LINETHICK2;
MA55:=MA(C,55),COLORFF00FF;
MA125:=MA(C,125),COLORFFCC66;
MA250:=MA(C,250),COLORBLUE;
{STICKLINE(CROSS(MA5,听股) AND MA5>听股 AND C>O,MA13,MA13-0.09,4,0),COLORYELLOW;}
DRAWTEXT(CROSS(MA5,听股) AND MA5>听股 AND C>O,MA13-0.12,'垂帘听股'),COLORWHITE;
T:=BARSLAST(L>REF(H,1));
E:=COUNT(L<REF(H,T+1),T)<2;
STICKLINE(L<REF(H,T+1 ) AND E,L,L-0.09,4,0),COLOR0099FF;
DRAWTEXT(L<REF(H,T+1 ) AND E,L-0.12,'缺口回补'),COLOR0099FF;
VLL:=CROSS(MA(C,13),MA(C,21));
DRAWTEXT(VLL,MA13,'●圆弧底'),COLORYELLOW;

 

融维创富

五日:MA(CLOSE,5),LINETHICK0;
十日:MA(CLOSE,10),COLORFFFFCC,LINETHICK1;
卅日:MA(CLOSE,30),COLORFF00FF,LINETHICK1;
六十:MA(CLOSE,60),COLORFFFFCC,LINETHICK1;
半年:MA(CLOSE,120),COLOR33FF33,LINETHICK1;
年:MA(CLOSE,240),COLOR0000FF,LINETHICK1;
X:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
Y:=EMA(CLOSE,10);
LL:=REF(CLOSE,2);
MM:=((SMA(MAX((CLOSE - LL),0),6,1) / SMA(ABS((CLOSE - LL)),6,1)) * 100);
DB:=IF(((MM < REF(MM,1)) AND (MM > 79)),MM,0);
DRAWTEXT(CROSS(Y,X),(LOW * 0.985),'▲'),LINETHICK2,COLOR00FF00;
DRAWTEXT(CROSS(X,Y),(HIGH * 1.015),'◆'),LINETHICK2,COLORFF6699;
DRAWTEXT(DB,(HIGH * 1.015),'○'),LINETHICK2,COLORFFCC99;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
DD:=EMA(((0.667 * REF(AK1,1)) + (0.333 * AK1)),2);
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((((CLOSE - VAR3) / (VAR4 - VAR3)) * 100),3);
VAR6:=((AK + VAR5) / 2);
VAR7:=EMA(((0.667 * REF(VAR5,1)) + (0.333 * AK1)),2);
VAR8:=EMA(VAR6,5);
BB:=EMA(((0.667 * REF(VAR8,1)) + (0.333 * VAR8)),2);
AB:=CROSS(AK1,AK);
BB1:=(CROSS(AK1,BB) AND (BB < 30));
CD:=(BB1 * 0.6);
DRAWTEXT((CD = 0.6),(LOW * 0.99),'□'),LINETHICK2,COLORFFFFFF;
DRAWTEXT((AB = 1),(LOW * 0.99),'■'),LINETHICK2,COLOR33CC99;

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>