琪琪@ / 选股公式 / 五日角度--简单实用的选股公式

   

五日角度--简单实用的选股公式

2010-04-09  琪琪@

五日角度--简单实用的选股公式

(2009-10-21 22:53:53)

抓强势股和爆发股的有力公式——(将3日和5日排序,就是最近3日的强势股,数值越大,走势越陡,只看前80名-盘中可快速排序!!!极实用)

5日角度

INPUT:N(0.005,0.001,1);
Var1:=MA(CLOSE,5);
Var2:=BARSLAST(Var1>=REF(Var1,1) AND REF(Var1,1)<=REF(Var1,2))+1;
Var3:=IF(Var1>=REF(Var1,1),REF(Var1,Var2+1),0);
Var4:=(Var1-REF(Var1,Var2))/REF(Var1,Var2)/N/Var2;
五日上升角度值: IF(Var1>=REF(Var1,1),ATAN(Var4)/3.142*180,0);
Var5:=MA(CLOSE,3);
Var6:=BARSLAST(Var5>=REF(Var5,1) AND REF(Var5,1)<=REF(Var5,2))+1;
Var7:=IF(Var5>=REF(Var5,1),REF(Var5,Var6+1),0);
Var8:=(Var5-REF(Var5,Var6))/REF(Var5,Var6)/N/Var6;
三日上升角度值: IF(Var5>=REF(Var5,1),ATAN(Var8)/3.142*180,0);
Var9:=MA(CLOSE,2);
Var10:=BARSLAST(Var9>=REF(Var9,1) AND REF(Var9,1)<=REF(Var9,2))+1;
Var11:=IF(Var9>=REF(Var9,1),REF(Var9,Var10+1),0);
Var12:=(Var9-REF(Var9,Var10))/REF(Var9,Var10)/N/Var10;
二日上升角度值: IF(Var10>=REF(Var10,1),ATAN(Var12)/3.142*180,0);

五日角度   去掉停牌股————————


五日角度(短线爆发1)

INPUT:N(0.005,0.001,1);
A1:=MA(CLOSE,5);{MA5}
A2:=BARSLAST(CROSS(A1,REF(A1,1)) OR CROSS(REF(A1,1),A1) OR BARPOS=1)+1;
A3:=(A1/REF(A1,A2)-1)/N/A2;
角度五:IF(dynainfo(4)>0,ATAN(A3)/3.142*180,0);
B1:=MA(CLOSE,3);{MA3}
B2:=BARSLAST(CROSS(B1,REF(B1,1)) OR CROSS(REF(B1,1),B1) OR BARPOS=1)+1;
B3:=(B1/REF(B1,B2)-1)/N/B2;
角度三:IF(dynainfo(4)>0,ATAN(B3)/3.142*180,0);
C1:=MA(CLOSE,2);{MA2}
C2:=BARSLAST(CROSS(C1,REF(C1,1)) OR CROSS(REF(C1,1),C1) OR BARPOS=1)+1;
C3:=(C1/REF(C1,C2)-1)/N/C2;
角度二:IF(dynainfo(4)>0,ATAN(C3)/3.142*180,0);
上涨角度: max(角度五*1.1,角度三);

 


snap298.gif

 

角度上升(短线爆发2)


MA5:=MA(C,5);
MA3:=MA(C,3);
MA2:=MA(C,2);
V0:=MA(C,3)>REF(MA(C,3),1) AND MA(C,5)>REF(MA(C,5),1) AND C>MA(C,3)
AND MA(C,3)>MA(C,5) ; {均线C,MA3,MA5多头排列并向上;}
角度五:IF(dynainfo(4)>0,ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416,0);
角度三:IF(dynainfo(4)>0,ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416,0);
角度二:IF(dynainfo(4)>0,ATAN((MA2/REF(MA2,1)-1)*100)*180/3.1416,0);
上涨:MAX(角度五,角度三,角度二);

 

三合一了,只排序“上涨”,就什么都有了,

 

snap306.gif

ma交易系统里ma1金叉ma5,选多头买入信号即可(日线)

 

 

新的条件出来了——

snap317.gif

 

snap318.gif

 

量比
V1:="vol.MA1#DAY";
t:=intpart(time/100);
a:=IF(T<1000,T-0930,IF(T<1100,T-1000+30,IF(T<1200,T-1100+90,
IF(T<1400,T-1300+120,IF(T<1500,T-1400+180,240)))));
量比曲线:(SUM(VOL,0)/240)/(V1/a);
{量比:当日即时为止的每分钟平均成交量/(过去5日的每分钟平均成交量*当日即时为止的交易时间)};

且根据如下说明,应选量比大于2,若嫌开盘量比太大,就过三分钟即可啊,公式改为---(除于236分钟,从9点34分算起),加入换手大于1


量比
V1:="vol.MA1#DAY";
t:=intpart(time/100);
a:=IF(T<1000,T-0934,IF(T<1100,T-1000+30,IF(T<1200,T-1100+90,
IF(T<1400,T-1300+120,IF(T<1500,T-1400+180,236)))));
量比曲线:(SUM(VOL,0)/236)/(V1/a);
今日换手:V/CAPITAL*100;

{量比:当日即时为止的每分钟平均成交量/(过去5日的每分钟平均成交量*当日即时为止的交易时间)};

用成交量公式,一般成交量公式都有Ma均线在其中(M1=5,M2=10,M3=20)

VOL
VOL,VOLSTICK;
MA1:MA(VOL,M1);
MA2:MA(VOL,M2);
MA3:MA(VOL,M3);

牛股辈出盘后选出的4个条件——
1,当天量比大于1.7
2,换手不低于4%
3,角度上升(2,3,5天综合的)数值不小于77
4.2日上升角度数值不低于77(尤为重要)

注意第一次在表中出现的股,常常是大牛股。。。。。。。

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    《个图VIP服务协议》

    全部>>