股金有缘人 / 我的图书馆 / 防空警报

分享

   

防空警报

2010-07-31  股金有缘人

黄色进,绿色出,拉响防空警报坚决出!{本文来源:www.028588.com}
{防空警报}源码如下:

80,COLOR888888,;
QW1:=(HIGH+LOW+CLOSE*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);
RK7:=EMA(QW6,10);
涨:EMA(QW6,10)+100/2-5,LINETHICK1,COLORRED,;
跌:=EMA(涨,4),LINETHICK1,COLORFFFF34,;
多线:IF(CROSS(涨,跌) AND 跌<-10,30,0),LINETHICK1,COLORFF00FF,;
空线:IF(CROSS(跌,80),70,100),COLORFF9900,;
买1:=EMA(跌,4),COLORWHITE,;
买2:=EMA(买1,4),COLORGREEN,;
买M3:=EMA(买2,4);
买M4:=EMA(买M3,4);
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),0,0 ),COLORWHITE,;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),8,0 ),COLOR008800,;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),7,0 ),COLOR009900,;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),6,0 ),COLOR00AA00,;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),5,0 ),COLOR00BB00,;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),4,0 ),COLOR00CC00,;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),3,0 ),COLOR00DD00,;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),2,0 ),COLOR00EE00,;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),1,0 ),COLOR00FF00,;

STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),0,0) ,COLOR00BBFF,;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),8,0) ,COLOR0011FF,;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),7,0) ,COLOR0022FF,;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),6,0) ,COLOR0044FF,;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),5,0) ,COLOR0066FF,;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),4,0) ,COLOR0088FF,;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),3,0) ,COLOR0099FF,;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),2,0) ,COLOR00AAFF,;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),1,0) ,COLOR00BBFF,;  DRAWICON(多线,30,1);   DRAWICON(CROSS(跌,80),70,2);  VAR7B:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);DRAWTEXT(VAR7B>0,60,'★探底'),COLORYELLOW;  DRAWTEXT(CROSS(涨,跌) AND 跌<20 AND 跌>-10,40,'买入'),COLORCCFF99;
DRAWTEXT(多线>0,-20,'看涨'),COLOR0000FF;
VAR811:=SUMBARS(VOL,(7)*100);
VAR822:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR883:=(CLOSE-VAR822)/VAR822*100;
VAR884:=HHV(VAR883,VAR811);
VAR885:=LLV(VAR883,VAR811);
VAR886:=(VAR883-VAR885)/(VAR884-VAR885)*100;
K:=SMA(VAR886,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
MA1:=MA(J,3);
STICKLINE(FILTER(J>MA1 AND J<=3,5)=1 AND 跌<0,涨,涨+20,6,0),COLORYELLOW,;
DRAWTEXT(FILTER(J>MA1 AND J<=3,5)=1 AND 跌<0,60,'考虑买进'),COLORFFFFFF;  VAR2:=MA(CLOSE,194);VAR44:=REF(CLOSE,1);
VAR45:=SMA(MAX(CLOSE-VAR44,0),6,1)/SMA(ABS(CLOSE-VAR44),6,1)*100;
STICKLINE(CROSS(84,VAR45),0,VAR2*15+3,3,1),COLORGREEN;
DRAWTEXT(CROSS(84,VAR45),80,'防空警报'),COLORGREEN;

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>