w2666 / 公式 / 主力净买入

0 0

   

主力净买入

2011-01-30  w2666
{【SUPERVIEW大资金流向】}
INPUT:N(0,0,300);
TODAY:="ddx.ddx"=0;{判断是否有正版数据}
{4}
{叠加副盘}
DRAWTEXTREL(0,10,'大资金流'),COLORYELLOW;
DRAWTEXTABS(50,5,'《夏卫东-原创》'),COLOR0000FF;
DRAWTEXTREL(190,5,datestr(REF((DATE),N))+' 星期'+REF(WEEKDAY,N)+' 【SUPERVIEW大资金流向】'+' '+STKLABEL+''+STKNAME+'  '+N+'天前数据(有效天数)'),LINETHICK4,Color00b5ff;{10}
{9}
{超赢}
主单买:=REF(IF(TODAY,"DDEDATA@BIGORDER"(1,2),IF(TODAY ,SELFDATA('特大买入')+SELFDATA('大单买入') ,BIGORDER(1,2))),N);
主单卖:=REF(IF(TODAY,"DDEDATA@BIGORDER"(2,2),IF(TODAY ,SELFDATA('特大卖出')+SELFDATA('大单卖出') ,BIGORDER(2,2))),N);
特单买:=REF(IF(TODAY,"DDEDATA@BIGORDER"(1,3),IF(TODAY ,SELFDATA('特大买入') ,bigorder(1,3))),N);
特单卖:=REF(IF(TODAY,"DDEDATA@BIGORDER"(2,3),IF(TODAY ,SELFDATA('特大卖出') ,bigorder(2,3))),N);
大单买:=REF(IF(TODAY,"DDEDATA@BIGORDER"(1,2)-"DDEDATA@BIGORDER"(1,3),IF(TODAY ,SELFDATA('大单买入') ,bigorder(1,2)-bigorder(1,3))),N);
大单卖:=REF(IF(TODAY,"DDEDATA@BIGORDER"(2,2)-"DDEDATA@BIGORDER"(2,3),IF(TODAY ,SELFDATA('大单卖出') ,bigorder(2,2)-bigorder(2,3))),N);
中单买:=REF(IF(TODAY,"DDEDATA@BIGORDER"(1,1)-"DDEDATA@BIGORDER"(1,2),IF(TODAY ,SELFDATA('中单买入') ,bigorder(1,1)-bigorder(1,2))),N);
中单卖:=REF(IF(TODAY,"DDEDATA@BIGORDER"(2,1)-"DDEDATA@BIGORDER"(2,2),IF(TODAY ,SELFDATA('中单卖出') ,bigorder(2,1)-bigorder(2,2))),N);
散单买:=REF(IF(TODAY,1-"DDEDATA@BIGORDER"(1,1),IF(TODAY ,1-(SELFDATA('特大买入')+SELFDATA('大单买入')+SELFDATA('中单买入')) ,1-bigorder(1,1))),N);
散单卖:=REF(IF(TODAY,1-"DDEDATA@BIGORDER"(2,1),IF(TODAY ,1-(SELFDATA('特大卖出')+SELFDATA('大单卖出')+SELFDATA('中单卖出')) ,1-bigorder(2,1))),N);
{21}
量比:=REF(VOL,N)/CAPITAL;{%}
散买:=散单买*REF(AMOUNT,N)/10000;{万元}
散卖:=散单卖*REF(AMOUNT,N)/10000;{万元}
散净:=散买-散卖;{万元}
散单:=散单买-散单卖;
散增:=量比*散单*100;{%}
散仓:= 25+Sum(散增,0);{%}
{29}
中买:=中单买*REF(AMOUNT,N)/10000;{万元}
中卖:=中单卖*REF(AMOUNT,N)/10000;{万元}
中净:=中买-中卖;{万元}
中单:=中单买-中单卖;
中增:=量比*中单*100;{%}
中仓:= 25+Sum(中增,0);{%}
{36}
大买:=大单买*REF(AMOUNT,N)/10000;{万元}
大卖:=大单卖*REF(AMOUNT,N)/10000;{万元}
大净:=大买-大卖;{万元}
大单:=大单买-大单卖;
大增:=量比*大单*100;{%}
大仓:=25+Sum(大增,0);{%}
{43}
超买:=特单买*REF(AMOUNT,N)/10000;{万元}
超卖:=特单卖*REF(AMOUNT,N)/10000;{万元}
超净:=超买-超卖;{万元}
超单:=特单买-特单卖;
超增:=量比*超单*100;{%}
超仓:=25+Sum(超增,0);{%}
{50}
主买:=主单买*REF(AMOUNT,N)/10000;{万元}
主卖:=主单卖*REF(AMOUNT,N)/10000;{万元}
主净:=主买-主卖;{万元}
主增:=(超增+大增);
主仓:=(超仓+大仓);{%}
{56}
{通栏显示}
成交量:REF(VOL,N),LINETHICK0,COLOR00FFFF,PRECIS0;{万手}
成交额:REF(AMOUNT/10000,N),LINETHICK0,COLORFF00FF,PRECIS2;{万元}
主力净买入:主净,LINETHICK0,COLORFFFF00,PRECIS2;{万元}
主力连红:LAST(主净 > 0),LINETHICK0,COLOR0030FF,PRECIS0;{天}
十日飚红:COUNT(主净 > 0,10),LINETHICK0,COLOR005BFF,PRECIS0;{天}
流通盘:CAPITAL,LINETHICK0,COLORFFFF00,PRECIS0;{万手}
{64}
{柱图值计算};
最大值:=400/(MAX(主买,主卖,超买,超卖,大买,大卖,中买,中卖,散买,散卖));
最大仓:=300/(MAX(主仓,超仓,大仓,中仓,散仓));
{68}
主力买:=600-(主买*最大值);
主力卖:=600-(主卖*最大值);
主仓增:=600-((主仓+(ABS(主增)*10))*最大仓);
主仓减:=600-((主仓-(ABS(主增)*10))*最大仓);
{73}
超大买:=600-(超买*最大值);
超大卖:=600-(超卖*最大值);
超仓增:=600-((超仓+(ABS(超增)*10))*最大仓);
超仓减:=600-((超仓-(ABS(超增)*10))*最大仓);
{78}
大户买:=600-(大买*最大值);
大户卖:=600-(大卖*最大值);
大仓增:=600-((大仓+(ABS(大增)*10))*最大仓);
大仓减:=600-((大仓-(ABS(大增)*10))*最大仓);
{83}
中户买:=600-(中买*最大值);
中户卖:=600-(中卖*最大值);
中仓增:=600-((中仓+(ABS(中增)*10))*最大仓);
中仓减:=600-((中仓-(ABS(中增)*10))*最大仓);
{88}
散户买:=600-(散买*最大值);
散户卖:=600-(散卖*最大值);
散仓增:=600-((散仓+(ABS(散增)*10))*最大仓);
散仓减:=600-((散仓-(ABS(散增)*10))*最大仓);
{93}
{画柱图}
DRAWRECTREL(245,主力买,270,610,RGB(200,0,0)),COLOR000000,LAYER5;{主力买}
DRAWRECTREL(270,主力卖,295,610,RGB(0,200,0)),COLOR000000,LAYER5;{主力卖}
DRAWRECTREL(245,612,320,655,(IF((主净 >= 0),RGB(255,0,0),RGB(0,255,0)))),COLOR000000,LAYER5;{横彩条}
DRAWRECTREL(295,主仓增,320,610,(IF((主增 >= 0),RGB(200,50,0),RGB(50,255,0)))),COLOR000000,LAYER5;{增仓比例增}
DRAWRECTREL(295,主仓减,320,610,RGB(255,255,0)),COLOR000000,LAYER5;{增仓比例减}
{100}
DRAWRECTREL(410,超大买,430,610,RGB(200,0,0)),COLOR000000,LAYER5;
DRAWRECTREL(430,超大卖,450,610,RGB(0,200,0)),COLOR000000,LAYER5;
DRAWRECTREL(410,612,470,655,(IF((超净 >= 0),RGB(255,0,0),RGB(0,255,0)))),COLOR000000,LAYER5;{横彩条}
DRAWRECTREL(450,超仓增,470,610,(IF((超增 >= 0),RGB(200,50,0),RGB(50,255,0)))),COLOR000000,LAYER5;{增仓比例增}
DRAWRECTREL(450,超仓减,470,610,RGB(255,255,0)),COLOR000000,LAYER5;{增仓比例减}
{106}
DRAWRECTREL(540,大户买,560,610,RGB(200,0,0)),COLOR000000,LAYER5;
DRAWRECTREL(560,大户卖,580,610,RGB(0,200,0)),COLOR000000,LAYER5;
DRAWRECTREL(540,612,600,655,(IF((大净 >= 0),RGB(255,0,0),RGB(0,255,0)))),COLOR000000,LAYER5;{横彩条}
DRAWRECTREL(580,大仓增,600,610,(IF((大增 >= 0),RGB(200,50,0),RGB(50,255,0)))),COLOR000000,LAYER5;{增仓比例增}
DRAWRECTREL(580,大仓减,600,610,RGB(255,255,0)),COLOR000000,LAYER5;{增仓比例减}
{112}
DRAWRECTREL(670,中户买,690,610,RGB(200,0,0)),COLOR000000,LAYER5;
DRAWRECTREL(690,中户卖,710,610,RGB(0,200,0)),COLOR000000,LAYER5;
DRAWRECTREL(670,612,730,655,(IF((中净 >= 0),RGB(255,0,0),RGB(0,255,0)))),COLOR000000,LAYER5;{横彩条}
DRAWRECTREL(710,中仓增,730,610,(IF((中增 >= 0),RGB(200,50,0),RGB(50,255,0)))),COLOR000000,LAYER5;{增仓比例增}
DRAWRECTREL(710,中仓减,730,610,RGB(255,255,0)),COLOR000000,LAYER5;{增仓比例减}
{118}
DRAWRECTREL(800,散户买,820,610,RGB(200,0,0)),COLOR000000,LAYER5;
DRAWRECTREL(820,散户卖,840,610,RGB(0,200,0)),COLOR000000,LAYER5;
DRAWRECTREL(800,612,860,655,(IF((散净 >= 0),RGB(255,0,0),RGB(0,255,0)))),COLOR000000,LAYER5;;{横彩条}
DRAWRECTREL(840,散仓增,860,610,(IF((散增 >= 0),RGB(200,50,0),RGB(50,255,0)))),COLOR000000,LAYER5;{增仓比例增}
DRAWRECTREL(840,散仓减,860,610,RGB(255,255,0)),COLOR000000,LAYER5;{增仓比例减}
{124}
{显示文字}
DRAWTEXTREL(190,420,'主'),LINETHICK2,ColorDDFFFF;
DRAWTEXTREL(190,580,'力'),LINETHICK2,ColorDDFFFF;
DRAWTEXTREL(210,500,'='),LINETHICK2,ColorDDFFFF;
DRAWTEXTREL(225,400,'超'),LINETHICK0,ColorDDFFFF;
DRAWTEXTREL(225,450,'大'),LINETHICK0,ColorDDFFFF;
DRAWTEXTREL(225,500,'加'),LINETHICK0,ColorDDFFFF;
DRAWTEXTREL(225,550,'大'),LINETHICK0,ColorDDFFFF;
DRAWTEXTREL(225,600,'户'),LINETHICK0,ColorDDFFFF;
DRAWTEXTREL(390,450,'超'),LINETHICK2,ColorDDFFFF;
DRAWTEXTREL(390,580,'大'),LINETHICK2,ColorDDFFFF;
DRAWTEXTREL(520,450,'大'),LINETHICK2,ColorDDFFFF;
DRAWTEXTREL(520,580,'户'),LINETHICK2,ColorDDFFFF;
DRAWTEXTREL(650,450,'中'),LINETHICK2,ColorDDFFFF;
DRAWTEXTREL(650,580,'户'),LINETHICK2,ColorDDFFFF;
DRAWTEXTREL(780,450,'散'),LINETHICK2,ColorDDFFFF;
DRAWTEXTREL(780,580,'户'),LINETHICK2,ColorDDFFFF;
{142}
DRAWTEXTREL(190,680,'买 入:'),colorred;
DRAWTEXTREL(190,750,'卖 出:'),Color00FF00;
DRAWTEXTREL(190,820,'净 买:'),COLORFFFF00;
DRAWTEXTREL(190,890,'持 仓:'),COLOR00FFFF;
DRAWTEXTREL(190,960,'增 仓:'),COLORFFFF00;
{148}
{显示数据}
DRAWTEXTREL(245,680,NUMTOSTRN(主买,2)),colorred;
DRAWTEXTREL(245,750,NUMTOSTRN(主卖,2)),COLOR00FF00;
DRAWTEXTREL(245,820,NUMTOSTRN(主净,2)),COLORFFFF00;
DRAWTEXTREL(245,890,NUMTOSTRN(主仓,2)+'%'),COLOR00FFFF;
DRAWTEXTREL(245,960,NUMTOSTRN(主增,2)+'%'),COLORFFFF00;
{155}
DRAWTEXTREL(410,680,NUMTOSTRN(超买,2)),colorred;
DRAWTEXTREL(410,750,NUMTOSTRN(超卖,2)),COLOR00FF00;
DRAWTEXTREL(410,820,NUMTOSTRN(超净,2)),COLORFFFF00;
DRAWTEXTREL(410,890,NUMTOSTRN(超仓,2)+'%'),COLOR00FFFF;
DRAWTEXTREL(410,960,NUMTOSTRN(超增,2)+'%'),COLORFFFF00;
{161}
DRAWTEXTREL(540,680,NUMTOSTRN(大买,2)),colorred;
DRAWTEXTREL(540,750,NUMTOSTRN(大卖,2)),COLOR00FF00;
DRAWTEXTREL(540,820,NUMTOSTRN(大净,2)),COLORFFFF00;
DRAWTEXTREL(540,890,NUMTOSTRN(大仓,2)+'%'),COLOR00FFFF;
DRAWTEXTREL(540,960,NUMTOSTRN(大增,2)+'%'),COLORFFFF00;
{167}
DRAWTEXTREL(670,680,NUMTOSTRN(中买,2)),colorred;
DRAWTEXTREL(670,750,NUMTOSTRN(中卖,2)),COLOR00FF00;
DRAWTEXTREL(670,820,NUMTOSTRN(中净,2)),COLORFFFF00;
DRAWTEXTREL(670,890,NUMTOSTRN(中仓,2)+'%'),COLOR00FFFF;
DRAWTEXTREL(670,960,NUMTOSTRN(中增,2)+'%'),COLORFFFF00;
{173}
DRAWTEXTREL(800,680,NUMTOSTRN(散买,2)),colorred;
DRAWTEXTREL(800,750,NUMTOSTRN(散卖,2)),COLOR00FF00;
DRAWTEXTREL(800,820,NUMTOSTRN(散净,2)),COLORFFFF00;
DRAWTEXTREL(800,890,NUMTOSTRN(散仓,2)+'%'),COLOR00FFFF;
DRAWTEXTREL(800,960,NUMTOSTRN(散增,2)+'%'),COLORFFFF00;
{179}
{五分钟资金趋势}
主5:=(主买-主卖)-REF((主买-主卖),5);
超5:=超净-REF(超净,5);
大5:=大净-REF(大净,5);
中5:=中净-REF(中净,5);
散5:=散净-REF(散净,5);
DRAWTEXTABS(120,25,'五分钟各单净买(万元):'),COLORFFFF00;
DRAWTEXTABS(240,25,'主力:'+ NUMTOSTRN(主5,2)),COLOR00FFFF;
DRAWTEXTABS(340,25,'超大:'+ NUMTOSTRN(超5,2)),COLORFF00FF;
DRAWTEXTABS(440,25,'大户:'+ NUMTOSTRN(大5,2)),COLOR00FF00;
DRAWTEXTABS(540,25,'中户:'+ NUMTOSTRN(中5,2)),COLORB5B5B5;
DRAWTEXTABS(640,25,'散户:'+ NUMTOSTRN(散5,2)),COLORFF9911;
{192}
DRAWTEXTABS(0,40,'大盘指数:'+INDEXC),COLORYELLOW;
DRAWTEXTABS(0,54,'大盘涨幅:'+((INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100)+'%'),LINETHICK0,PRECIS2,COLORred;
DRAWTEXTABS(0,68,'上涨家数:'+NUMTOSTRN(DYNAINFO(66),0)+'家'),COLOR0000FF;
DRAWTEXTABS(0,82,'下跌家数:'+NUMTOSTRN(DYNAINFO(67),0)+'家'),COLOR00FF00;
DRAWTEXTABS(0,96,'平盘家数:'+NUMTOSTRN(DYNAINFO(68),0)+'家'),COLORFFFFFF;
DRAWTEXTABS(0,112,'股票代码:'+STKLABEL),COLORFFFF00;
DRAWTEXTABS(0,126,'股票名称:'+STKNAME),COLORFFFF00;
DRAWTEXTABS(0,140,'最新价格:'+DYNAINFO(7)+'元'),COLORFF00FF;
DRAWTEXTABS(0,154,'今日涨幅:'+DYNAINFO(14)*100+'%'),COLOR00FFFF;
DRAWTEXTABS(0,168,'历史最高:'+HHV(HIGH,0)+'元'),Colorred;
DRAWTEXTABS(0,182,'历史最低:'+LLV(LOW,0)+'元'),COLOR00FF00;
DRAWTEXTABS(0,196,'换 手 率:'+ DYNAINFO(37)*100+'%'),COLORFF00FF;
DRAWTEXTABS(0,210,'市 盈 率:'+ DYNAINFO(39)+'%'),COLOR00FFFF;
DRAWTEXTABS(0,224,'市 净 率:'+ DYNAINFO(58)+'%'),COLOR00FF00;
{207};

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    来自: w2666 > 《公式》

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多