hsh1086 / 股票 / 数字解盘 及选股公式(源码 贴图)

0 0

   

数字解盘 及选股公式(源码 贴图)

2011-04-08  hsh1086

{数字解盘}
AAA:=REFDATE(HHV(H,130),DATE);
BBB:=REFDATE(LLV(L,130),DATE);
{DRAWBAND(AAA,RGB(0,80,80),BBB,RGB(00,00,00))};{背景}
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
DKX:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)
+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)
+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)
+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)
+2*REF(MID,18)+REF(MID,20))/210,COLOR0099FF;
DKMA:MA(DKX,6),COLORD9D9F3;
DRAWBAND(DKX,RGB(150,0,150),DKMA,RGB(150,150,150));
{红}
STICKLINE(C>O,C,O,3,0),COLOR000077;
STICKLINE(C>O,C,O,2,0),COLOR000099;
STICKLINE(C>O,C,O,1,0),COLOR0000BB;
STICKLINE(C>O,H,L,0,0),COLOR0000FF;
{绿}
STICKLINE(C<O,C,O,3,0),COLOR007700;
STICKLINE(C<O,C,O,2,0),COLOR009900;
STICKLINE(C<O,C,O,1,0),COLOR00BB00;
STICKLINE(C<O,H,L,0,0),COLOR00FF00;

套牢盘%:=100*(1-WINNER(C));
获利盘%:=100*WINNER(C);
集中度90%:=(COST(95)-COST(5))/(COST(100))*100;
集中度70%:=(COST(85)-COST(15))/(COST(100))*100;
平均成本:=COST(50);
主力成本:=COST(4);
短期压力:=HHV(H,20);
短期支撑:=LLV(L,20);
PT:=REF(HIGH,1)-REF(LOW,1);
中价:=(H+L+C)/3;
近高:=2*中价-LOW;
近低:=2*中价-HIGH;
最高:=中价+PT;
最低:=中价-PT;

T1:=CONST(IF(获利盘%,1,0));
T2:=CONST(IF(套牢盘%,1,0));
T3:=CONST(IF(集中度90%,1,0));
T4:=CONST(IF(集中度70%,1,0));
T5:=CONST(IF(平均成本,1,0));
T6:=CONST(IF(主力成本,1,0));
T7:=CONST(IF(短期压力,1,0));
T8:=CONST(IF(短期支撑,1,0));
T9:=CONST(IF(中价,1,0));
T10:=CONST(IF(近高,1,0));
T11:=CONST(IF(近低,1,0));
T12:=CONST(IF(最高,1,0));
T13:=CONST(IF(最低,1,0));

TS1:=IF(T1=1,0+0.03,0);
TS2:=IF(T2=1,TS1+0.03,TS1);
TS3:=IF(T3=1,TS2+0.05,TS2);
TS4:=IF(T4=1,TS3+0.03,TS3);
TS5:=IF(T5=1,0+0.03,0);
TS6:=IF(T6=1,TS5+0.03,TS5);
TS7:=IF(T7=1,TS6+0.05,TS6);
TS8:=IF(T8=1,TS7+0.03,TS7);
TS9:=IF(T9=1,0+0.03,0);
TS10:=IF(T10=1,TS9+0.05,TS9);
TS11:=IF(T11=1,TS10+0.03,TS10);
TS12:=IF(T12=1,TS11+0.05,TS11);
TS13:=IF(T13=1,TS12+0.03,TS12);

N1:=30;
N2:=20;
N3:=10;
DRAWTEXT(T1=1 AND CURRBARSCOUNT=N1 AND PERIOD=5,AAA-(AAA*TS1),'【获利盘%】'),COLORRED;
DRAWTEXT(T2=1 AND CURRBARSCOUNT=N1 AND PERIOD=5,AAA-(AAA*TS2),'【套牢盘%】'),COLOR00FF00;
DRAWTEXT(T3=1 AND CURRBARSCOUNT=N1 AND PERIOD=5,AAA-(AAA*TS3),'【90%成本集中度】'),COLORYELLOW;
DRAWTEXT(T4=1 AND CURRBARSCOUNT=N1 AND PERIOD=5,AAA-(AAA*TS4),'【70%成本集中度】'),COLOR008FFF;
DRAWTEXT(T5=1 AND CURRBARSCOUNT=N2 AND PERIOD=5,AAA-(AAA*TS5),'【平均成本】'),COLORFF99FF;
DRAWTEXT(T6=1 AND CURRBARSCOUNT=N2 AND PERIOD=5,AAA-(AAA*TS6),'【主力成本】'),COLORFF00FF;
DRAWTEXT(T7=1 AND CURRBARSCOUNT=N2 AND PERIOD=5,AAA-(AAA*TS7),'【短期压力】'),COLORFFFFBF;
DRAWTEXT(T8=1 AND CURRBARSCOUNT=N2 AND PERIOD=5,AAA-(AAA*TS8),'【短期支撑】'),COLORF0F000;
DRAWTEXT(T9=1 AND CURRBARSCOUNT=N3 AND PERIOD=5,AAA-(AAA*TS9),'【中价】'),COLORWHITE;
DRAWTEXT(T10=1 AND CURRBARSCOUNT=N3 AND PERIOD=5,AAA-(AAA*TS10),'【近高】'),COLORFFFFBF;
DRAWTEXT(T11=1 AND CURRBARSCOUNT=N3 AND PERIOD=5,AAA-(AAA*TS11),'【近低】'),COLORF0F000;
DRAWTEXT(T12=1 AND CURRBARSCOUNT=N3 AND PERIOD=5,AAA-(AAA*TS12),'【最高】'),COLORFF99FF;
DRAWTEXT(T13=1 AND CURRBARSCOUNT=N3 AND PERIOD=5,AAA-(AAA*TS13),'【最低】'),COLORFF00FF;

DRAWNUMBER(T1=1 AND CURRBARSCOUNT=N1-6 AND PERIOD=5,AAA-(AAA*TS1),CONST(获利盘%)),COLORRED;
DRAWNUMBER(T2=1 AND CURRBARSCOUNT=N1-6 AND PERIOD=5,AAA-(AAA*TS2),CONST(套牢盘%)),COLOR00FF00;
DRAWNUMBER(T3=1 AND CURRBARSCOUNT=N1-7 AND PERIOD=5,AAA-(AAA*TS3),CONST(集中度90%)),COLORYELLOW;
DRAWNUMBER(T4=1 AND CURRBARSCOUNT=N1-7 AND PERIOD=5,AAA-(AAA*TS4),CONST(集中度70%)),COLOR008FFF;
DRAWNUMBER(T5=1 AND CURRBARSCOUNT=N2-6 AND PERIOD=5,AAA-(AAA*TS5),CONST(平均成本)),COLORFF99FF;
DRAWNUMBER(T6=1 AND CURRBARSCOUNT=N2-6 AND PERIOD=5,AAA-(AAA*TS6),CONST(主力成本)),COLORFF00FF;
DRAWNUMBER(T7=1 AND CURRBARSCOUNT=N2-6 AND PERIOD=5,AAA-(AAA*TS7),CONST(短期压力)),COLORFFFFBF;
DRAWNUMBER(T8=1 AND CURRBARSCOUNT=N2-6 AND PERIOD=5,AAA-(AAA*TS8),CONST(短期支撑)),COLORF0F000;
DRAWNUMBER(T9=1 AND CURRBARSCOUNT=N3-4 AND PERIOD=5,AAA-(AAA*TS9),CONST(中价)),COLORWHITE;
DRAWNUMBER(T10=1 AND CURRBARSCOUNT=N3-4 AND PERIOD=5,AAA-(AAA*TS10),CONST(近高)),COLORFFFFBF;
DRAWNUMBER(T11=1 AND CURRBARSCOUNT=N3-4 AND PERIOD=5,AAA-(AAA*TS11),CONST(近低)),COLORF0F000;
DRAWNUMBER(T12=1 AND CURRBARSCOUNT=N3-4 AND PERIOD=5,AAA-(AAA*TS12),CONST(最高)),COLORFF99FF;
DRAWNUMBER(T13=1 AND CURRBARSCOUNT=N3-4 AND PERIOD=5,AAA-(AAA*TS13),CONST(最低)),COLORFF00FF;

请高手做两个选股公式:

(1)股价高于主力成本10%以下,10%数字可调;
(2)股价低于主力成本10%以内,10%数字可调。

条件太笼统,信号太多,修改一下,放在你值标的后面就可以看了
高于成本:C>主力成本*0.1+主力成本,NODRAW;
DRAWICON(高于成本,H*1.02,3);
低于成本:C<主力成本,NODRAW;
DRAWICON(低于成本,L*0.95,9);

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多