2通达信加密公式破解

2011-04-22   ttgg8891
鼠标指定你要修改的指标,右击“当前指标”点击“修改指标参数”,就能看到源码。
时间限制是一种加密的方法,其原理是在指标中加入时间函数,把时间设定在一定的使用范围内,当超过设定的时间之后,指标图形中的线条和有关信号消失或失真,造成指标不能继续使用。用时间限制加密的形式有多种,举例子加以说明解除的方法:
看这个副图指标:
Var1:=IF(DATE<=1040701,1,0);
Var2:=DMA(CLOSE,HIGH/MA(LOW,4)/4);
Var3:=DMA(CLOSE,CLOSE/MA(LOW,30)/30);
Var4:=(LOW-Var2)/Var2*100<-5.889;
Var5:=(Var2-Var3)/Var3*100<-15.889;
Var6:=Var4 AND Var5 AND (HIGH-MA(LOW,3))/REF(LOW,2)>-0.059;
Var7:=Var6>0;
Var8:=AMOUNT/VOL/100;
Var9:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VarA:=SUM(AMOUNT,13)/Var8/100;
VarB:=DMA(Var9,VOL/VarA);
VarC:=MA(HHV(HIGH,488),18);
VarD:=MA(HHV(HIGH,220),18);
VarE:=MA(HHV(HIGH,98),18);
VarF:=MA(LLV(LOW,488),18);
Var10:=MA(LLV(LOW,220),18);
Var11:=MA(LLV(LOW,98),18);
Var12:=MA((VarF*0.96+Var10*0.96+Var11*0.96+VarC*0.558+VarD*0.558+VarE*0.558)/6,18);
Var13:=MA((VarF*1.25+Var10*1.23+Var11*1.2+VarC*0.55+VarD*0.55+VarE*0.65)/6,18);
Var14:=MA((VarF*1.3+Var10*1.3+Var11*1.3+VarC*0.68+VarD*0.68+VarE*0.68)/6,18);
Var15:=MA((Var12*3+Var13*2+Var14)/6*1.738,18);
Var16:=IF(DATE<=1021231,Var15,Var15*DAY);
Var17:=LOW;
Var18:=REF(LOW,1);
Var19:=SMA(ABS(Var17-Var18),3,1)/SMA(MAX(Var17-Var18,0),3,1)*100;
Var1A:=MA(IF(CLOSE*1.35{<=Var16},Var19*10,Var19/10),3);
Var1B:=LLV(LOW,30);
Var1C:=HHV(Var1A,30);
Var1D:=IF(LOW<=Var1B,(Var1A+Var1C*2)/2,0);
Var1E:=MA(Var1D AND CLOSE<COST(1),3) AND (CLOSE-VarB)/VarB*100<-11;
Var1F:=MA(CLOSE,5);
Var20:=MA(CLOSE,10);
Var21:=MA(CLOSE,20);
Var22:=MA(CLOSE,30);
Var23:=(Var1F+Var20+Var21+Var22)/4;
Var24:=(Var23-REF(Var23,15))/REF(Var23,15)*100;
Var25:=IF(Var24<-10 AND Var24<REF(Var24,1),20,0);
买入: Var7*Var1 AND Var1E*Var1 AND Var25*Var1 AND (CLOSE-OPEN)*Var1>0,linethick2 , colorred;
这个指标中的VAR1、VAR16和买入这3条语句引用了时间限制函数,限制在2004年7月1日前可正常使用,超过这个时间就不能正常使用了。解除时间限制的方法比较简单,只要把VAR1和VAR16这2条语句删除,再把买入语句中的*VA1删除就完全解除了时间限制。
最后再看一个指标:
Var1:=IF(DATE<1030830 AND DATE>900101,1,0);
Var2:=LLV(LOW,10);
Var3:=HHV(HIGH,25);
警戒线:=2.8*Var1;
减仓线:=3.2*Var1;
动力线:=EMA((CLOSE-Var2)/(Var3-Var2)*4,4)*Var1;
VAR4:CROSS(动力线,警戒线);
STICKLINE(VAR4,0,50,4,0);
DRAWICON(CROSS(动力线,警戒线),53,2);
这个指标中的VAR1引用了时间限制函数,限制在2003年8月30日前可正常使用,超过这个时间就不能正常使用了。解除时间限制的方法比较简单,只要把VAR1这条语句删除,再把语句中的*VAR1删除就完全解除了时间限制。
以上例举了2个解除时间限制的方法,试一下吧!
 
把T0002文件夹下PriGS.DAT文件复制后粘贴到你的没时间限制的通达信软件下T0002文件下去复盖没时间限制的PriGS.DAT文件,你要的都有了
 

通达信加密公式破解

 

P1: 2        20    5
P2: 2        20    4
80, POINTDOT;
20, POINTDOT;
VAR1:=LLV(LOW,P1);
VAR2:=HHV(HIGH,P1);
K: EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,P2),COLORFF9900 , ;
D: EMA(0.667*REF(K,1)+0.333*K,2), ,;
VARC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1);
VARD:=EMA(IF(C< EMA(C,250),VARC*1000,VARC*10),3);
火焰山:EMA(IF(L<=LLV(L,30),VARD/2+HHV(VARD,30),0),3)/618;
STICKLINE(火焰山>100,0,火焰山*1.2,8,0);
STICKLINE(火焰山>100,0,火焰山,4,1);
金包: IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,20,0),COLORYELLOW ,LINETHICK1 ;
VAR3:=PEAKBARS(3,15,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);
顶A:IF(顶>REF(顶,1),50,0),COLORGREEN;
DRAWTEXT(顶A=50,45,'快逃'),COLOR00FF00;
DRAWTEXT(金包=20,20,'金包'),COLORRED;
 

通达信公式破解方法

 

P1: 2        20    5
P2: 2        20    4
80, POINTDOT;
20, POINTDOT;
VAR1:=LLV(LOW,P1);
VAR2:=HHV(HIGH,P1);
K: EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,P2),COLORFF9900 , ;
D: EMA(0.667*REF(K,1)+0.333*K,2), ,;
VARC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1);
VARD:=EMA(IF(C< EMA(C,250),VARC*1000,VARC*10),3);
火焰山:EMA(IF(L<=LLV(L,30),VARD/2+HHV(VARD,30),0),3)/618;
STICKLINE(火焰山>100,0,火焰山*1.2,8,0);
STICKLINE(火焰山>100,0,火焰山,4,1);
金包: IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,20,0),COLORYELLOW ,LINETHICK1 ;
VAR3:=PEAKBARS(3,15,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);
顶A:IF(顶>REF(顶,1),50,0),COLORGREEN;
DRAWTEXT(顶A=50,45,'快逃'),COLOR00FF00;
DRAWTEXT(金包=20,20,'金包'),COLORRED;
 
加密公式的破解,需要较深厚的基本功。
现在有数十种股软,许多种不同股软函数加起来有数千个,编制技法随着的知识更新更是层出不穷。
目前人工破解还是以观其“ 形”,查其“神”,来揣摩其作者的设计思路和编制机理及各种技法运用。
其中最关键的就是要摸清作者的设计思路,也可以说这就是破解中的“纲”!
把握住了这个" 纲“,编制机理及各种技法也就迎刃而解了!
这是一个很苦的差事,需要大量的时间反复去验证,测试。
也是一门专业性很强的差事,需要专业知识和编程技巧和精益求精及刻苦专研的毅力,不是任何人都能做到的。
简单的说:很简单的一条均线,就有许多计算方式,首先你要确定下来加密公式这一条线的是什么类型的?接着你就要做出一条线在股软里对照加密公式来对比,来不断地调整参数来比较两条线的数据每一天的数值是否相符,这是很枯燥费时费事的事情!
这仅仅是简单的一条线而已,其他的也不必说了,其破解费时费事可想而知。
所以,一般价值不是很大的公式是不值得破解的!
1:不是使用Winhex,而是使用Ollydbg来破解.
2:只是用户公式修改密码有效。对于导入密码无效。对于系统公式密码无效,默认的系统公式密码可能是OK_TDX(测试了两个版本,其他的不知道)
不过好像有的不能编辑,不过VOL_TDX等系统的公式好像可以查看和修改。


方法:1:使用Ollydbg,点文件,打开,选择通达信的可执行文件(或者把通达信的执行文件直接拖进Ollydbg的窗口),按F9运行程序。
2:正常使用通达信,进入到K线图后,在k线图(主图或者副图上)点右键,选择指标,然后选择一个加密的公式,点确定。
此时公式应该能正确使用并且在图上显示出来。
3:点右键,选当前指标,选修改指标公式,此时需要输入密码,随便输入几个数,但不要点确定。
4:在Ollydbg的左下角,有一个命令编辑框,输入命令bp _mbscmp,回车,这时断点下好了。
5:点修改密码公式框中的确定按钮,此时中断在_mbscmp中,在右上角的EAX的值就是密码,ECX值是你随便输入的数。
6:找到密码后,点在左上角的红黑色的一行代码,点F2取消断点,再点F9来继续程序执行。可以循环2-6步来得到其他的密码。
7:完成。


Ollydbg软件下载


【通达信】买入红K涨停
徐文明操盘线【通达信公式】

波段王 - 最有钱赚的就是波段[通达信版]

500万通达信版

大盘危险系数公式【通达信版】



【通达信】愚公赢钱
 
股票指标公式破解站(www.gongshi8.cn)提示:您正在下载的是:资金指数 - 有使用方法
资金指数STICKLINE(C>0,0,90,6,0),COLOR373829;
STICKLINE(C>0,90,100,6,0),COLOR000068;
0,POINTDOT;
个股资金指数:EMA(((100 * (CLOSE - LLV(LOW,17))) / (HHV(HIGH,17) - LLV(LOW,17))),3);DRAWBAND(个股资金指数>20 ,RGB(0,24,224),个股资金指数,RGB(5,96,96));
STICKLINE(C>0,0,20,8,0),COLOR000068;
STICKLINE(C>0,90,100,8,0),COLOR000068;
市场资金指数:EMA(((100 * (INDEXC - LLV(INDEXL,17))) / (HHV(INDEXH,17) - LLV(INDEXL,17))),3),COLORYELLOW;
博弈线:80;
20;
50;
引用公式:
{ZJZJE 资金指数引用公式}
T:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);

{资金指数 通达信}
弱区:20,POINTDOT,COLORGREEN;
分界:50,POINTDOT,COLORWHITE;
强区:80,POINTDOT,COLORYELLOW;
主流资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORMAGENTA,LINETHICK2;
非主流资金:"999999$ZJZJE.T",COLORGREEN,LINETHICK2;

{资金指数 DZH2}
弱区:20,POINTDOT,COLORGREEN;
分界:50,POINTDOT,COLORWHITE;
强区:80,POINTDOT,COLORYELLOW;
主流资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORMAGENTA,LINETHICK2;
非主流资金:STKINDI('SH000001','ZJZJE.t'),COLORGREEN,LINETHICK2;

{资金指数 飞狐}
弱区:20,POINTDOT,COLORGREEN;
分界:50,POINTDOT,COLORWHITE;
强区:80,POINTDOT,COLORYELLOW;
主流资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORMAGENTA,LINETHICK2;
非主流资金:STKINDI('1A0001','ZJZJE.t',0,DATAPERIOD),COLORGREEN,LINETHICK2;



通达信:

 通达信资金指数源码公式
{资金指数(副图指标)}


主流资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORRED,linethick2;
非主流资金:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),colorgreen,linethick2;
20,pointdot,colorf00ff0;
50,pointdot,colorgreen;
80,pointdot,colorwhite;

指标说明:
该指标是软件的精华所在,可以清楚的看出一只股票中主力及散户的强弱关系。它由两条趋势线及三条水平线组成,紫色趋势线代表市场主流金,绿色趋势线代表非主流资金。指标有三条水平线,从上自下数值分别为80、50、20。80以上为超强区,20以下为超弱区,50为强弱分水岭(80—50为强势区,50—20为弱势区)。

使用方法:  
当主流资金摆脱非主流资金上攻,且上穿50,表示主力在投入资金,股价上涨。当主流资金在80以上运行一段时间之后,向下穿越80,显示主力减仓股价可能走弱。
 

 

    猜你喜欢
    发表评论 评论公约
    喜欢该文的人也喜欢 更多