六八六六 / 我的图书馆 / 黑马王子九阴真经1,2公式源码共享

0 0

   

黑马王子九阴真经1,2公式源码共享

2011-04-27  六八六六

来自:王向辉的日志

黑马王子九阴真经1,2公式源码共享

-
效果图如下:
{九阴真经-量柱三阴  编写:王向辉}
{① 量柱三阴:}
{阴过阳,不要娘(当前阴柱超过此前阳柱);}
{阴并阳,宜空仓(当前阴柱并肩此前阳柱);}
{倍量阴,出干净(当前阴柱倍量此前阳柱)。}
量柱三阴:VOL,VOLSTICK;
V13:MA(VOL,13);
YGYJ1:=REF(C,1)>REF(O,1) AND REF(C,1)>REF(C,2) AND C<O AND H>REF(H,1) AND (L<REF(L,1) OR L=REF(L,1));
阴过阳:YGYJ1 AND VOL>REF(VOL,1),COLORYELLOW;
STICKLINE(阴过阳,0,V,1,0),COLORYELLOW;
{DRAWTEXT(阴过阳,VOL*1.40,'阴过阳'),COLORRED;}
DRAWTEXT(阴过阳,VOL*1.25,'不要娘'),COLORYELLOW;
YBYJ1:=REF(C,1)>REF(O,1) AND C<O;
阴并阳:YBYJ1 AND VOL<REF(VOL,1)*1.03 AND VOL>REF(VOL,1)*0.98,COLORGREEN;
STICKLINE(阴并阳,0,V,1,0),COLORGREEN;
{DRAWTEXT(阴并阳,VOL*1.60,'阴并阳'),COLORYELLOW;}
DRAWTEXT(阴并阳,VOL*1.35,'宜空仓'),COLORGREEN;
BLYJ1:=REF(C,1)>REF(O,1) AND C<O;
倍量阴:BLYJ1 AND VOL>REF(VOL,1)*2,COLORRED;
STICKLINE(倍量阴,0,V,1,0),COLORRED;
{DRAWTEXT(倍量阴,VOL*1.70,'倍量阴'),COLORWHITE;}
DRAWTEXT(倍量阴,VOL*1.45,'出干净'),COLORRED;
 
 
=============================================
{九阴真经-量价三阴  编写:王向辉 }
{量价三阴}
{跳空阴,不要命(当前阴线跳离此前阳线);}
{阴盖阳,宜减仓(当前阴线长于此前阳线);}
{双阴露,往外吐(当前连续出现两根阴线)。}
量价三阴:VOL,VOLSTICK;
V13:MA(VOL,9);
YGYJ1:=REF(C,1)>REF(O,1) AND C<O AND ((O-C)>REF(C,1)-REF(O,1));
阴盖阳:YGYJ1,COLORYELLOW;
STICKLINE(阴盖阳,0,V,1,0),COLORYELLOW;
{DRAWTEXT(阴盖阳,VOL*1.30,'阴盖阳'),COLORYELLOW;}
DRAWTEXT(阴盖阳,VOL*1.35,'宜减仓'),COLORYELLOW;
SYLJ1:=REF(C,1)<REF(O,1) AND C<O;
双阴露:SYLJ1,COLORGREEN;
STICKLINE(双阴露,0,V,1,0),COLORGREEN;
{DRAWTEXT(双阴露,VOL*1.70,'双阴露'),COLORWHITE;}
DRAWTEXT(双阴露,VOL*1.45,'往外吐'),COLORGREEN;
TKYJ1:=C<O AND O<REF(L,1) AND H<REF(L,1);
跳空阴:TKYJ1,COLORRED;
STICKLINE(跳空阴,0,V,1,0),COLORRED;
{DRAWTEXT(跳空阴,VOL*1.50,'跳空阴'),COLORBLUE;}
DRAWTEXT(跳空阴,VOL*1.7,'不要命'),COLORRED;
 
 
==========================================修正:剔除假阴线===============
{九阴真经-量价三阴  编写:王向辉 }
{量价三阴}
{跳空阴,不要命(当前阴线跳离此前阳线);}
{阴盖阳,宜减仓(当前阴线长于此前阳线);}
{双阴露,往外吐(当前连续出现两根阴线)。}
量价三阴:VOL,VOLSTICK;
V13:MA(VOL,9);
YGYJ1:=REF(C,1)>REF(O,1) AND C<O AND ((O-C)>REF(C,1)-REF(O,1)) AND C<REF(C,1);
阴盖阳:YGYJ1,COLORYELLOW;
STICKLINE(阴盖阳,0,V,1,0),COLORYELLOW;
{DRAWTEXT(阴盖阳,VOL*1.30,'阴盖阳'),COLORYELLOW;}
DRAWTEXT(阴盖阳,VOL*1.35,'宜减仓'),COLORYELLOW;
SYLJ1:=REF(C,1)<REF(O,1) AND C<O AND C<REF(C,1);
双阴露:SYLJ1,COLORGREEN;
STICKLINE(双阴露,0,V,1,0),COLORGREEN;
{DRAWTEXT(双阴露,VOL*1.70,'双阴露'),COLORWHITE;}
DRAWTEXT(双阴露,VOL*1.45,'往外吐'),COLORGREEN;
TKYJ1:=C<O AND O<REF(L,1) AND H<REF(L,1);
跳空阴:TKYJ1,COLORRED;
STICKLINE(跳空阴,0,V,1,0),COLORRED;
{DRAWTEXT(跳空阴,VOL*1.50,'跳空阴'),COLORBLUE;}
DRAWTEXT(跳空阴,VOL*1.7,'不要命'),COLORRED;
============================================
{九阴真经-量柱三阴  编写:王向辉}
{① 量柱三阴:}
{阴过阳,不要娘(当前阴柱超过此前阳柱);}
{阴并阳,宜空仓(当前阴柱并肩此前阳柱);}
{倍量阴,出干净(当前阴柱倍量此前阳柱)。}
量柱三阴:VOL,VOLSTICK;
V13:MA(VOL,13);
YGYJ1:=REF(C,1)>REF(O,1) AND REF(C,1)>REF(C,2) AND C<O AND H>REF(H,1) AND (L<REF(L,1) OR L=REF(L,1));
阴过阳:YGYJ1 AND VOL>REF(VOL,1),COLORYELLOW;
STICKLINE(阴过阳,0,V,1,0),COLORYELLOW;
{DRAWTEXT(阴过阳,VOL*1.40,'阴过阳'),COLORRED;}
DRAWTEXT(阴过阳,VOL*1.25,'不要娘'),COLORYELLOW;
YBYJ1:=REF(C,1)>REF(O,1) AND C<O AND C<REF(C,1);
阴并阳:YBYJ1 AND VOL<REF(VOL,1)*1.03 AND VOL>REF(VOL,1)*0.98,COLORGREEN;
STICKLINE(阴并阳,0,V,1,0),COLORGREEN;
{DRAWTEXT(阴并阳,VOL*1.60,'阴并阳'),COLORYELLOW;}
DRAWTEXT(阴并阳,VOL*1.35,'宜空仓'),COLORGREEN;
BLYJ1:=REF(C,1)>REF(O,1) AND C<O AND C<REF(C,1);
倍量阴:BLYJ1 AND VOL>REF(VOL,1)*2,COLORRED;
STICKLINE(倍量阴,0,V,1,0),COLORRED;
{DRAWTEXT(倍量阴,VOL*1.70,'倍量阴'),COLORWHITE;}
DRAWTEXT(倍量阴,VOL*1.45,'出干净'),COLORRED;

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多