嘉陵山水 / 同花顺 / 另类布林2(主图、源码、贴图) - 股票公式...

0 0

   

另类布林2(主图、源码、贴图) - 股票公式,股票软件,股票书籍,股票新闻 - 分析家公式...

2011-05-08  嘉陵山水
H1:=EMA(CLOSE,5);
H2:=EMA(H1,12);
UPR:H2+3*STD(H2,10),COLOR008364,LINETHICK2;
DWN:H2-3*STD(H2,10),COLOR008364,LINETHICK2;
Var1:=(CLOSE*2+HIGH+LOW)/4;
Var2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
Var3:=EMA(Var2,3);
Var4:=EMA(Var3,6);
L1:= EMA(Var2,3);
L2:= EMA(Var3,4);
L3:= EMA(Var4,5);
STICKLINE(L1>=L2,(OPEN),(CLOSE),6,0), colorred;
STICKLINE(L1>=L2,(HIGH),(LOW),0.5,0), colorred;
STICKLINE(L1<L2,(CLOSE),(OPEN),6,0) ,colorgreen;
STICKLINE(L1<L2,(HIGH),(LOW),0.5,0), colorgreen;
Var5:=REF(L1,1)>L1 AND L1>L2;
Var6:=L1>L2 AND CLOSE<OPEN;
Var7:=REF(L1,1)<L1 AND L1<L2;
STICKLINE(Var5,(OPEN),(CLOSE),6,0), colorblue;
STICKLINE(Var5,(HIGH),(LOW),0.5,0), colorblue;
STICKLINE(Var7,(OPEN),(CLOSE),6,0), colormagenta;
STICKLINE(Var7,(HIGH),(LOW),0.5,0), colormagenta;
VarE:=SAR(5,1,5);
VarF:=MA(CLOSE,20);
Var10:=IF(CLOSE>450,8,IF(CLOSE>=20 AND CLOSE<150,0.2,IF(CLOSE<20 AND CLOSE>=10,0.07,IF(CLOSE<10,0.03,0.07))));
STICKLINE(CLOSE>VarE,VarF,VarF+Var10,6,0),COLOR0066FF;
STICKLINE(CLOSE<VarE,VarF,VarF-Var10,6,0),COLORFFFF00;
STICKLINE(CROSS(CLOSE,VarE),VarF,VarF-Var10,6,0);
STICKLINE(CROSS(VarE,CLOSE),VarF,VarF+Var10,6,0);
STICKLINE(RANGE(DAY,6,9) OR RANGE(DAY,27,30),VarF+0.01,VarF-0.01,6,0),COLOR00FFFF;
ma20:=MA(C,20);
ma120:=MA(C,120);
ma250:=MA(C,250);
乖离线:=((C-REF(ma20,1))/20+ma20)*1.20;
tt1:=CROSS(ma20,ma120) AND CROSS(ma20,ma250) AND V>REF(V,1);
tt2:=ma20>REF(ma20,2) AND V>REF(V,1) AND CROSS(C,ma20);
STICKLINE(TT1,L,L-0.09,4,0),coloryellow;
DRAWTEXT(TT1,L-0.13,'金叉'),coloryellow;
STICKLINE(CROSS(C,ma120) AND CROSS(C,ma250) AND CROSS(C,ma20),L,L-0.09,4,0),coloryellow;
DRAWTEXT(CROSS(C,ma120) AND CROSS(C,ma250) AND CROSS(C,ma20),L-0.13,'并线开花'),coloryellow;
STICKLINE(tt2,L,L-0.09,4,0),coloryellow;
DRAWTEXT(tt2,L-0.13,'买点1'),coloryellow;
STICKLINE(CROSS(C,乖离线),H,H+0.09,4,0),color00ff00;
DRAWTEXT(CROSS(C,乖离线) ,H+0.13,'卖点'),color00ff00;
STICKLINE(ma250>=REF(ma250,1) AND ma20>=REF(ma20,1) AND CROSS(C,ma250),L,L-0.09,4,0),colorffcc66;
DRAWTEXT(ma250>=REF(ma250,1) AND ma20>=REF(ma20,1) AND CROSS(C,ma250),L-0.13,'牛象'),colorffcc66;
STICKLINE(ma120>=REF(ma120,1) AND CROSS(C,ma20) AND CROSS(C,ma120) AND V>REF(V,1),L,L-0.09,4,0),colorff00ff;
DRAWTEXT(ma120>=REF(ma120,1) AND CROSS(C,ma20) AND CROSS(C,ma120) AND V>REF(V,1),L-0.13,'买点2'),colorff00ff;
RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
U2L:=IF((CLOSE >= MA(CLOSE,20)),80,50);
L2L:=IF((CLOSE >= MA(CLOSE,20)),50,20);
RH1:=IF(((J < U2L) AND (REF(J,1) >= U2L)),HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),REF(HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),BARSLAST(((J < U2L) AND REF(J,1)))));
RH4:=IF((HIGH > RH1),LOW,REF(LOW,BARSLAST((HIGH > RH1))));
RH42:=IF((HIGH > RH1),J,REF(J,BARSLAST((HIGH > RH1))));
RH5:=IF((((HIGH > RH4) AND (J < RH42)) AND (J < J24)),HIGH,REF(HIGH,BARSLAST((((HIGH > RH4) AND (J < RH42)) AND (J < J24)))));
DRAWTEXT(FILTER(((((((((OPEN > ma120) AND (ma20 < ma120)) AND (LOW <= ma120)) AND ((ma20 - REF(ma20,1)) > 0)) AND (CLOSE > OPEN)) AND ((ma120 -REF(ma120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE >= ma120)),15),LOW,'★120跳马');
通达信(源码)
H1:=EMA(CLOSE,5);
H2:=EMA(H1,12);
UPR:H2+3*STD(H2,10),COLOR008364,LINETHICK2;
DWN:H2-3*STD(H2,10),COLOR008364,LINETHICK2;
VAR1:=(CLOSE*2+HIGH+LOW)/4;
VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3:=EMA(VAR2,3);
VAR4:=EMA(VAR3,6);
L1:= EMA(VAR2,3);
L2:= EMA(VAR3,4);
L3:= EMA(VAR4,5);
STICKLINE(L1>=L2,(OPEN),(CLOSE),2,0), COLORRED;
STICKLINE(L1>=L2,(HIGH),(LOW),0,0), COLORRED;
STICKLINE(L1<L2,(CLOSE),(OPEN),2,0) ,COLORGREEN;
STICKLINE(L1<L2,(HIGH),(LOW),0,0), COLORGREEN;
VAR5:=REF(L1,1)>L1 AND L1>L2;
VAR6:=L1>L2 AND CLOSE<OPEN;
VAR7:=REF(L1,1)<L1 AND L1<L2;
STICKLINE(VAR5,(OPEN),(CLOSE),2,0), COLORBLUE;
STICKLINE(VAR5,(HIGH),(LOW),0,0), COLORBLUE;
STICKLINE(VAR7,(OPEN),(CLOSE),2,0), COLORMAGENTA;
STICKLINE(VAR7,(HIGH),(LOW),0,0), COLORMAGENTA;
VARE:=SAR(5,1,5);
VARF:=MA(CLOSE,20);
VAR10:=IF(CLOSE>450,8,IF(CLOSE>=20 AND CLOSE<150,0.2,IF(CLOSE<20 AND CLOSE>=10,0.07,IF(CLOSE<10,0.03,0.07))));
STICKLINE(CLOSE>VARE,VARF,VARF+VAR10,2,0),COLOR0066FF;
STICKLINE(CLOSE<VARE,VARF,VARF-VAR10,2,0),COLORFFFF00;
STICKLINE(CROSS(CLOSE,VARE),VARF,VARF-VAR10,2,0);
STICKLINE(CROSS(VARE,CLOSE),VARF,VARF+VAR10,2,0);
STICKLINE(RANGE(DAY,6,9) OR RANGE(DAY,27,30),VARF+0.01,VARF-0.01,2,0),COLOR00FFFF;
MA20:=MA(C,20);
MA120:=MA(C,120);
MA250:=MA(C,250);
乖离线:=((C-REF(MA20,1))/20+MA20)*1.20;
TT1:=CROSS(MA20,MA120) AND CROSS(MA20,MA250) AND V>REF(V,1);
TT2:=MA20>REF(MA20,2) AND V>REF(V,1) AND CROSS(C,MA20);
STICKLINE(TT1,L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(TT1,L-0.13,'金叉'),COLORYELLOW;
STICKLINE(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L-0.13,'并线开花'),COLORYELLOW;
STICKLINE(TT2,L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(TT2,L-0.13,'买点1'),COLORYELLOW;
STICKLINE(CROSS(C,乖离线),H,H+0.09,4,0),COLOR00FF00;
DRAWTEXT(CROSS(C,乖离线) ,H+0.13,'卖点'),COLOR00FF00;
STICKLINE(MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250),L,L-0.09,4,0),COLORFFCC66;
DRAWTEXT(MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250),L-0.13,'牛象'),COLORFFCC66;
STICKLINE(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L,L-0.09,4,0),COLORFF00FF;
DRAWTEXT(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L-0.13,'买点2'),COLORFF00FF;
RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
U2L:=IF((CLOSE >= MA(CLOSE,20)),80,50);
L2L:=IF((CLOSE >= MA(CLOSE,20)),50,20);
RH1:=IF(((J < U2L) AND (REF(J,1) >= U2L)),HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),REF(HHV(REF(HIGH,1),(BARSLAST(((J >= U2L) AND (REF(J,1) < U2L))) - 1)),BARSLAST(((J < U2L) AND REF(J,1)))));
RH4:=IF((HIGH > RH1),LOW,REF(LOW,BARSLAST((HIGH > RH1))));
RH42:=IF((HIGH > RH1),J,REF(J,BARSLAST((HIGH > RH1))));
RH5:=IF((((HIGH > RH4) AND (J < RH42)) AND (J < J24)),HIGH,REF(HIGH,BARSLAST((((HIGH > RH4) AND (J < RH42)) AND (J < J24)))));
DRAWTEXT(FILTER(((((((((OPEN > ma120) AND (ma20 < ma120)) AND (LOW <= ma120)) AND ((ma20 - REF(ma20,1)) > 0)) AND (CLOSE > OPEN)) AND ((ma120 -REF(ma120,1)) > 0)) AND (HIGH < RH5)) AND (CLOSE >= ma120)),15),LOW,'★120跳马');

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多

    ×
    ×