windds / 我的图书馆 / 【转】股票“最佳买卖点”公式源码及效果图

0 0

   

【转】股票“最佳买卖点”公式源码及效果图

2011-08-24  windds

股票指标公式对高手来说,可能并不重要,但对一般散户,有还是比没有好。所谓“若要工其事,必先利其器”。


图片

 

 

一、“最佳买卖点”公式源码如下:

AA05:MA(C,5),COLOR0099CC;五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),LINETHICK0;
STICKLINE(BB05>30 AND AA05>REF(AA05,1),
AA05,REF(AA05,1),3,1),COLORCYAN;
AA10:MA(C,10);AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
STICKLINE(BB05<0
AND AA05<REF(AA05,1),
AA05,REF(AA05,1),3,1),COLORYELLOW;
AA30:MA(C,30);三拾日乖离率:=(C-AA30)/AA30*100;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1)
AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);

VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND
AA30<REF(AA30,1);

BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
STICKLINE(BB30>15 AND
AA30>REF(AA30,1),
AA30,REF(AA30,1),3,1),COLORFF00FF;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND
CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND
AA05>REF(AA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND
AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10)
;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND
AA05<REF(AA05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND
AA10<REF(AA10,1),10);
DRAWTEXT(加仓
,LOW*0.98,'←加仓'),COLORRED;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND
AA10>REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1
AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5
AND
REF(C,1)<AA30;
买入:=FILTER(MR,10);DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORCYAN;
DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;
DRAWTEXT(清仓
,HIGH*1.02,'←清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;
VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;

 

二、“最佳买卖点”公式源码释义:

输出AA05:收盘价的5日简单移动平均,COLOR0099CC
五日乖离率赋值:(收盘价-AA05)/AA05*100
BB05赋值:(AA05/昨日AA05-1)*100的反正切*180/3.1416
速度5赋值:(AA05-昨日AA05)/昨日AA05的3日指数移动平均*100的3日[1日权重]移动平均
加速度5赋值:(速度5-昨日速度5)的3日指数移动平均,LINETHICK0
当满足条件BB05>30ANDAA05>昨日AA05时,在AA05和昨日AA05位置之间画柱状线,宽度为3,1不为0则画空心柱.,画青色
输出AA10:收盘价的10日简单移动平均
AA20赋值:收盘价的20日简单移动平均
BB10赋值:(AA10/昨日AA10-1)*100的反正切*180/3.1416
当满足条件BB05<0ANDAA05<昨日AA05时,在AA05和昨日AA05位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色
输出AA30:收盘价的30日简单移动平均
三拾日乖离率赋值:(收盘价-AA30)/AA30*100
VAR1赋值:(AA20-AA30)>昨日(AA20-AA30) AND AA20>昨日AA20 AND AA30>昨日AA30
VAR2赋值:(AA30-AA20)<昨日(AA30-AA20) AND AA20<昨日AA20 AND AA30<昨日AA30
BB30赋值:(AA30/昨日AA30-1)*100的反正切*180/3.1416
当满足条件BB30>15ANDAA30>昨日AA30时,在AA30和昨日AA30位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLORFF00FF
强势狙击赋值:BB30>30ANDBB10>45ANDCROSS(BB05,60)的10日过滤
加仓赋值:统计5日中满足BB05上穿30的天数>=1ANDAA05>昨日AA05AND三拾日乖离率>昨日三拾日乖离率ANDAA10>昨日AA10AND加速度5>昨日加速度5AND速度5>昨日速度5的10日过滤
清仓赋值:统计5日中满足30上穿BB05的天数>=1AND(收盘价>AA30ORO>AA30)ANDAA05<昨日AA05AND三拾日乖离率<昨日三拾日乖离率ANDAA10<昨日AA10的10日过滤
当满足条件加仓时,在最低价*0.98位置书写文字,画红色
JC赋值:0上穿五日乖离率 AND 三拾日乖离率<昨日三拾日乖离率 AND AA10>昨日AA10
减仓赋值:JC的10日过滤
MR赋值:统计3日中满足五日乖离率上穿0的天数>=1 AND 三拾日乖离率>昨日三拾日乖离率 AND AA05>昨日AA05 AND (收盘价/昨收-1)*100>5 AND 昨收<AA30
买入赋值:MR的10日过滤
当满足条件减仓时,在最高价*1.02位置书写文字,画青色
当满足条件买入时,在最低价*0.98位置书写文字,画黄色
当满足条件清仓时,在最高价*1.02位置书写文字,画绿色
当满足条件强势狙击时,在最低价*0.98位置书写文字,画黄色
VAR21赋值:最高价-成交额(元)/成交量(手)/100的绝对值和成交额(元)/成交量(手)/100-最低价的绝对值的较大值
VAR3赋值:(开盘价+收盘价)/2-成交额(元)/成交量(手)/100的绝对值
MV赋值:(VAR21+VAR3)/成交额(元)*成交量(手)*100*50

 

三、“最佳买卖点”公式效果图:


图片
 修改后的最佳买点:

M55:MA(CLOSE,55),COLORRED,LINETHICK3;
AA05:=MA(C,5);五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),LINETHICK0;

AA10:MA(C,10);AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;

AA30:MA(C,30);三拾日乖离率:=(C-AA30)/AA30*100;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1)
AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);

VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND
AA30<REF(AA30,1);

BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;

强势狙击:=FILTER(BB30>30 AND BB10>45 AND
CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND
AA05>REF(AA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND
AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10)
;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND
AA05<REF(AA05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND
AA10<REF(AA10,1),10);
DRAWTEXT(加仓
,LOW*0.98,'↑'),COLORYELLOW;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND
AA10>REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1
AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5
AND
REF(C,1)<AA30;
买入:=FILTER(MR,10);DRAWTEXT(减仓,HIGH*1.02,'↓'),COLORYELLOW;
DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;
DRAWTEXT(清仓
,HIGH*1.02,'←清仓'),COLORGREEN;

VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;

 

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多