tianyafangxin / 股市公式 / 选股公式

0 0

   

选股公式

2011-09-01  tianyafan...
5日,10日,20日,30日均线拐头向上选股公式

参数设置:N:缺省5 ,  N1   10 , n2   20,n3   30}

MA(C,N)>=REF(MA(C,N),1),;

MA(C,N1)>=REF(MA(C,N1),1),;

MA(C,N2)>=REF(MA(C,N2),1),;

MA(C,N3)>=REF(MA(C,N3),1),;

几种实用的条件选股公式

  条件选股公式:D!HMCSF (黑马草上飞) 缺省周期:日线
 
LCZ:=(C-MA(C,60))MA(C,60)*100;
A1:=COUNT(MA(C,60)>REF(MA(C,60),1),100)>95;
A2:=COUNT(LCZ<20,100)>95;
A3:=COUNT(C>MA(C,60),100)>80;
A4:=CREF(C,1)>1.04;
 A5:=VCAPITAL*100>2.8;
ZTJ:=A1 AND A2 AND A3 AND A4 AND A5;
ZTJ AND (REF(BARSLAST(ZTJ),1)>20 OR BARSSINCE( ZTJ)=0);
 
黑马草上飞: 160日价格均线平稳上扬。 2、日K线按照60日均线斜率震荡上行。 3、经过大半年的震荡向上,终于向上突破。操作:发出信号后逢低积极介入。 
 
条件选股公式:D!LYT (老鸭头)缺省周期:日线
 
MA5 := MA(close,5);
MA10 := MA(close,10);
MA60 := MA(close,60);
pday1 := barslast(cross(ma5,ma60));{5日均线上穿60日均线}
pday2 := barslast(cross(ma10,ma60));{10
日均线上穿60日均线,至此形成鸭颈部}
pday3 := barslast(high=hhv(high,pday2));{
形成头部,要下跌}
 
pday4 := barslast(cross(ma10,ma5));{下跌后,5日均线和10日均线死叉}
pday5 := barslast(cross(ma5,ma10));{
回落不久,5日均线和10日均线形成金叉,形成嘴部}

a1:= pday1>pday2 and pday2>pday3 and pday3>pday4 and pday4>pday5 and pday5<5;

a2:= count(cross(ma10,ma5),pday2)=1;
 
A1 AND A2;


老鸭头:(1)采用51060周期的价格平均线。当5日、10日均线放量上穿60日平均线后,形成鸭颈部。
2)股价回落时形成的高点形成鸭头部。
3)当股价回落不久,5日、10日均线再次金叉向上形成鸭嘴部。
操作:(
1)在5日、10日均线放量上穿60日平均线形成鸭颈部时买入。
2)在鸭嘴部附近成交量芝麻点一带逢低买入。
3)当股价放量冲过鸭头顶瞬间时介入。
 
条件选股公式:D!LZMD (量芝麻点) 缺省周期:日线 
V1:=MA(V,40);
HSL:=VCAPITAL*100;
A1:=COUNT(VV1<1.3,14)>11;
 A2:=CROSS(HSL,2);
 A3:=CREF(C,1)>1.025 AND C>OPEN;
ZTJ:=A1 AND A2 AND A3;
 
量芝麻点:成交量连续出现萎缩,在量柱体图上表现为小芝麻点,连续的小芝麻点与40日量平均线形成一个小水坑。
操作建议:最好
K线浅幅回档,且成交量越小越好,当放量上行时买入。
 
条件选股公式:D!QLQS (青龙取水) 缺省周期:日线 
A1:=MIN(MA(C,5),MA(C,10))>MA(C,60) AND CROSS(MA(C,5),MA(C,10));
A2:=MIN(MA(C,5),MA(C,10))MA(C,60)<1.05;
A3:=COUNT(V<MA(V,10),10)>6;
A1 AND A2 AND A3; 
青龙取水: 1、在5日、10日、60日均线图上,510日均线起伏不定,日K线在60日均线上逶迤。
2
、龙头回到60日均线附近,犹如青龙取水,同时成交量萎缩
3
、然后大涨。
 
操作:待龙头形成,成交量萎缩又放大后,逢低介入。 
条件选股公式:D!QSGT (轻松过头) 缺省周期:日线 
nday := hhvbars(high,120); {120
日内最高价的周期数}
 nday1:= nday-10; {
最高点之后10}
nday2:= nday+10; {
庄家应该在nday1--nday2之间吸纳大部分筹码}
a1 := nday>=30;{
确保高点出现的周期数大于30}
a2 := ref(sum(vol,20),nday1) > finance(7) * 0.4; {
吸纳40%} VMA:=MA(Vol,40);{40日量均线}
A3:=COUNT(Vol<VMA,nday1)nday1>0.9;{
成交量呈现芝麻点}
A4:=Close>=hhv(high,120);{
股价在冲击前高位}
A5:=COUNT(Vol<(MA(vol,10)*1.3),10)>8;{
近期无明显放量}
A1 AND A2 AND A3 AND A4 AND A5; 
轻松过头:
1)前一个头部下方的成交量巨大,股价筑头后开始回档。
2)回档完毕后成交量呈量芝麻点,股价再次上扬冲击前一头部。
3)轻松冲过前一头部并未明显放量。
操作:(
1)在前一头部成交量巨大时跟进。
2)在回档完毕后成交量呈现芝麻点时逢低吸纳。
3)最经济、最大利润化的方法是在轻松过头前的一瞬间迅速介入。
4)前头部价格一般是上升浪的腰部。 
条件选股公式:D!SJCJD (三金叉见底) 缺省周期:日线 
nday := 5;
down := closellv(low,60)<=1.2;
pma1 := ma(close,5);
pma2 := ma(close,10);
vma1 := ma(vol,5);
vma2 := ma(vol,10);
 diff := ema(close,12) - ema(close,26);
dea := ema(diff,9);

 
ppday := barslast(cross(pma1,pma2));
vvday := barslast(cross(vma1,vma2));
macdday := barslast(cross(diff,dea));
sjcjd:= if((ppday<=nday and vvday<=nday and macdday<=nday),1,0);

三金叉见底:
1)当股价长期下跌后开始企稳筑底,而后股价缓慢上升。有时会同时出现5日和10日均价线、5日和10日均量线、MACD的黄金交叉点,这是股价见底回升的信号。
2)有时会伴随出现两阳夹一阴多方炮、出水芙蓉、量顶天立地和MACD上穿零线等图形。
操作:
1)当出现三金叉后开始买入股票。
 
2)或等股价回档时在10日均线附近逢低吸纳。 
条件选股公式:D!SSCJD (三死叉见顶) 缺省周期:日线 
nday := 5;
down := hhv(high,20)high<=1.15;
 pma1 := ma(close,5);
 pma2 := ma(close,10);
vma1 := ma(vol,5);
vma2 := ma(vol,10);
diff := ema(close,12) - ema(close,26);
dea := ema(diff,9);
ppday := barslast(cross(pma2,pma1));
 vvday := barslast(cross(vma2,vma1));
macdday := barslast(cross(dea,diff));
sscjd:= if((ppday<=nday and vvday<=nday and macdday<=nday),1,0);
 
三死叉见顶:
1)当股价长期上涨后开始进入头部,而后股价缓慢下跌。有时会同时出现5日和10日均价线、5日和10日均量线、MACD的死亡交叉点,这是股价见顶回落的信号。 2)有时会伴随出现两阴夹一阳空方炮、断头铡刀MACD下穿零线等图形。
操作:(
1)当出现三死叉后坚决卖出股票。(2)或等股价反弹到10日均线附近逢高派发。
 
 
 
 选股小公式
1,30个交易日内,股价跌幅达到一半的股票:
xg:(hhv(c,30)-c)/hhv(c,30)>0.5;

2,今天的量  是5天平均的 2倍以上  
xg:v>ma(v,5)*2;

缩量

vol/ma(vol,10)<0.3;

 

3,两天内,累计下跌等于或超过20%选股.
 
xg:(ref(c,2)-c)/c>0.2;

 

4,股价是25天以来新低. 

 xg:c<ref(llv(c,25),1);


5,选股:EXPMA 5日与10日金叉 并且第二天的收盘价在EXPMA的5日线以上.

cross(ref(ema(c,5),1),ref(ema(c,10),1)) and c>ema(c,5);

 

6,请编买入公式:
1. 将BIAS指标的参数设置为24日,将KD指标的参数设置为9;3;3。
2. BIAS指标要小于-6,这只是确认该股超跌的初选条件。
3. KD指标产生黄金交叉,K线上穿D线。
4. KD交叉同时,KD指标中的D值要小于16。

BIAS3 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100,colorff00ff;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
xg:BIAS3<-6 and cross(k,d) and d<16;

 

7,要求是量大、换手率达到3左右,涨幅>7个点。

xg:v/capital*100>3 and (c/ref(c,1)>1.07;

 

8,个股分时图上都有一条黄线,叫做均价线

 a/capital*100;

 

9,"阴转阳"的公式(也就是昨天收阴线,今天收阳线)

 xg:ref(c,1)<ref(o,1) and c>o;

 

10,股价回抽20日均线选股公式

 xg:ref(c,1)>ma(c,20) and cross(ma(c,20),c);

 

11,一根大阳线,至少有5个点以上,再连着出现二根振幅不大于5的十字星或是小K线

 xg:(ref(c,3)-ref(c,4))/ref(c,3)>0.05 and count((h-l)/l<0.05,2)=2;

 

12,行情信息里的“涨幅”的原码

 (c-ref(c,1))/c*100;

 

13,kdj的J从上向下穿越O轴发出信号

 RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
xg:cross(0,j);

 

 14,股价4天中有两天在10日线上

count(c>ma(c,10),4)=2;

 

15,选出10天内出现了涨停的个股

 count(c/ref(c,1)>1.1,10)>0;

 

 又:

今涨停:=C/REF(C,1)>1.09;
选股:count(今涨停,n);

 

16,一阳上穿10,20,30日线,量能是前一天3倍。

 xg:cross(c,ma(c,10)) and cross(c,ma(c,20)) and cross(c,ma(c,30)) and v>ref(v,1)*3;

 

 17,共三根K线,第一根K线为阴线;第二根K线为阴线线,最高价低于第一根K线,最低价高于第一根K线;第三根K线阴阳不限,最高价低于第二根K线,最低价高于第二根K线。满足后发出信号~

w1:=ref(c,2)<ref(o,2);
w2:=ref(h,2)>ref(h,1) and ref(l,2)<ref(l,1);
w3:=ref(h,1)>h and ref(l,1)<l;
xg:w1 and w2 and w3;

 

18, 选出今日成交量大于昨日成交量一成的股票。

 xg:v>ref(v,1)*1.1;

 

19, 连续5天,当日的5日均线减前一天的5日均线差值小于1.

 count((ma(c,5)-ref(ma(c,5),1))<1,5)=5;

 

20,股价上穿5周均线:
xg:cross(c,ma(c,5));
注意:选股时用周线

 

21,上穿30日均线的公式
xg:cross(c,ma(c,30));

 

22,两笔阴线中间夹着一根阳线或数根K线,其中两笔阴线最低点相等
 xg:ref(l,2)=l;

 

23,量比大于1 同时换手大于2的公式
 xg:v/ref(v,1)>1 and AMOUNT/CAPITAL*100>2;

 

 24,换手:VOL*100/CAPITAL;
     周期换手:SUM(换手,10);

 

 25,流通盘小于4000万 的选股公式 

 xg:CAPITAL/100<4000;

 

26,涨停开盘跌停收盘选股

xg:h/ref(c,1)>1.1 and ref(c,1)/l>1.1;

 

 27,当天开盘价与收盘价相等的选股公式

 xg:c=o;

 

28,5日均线向上 流通盘小于5000万 换手率大于3的选股公式 

 lt:CAPITAL/100<5000;
换手:=VOL*100/CAPITAL<3;
w1:ma(c,5)>ref(ma(c,5),1);
xg:lt and 换手 and w1;

 

29,收下影线

 xg:c>l;

 

30, o=l就没有下引线了,那就:
xg:c>l and o>l;

 

31,当日收盘下穿5日均价

 xg:cross(ma(c,5),c);

 

32,最低价小于前一日的最低价但收盘后为阳线。
xg:l<ref(l,1) and c>o;

 

33,30日内到本日收盘价下跌20%的公式

 xg:hhv(c,30)/c>1.2;

 

34,选周线跳空缺口的个股。

 xg:HIGH<REF(LOW,1) OR
LOW>REF(HIGH,1);

周期选周线


35,30日均线走平或走高的个股

 xg:ma(c,30)>ref(ma(c,30),1);

 

 36,连续4天的收盘价格波动幅度在3%之内连续走平或向上
 count(abs(c-ref(c,1)/ref(c,1))<0.03 and c>ref(c,1),3)=3;

 

 37,下影线长于上影线 

 (c-l)>(h-c);

 

38, 收盘价+收盘价的10%
(c+c*0.1);

 

39,今天高开的公式
 c>o;

 

 40,今天的量大于等于昨天量的2倍,股价上涨
xg:v>ref(v,1)*2 and c>ref(c,1);
 

 41,今天的量小于昨天量的2倍以上,股价上涨
xg:v<ref(v,1)*2 and c>ref(c,1);

 

 42,大部分股票跌到43日均线时就会反弹,如果在43日均线附近买入,短线成功率占90%以上,即时选出还差几分钱就跌到43日均线的股票。

xg:abs(c-ma(c,43))/ma(c,43)<0.01;

 

 

43,{选出每天换手5%-15%之间的股票}
Var1:=100*VOL/CAPITAL;
w1:=var1>5;
w2:=var1<15;
xg:w1 and w2;

 

44,换手率10天80%以上的选股公式
sum(VOL/CAPITAL*100,10)>80;

 

45,60个交易日内,涨幅大于9.9%(涨停)的天数

 count(c/ref(c,1)>1.099,60);

 

46,昨天跌幅大于3%,今天开盘高开2%以上的选股公式。

 xg:ref(c,1)/ref(c,2)<0.97 and o/ref(c,1)>1.02;

 

47,选出周换手率小于10%的股票
 sum(VOL/CAPITAL*100,5)<10;

 

48,成交量创20日新低,并且股价也创20日新低

 xg:v=llv(v,20) and c=llv(c,20);

 

 49,5日不涨,绿线收盘选票指标

 count(c<o,5)=5;

 

 50"今日MACD等于昨天的MACD  ,且macd>0"  的指标

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
xg:macd=ref(macd,1) and macd>0

 

 51连续2天收盘价跌破30日均线,就显示"卖出"信号

 a1:count(c<ma(c,30),2)=2;
drawtext(a1,c,'卖出'),colorgreen;

 

52,股票在这条均线上在8天以上,上下幅度不大,

 a1:abs((c-ma(c,120))/ma(c,120))<0.1;
xg:count(a1,8)=8;

 

53, 连续三天高开高走的选股公式

count(o>ref(c,1) and c>o,3)=3;

 

 54,n天内曾经有m个涨停

 
count(c/ref(c,1)>1.09,n)>m;

 

 55,股价比昨天的高,量比昨天小,放量。
xg:c>ref(c,1) and v<ref(v,1) and ref(v,1)>ref(v,2)*2;

 

56,连续3天每天的最低价都比前一天高

count(l>ref(c,1),3)=3;

 

 57,周量缩小50%或40%或n%
 
a1:vol/capital*100;
xg:a1/ref(a1,1)<n/100;

 

 58,股价超过五日均价的15%以上,并给出卖出信号

 卖出:c/ma(c,5)>1.15;

 

59,连收两个十字星的选股公式

 count(abs((c-o)/o<0.01),2)=2;

 

60,n横盘天数,n1横盘的上下幅度

REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=(n1/100)
and ref(v,1)<ref(ma(v,5),1) and cross(v,ma(v,5)) and cross(v,ma(v,10));

 

 

 61,收盘价连续8天都站在5日均线的股票。

 count(c>ma(c,5),8)=8;

 

62,振幅大于5%,收盘价大于3.5小于15元,三日均线大于昨日的三日均线,去掉ST股。

 
a1:=h/l>1.05;
a2:=c>3.5 and c<15;
a3:=ma(c,3)>ref(ma(c,3),1);
xg:a1 and a2 and a3;

 

63,收盘价下有60天前的远期获利盘n%。
{60天前的远期获利盘:=ppart(60)*100;} 

 aa:WINNER(ref(c,60 ))*100;

 

 64,连续三日收阳 后日收盘高于前日 且每日收于当日最高价附近 每日涨幅不大于4%

选股:count(c>o and c>ref(c,1) and abs((h-c)/c)<0.01 and c/ref(c,1)<1.04,3)=3;

 

65,昨日收阴, 今日收阳,的K线组合。

 C>O AND REF(C,1)<REF(O,1);

 

66,股价突破5ma买入,跌破5ma卖出。买入和卖出用箭头表示 (副图)

a1:cross(c,ma(c,5));
a2:cross(ma(c,5),c);
drawtext(a1,low*0.98,'↑'),colorred;
drawtext(a2,h*1.02,'↑'),color00ffff;

 

67,今天的250平均线大于昨天的昨天的250平均线
 ma(c,250)>ref(ma(c,250),1);

 

68,历史高点到前一高点画线

 POLYLINE(h>=hhv(c,0),h);

 

 69,均线中增加一根线,这根线的价格是5日线的1.2倍

aa:ma(c,5)*1.2;

 

 70,20天均线向上的股

 xg:ma(c,20)>ref(ma(c,20),1);

 

71,连续3天收盘全是阴线。

 count(c<ref(c,1),3)=3;

 

72,今天收盘价在昨天收盘价-2%~2%之间

c/ref(c,1)>0.98 and c/ref(c,1)<1.02;

 

 73,收盘价在5日均线以上5天

 count(c>ma(c,5),5)=5;

 

74,N天前换手率大于8%  

REF(VOL/CAPITAL*100,N)>8;

 

75,一条均线18MA  股价上涨后“缩量”回调到18MA
  XG:COUNT(V<REF(V,1) AND C<O,N)=N AND C>MA(C,18);
N  “缩量”回调的天数

 

76,1。昨日量是n天以来最低量,(n可调);2。今日量是昨日量的m倍,(m可调);3。今日k线收阳线;
 xg:ref(v,1)=llv(ref(v,1),n) and v>ref(v,1)*m and c>o;

 

77,第一天收阴,第二天,第三天,第四天,收出红三兵

 XG:REF(C,3)<REF(C,4) AND COUNT(C>O,3)=3;

 

78,月k线十字星收盘  并且5月线拐点向上。
 XG:ABS(C-O)/O<0.02 AND MA(C,5)>REF(MA(C,5),1);
用月线选股

 

79,最近3天(包括昨天.前天)股价突破250日均线

COUNT(C>MA(C,250),3)=3;

 

80,跳高大阴线,条件: 1 开盘跳空4%以上2 大阴线实体6%以上.
O/REF(C,1)>1.04 AND C/REF(C,1)<0.94;

 

81,条件:1: 假设大前天创最近新高,要求这天涨幅是超过7%的大阳线,且创最近一个月的新高.
         2: 那么前天,昨天,今天都收小K线,要求小K线实体

xg:ref(c,3)/ref(c,4)>1.07 and ref(c,3)=hhv(c,20) and count(abs((c-ref(c,1))/ref(c,1)<0.02,3)))=3;

 

 82,60与120均线距离在n%内

 XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))<N/100;

 

83,5日均线倾角大于60度

X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;

也可以这样:
X:(ATAN((EMA(C,5)/REF(EMA(C,5),1)-1)*100)*180/3.14115926)>60;
 
利用指标排序:
X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
 
 
84,“中阴之后,跳拉阳”
c/ref(c,1)>1.05;

 

------------------------------------------------------------------------------------------------------ 

85,count(x,n) 意思是n天内出现过信号的,假设n=10,那么就是10天内出现信号(包括今天),如果不加这个的话,就是限定在今天出信号才选出来,以前的不管。

86, 今天涨停的公式
C/REF(C,1)>1.09;
 
 
87,10日内有涨停的公式
今涨停:=C/REF(C,1)>1.09;
选股:count(今涨停,10);
 
 
88,昨日前日涨停的
REF(C,1)/REF(C,2)>1.095;
--------------------------------------------------------------------------------------------------------
 89,近5日K线最高价和最低价格波动在10%以内,成交量是昨日2倍,收盘涨5%
XG:(HHV(C,5)-LLV(C,5))/LLV(C,5)<0.1 AND V>REF(V,1)*2 AND C/REF(C,1)>1.05;
 
 
90,60与120均线距离在n%内
XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))<N/100;
 
 
 91,“中阴之后,跳拉阳”
c/ref(c,1)>1.05;
 
 
 92,能在图上提示个股(不含S或ST股)出现过的涨跌停板日期的公式

w1:if((c-ref(c,1))/ref(c,1)>0.1,date-1000000,c);
 
 
 93,涨幅≤2%
 (c-ref(c,1)/ref(c,1)*100<2;
 
 
 94,5日,10日,30日贴近公式,越贴越好
m1:=ma(close,5);
m2:=ma(close,10);
m3:=ma(close,20);
m4:=ma(close,30);
y1:=max(max(max(m1,m2),m3),m4);
x1:=min(min(min(m1,m2),m3),m4);
黏合:y1/x1<n;
n越小越黏合(n,1.01-----1.05)
 
 
95,(1)换手率均线DMA(c ,v/CAPITAL );
(2)20天以来的任意天期(n),换手率均线正负波动值<=p%;

AA:=DMA(c ,v/CAPITAL );
ab:=(aa-ref(aa,1))/ref(aa,1)*100<p;
bb:count(ab,20)>=n;
 
 
96, 30天线拐头向上出现提示
ma(c,30)>ref(ma(c,30),1);
 
97,今天的换手率大于前天的一倍以上
w1:=v*100/capital;
w1>ref(w1,2)*2;
 
98,K线沿着5日均线往上爬的选股公式
w1:ma(c,5);
w2:abc(c-w1)/w1<0.01;
xg:count(w1>ref(w1,1),5)=5 and w2;
 
 
99,20日均线,上穿62日均线
xg:cross(ma(c,20),ma(c,62));
 
 
 100,平台整理的公式,整理时间和整理幅度可调
COUNT(CLOSE,0)>N AND
(HHV(CLOSE,N)-LLV(CLOSE,N))/LLV(CLOSE,N)<=(N1/100);
N整理时间,N1整理幅度
 
 
 101,选出当日收盘价突破10日均线5%的个股
cross(c,ma(c,10)*1.05);
 
 
102,选出当日最低价在10日均线上下0.05%内,收盘价在均线上方的个股

abs(l-ma(c,10))<0.005 and c>ma(c,10);
 
 
103,第一天股票涨停,第二天成交量是第一天成交量的1倍,并超过10%.那第三天就是买点
w1:=ref(c,2)/ref(c,3)>1.1;
w2:=ref(v,1)/ref(v,2)>2;
xg:w1 and w2;
 
104,放量2倍突破300日线的选股指标
cross(c,ma(c,300)) and v>ref(v,1)*2;
 
 
105,3日均线上穿10日均线,KDJ有效金叉
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
w1:=cross(ma(c,3),ma(c,10));
xg:w1 and cross(k,d);
 
 
 106,30日均线拐头向上
 ma(c,30)>ref(ma(c,30),1);
 
107,连续3-5天,每天的收盘价涨跌幅不超过1%.
 w1:abs(c-o)<0.01;
xg:count(w1,5)>=3;
 
108,K线收十字星
 abs(c-o)/o<0.01;
 
109,MACD在8天以内两次金叉
DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);
w1:cross(DIFF,dea);
xg:count(w1,8)>=2;
 
110,昨天升降幅在-n%----n%之间
w1:abs(ref(c,1)-ref(c,2))/ref(c,2)*100<n;
 
 
111,于20日均线相差2个百分点的
w1:abs(c-ma(c,20)/ma(c,20)*100<2;
N日均线相差M个百分点的公式.
w1:abs(c-ma(c,n)/ma(c,n)*100<m;
n:N日 m:M个百分点
 
 
 112,60MA由向下调头向上
 ma(c,60)>ref(ma(c,60),1);
 
 
113, 股价回调到14日均线的选股
abs(c-ma(c,14))/ma(c,14)<0.005;
 
114,历史第5根K线到第30根K线之间的最高价
hhv(ref(c,5),25);
 
115,MACD的拐点公式
DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);
拐点:ref(macd,2)>ref(macd,1) and ref(macd,1)<macd;
 
 
116,跳空高开收阳线
LOW>REF(HIGH,1) and c>o;
 
 
117,涨停过300日线的选股公式
 c/ref(c,1)>1.09 and cross(c,ma(c,300));
 
 
 118,成交量是前5天中其他任何一天的10天均量线的3.5倍以上
 w1:=llv(ma(v,10),5);
xg:v>w1*3.5;
 
 
119,股价N天内连续沿着5天线走,且每天收盘价与5天线的距离不超过2%的选股公式
 w1:=abs(c-ma(c,5))/ma(c,5)<0.02;
xg:count(w1,n)=n;
 
 
120,跳空高开后,三天内没有回补缺口
 ref(LOW,2)>REF(HIGH,3) and l>ref(LOW,2);
 
 
121,日涨幅小于3%
C>0    AND    C/REF(C,1)  >1.03;
 
 
122, 股价创30个交易日的新高
H>ref(H,30);

123,连续n天收阳线
UP:=CLOSE>OPEN;
COUNT(UP,N)=N;
 
124, {5日内第二大量}
zdl:=hhv(v,5);
v0:=IF(v>=zdl,0,v);
v1:=IF(ref(v,1)>=zdl,0,ref(v,1));
v2:=IF(ref(v,2)>=zdl,0,ref(v,2));
v3:=IF(ref(v,3)>=zdl,0,ref(v,3));
v4:=IF(ref(v,4)>=zdl,0,ref(v,4));
第二大量:MAX(MAX(MAX(MAX(v0,v1),v2),v3),v4);
DRAWTEXTABS( 0,10 ,'第一大量 '+ zdl+'  第二大量'+第二大量);
 
同理可求出第三大、第四大和最小量.实行简单的排列.
这个公式好比是一件完整产品中的一个零部件,解决了一个思路问题.
 
 
125,{5日均线倾角大于60度}
X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;
 
126,连续三涨停---- ㊣
A:=C/REF(C,1)>1.095;
XG:EVERY(A,3);


127,30日线开始上翘---- ㊣
MA30:MA(C,30);
(MA30>REF(MA30,1))(REF(MA30,1)<=REF(MA30,2));


128,当收盘价大于10均线时,主图背景是黄色的,小于的时候是绿色的★★★---经典
ma10:=ma(c,10);
DRAWGBK(c>=ma10),colorred;
DRAWGBK(c<ma10),colorgreen;


129,日涨幅小于3%---- ㊣
C>0  AND  C/REF(C,1)  <1.03;


130,股价创30个交易日的新高---- ㊣
H>ref(H,30);
收盘创30个交易日的新高:
c>ref((c,30),1);



131,3根阳线,并且第二根阳线的量比第一根小,第三根的量比第二根小---- ㊣
EY:=CLOSE>OPEN;
ZL:=VOL<REF(VOL,1);
XG:SUM(EY,3)=3SUM(ZL,3)=3;

或者这样:
EY:=CLOSE>OPEN;
ZL:=VOL<REF(VOL,1);
XG:COUNT(EY,3)=3COUNT(ZL,3)=3;

132,昨天的量为阴量,或昨天量比前天量要小(缩量)---- ㊣
SL:REF(VOL,1)<REF(VOL,2)REF(CLOSE,1)<REF(OPEN,1);

133,只要交换金叉时均线前后的位置,就变成死叉的写法了:---- ㊣
死叉:CROSS(MA(C,10),MA(C,5));


134,macd后金叉高于前金叉
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
JC:=CROSS(DIFF,DEA)AND DEA<0;
JJ:=BARSLAST(JC);
QC:=CROSS(DIFF,DEA)AND COUNT(JC,30)=2;
REF(DEA>REF(DEA,JJ),1)AND QC;
REF(DEA<REF(DEA,JJ),1)QC;

135,计算N日均线斜率:★★★---经典★★★---经典
JX:=REF(EMA(C,N),1);
斜率:(EMA(C,N)-JX)/JX*100;

136,开盘N小时内,股价一直大于均价
IF(OPENMINUTES(HOUR<N),C>DYNAINFO(11),0);

137,N天内跌幅超过X:★★★---经典
N:=20;X:=30;
IF(SUM((1-C/REF(C,1))*100,N)>X,1,0);

138,macd二次金叉:---- ㊣
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
JC:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));//首先界定金叉条件:
选股:CROSS(DIFF,DEA)DEA<0JC=2; //定位金叉的次数:

139,M天内、曾经连续N次涨停:---- ㊣
连续涨停:=COUNT(C/REF(C,1)>1.099,N)=N;
所有个股:COUNT(连续涨停,M)=1;


教你如何将公式改为选股公式
步骤一.将所有的显示式":",改为不显示式":="
选股条件的基本要求为只能输出1个条件式,故要先将公式中所有的显示式":"改为不显示式":=",
如果原来显示式后面接有线型描述(颜色.对齐..等),也一并删除
例如:
ma1:ma(c,5),colorred;
ma2:ma(c,10),colorgreen,POINTDOT;
.....

先改为
ma1:=ma(c,5);
ma2:=ma(c,10);
.....

步骤二.找出选股条件,并写成选股式引用:
条件的寻找方法,依不同目的,大致可分以下几种:
--------------------------------------------------------------------------------------------
1.'字'选股     如:'买'选股
方法:先找出公式中出现有'字'的地方,该式开头会以DRAW..TEXT开头,
DRAWTEXT  DRAWTEXTEX  DRAWYITEXT DRAWFLAGTEXT DRAWMOVETEXT
找到后,该函数(条件, ,'字')后面括号内的第1个即为条件,将该条件复制出来并加上分号即可
例如:
{求'5日均>10日均'选股}
ma1:=ma(c,5);
ma2:=ma(c,10);
DRAWTEXT(ma1>ma2,ma1,'5日均>10日均');
[解]
ma1:=ma(c,5);
ma2:=ma(c,10);
ma1>ma2;
--------------------------------------------------------------------------
2.图标选股     如:笑脸选股
方法:
先依不同软件,找出该图标的代号,
再找出公式中出现DRAWICON函数(条件,   ,图标代号)的式子,对照图标的代号(括号内的第3个),如果该图标代号为所求代号,
该函数后面括号内的第1个即为条件,将该条件复制出来并加上分号即可
例如:
{求图标1选股}
ma1:=ma(c,5);
ma2:=ma(c,10);
DRAWicon(ma1>ma2,ma1,1);
[解]
ma1:=ma(c,5);
ma2:=ma(c,10);
ma1>ma2;
--------------------------------------------------------------------------------
3.A线上穿(下穿)B线选股  {上穿--金叉,下穿--死叉}
方法:A线上穿B线:  cross(A,B);
     A线下穿B线:  cross(B,A);
例如:
{求ma1上穿ma2选股}
ma1:ma(c,5);
ma2:ma(c,10);
[解]
ma1:=ma(c,5);
ma2:=ma(c,10);
cross(ma1,ma2);

{求ma1下穿ma2选股}
ma1:ma(c,5);
ma2:ma(c,10);
[解]
ma1:=ma(c,5);
ma2:=ma(c,10);
cross(ma2,ma1);

-------------------------------------------------------------------------------------------
4.线A上穿(下穿) 选股  
方法:线A上穿:  cross(A,ma(A,2));    或  cross(A,ref(A,1));
     线A下穿:  cross(ma(A,2),A);    或  cross(ref(A,1),A);
例如:
{求改成ma1上穿}
ma1:ma(c,5);
[解]
ma1:=ma(c,5);
cross(ma1,ma(ma1,2));

ma1:=ma(c,5);
cross(ma1,ref(ma1,1));

{求改成ma1下穿}
ma1:ma(c,5);
[解]
ma1:=ma(c,5);
cross(ma(ma1,2),ma1);
或  
ma1:=ma(c,5);
cross(ref(ma1,1),ma1);
---------------------------------------------------------------------------------------------
5.第1次出现条件A 选股
方法:先找出条件A,
     再利用cross(A,0.5);

例如:
{求改成出现图标1选股}
ma1:=ma(c,5);
ma2:=ma(c,10);
DRAWicon(ma1>ma2,ma1,1);
[解1]
ma1:=ma(c,5);
ma2:=ma(c,10);
A:=ma1>ma2;
cross(A,0.5);
[解2--直接将条件A写入]
ma1:=ma(c,5);
ma2:=ma(c,10);
cross(ma1>ma2,0.5);
-------------------------------------------------------------------------------------------
6.线变色选股   如:黄线变红色选股 (指标线为黄线,再利用函数变红色线)
方法:先依不同软件,找出条件A,
     再用cross(A,0.5);

(1)飞狐
条件在PARTLINE(条件A, ),colorred;括号内的第1个即为条件,将该条件复制出来并加上分号即可
例如:
{求黄线变红色选股  飞狐}
ma1:ma(c,5),coloryellow;
PARTLINE(ma1>REF(ma1,1),ma1),colorred;
[解]
ma1:=ma(c,5);
A:=ma1>REF(ma1,1);
cross(A,0.5);

(2)大智慧L2.分析家
条件在PARTLINE(  ,条件A,rgb(255,0,0),  , ...);
括号内为rgb(255,0,0)的前1个即为条件,将该条件复制出来并加上分号即可
例如:
{求黄线变红色选股  大智慧L2.分析家}
ma1:=ma(c,5);
PARTLINE(ma1,ma1>REF(ma1,1),rgb(255,0,0),1,rgb(255,255,0));
[解]
ma1:=ma(c,5);
A:=ma1>REF(ma1,1);
cross(A,0.5);

(3)通达信
条件在IF(条件A,   ,DRAWNULL),colorred;括号内的第1个即为条件,将该条件复制出来并加上分号即可
例如:
{求黄线变红色选股  通达信}
MA1:MA(C,5),COLORYELLOW;
IF(MA1>REF(MA1,1),MA1,DRAWNULL),COLORRED;
[解]
MA1:=MA(C,5);
A:=MA1>REF(MA1,1);
CROSS(MA1>REF(MA1,1),0.5);
--------------------------------------------------------------------------------
7.颜色柱选股
方法:先找出公式中出现有STICKLINE函数的地方,
找到后,核对该函数后面的颜色,是否为所求颜色,
若颜色相同,则括号内的第1个即为条件A,将该条件复制出来并加上分号即可

例如:
{求红色柱选股}
STICKLINE(c>o,h,l,0.8,1),colorred;
[解]
A:c>o;

{求第1次红色柱选股}
STICKLINE(c>o,h,l,0.8,1),colorred;
[解]
A:=c>o;
cross(A,0.5);

步骤三.最后将所有绘图函数及单一输出值(如 0;  k;  if(,,); )全删除,使公式只剩1个选股式输出即成,
(若有2个以上条件,条件同时成立时,可在条件间用"and"连接;
  若有2个以上条件,允许条件不同时成立时,可在条件间用"or"连接);

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多