西北能胜 / 我的图书馆 / 135战法指标主图附图

0 0

   

135战法指标主图附图

2011-12-11  西北能胜

1》主图指标

N :=5;
EMA13:EMA(C,13),COLORWHITE,LINETHICK2;
EMA34:EMA(C,34),COLORYELLOW;
EMA55:EMA(C,55),COLORFF00FF;
EMA120:EMA(C,120),COLORFFCC66,COLORRED,LINETHICK2;
AR1:=EMA55>EMA34 AND EMA34>EMA13;
AR2:=BARSLAST((C-EMA13)/EMA13*100<-6);
AR3:=EMA13>=REF(EMA13,2);
AR4:=COUNT(CROSS(C,EMA13),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
AR6:=AR5 AND FILTER(AR5,10);
DRAWTEXT(AR6,L-0.09,'红杏出墙'),COLORYELLOW;
{STICKLINE(AR6,H,L,0.5,1),COLORYELLOW;}
{STICKLINE(AR6,O,C,6,1),LINETHICK2,COLORYELLOW;}
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2;
BR3:=C>EMA55 AND (REF(C,1)<REF(EMA55,1) OR REF(C,2)<REF(EMA55,2) OR REF(C,3)<REF(EMA55,3)
OR REF(C,4)<REF(EMA55,4) OR REF
(C,5)<REF(EMA55,5));
BR4:=BR1 AND BR2 AND BR3;
DRAWTEXT(BR4 AND FILTER(BR4,10),L-0.09,'蚂蚁上树'),COLOR00C5FF,COLORLIGREEN;
STICKLINE(BR4 AND FILTER(BR4,10),H,L,0.5,1),COLOR00C5FF,COLORLIGREEN;
{STICKLINE(BR4 AND FILTER(BR4,10),O,C,6,1),LINETHICK2,COLOR00C5FF;}
CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
CR2:=V>MA(V,5)*0.6;
CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;
CR4:=ABS(EMA34-EMA55)/EMA55<0.03;
CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);
CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
{STICKLINE(CR6,H,L,0.5,1),COLORF00FF0;}
{STICKLINE(CR6,O,C,6,1),LINETHICK2,COLORF00FF0;}
DRAWTEXT(CR6,L-0.09,'红衣侠女'),COLORF00FF0,COLORLIRED;
DR1:=EMA13>EMA34 AND EMA34<EMA55;
DR2:=BARSLAST(CROSS(C,EMA55) );
DR3:=H=HHV(H,DR2);
DR4:=BARSLAST(DR3);
DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1;
DR6:=C>REF(C,1) ;
DR7:= DR1 AND DR5 AND DR6 ;
DR8:=DR7 AND FILTER(DR7 ,10);
DRAWTEXT(DR8,L-0.09,'黑客点击'),COLORD6BA63,COLORMAGENTA;
{STICKLINE(DR8,H,L,0.5,1),COLORD6BA63;}
STICKLINE(DR8,O,C,6,1),LINETHICK2,COLORD6BA63,COLORMAGENTA;
ER:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);
DRAWTEXT(ER,L-0.09,'均线互换'),COLOR0099FF;
{STICKLINE(ER,H,L,0.5,1),COLOR0099FF;}
{STICKLINE(ER,O,C,6,1),LINETHICK2,COLOR0099FF;}
FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34);
DRAWTEXT(FR,L-0.09,'梅开二度'),COLORRED;
STICKLINE(FR,H,L,0.5,1),COLORRED;
{STICKLINE(FR,O,C,6,1),LINETHICK2,COLORWHITE;}
GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5) );
GR2:=EMA13>EMA34 AND EMA34>EMA55 AND EMA13>REF(EMA13,1);
GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1);
GR4:=H=HHV(H,GR1);
GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1);
GR6:=GR2 AND GR3 AND GR4;
GR7:=GR2 AND GR3 AND GR4 AND GR5;
DRAWTEXT(GR6 AND GR7,H+0.13,'见好就收!'),COLOR00FF00;
STICKLINE(GR6 AND GR7,H,H+0.09,4,0),COLOR00FF00;
HR2:=EMA13>=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13)
AND CROSS(C,EMA34) AND CROSS
(C,EMA55){ AND CROSS(C,EMA120)};
DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.09,'三线推进'),COLORFFC8FF,COLORBLUE;
 

2》附图指标
EMA13:=MA(C,13);
EMA34:=MA(C,34);
EMA55:=MA(C,55);
HX1:=EMA55>EMA34 AND EMA34>EMA13;
HX2:=C>=OPEN;
HX3:=C/REF(C,1)>=1.01;
HX4:=EMA13>=REF(EMA13,1);
HX5:=COUNT(CROSS(C,EMA13),2)=1;
HX6:=V>=MA(V,5)*0.55*2;
红杏出墙:IF(HX1 AND HX2 AND HX3 AND HX4 AND HX5 AND HX6,1,0),COLORYELLOW,LINETHICK2;
EMA120:=MA(C,120);
HY1:=C>OPEN;
HY2:=C/REF(C,1)>=1.01;
HY3:=ABS(EMA34-EMA55)/EMA55<0.10 AND ABS(EMA55-REF(EMA55,5))<=0.05*EMA55;
HY4:=COUNT(CROSS(EMA13,EMA55),2)=1;
HY5:=EMA13>=REF(EMA13,1);
HY6:=C/EMA13<=1.12 AND C>EMA13 AND C>EMA55;
HY7:=V>=MA(V,5)*0.6*2;
红衣侠女:IF(HY1 AND HY2 AND HY3 AND HY4 AND HY5 AND HY6 AND HY7,1.5,0),COLORLIRED,LINETHICK2;
HK1:=C<OPEN;
HK2:=C/REF(C,1)<1.0;
HK3:=COUNT(CROSS(EMA13,EMA55),3)=1;
HK4:=ABS(EMA34-EMA55)/EMA55<0.10 AND ABS(EMA55-REF(EMA55,5))<=0.05*EMA55;
HK5:=C/EMA13<=1.08 AND C>EMA13 AND C>EMA55;
HK6:=V<=MA(V,5)*0.425*2;
黑客点击:IF(HK1 AND HK2 AND HK3 AND HK4 AND HK5 AND HK6,2,0),LINETHICK2;
YY1:=C>EMA13 AND OPEN<EMA13;
YY2:=C>EMA34 AND OPEN<EMA34;
YY3:=C>EMA55 AND OPEN<EMA55;
YY4:=ABS(REF(EMA13,1)-REF(EMA34,1))<=0.1*REF(EMA13,1) AND ABS(REF(EMA13,1)-REF(EMA55,1))
<=0.1*REF(EMA13,1) ;
YY5:=ABS(REF(EMA13,2)-REF(EMA34,2))<=0.1*REF(EMA13,2) AND ABS(REF(EMA13,2)-REF(EMA55,2))
<=0.1*REF(EMA13,2) ;
YY6:=V>=MA(V,5)*0.6*2;
一阳穿三线:IF(YY1 AND YY2 AND YY3 AND YY4 AND YY5 AND YY6,2.5,0),COLORGREEN,LINETHICK2;
JG1:=ABS(REF(EMA13,1)-REF(EMA34,1))<=0.1*REF(EMA13,1) AND ABS(REF(EMA13,1)-REF(EMA55,1))
<=0.1*REF(EMA13,1) ;
JG2:=ABS(REF(EMA13,2)-REF(EMA34,2))<=0.1*REF(EMA13,2) AND ABS(REF(EMA13,2)-REF(EMA55,2))
<=0.1*REF(EMA13,2) ;
JG3:=C>OPEN;
JG4:=C/REF(C,1)>=1.02;{涨幅2%}
JG5:=C<=EMA13*1.1 AND C>=1.0*EMA13 AND OPEN>=0.9*EMA13;
JG6:=C>=1.0*EMA34 AND OPEN>=0.9*EMA34;
JG7:=C>=1.0*EMA55 AND OPEN>=0.9*EMA55;
JG8:=EMA13>=REF(EMA13,1);
JG9:=V>=MA(V,5)*0.6*2;
揭竿而起:IF(JG1 AND JG2 AND JG3 AND JG4 AND JG5 AND JG6 AND JG7 AND JG8 AND
JG9,3,0),COLORLIBLUE,LINETHICK2;
MK1:=EMA13>EMA55 AND EMA34>EMA55;
MK2:=CROSS(EMA13,EMA34);
MK3:=EMA13>=REF(EMA13,1);
MK4:=C>OPEN;
MK5:=C/REF(C,1)>=1.02;{涨幅2%}
MK6:=V>=MA(V,5)*0.6*2;
梅开二度:IF(MK1 AND MK2 AND MK3 AND MK4 AND MK5 AND MK6,3.5,0),COLORRED,LINETHICK2;
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2;
BR3:=C>EMA55 AND (REF(C,1)<REF(EMA55,1) OR REF(C,2)<REF(EMA55,2) OR
REF(C,3)<REF(EMA55,3) OR REF(C,4)<REF(EMA55,4) OR REF(C,5)<REF(EMA55,5));
蚂蚁上树:IF(BR1 AND BR2 AND BR3,4,0),COLORLIGREEN,LINETHICK2;
HR2:=EMA13>=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13) AND CROSS(C,EMA34) AND CROSS(C,EMA55);
三线推进:IF((HR2 AND FILTER(HR2,10)),4.5,0),COLORBLUE,LINETHICK2;
 
 3>>选股
 
1.
{梅开二度选股}
EMA13:=EMA(C,13);
EMA34:=EMA(C,34);
梅开二度:BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34);
2.
{黑客点击选股}
EMA13:=EMA(C,13);
EMA34:=EMA(C,34);
EMA55:=EMA(C,55);
DR1:=EMA13>EMA34 AND EMA34<EMA55;
DR2:=BARSLAST(CROSS(C,EMA55) );
DR3:=H=HHV(H,DR2);
DR4:=BARSLAST(DR3);
DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1;
DR6:=C>REF(C,1) ;
DR7:=DR1 AND DR5 AND DR6 ;
黑客点击:DR7 AND FILTER(DR7,10);
3.
{红衣侠女选股}
EMA13:=EMA(C,13);
EMA34:=EMA(C,34);
EMA55:=EMA(C,55);
EMA120:=EMA(C,120);
CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
CR2:=V>MA(V,5)*0.6;
CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;
CR4:=ABS(EMA34-EMA55)/EMA55<0.03;
CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);
红衣侠女:FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
4.
{三线推进选股}
EMA13:=EMA(C,13);
EMA34:=EMA(C,34);
EMA55:=EMA(C,55);
HR2:=EMA13>=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13) AND
CROSS(C,EMA34) AND CROSS(C,EMA55);
三线推进:(HR2 AND FILTER(HR2,10));
5.
{均线互换选股}
EMA34:=EMA(C,34);
EMA55:=EMA(C,55);
均线互换:BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);
 
6.
{蚂蚁上树选股}
EMA13:=EMA(C,13);
EMA34:=EMA(C,34);
EMA55:=EMA(C,55);
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2;
BR3:=C>EMA55 AND (REF(C,1)<REF(EMA55,1) OR REF(C,2)<REF(EMA55,2) OR REF(C,3)<REF(EMA55,3) OR REF
(C,4)<REF(EMA55,4) OR REF(C,5)<REF(EMA55,5));
蚂蚁上树:BR1 AND BR2 AND BR3;
7.
{红杏出墙选股}
EMA13:=EMA(C,13);
EMA34:=EMA(C,34);
EMA55:=EMA(C,55);
AR1:=EMA55>EMA34 AND EMA34>EMA13;
AR2:=BARSLAST((C-EMA13)/EMA13*100<-6);
AR3:=EMA13>=REF(EMA13,2);
AR4:=COUNT(CROSS(C,EMA13),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
红杏出墙:AR5 AND FILTER(AR5,10);
8.
{一阳三线}
VAR1:=C>MA(C,13) AND OPEN<MA(C,13);
VAR2:=C>MA(C,34) AND OPEN<MA(C,34);
VAR3:=C>MA(C,55) AND OPEN<MA(C,55);
XG:VAR1 AND VAR3 AND VAR2;
9.
{揭竿而起}
VAR1:=ABS(MA(C,13)-MA(C,34))<C*0.02 AND ABS(MA(C,13)-MA(C,55))<C*0.02;
VAR2:=O>MA(C,13) OR O=MA(C,13);
VAR3:=C/OPEN>1.03 ;
XG:VAR1 AND VAR2 AND VAR3;
10.
 {日月合璧}
VAR1:=C/OPEN>1.04;
VAR2:=REF(OPEN,1)/REF(CLOSE,1)>1.04;
VAR3:=ABS(OPEN-REF(C,1))<C*0.02 AND ABS(C-REF(OPEN,1))<C*0.02;
XG:VAR1 AND VAR2 AND VAR3;
 

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多