牛行者是也 / 待分类1 / mACD公式

0 0

   

mACD公式

2012-10-08  牛行者是也
“防狼术”条件选股公式

一,MACD的DEA在0轴之上的选股公式:

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
RET:DEA>=0;

二,MACD的DEA刚上穿0轴的选股公式:

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
RET:DEA>=0 AND REF(DEA,1)<0;

三,MACD的DEA上穿零轴后,回调不破零轴选股公式:

{MACD的DEA上穿零轴后,回调不破零轴选股}
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
不破零轴:=DIFF>0 AND DEA>0;
上次零下金叉:=REF(DEA,BARSLAST(REF(CROSS(DIFF,DEA),1))+1)<0;
金叉:=CROSS(DIFF,DEA);
上穿零轴:=CROSS(DEA,0);
回调:= MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3);
第一种:=不破零轴 AND 回调 AND MACD>0  AND 上次零下金叉;{DIFF与DEA收口后再张口}
第二种:=不破零轴 AND 回调 AND MACD<0;
第三种:=不破零轴 AND 金叉 AND 上次零下金叉;{DIFF与DEA在0轴上死叉后,再次在0轴上第一次金叉}
选股:第一种 OR 第二种 OR 第三种;

四, 沿20日线上涨,股价回调不破20日线选股公式:

MA20:=MA(C,20);
XG:COUNT(MA20>REF(MA20,1),3)=3 AND BETWEEN(L,MA20*0.98,MA20*1.02) AND C>=MA20;

五,股价在60日线之上,且5日线上交20日线选股公式:

C>MA(C,60) AND CROSS(MA(C,5),MA(C,20));

六,底分型选股公式:

 V00:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
V01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
V02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW
 AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
V1:= COUNT(V00,6)>=3 AND COUNT(V01 OR V02,5)=0 AND LLVBARS(LOW,6) = 1 AND HHVBARS(HIGH,6) >= 5 AND V03;
V2:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 2 AND HHVBARS(HIGH,7) >= 6 AND V04;
V3:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 1 AND HHVBARS(HIGH,7) >= 6 AND V03;
V4:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 2 AND HHVBARS(HIGH,8) >= 7 AND V04;
V5:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 1 AND HHVBARS(HIGH,8) >= 7 AND V03;
V6:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 2 AND HHVBARS(HIGH,9) >= 8 AND V04;
V7:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 1 AND HHVBARS(HIGH,9) >= 8 AND V03;
V8:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 2 AND HHVBARS(HIGH,10) >= 9 AND V04;
V9:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 1 AND HHVBARS(HIGH,10) >= 9 AND V03;
V10:= COUNT(V00,11)>=3 AND COUNT(V01 OR V02,10)<=5 AND LLVBARS(LOW,11) = 2 AND HHVBARS(HIGH,11) >= 10 AND V04;
XG: V1 OR V2 OR V3 OR V4 OR V5 OR V6 OR V7 OR V8 OR V9 OR V10;

七,三买点选股公式:

N1:=5;{最近下跌天数}
N2:=31;{上涨天数}
N3:=55;{平台高点天数}
LL:=LLV(L,N1);
HH:=REF(HHV(H,N2),N1);
H0:=REF(HHV(H,N3),N1+N2);
ZF:=(C-REF(C,1))/REF(C,1)*100;
缠论三买点:HH=HHV(H,N2+N1) AND LL>=H0  AND SUM(ZF>9.9,30)>1 OR SUM(ZF>8.9,30)>1;

--------------------------------------------------------------------------------

{三买选股公式2.5}

N1:=9;{最近下跌天数}
N2:=30;{上涨天数}
N3:=56;{平台高点天数}

LL:=LLV(L,N1);
HH:=HHV(H,2*N1);
H0:=REF(HHV(H,N3),N1+N2);


选股:HH=HHV(H,N2+N1+N3) AND LL>H0 AND LL/HH<0.85;
{创N2+N1+N3天新高,回调低点I不破前平台高点(可根据自己要求适当放宽到0.97),本次回调低点最低值与最高值下跌幅度不低于15%};
--------------------------------------------------------------------------------

{三买选股公式2.0}

N1:=5;{最近下跌天数}
N2:=31;{上涨天数}
N3:=55;{平台高点天数}

LL:=LLV(L,N1);
HH:=REF(HHV(H,N2),N1);
H0:=REF(HHV(H,N3),N1+N2);


选股:HH=HHV(H,N2+N1+N3) AND LL>=0.97*H0 AND LL/HH<0.85;
{创N2+N1+N3天新高,回调低点不低于前平台高点(我适当放宽到0.97,严格的朋友可自己调整),回调低点最低值与最高值下跌幅度不低于15%};
----------------------------------------------------------------------------------

{三买选股公式1.0}

N1:=5;{最近下跌天数}
N2:=31;{上涨天数}
N3:=55;{平台高点天数}
LL:=LLV(L,N1);
HH:=REF(HHV(H,N2),N1);
H0:=REF(HHV(H,N3),N1+N2);

选股:HH=HHV(H,N2+N1) AND LL>=H0;

八,选股:EXPMA 5日与10日金叉并且第二天的收盘价在EXPMA的5日线以上.
cross(ref(ema(c,5),1),ref(ema(c,10),1)) and c>ema(c,5);

九,股价上穿5周均线:注意:选股时用周线
xg:cross(c,ma(c,5));

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多