图文宝藏 / 我的股票 / 高手波段操盘系统副图指标【通达信】

0 0

   

高手波段操盘系统副图指标【通达信】

2012-11-26  图文宝藏
VAR3:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K13:SMA(VAR3,3,1) ;
D14:SMA(K13,3,1) ;
J13:=3*K13-2*D14;
VAR31:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
K21:=SMA(VAR31,3,1) ;
D21:=SMA(K21,3,1) ;
VAR34:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K34:=SMA(VAR34,3,1);
D34:=SMA(K34,3,1) ;
VAR55:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K55:SMA(VAR55,5,1) ,COLORGREEN,LINETHICK1;
D55:SMA(K55,5,1),COLORFF9933;
J55:=3*K55-2*D55;
VAR79:IF(WINNER(CLOSE),WINNER(CLOSE)*100,20),VOLSTICK;
DIBU:= K13<20 AND D14<20 AND K21<20 AND D21<20 AND K34<20 AND D34<20 AND K55<20 AND D55<20;
STICKLINE(DIBU=1,80,60,5.8,1),COLORRED;
TOBU:= K13>80 AND D14>80 AND K21>80 AND D21>80 AND K34>80 AND D34>80 AND K55>80 AND D55>80;
STICKLINE(TOBU=1,40,20,5.8,1),COLORGREEN;
{顶部:80,COLOR55AA77,LINETHICK1;
底部:20,COLOR55AA77,LINETHICK1;
中轴线:50,POINTDOT,COLORWHITE;
天线:100, POINTDOT,COLORWHITE;
底线:0, POINTDOT,COLORWHITE;}
现价:=C;
VAR108:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR118:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR128:=VAR108<REF(VAR118,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR128 AND COUNT(VAR128,30)=1,40,'有大资金进场迹象,关注!');
VAR2:=LLV(LOW,10);
VAR33:=HHV(HIGH,25);
动力线:= EMA((CLOSE-VAR2)/(VAR33-VAR2)*4,4);
底部2:=0.2,COLOR70DB93;
关注:=0.5,COLORYELLOW;
数值:=动力线,COLORA8A8A8;
阶段底部:=CROSS(动力线,底部2);
STICKLINE(阶段底部,0.2,49,1,0),COLORRED;
DRAWICON(阶段底部,50,11);
阶段关注:=CROSS(动力线,关注);
STICKLINE(阶段关注,0.1,20,3,0),COLORMAGENTA;
阶段卖出:= 3.2,COLORC6C600;
BB:=3.5,COLOR0088FF;
清仓卖出:=3.5,COLORFF75FF;
清仓:=CROSS(清仓卖出,动力线);
STICKLINE(清仓,100,70,1,0),COLORBLUE;
短线卖出:=CROSS(阶段卖出,动力线);
STICKLINE(短线卖出,100,90,2,0),COLORGREEN;
A1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A2:=SMA(A1,3,1);
A3:=SMA(A2,3,1);
A4:=3*A2-2*A3;
X:=LLV(A4,2)=LLV(A4,8);
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX); DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:=IF(CROSS(最佳买入,0),1,0);
VAR11:=SMA(最佳买入选股,3,1);
VAR22:=SMA(VAR11,3,1);
VAR333:=SMA(VAR22,3,1);
XG:=CROSS(A4,REF(A4+0.01,1)) AND X AND A4<20 AND CROSS(VAR22,VAR333) AND VAR22<40;
STICKLINE(XG,0.2,10,2,0),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=60,90,'K值线多头排列,做多'),COLORRED;
地量:DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L*1,'地量'),COLOR00FFFF;
STICKLINE(地量>0,0,30,2,0),COLOR008888;
STICKLINE(地量>0,0,30,1.5,0),COLOR00AAAA;
STICKLINE(地量>0,0,30,0.8,0),COLOR00DDDD;
STICKLINE(地量>0,0,30,0.3,0),COLOR00FFFF;

P1:=-6;
BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM,3),COLORRED,LINETHICK1;
买入信号:=EMA(MN,2);
绿尖红框手抄底:IF(MN<P1,35,0),COLORGREEN;
DRAWTEXT(CROSS(MN,买入信号) AND COUNT(买入信号<P1,2)>1,-10,'买'),COLORRED,LINETHICK6;

爱生活 爱Delphi

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多