蓉慧娇 / 公式 / 四方数浪(实时线、神秘线)

分享

   

四方数浪(实时线、神秘线)

2014-04-12  蓉慧娇
 
四方数浪(实时线、神秘线)
-
指标公式源码
 
 
V1:=DMA((HIGH+LOW+(CLOSE)*(2))/(4.15),0.9);
HY1:=REF(EMA(V1,3),1); 
实时线:MA(CLOSE,1),COLORCYAN ;
神秘线:HY1,COLORBROWN; 
STICKLINE(C>REF(C,1),H,L,0,1),COLOR0000FF;
STICKLINE(C>REF(C,1),O,C,3.2,0),COLOR000055;
STICKLINE(C>REF(C,1),O,C,2.7,0),COLOR000077; 
STICKLINE(C>REF(C,1),O,C,2.1,0),COLOR000099;
STICKLINE(C>REF(C,1),O,C,1.5,0),COLOR0000BB;
STICKLINE(C>REF(C,1),O,C,0.9,0),COLOR0000DD;
STICKLINE(C<REF(C,1),O,C,0.3,0),COLOR0000FF;
STICKLINE(C<REF(C,1),H,L,0,1),COLORFFFF00;
STICKLINE(C<REF(C,1),O,C,3.2,0),COLOR990000;
STICKLINE(C<REF(C,1),O,C,2.7,0),COLORCC0000; 
STICKLINE(C<REF(C,1),O,C,2.1,0),COLORFF4400;
STICKLINE(C<REF(C,1),O,C,1.5,0),COLORFF8800;
STICKLINE(C<REF(C,1),O,C,0.9,0),COLORFFCC00;
STICKLINE(C<REF(C,1),O,C,0.3,0),COLORFFFF00;
STICKLINE(C=REF(C,1),H,L,0,1),COLORFFFFFF;
STICKLINE(C=REF(C,1),O,C,3.2,0),COLOR555555;
STICKLINE(C=REF(C,1),O,C,2.7,0),COLOR777777; 
STICKLINE(C=REF(C,1),O,C,2.1,0),COLOR999999;
STICKLINE(C=REF(C,1),O,C,1.5,0),COLORBBBBBB;
STICKLINE(C=REF(C,1),O,C,0.9,0),COLORDDDDDD;
STICKLINE(C=REF(C,1),O,C,0.3,0),COLORFFFFFF; 
DRAWTEXT(CROSS(CLOSE,HY1),LOW,'买点'),LINETHICK2,COLOR00FFFF;
DRAWTEXT(CROSS(HY1,CLOSE),(HIGH)*(1.08),'卖点'),LINETHICK2,COLORGREEN; 
APP:=(VOL)/((HIGH-LOW)*(2)-ABS(CLOSE-OPEN)); 
ZL:=IF((CLOSE>OPEN),(APP)*(HIGH-LOW),IF((CLOSE<OPEN),(APP)*(HIGH-OPEN+CLOSE-LOW),(VOL)/(2)));
SF:=IF((CLOSE>OPEN),0-(APP)*(HIGH-CLOSE+OPEN-LOW),IF((CLOSE<OPEN),0-(APP)*(HIGH-LOW),0-(VOL)/(2)));
库存能量:=MA(ZL+SF,2);
库存平均:=MA(ZL+SF,5);
DRAWTEXT(CROSS(库存能量,库存平 均),(LOW)*(0.97),''),LINETHICK4,COLORFF00FF;
GET:ZIG(3,5),COLORYELLOW;
PL5:=ZIG(3,5); 
EN1:=PL5>REF(PL5,1) AND REF(PL5,1)<=REF(PL5,2) AND REF(PL5,2)<=REF(PL5,3); 
EX1:=PL5<REF(PL5,1) AND REF(PL5,1)>=REF(PL5,2) AND REF(PL5,2)>=REF(PL5,3);
PL10:=ZIG(3,10); 
EN2:=PL10>REF(PL10,1) AND REF(PL10,1)<=REF(PL10,2) AND REF(PL10,2)<=REF(PL10,3); 
EX2:=PL10<REF(PL10,1) AND REF(PL10,1)>=REF(PL10,2) AND REF(PL10,2)>=REF(PL10,3);
PL20:=ZIG(3,20); 
EN3:=PL20>REF(PL20,1) AND REF(PL20,1)<=REF(PL20,2) AND REF(PL20,2)<=REF(PL20,3); 
EX3:=PL20<REF(PL20,1) AND REF(PL20,1)>=REF(PL20,2) AND REF(PL20,2)>=REF(PL20,3);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1)); 
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'㈠'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'㈡'),COLORFFFF00;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'㈢'),COLORFFFF00; 
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'⑴'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'⑵'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'⑶'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'⑷'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'⑸'),COLOR0000FF; 
DRAWTEXT(EN2 AND DTJZ10=1,L*0.9,'Ⅰ'),COLORRED;
DRAWTEXT(EX2 AND DTJD10=2,H*0.9,'Ⅱ'),COLORRED;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.9,'Ⅲ'),COLORRED; 
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.06,'①'),LINETHICK2,COLOR00FFFF; 
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.94,'②'),LINETHICK2,COLOR00FFFF; 
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.06,'③'),LINETHICK2,COLOR00FFFF; 
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.94,'④'),LINETHICK2,COLOR00FFFF;
WCB2:=REF(C,1); 
涨停:=IF((C-WCB2)*100/WCB2>=(10-0.01*100/WCB2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED; 
跌停:=IF((WCB2-C)*100/WCB2>=(10-0.01*100/WCB2),1,0); 
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
 
 
 
“工作线上穿神秘线、XG等于1”的选股公式,
参数:P1:1、300、7
          P2:1、300、21
          P3:1、300、250
MA1:EMA(CLOSE,P1),COLORWHITE,LINETHICK1;
MA2:EMA(CLOSE,P2),COLORRED,LINETHICK1;
MA3:EMA(CLOSE,P3),COLORYELLOW,LINETHICK1;
工作线: EMA(CLOSE,P1),COLORWHITE,LINETHICK1;
神秘线: EMA(CLOSE,P2),COLORRED,LINETHICK1;
生命线:EMA(CLOSE,P3),COLORWHITE,LINETHICK1;
DRAWTEXT(CROSS(工作线,神秘线),工作线,'★建仓') ,COLORYELLOW;
DRAWTEXT(CROSS(神秘线,工作线),神秘线,'★空仓') ,COLORGREEN;
LC:=REF(CLOSE,3);
JH:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(FILTER(CROSS(JH,30),55),LOW*0.98,'↑关注'),COLORYELLOW,LINETHICK1;
DRAWTEXT(FILTER(CROSS(84,JH),22),HIGH*1.02,'↓小心'),COLOR00FF00;
 
 
V00:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
V01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
V02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW
AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
V1:= COUNT(V00,6)>=3 AND COUNT(V01 OR V02,5)=0 AND LLVBARS(LOW,6) = 1 AND HHVBARS(HIGH,6) >= 5 AND V03;
V2:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 2 AND HHVBARS(HIGH,7) >= 6 AND V04;
V3:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 1 AND HHVBARS(HIGH,7) >= 6 AND V03;
V4:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 2 AND HHVBARS(HIGH,8) >= 7 AND V04;
V5:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 1 AND HHVBARS(HIGH,8) >= 7 AND V03;
V6:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 2 AND HHVBARS(HIGH,9) >= 8 AND V04;
V7:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 1 AND HHVBARS(HIGH,9) >= 8 AND V03;
V8:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 2 AND HHVBARS(HIGH,10) >= 9 AND V04;
V9:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 1 AND HHVBARS(HIGH,10) >= 9 AND V03;
V10:= COUNT(V00,11)>=3 AND COUNT(V01 OR V02,10)<=5 AND LLVBARS(LOW,11) = 2 AND HHVBARS(HIGH,11) >= 10 AND V04;
XG:=V1 OR V2 OR V3 OR V4 OR V5 OR V6 OR V7 OR V8 OR V9 OR V10;
cross(EMA(CLOSE,7),EMA(CLOSE,21)) and xg;
 
 
神秘线趋势
B1:=REF(C,1);B2:=REF(C,2);
SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));
SM:=IF(REF(SS,1)<>0,REF(SS,1),IF(REF(SS,2)<>0,REF(SS,2),IF(REF(SS,3)<>0,REF(SS,3),IF(REF(SS,5)<>0,REF(SS,5),IF(REF(SS,6)<>0,REF(SS,6),IF(REF(SS,7)<>0,REF(SS,7),0))))));
STICKLINE(SS=1 OR SM>=1 AND SS=0,B1,C,4,1),COLORRED;
STICKLINE(SS=-1 OR SM<=-1 AND SS=0,B1,C,4,0),colorFF9000;
STICKLINE(SS=2,B2,C,4,1),COLORRED;
STICKLINE(SS=-2,B2,C,4,0),colorFF9000;
STICKLINE((SS=-1 OR SS=-2) AND SM>0,B2,B1,4,1),COLORRED;
STICKLINE((SS=1 OR SS=2) AND SM<0,B2,B1,4,0),colorFF9000;
ZJ:=(C+H+L)/3;
Var1:=MA(ZJ,30);
Var2:=MA(ZJ,13)-MA(ZJ,34);
Var3:=MA(Var2,5);
Var4:=(Var2-Var3)*5;
Var5:=MA(IF(Var4>=1000,1000,IF(Var4<=ZJ,ZJ,Var4) ),1);
Var6:=MA(IF(Var4>=1000,1000,IF(Var4<=ZJ,ZJ,Var4) ),3);
神秘线中线趋势:Var1+2.2*STD(ZJ,30),COLORRED;
KS:=(C-MA(C,13))/MA(C,13)*(-100);
RKS:=REF(KS,1);
MLS:=RKS/KS>=1.23 AND RKS>=8 AND C/REF(C,1)>=1.02;
feng:EMA(C,10),colorwhite;
yun:EMA(KS/10+EMA(C,10),3),coloryellow;
魔斗士:(EMA(C,5)*7+EMA(C,5)*3)/10,colorblue;
DRAWTEXT(cross(feng,yun),yun,'买'),coloryellow,LINETHICK4;
Var3:=(C-b1)/b1*100;
筹码:=MA((C-REF(O,34))/REF(O,34),1)*100;
筹码差:=MA(筹码,10);
Var5:=V/CAPITAL*100;
上轨道:=SUM(Var5,30);
下轨道:=REVERSE(SUM(Var5,30));
跌筹比:=筹码/下轨道;
DRAWTEXT(COUNT(跌筹比>95/100 AND 筹码<-25 AND Var3>5.5,12) AND C<0.95*b1,yun,'震'),colorred;
DRAWTEXT(COUNT(跌筹比>95/100 AND 筹码<-25 AND Var3>5.5,12) AND C<0.98*b1 AND C>0.96*b1,yun,'打'),colorgreen;
DRAWTEXT(COUNT(跌筹比>95/100 AND 筹码<-25 AND Var3>5.5,12) AND C<0.96*b1 AND C>0.94*b1,yun,'压'),colorgreen;

 
 
 
 
 
 
 
 
 
 
 
 
 资金进仓
A1:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
BL:=VOL/CAPITAL*100;
STICKLINE(A1>=0,0,A1,3,3),COLORYELLOW;
STICKLINE(A1<0,0,A1,3,3),COLORGREEN;

选股。
A1:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
BL:=VOL/CAPITAL*100;
xg:(A1>=0);
 
 
小树理念成交厚度公式
成交:=IF(BUYVOL>0 OR SELLVOL>0,1,0);
统计:SUM(成交,0);
成交厚度:"引用2.统计#TICK"-REF("引用2.统计#TICK",1);股票
 

公式全部公开 用法非常筒单 将下面的公式源码引入即可 每晚下载数据完毕 做收盘 然后运行软件到20点30分 最后 我的池对系统时间卡的紧
名称;马留引用
mr:IF(ISBUYORDER=1,vol*c/100,0);
总买入:sum(mr,0);
mc:IF(ISBUYORDER=0,vol*c/100,0);
总卖出:sum(mc,0);
主买:SUM(mr*100/c,0);
主卖:SUM(mc*100/c,0);
mr4:if(mr>0 and (CLOSE-REF(CLOSE,1))*100>=0 and (CLOSE-REF(CLOSE,1))*100<0.5 and ASKPRICE(1)=REF(ASKPRICE(1),1),mr,0);
中单买入:sum(mr4,0);
mc4:if(mc>0 and (CLOSE-REF(CLOSE,1))*100<=0 and (CLOSE-REF(CLOSE,1))*100>-0.5 and BIDPRICE(1)=REF(BIDPRICE(1),1),mc,0);
中单卖出:sum(mc4,0);  
mr20:if(mr>0 and (CLOSE-REF(CLOSE,1))*100>=0.5 and (CLOSE-REF(CLOSE,1))*100<1 and ASKPRICE(1)>REF(ASKPRICE(1),1) and ASKPRICE(1)<=REF(ASKPRICE(2),1),mr,0);
大单买入:sum(mr20,0);
mc20:if(mc>0 and (CLOSE-REF(CLOSE,1))*100<=-0.5 and (CLOSE-REF(CLOSE,1))*100>-1 and BIDPRICE(1)>REF(BIDPRICE(1),1) and BIDPRICE(1)<=REF(BIDPRICE(2),1),mc,0);
大单卖出:sum(mc20,0);
mr100:if(mr>0 and (CLOSE-REF(CLOSE,1))*100>=1 and ASKPRICE(1)>REF(ASKPRICE(2),1),mr,0);
特大买入:sum(mr100,0);
mc100:if(mc>0 and (CLOSE-REF(CLOSE,1))*100<=-1 and BIDPRICE(1)>REF(BIDPRICE(2),1),mc,0);
特大卖出:sum(mc100,0);
mr4下:if(mr>0 and (CLOSE-REF(CLOSE,1))*100=0 and ASKPRICE(1)=REF(ASKPRICE(1),1),1-(mr100+mr20+mr4),0);
散单买入:sum(mr4下,0);
mc4下:if(mc>0 and (CLOSE-REF(CLOSE,1))*100=0 and BIDPRICE(1)=REF(BIDPRICE(1),1),1-(mc100+mc20+mc4),0);
散单卖出:sum(mc4下,0); 
 
 
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,1,1),COLOR00FF00;
STICKLINE(控盘>REF(控盘,1) AND 控盘<0,控盘,0,1,1),COLORFF00FF;
无庄控盘:=控盘<0;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLOR0000FF;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLORFFFF00;
主力出货:=控盘<REF(控盘,1) AND 控盘>0;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,0),COLORYELLOW;
高度控盘: VAR2>50 AND COST(85)<CLOSE AND 控盘>0,COLORYELLOW,LINETHICK2;
A10:=CROSS(控盘,0);
控盘B:=FILTER(IF(A10,1,0),5);

选股
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
JJ:=DYNAINFO(11);
P:=55;S:=8;M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;
神:=EMA(财,M1),COLORGREEN,LINETHICK1;
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ3:=CROSS(财,神) AND  财<-0.3;
抄底:FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
 

樱桃抓牛公式源码:
VAB0:=13;VAB1:=1500000;VAB2:=VAB0 + VAB1; VAB3:=IF(DATE > VAB2,0,1);
LC:=REF(CLOSE,1);
SG:=EMA(HHV(HIGH,1),8);
X1:=EMA(CLOSE,8);
X30:=((X1 < REF(X1,1)) AND (CLOSE < X1));
X31:=IF(((SG < REF(SG,1)) OR X30),1,0);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100,COLORRED,LINETHICK2;
震仓:=45,COLORMAGENTA;
底线:=20,COLORGREEN;
PP:=操作线<震仓 AND REF(操作线,1)>震仓 ;
PP3:=操作线<底线 AND REF(操作线,1)>底线*VAB3;
抓牛:(((((COUNT((X31 = 1),4) = 3) AND (X31 = 0))AND O<C AND (((C-REF(C,1))/REF(C,1))>0.065))*10) >=10)OR((C-REF(C,1))/REF(C,1)>0.065 AND (REF(PP3,1) OR REF(PP,1))) AND VAB3=1,STICK,COLORYELLOW,LINETHICK4;
DRAWTEXT(抓牛,抓牛*0.71,' ←马上有钱'),COLORYELLOW;
强反转:(H-REF(C,1))/REF(C,1)*100,NODRAW;
H0:="MACD.MACD";
H3:=REF(H0,3);
H2:=REF(H0,2);
H1:=REF(H0,1);
MA13:=MA(C,13);
MA20:=MA(C,20);
AA:=H1>0 AND MA13>MA20 AND H3>H2 AND H2>H1 AND H0>H1 AND "MACD.DIF">0 AND "MACD.DEA">0;
AA1:=C/REF(C,1)>1.03 AND (H-C)/C*100<0.5;

选股:抓牛 and AA1;
 
 
【美人眼KD (Stochastics随机指标)】__非常优秀的买卖时机(扳机)指标
{以下为各股软的专用源码,请选用你要的股票软件源码}
PARTLINE(DIF<DN,-5),LINETHICK3,COLOR00BB00;  {飞狐}
PARTLINE(DIF>UP,104),LINETHICK3,COLOR00BB00;  {飞狐}
IF(DIF<DN,-5,DRAWNULL),COLOR00BB00,LINETHICK3;  {通达信}
IF(DIF>UP,104,DRAWNULL),COLOR00BB00,LINETHICK3;  {通达信}
PARTLINE(-5,DIF<DN,RGB(0,180,0)),LINETHICK3,LAYER7;  {大智慧l2}
PARTLINE(104,DIF>UP,RGB(0,180,0)),LINETHICK3,LAYER7;  {大智慧l2}

{通达信源码 参数设置看下图}
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
%K:MA(RSV,M1);
%D:MA(%K,M2),COLORAA00DD;
Y1,color007a00;
Y2,color007a00;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
VAR1:=HHV(DEA,53);
VAR2:=LLV(DEA,55);
VAR3:=DEA-(DIF-DEA);
UP:=IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1);
DN:=IF(DIF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR3),VAR2);
IF(DIF<DN,-5,DRAWNULL),COLOR00BB00,LINETHICK3;
IF(DIF>UP,104,DRAWNULL),COLOR00BB00,LINETHICK3;
这个指标很不错  确实不错。
但是还是摆脱不了指标会钝化的事实,所以使用好他,就要费费心喽。
该指标重要的是趋势的判断原理……其实就是运用了macd夹心指标的功能,所以,核心的技术还是macd夹心指标
 
{ N 2,99,14。M1 2,50,3。M2 2,50,3。Y1 0,50,25。Y2 50,100,75。     } 
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
%K:MA(RSV,M1);
%D:MA(%K,M2),COLORAA00DD;
Y1,COLOR007A00;
Y2,COLOR007A00;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
VAR1:=HHV(DEA,53);
VAR2:=LLV(DEA,55);
VAR3:=DEA-(DIF-DEA);
UP:=IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1);
DN:=IF(DIF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR3),VAR2);
IF(DIF<DN,-5,DRAWNULL),COLOR00BB00,LINETHICK3;
IF(DIF>UP,104,DRAWNULL),COLOR00BB00,LINETHICK3;
 
一组神奇的指标——黑马绝招三线三上
指标介绍:
这是北京财经电视台中刘舒老师的抓黑码绝招之一的方法,编成公式以飨股友。意思是:量在五日线上,均量线在五日均量线上,MACD影线在曲线之上,五日线在21日线上,五日量在72日量上。该指标来自同花顺(300033)软件中的指标平台。
公式源码:
M1:=5;M2:=21;SHORT:=12;LONG:=26;MID:=9;
MA1:=MA(CLOSE,M1);
MA2:=MA(CLOSE,M2);
五日线XG1:=MA1>=MA2 AND C>=MA1;
五日量XG2:=CROSS(MA(V,5),MA(V,72)) AND VOL>MA(V,5) ;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,COLORSTICK;
MACDXG3:=MACD>DIF AND MACD>DEA;
三线三上XG:五日线XG1 AND 五日量XG2 AND MACDXG3;
 
 
{破浪--力度指数}
Var2:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*200*10;
买卖力度: SMA(Var2,5,1),colorgreen;
卖出区: 1500,coloryellow;
Var3:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
Var4:=(IF(CLOSE>OPEN,Var3*(HIGH-LOW),IF(CLOSE<OPEN,Var3*(HIGH-OPEN+CLOSE-LOW),VOL/2))/(IF(CLOSE>OPEN,0-Var3*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-Var3*(HIGH-LOW),0-VOL/2))*(-1))-IF(CLOSE>OPEN,0-Var3*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-Var3*(HIGH-LOW),0-VOL/2))*(-1)/IF(CLOSE>OPEN,Var3*(HIGH-LOW),IF(CLOSE<OPEN,Var3*(HIGH-OPEN+CLOSE-LOW),VOL/2)));
Var5:=AMOUNT/(100*VOL);
Var6:=MA(Var5,40);
Var7:=100*(CLOSE-Var6)/Var6;
底部追击: IF(Var4>0 AND Var7<-12 AND CLOSE/OPEN>1.08,300,200),colorgreen;
STICKLINE(Var4>0 AND Var7<-12 AND CLOSE/OPEN>1.08,1200,200,10,0) , colorgreen;
买进: IF(Var4>0 AND Var7<-12 AND CLOSE/OPEN>1.05,300,200),colormagenta;
STICKLINE(Var4>0 AND Var7<-12 AND CLOSE/OPEN>1.05,800,200,6,1),colormagenta;
Var8:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
Var9:=SMA(Var8,3,1);
VarA:=SMA(Var9,3,1);
D: SMA(VarA,5,1)*20, colorcyan;
简单说一下用法:
黄色横线以上为卖出区域,红色线横一下为卖出区域。
但不是简单的到那区域就买或卖,要根据兰、绿两条线在此区间的运行来决定。
兰线为慢线,如和股价出现背离,那信号是最准的。
这个指标对于分辨股价的真假突破奇准。
 
筹码攻击量选股公式
01.HSL:=EMA(V/CAPITAL,3);
02.ZDL:=HHV(HSL,240);
03.ZXL:=LLV(HSL,240);
04.XS:=MA(C,33);
05.HL10:=WINNER(C/1.1)*100,STICK,COLORRED;
06.STICKLINE(((C/1.1)*100),HL10,0,2.7,0),COLOR000055;
07.STICKLINE(((C/1.1)*100),HL10,0,1.7,0),COLOR000077;
08.STICKLINE(((C/1.1)*100),HL10,0,0.7,0),COLOR0000BB;
09.STICKLINE(((C/1.1)*100),HL10,0,0.2,0),COLOR0000FF;
10.HL20:=WINNER(C/1.2)*100,STICK,COLORYELLOW;
11.STICKLINE(((C/1.2)*100),HL20,0,2.7,0)COLOR009999;
12.STICKLINE(((C/1.2)*100),HL20,0,1.7,0)COLOR00BBBB;
13.STICKLINE(((C/1.2)*100),HL20,0,0.7,0)COLOR00DDDD;
14.STICKLINE(((C/1.2)*100),HL20,0,0.2,0)COLOR00FFFF;
15.HL30:=WINNER(C/1.3)*100,STICK,COLORFF00FF;
16.STICKLINE(((C/1.3)*100),HL30,0,2.7,0),COLORFF1100;
17.STICKLINE(((C/1.3)*100),HL30,0,1.7,0),COLORFF5500;
18.STICKLINE(((C/1.3)*100),HL30,0,0.7,0),COLORFF9900;
19.STICKLINE(((C/1.3)*100),HL30,0,0.2,0),COLORFFDD00;
20.BB:=100,POINTDOT,LINETHICK2,COLORRED;
21.AA:=15,COLORYELLOW;
22.DD:=70,COLORYELLOW;
23.CC:=300,POINTDOT,LINETHICK2,COLORGREEN;
24.X4:=EMA(C,20);
25.二十日斜率:(X4-REF(X4,1))/REF(X4,1)*100,LINETHICK0;
26.十日换手率:SUM(VOL,10)/CAPITAL*100,LINETHICK0;
27.锁定筹码:EMA((HSL-ZXL)/ZXL*XS,13),LINETHICK2;
28.浮动筹码:EMA((ZDL-HSL)/HSL*XS,13),LINETHICK2;
29.力量对比:锁定筹码-浮动筹码,COLORSTICK;
30.
复制代码
HSL:=EMA(V/CAPITAL,3);
ZDL:=HHV(HSL,240);
ZXL:=LLV(HSL,240);
XS:=MA(C,33);
HL10:=WINNER(C/1.1)*100,STICK,COLORRED;
STICKLINE(((C/1.1)*100),HL10,0,2.7,0),COLOR000055;
STICKLINE(((C/1.1)*100),HL10,0,1.7,0),COLOR000077;
STICKLINE(((C/1.1)*100),HL10,0,0.7,0),COLOR0000BB;
STICKLINE(((C/1.1)*100),HL10,0,0.2,0),COLOR0000FF;
HL20:=WINNER(C/1.2)*100,STICK,COLORYELLOW;
STICKLINE(((C/1.2)*100),HL20,0,2.7,0)COLOR009999;
STICKLINE(((C/1.2)*100),HL20,0,1.7,0)COLOR00BBBB;
STICKLINE(((C/1.2)*100),HL20,0,0.7,0)COLOR00DDDD;
STICKLINE(((C/1.2)*100),HL20,0,0.2,0)COLOR00FFFF;
HL30:=WINNER(C/1.3)*100,STICK,COLORFF00FF;
STICKLINE(((C/1.3)*100),HL30,0,2.7,0),COLORFF1100;
STICKLINE(((C/1.3)*100),HL30,0,1.7,0),COLORFF5500;
STICKLINE(((C/1.3)*100),HL30,0,0.7,0),COLORFF9900;
STICKLINE(((C/1.3)*100),HL30,0,0.2,0),COLORFFDD00;
BB:=100,POINTDOT,LINETHICK2,COLORRED;
AA:=15,COLORYELLOW;
DD:=70,COLORYELLOW;
CC:=300,POINTDOT,LINETHICK2,COLORGREEN;
X4:=EMA(C,20);
二十日斜率X4-REF(X4,1))/REF(X4,1)*100,LINETHICK0;
十日换手率:SUM(VOL,10)/CAPITAL*100,LINETHICK0;
锁定筹码:EMA((HSL-ZXL)/ZXL*XS,13),LINETHICK2;
浮动筹码:EMA((ZDL-HSL)/HSL*XS,13),LINETHICK2;
力量对比:锁定筹码-浮动筹码,COLORSTICK;

选股条件及选股公式是自己所创,希望给大家一点借鉴:
HSL:=EMA(V/CAPITAL,3);
ZDL:=HHV(HSL,240);
ZXL:=LLV(HSL,240);
XS:=MA(C,33);
HL10:=WINNER(C/1.1)*100;
HL20:=WINNER(C/1.2)*100;
HL30:=WINNER(C/1.3)*100;
X4:=EMA(C,20);
二十日斜率:=(X4-REF(X4,1))/REF(X4,1)*100,LINETHICK0;
十日换手率:=SUM(VOL,10)/CAPITAL*100,LINETHICK0;
锁定筹码:=EMA((HSL-ZXL)/ZXL*XS,13),LINETHICK2;
浮动筹码:=EMA((ZDL-HSL)/HSL*XS,13),LINETHICK2;
力量对比:=锁定筹码-浮动筹码;
ZF:=C*100/REF(C,30)-100<30;
选股:二十日斜率>0.75 AND 十日换手率>60 AND 力量对比>0 AND ZF;
选股条件含义:
1.股票处于上升通道,斜率大于75度角。
2.10天换手率总和大于百分之六十。
3.13天内获利筹码多于亏损筹码。
4.30天内涨幅小于百分之三十。
 
 
VAR1:=(CLOSE*2+HIGH+LOW)/4; SK: EMA(VAR1,13)-EMA(VAR1,21); SD: EMA(SK,2); ?à·??üá?: 2*(SK-SD)*3.8, LINESTICK; ??·??üá?:= (-2)*(SK-SD)*3.8, LINESTICK; ??è?·???:= 0, CIRCLEDOT; STICKLINE(CROSS(SK,SD),SK,0,1,0),LINETHICK2,COLORRED; DRAWTEXT((CROSS(SK,SD)),SK,'???ì?ò'),LINETHICK2,COLORRED; STICKLINE((CROSS(ZIG(3,8),REF(ZIG(3,8),1))),SK,0,1,0),LINETHICK2,COLORYELLOW; DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),SK,'??±??? '),LINETHICK2,COLORYELLOW; DRAWICON(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),SK,9); DRAWICON((CROSS(SK,SD)),SK,1);
改为选股预警公式,我要备钱在昨天,短买在今天,或者是两个连为一个力量柱谢谢
VAR1:=(CLOSE*2+HIGH+LOW)/4;SK: EMA(VAR1,13)-EMA(VAR1,21);SD: EMA(SK,2);短买:CROSS(SK,SD);你要的备钱在昨天含有未来函数,只选了短买在今天的选股公式
VAR1:=(CLOSE*2+HIGH+LOW)/4;SK:=EMA(VAR1,13)-EMA(VAR1,21);SD:=EMA(SK,2);短买:CROSS(SK,SD);
 
 
 

1.30个交易日内,股价跌幅达到一半的股票:
xg:(hhv(c,30)-c)/hhv(c,30)>0.5;
2,今天的量   是5天平均的 2倍以上
xg:v>ma(v,5)*2;
缩量
vol/ma(vol,10)<0.3;
3,两天内,累计下跌等于或超过20%选股.
xg:(ref(c,2)-c)/c>0.2;
4,股价是25天以来新低.
xg:c<ref(llv(c,25),1);
5,选股:EXPMA 5日与10日金叉 并且第二天的收盘价在EXPMA的5日线以上.
cross(ref(ema(c,5),1),ref(ema(c,10),1)) and c>ema(c,5);
6,请编买入公式:
1. 将BIAS指标的参数设置为24日,将KD指标的参数设置为9;3;3。
2. BIAS指标要小于-6,这只是确认该股超跌的初选条件。
3. KD指标产生黄金交叉,K线上穿D线。
4. KD交叉同时,KD指标中的D值要小于16。
BIAS3 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100,colorff00ff;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
xg:BIAS3<-6 and cross(k,d) and d<16;
7,要求是量大、换手率达到3左右,涨幅>7个点。
xg:v/capital*100>3 and (c/ref(c,1)>1.07;
8,个股分时图上都有一条黄线,叫做均价线
a/capital*100;
9,"阴转阳"的公式(也就是昨天收阴线,今天收阳线)
xg:ref(c,1)<ref(o,1) and c>o;
10,股价回抽20日均线选股公式
xg:ref(c,1)>ma(c,20) and cross(ma(c,20),c);
11,一根大阳线,至少有5个点以上,再连着出现二根振幅不大于5的十字星或是小K线
xg:(ref(c,3)-ref(c,4))/ref(c,3)>0.05 and count((h-l)/l<0.05,2)=2;
12,行情信息里的“涨幅”的原码
(c-ref(c,1))/c*100;
13,kdj的J从上向下穿越O轴发出信号
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
xg:cross(0,j);
14,股价4天中有两天在10日线上
count(c>ma(c,10),4)=2;
15,选出10天内出现了涨停的个股
count(c/ref(c,1)>1.1,10)>0;
又:
今涨停:=C/REF(C,1)>1.09;
选股:count(今涨停,n);
16,一阳上穿10,20,30日线,量能是前一天3倍。
xg:cross(c,ma(c,10)) and cross(c,ma(c,20)) and cross(c,ma(c,30)) and v>ref(v,1)*3;
17,共三根K线,第一根K线为阴线;第二根K线为阴线线,最高价低于第一根K线,最低价高于第一根K线;第三根K线阴阳不限,最高价低于第二根K线,最低价高于第二根K线。满足后发出信号~
w1:=ref(c,2)<ref(o,2);
w2:=ref(h,2)>ref(h,1) and ref(l,2)<ref(l,1);
w3:=ref(h,1)>h and ref(l,1)<l;
xg:w1 and w2 and w3;
18, 选出今日成交量大于昨日成交量一成的股票。
xg:v>ref(v,1)*1.1;
19, 连续5天,当日的5日均线减前一天的5日均线差值小于1.
count((ma(c,5)-ref(ma(c,5),1))<1,5)=5;
20,股价上穿5周均线:
xg:cross(c,ma(c,5));
注意:选股时用周线
21,上穿30日均线的公式
xg:cross(c,ma(c,30));
22,两笔阴线中间夹着一根阳线或数根K线,其中两笔阴线最低点相等
xg:ref(l,2)=l;
23,量比大于1 同时换手大于2的公式
xg:v/ref(v,1)>1 and AMOUNT/CAPITAL*100>2;
24,换手:VOL*100/CAPITAL;
     周期换手:SUM(换手,10);
25,流通盘小于4000万 的选股公式
xg:CAPITAL/100<4000;
26,涨停开盘跌停收盘选股
xg:h/ref(c,1)>1.1 and ref(c,1)/l>1.1;
27,当天开盘价与收盘价相等的选股公式
xg:c=o;
28,5日均线向上 流通盘小于5000万 换手率大于3的选股公式
lt:CAPITAL/100<5000;
换手:=VOL*100/CAPITAL<3;
w1:ma(c,5)>ref(ma(c,5),1);
xg:lt and 换手 and w1;
29,收下影线
xg:c>l;
30, o=l就没有下引线了,那就:
xg:c>l and o>l;
31,当日收盘下穿5日均价
xg:cross(ma(c,5),c);
32,最低价小于前一日的最低价但收盘后为阳线。
xg:l<ref(l,1) and c>o;
33,30日内到本日收盘价下跌20%的公式
xg:hhv(c,30)/c>1.2;
34,选周线跳空缺口的个股。
xg:HIGH<REF(LOW,1) OR
LOW>REF(HIGH,1);
周期选周线
35,30日均线走平或走高的个股
xg:ma(c,30)>ref(ma(c,30),1);
36,连续4天的收盘价格波动幅度在3%之内连续走平或向上
count(abs(c-ref(c,1)/ref(c,1))<0.03 and c>ref(c,1),3)=3;
37,下影线长于上影线
(c-l)>(h-c);

38, 收盘价+收盘价的10%
(c+c*0.1);
39,今天高开的公式
c>o;
40,今天的量大于等于昨天量的2倍,股价上涨
xg:v>ref(v,1)*2 and c>ref(c,1);
41,今天的量小于昨天量的2倍以上,股价上涨
xg:v<ref(v,1)*2 and c>ref(c,1);
42,大部分股票跌到43日均线时就会反弹,如果在43日均线附近买入,短线成功率占90%以上,即时选出还差几分钱就跌到43日均线的股票。
xg:abs(c-ma(c,43))/ma(c,43)<0.01;
43,{选出每天换手5%-15%之间的股票}
Var1:=100*VOL/CAPITAL;
w1:=var1>5;
w2:=var1<15;
xg:w1 and w2;

44,换手率10天80%以上的选股公式
sum(VOL/CAPITAL*100,10)>80;

45,60个交易日内,涨幅大于9.9%(涨停)的天数
count(c/ref(c,1)>1.099,60);

46,昨天跌幅大于3%,今天开盘高开2%以上的选股公式。
xg:ref(c,1)/ref(c,2)<0.97 and o/ref(c,1)>1.02;

47,选出周换手率小于10%的股票
sum(VOL/CAPITAL*100,5)<10;

48,成交量创20日新低,并且股价也创20日新低
xg:v=llv(v,20) and c=llv(c,20);

49,5日不涨,绿线收盘选票指标
count(c<o,5)=5;

50,"今日MACD等于昨天的MACD   ,且macd>0"   的指标
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
xg:macd=ref(macd,1) and macd>0

51,连续2天收盘价跌破30日均线,就显示”卖出”信号
a1:count(c<ma(c,30),2)=2;
drawtext(a1,c,'卖出'),colorgreen;

52,股票在这条均线上在8天以上,上下幅度不大,
a1:abs((c-ma(c,120))/ma(c,120))<0.1;
xg:count(a1,8)=8;

53, 连续三天高开高走的选股公式
count(o>ref(c,1) and c>o,3)=3;

54,n天内曾经有m个涨停
count(c/ref(c,1)>1.09,n)>m;

55,股价比昨天的高,量比昨天小,放量。
xg:c>ref(c,1) and v<ref(v,1) and ref(v,1)>ref(v,2)*2;

56,连续3天每天的最低价都比前一天高
count(l>ref(c,1),3)=3;

57,周量缩小50%或40%或n%
a1:vol/capital*100;
xg:a1/ref(a1,1)<n/100;

58,股价超过五日均价的15%以上,并给出卖出信号
卖出:c/ma(c,5)>1.15;

59,连收两个十字星的选股公式
count(abs((c-o)/o<0.01),2)=2;

60,n横盘天数,n1横盘的上下幅度
REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=(n1/100)
and ref(v,1)<ref(ma(v,5),1) and cross(v,ma(v,5)) and cross(v,ma(v,10));

61,收盘价连续8天都站在5日均线的股票。
count(c>ma(c,5),8)=8;

62,振幅大于5%,收盘价大于3.5小于15元,三日均线大于昨日的三日均线,去掉ST股。
a1:=h/l>1.05;
a2:=c>3.5 and c<15;
a3:=ma(c,3)>ref(ma(c,3),1);
xg:a1 and a2 and a3;

63,收盘价下有60天前的远期获利盘n%。
{60天前的远期获利盘:=ppart(60)*100;}

aa:WINNER(ref(c,60 ))*100;

64,连续三日收阳 后日收盘高于前日 且每日收于当日最高价附近 每日涨幅不大于4%
选股:count(c>o and c>ref(c,1) and abs((h-c)/c)<0.01 and c/ref(c,1)<1.04,3)=3;

65,昨日收阴, 今日收阳,的K线组合。
C>O AND REF(C,1)<REF(O,1);

66,股价突破5ma买入,跌破5ma卖出。买入和卖出用箭头表示 (副图)
a1:cross(c,ma(c,5));
a2:cross(ma(c,5),c);
drawtext(a1,low*0.98,'↑'),colorred;
drawtext(a2,h*1.02,'↑'),color00ffff;

67,今天的250平均线大于昨天的昨天的250平均线
ma(c,250)>ref(ma(c,250),1);

68,历史高点到前一高点画线
POLYLINE(h>=hhv(c,0),h);

69,均线中增加一根线,这根线的价格是5日线的1.2倍
aa:ma(c,5)*1.2;

70,20天均线向上的股
xg:ma(c,20)>ref(ma(c,20),1);

71,连续3天收盘全是阴线。
count(c<ref(c,1),3)=3;

72,今天收盘价在昨天收盘价-2%~2%之间
c/ref(c,1)>0.98 and c/ref(c,1)<1.02;

73,收盘价在5日均线以上5天
count(c>ma(c,5),5)=5;

74,N天前换手率大于8%
REF(VOL/CAPITAL*100,N)>8;

75,一条均线18MA   股价上涨后“缩量”回调到18MA
XG:COUNT(V<REF(V,1) AND C<O,N)=N AND C>MA(C,18);
N   “缩量”回调的天数

76,1。昨日量是n天以来最低量,(n可调);2。今日量是昨日量的m倍,(m可调);3。今日k线收阳线;
xg:ref(v,1)=llv(ref(v,1),n) and v>ref(v,1)*m and c>o;

77,第一天收阴,第二天,第三天,第四天,收出红三兵
XG:REF(C,3)<REF(C,4) AND COUNT(C>O,3)=3;

78,月k线十字星收盘   并且5月线拐点向上。
XG:ABS(C-O)/O<0.02 AND MA(C,5)>REF(MA(C,5),1);
用月线选股

79,最近3天(包括昨天.前天)股价突破250日均线
COUNT(C>MA(C,250),3)=3;

80,跳高大阴线,条件: 1 开盘跳空4%以上2 大阴线实体6%以上.
O/REF(C,1)>1.04 AND C/REF(C,1)<0.94;

81,条件:1: 假设大前天创最近新高,要求这天涨幅是超过7%的大阳线,且创最近一个月的新高.
      2: 那么前天,昨天,今天都收小K线,要求小K线实体
xg:ref(c,3)/ref(c,4)>1.07 and ref(c,3)=hhv(c,20) and count(abs((c-ref(c,1))/ref(c,1)<0.02,3)))=3;
82,60与120均线距离在n%内
XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))<N/100;

83,5日均线倾角大于60度
X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;
也可以这样:
X:(ATAN((EMA(C,5)/REF(EMA(C,5),1)-1)*100)*180/3.14115926)>60;利用指标排序:X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
84,“中阴之后,跳拉阳”c/ref(c,1)>1.05;
------------------------------------------------------------------------------------------------------
85,count(x,n) 意思是n天内出现过信号的,假设n=10,那么就是10天内出现信号(包括今天),如果不加这个的话,就是限定在今天出信号才选出来,以前的不管。
86, 今天涨停的公式C/REF(C,1)>1.09;
87,10日内有涨停的公式今涨停:=C/REF(C,1)>1.09;
选股:count(今涨停,10);
88,昨日前日涨停的REF(C,1)/REF(C,2)>1.095;
--------------------------------------------------------------------------------------------------------
89,近5日K线最高价和最低价格波动在10%以内,成交量是昨日2倍,收盘涨5%
XG:(HHV(C,5)-LLV(C,5))/LLV(C,5)<0.1 AND V>REF(V,1)*2 AND C/REF(C,1)>1.05;
90,60与120均线距离在n%内XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))<N/100;
91,“中阴之后,跳拉阳”c/ref(c,1)>1.05;
92,能在图上提示个股(不含S或ST股)出现过的涨跌停板日期的公式
w1:if((c-ref(c,1))/ref(c,1)>0.1,date-1000000,c);
93,涨幅≤2%(c-ref(c,1)/ref(c,1)*100<2;
94,5日,10日,30日贴近公式,越贴越好m1:=ma(close,5);
m2:=ma(close,10);
m3:=ma(close,20);
m4:=ma(close,30);
y1:=max(max(max(m1,m2),m3),m4);
x1:=min(min(min(m1,m2),m3),m4);
黏合:y1/x1<n;
n越小越黏合(n,1.01-----1.05)
95,(1)换手率均线DMA(c ,v/CAPITAL );
(2)20天以来的任意天期(n),换手率均线正负波动值<=p%;
AA:=DMA(c ,v/CAPITAL );
ab:=(aa-ref(aa,1))/ref(aa,1)*100<p;
bb:count(ab,20)>=n;
96, 30天线拐头向上出现提示
ma(c,30)>ref(ma(c,30),1);
97,今天的换手率大于前天的一倍以上
w1:=v*100/capital;
w1>ref(w1,2)*2;
98,K线沿着5日均线往上爬的选股公式 w1:ma(c,5);
w2:abc(c-w1)/w1<0.01;
xg:count(w1>ref(w1,1),5)=5 and w2;
99,20日均线,上穿62日均线 xg:cross(ma(c,20),ma(c,62));
100,平台整理的公式,整理时间和整理幅度可调
COUNT(CLOSE,0)>N AND
(HHV(CLOSE,N)-LLV(CLOSE,N))/LLV(CLOSE,N)<=(N1/100);
N整理时间,N1整理幅度
101,选出当日收盘价突破10日均线5%的个股
cross(c,ma(c,10)*1.05);
102,选出当日最低价在10日均线上下0.05%内,收盘价在均线上方的个股
abs(l-ma(c,10))<0.005 and c>ma(c,10);
103,第一天股票涨停,第二天成交量是第一天成交量的1倍,并超过10%.那第三天就是买点
w1:=ref(c,2)/ref(c,3)>1.1;
w2:=ref(v,1)/ref(v,2)>2;
xg:w1 and w2;
104,放量2倍突破300日线的选股指标
cross(c,ma(c,300)) and v>ref(v,1)*2;
105,3日均线上穿10日均线,KDJ有效金叉
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
w1:=cross(ma(c,3),ma(c,10));
xg:w1 and cross(k,d);
106,30日均线拐头向上ma(c,30)>ref(ma(c,30),1);
107,连续3-5天,每天的收盘价涨跌幅不超过1%.w1:abs(c-o)<0.01;
xg:count(w1,5)>=3;
108,K线收十字星abs(c-o)/o<0.01;
109,MACD在8天以内两次金叉DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);
w1:cross(DIFF,dea);
xg:count(w1,8)>=2;
110,昨天升降幅在-n%----n%之间
w1:abs(ref(c,1)-ref(c,2))/ref(c,2)*100<n;
111,于20日均线相差2个百分点的
w1:abs(c-ma(c,20)/ma(c,20)*100<2;
N日均线相差M个百分点的公式.
w1:abs(c-ma(c,n)/ma(c,n)*100<m;
n:N日 m:M个百分点
112,60MA由向下调头向上ma(c,60)>ref(ma(c,60),1);
113, 股价回调到14日均线的选股 abs(c-ma(c,14))/ma(c,14)<0.005;
114,历史第5根K线到第30根K线之间的最高价hhv(ref(c,5),25);
115,MACD的拐点公式DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);
拐点:ref(macd,2)>ref(macd,1) and ref(macd,1)<macd;
116,跳空高开收阳线LOW>REF(HIGH,1) and c>o;
117,涨停过300日线的选股公式
c/ref(c,1)>1.09 and cross(c,ma(c,300));
118,成交量是前5天中其他任何一天的10天均量线的3.5倍以上
w1:=llv(ma(v,10),5);
xg:v>w1*3.5;

119,股价N天内连续沿着5天线走,且每天收盘价与5天线的距离不超过2%的选股公式
w1:=abs(c-ma(c,5))/ma(c,5)<0.02;
xg:count(w1,n)=n;

120,跳空高开后,三天内没有回补缺口
ref(LOW,2)>REF(HIGH,3) and l>ref(LOW,2);121,日涨幅小于3%C>0 AND C/REF(C,1)   >1.03;
122, 股价创30个交易日的新高H>ref(H,30);
123,连续n天收阳线UP:=CLOSE>OPEN;
COUNT(UP,N)=N;
124, {5日内第二大量}
zdl:=hhv(v,5);
v0:=IF(v>=zdl,0,v);
v1:=IF(ref(v,1)>=zdl,0,ref(v,1));
v2:=IF(ref(v,2)>=zdl,0,ref(v,2));
v3:=IF(ref(v,3)>=zdl,0,ref(v,3));
v4:=IF(ref(v,4)>=zdl,0,ref(v,4));
第二大量:MAX(MAX(MAX(MAX(v0,v1),v2),v3),v4);
DRAWTEXTABS( 0,10 ,'第一大量 '+ zdl+' 第二大量'+第二大量);同理可求出第三大、第四大和最小量.实行简单的排列.
这个公式好比是一件完整产品中的一个零部件,解决了一个思路问题.
125,{5日均线倾角大于60度}
X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;
 
 

四处寻找指标,不如精通MACD指标(附选股公式)
   四处寻找所谓“一定赚钱”的各种指标。才发现,很难找到这样指标,其实最好的指标,就在自己身边,大家软件中最普通的指标,也就是最经典的,MACD就是此类指标里面精华的精华。
    MACD实战战法
    一、“MACD低位两次金叉”
    MACD指标的要素主要有红色柱、绿色柱、DIF指标、DEA指标。其中,当DIF、DEA指标处于O轴以下的时候,如果短期内(8或13个交易日内)连续发生两次金叉,则发生第二次金叉的时候,可能发生暴涨。若DIF由下向上穿越O轴时,可看作大势可能布入多头市场。预示着大势将走强,操作上应部分资金参与。若MACD由下向上穿越O轴时确认大势进入多头市场。投资者可以大胆持股,积极介入。在多头市场中,获得的收益高于承担的风险。
    在MACD指标中,红色能量柱和绿色能量柱,分别代表了多头和空头能量的强弱盛衰。它们对市场的反应,要比短期均线DIF在时间上提前。在MACD指标中,能量释入的过程,是一个循序渐近的过程,通常是呈逐渐放大的。在东方哲学中讲求,”阳盛则衰.阴盛则强”.在使用能量柱时,利用红色能量柱结合K线走势图就得出,当K线走势图近乎90度的上升,加之红色能量柱的快速放大,预示着大势的顶部已近.尤其是相邻的两段红色能量柱产生连片时,所爆发的行情将更加迅猛.反之,在空头市场中,这种现象也成立.在熟悉了这种操作手法后,对投资者逃顶和抄底将大有益处。
    使用“MACD低位二次金叉”寻找短线暴涨股,需注意下列事项:(一)MACD低位一次金叉的,未必不能出暴涨股,但“MACD低位二次金叉”出暴涨股的概率和把握更高一些。(二)“MACD低位二次金叉”出暴涨股的概率和把握所以更高一些,是因为经过“第一次金叉”之后,空头虽然再度小幅进攻、造成又一次死叉,但是,空头的进攻在多方的“二次金叉”面前,遭遇溃败。从而造成多头力量的喷发。(三)“MACD低位二次金叉”,如果结合K线形态上的攻击形态研判,则可信度将提高,操盘手盘中将更容易下决心介入。
    在使用MACD指标过程中,有两点需要注意,第一,MACD指标对于研判短期顶部和底部,并不一定可信,只有结合中期乖离率和静态钱龙中的ADR指标,才可以判定。第二,利用周线中的MACD指标分析比日线的MACD指标效果好。
    二、活用“探底器”,寻觅真底部
    在此介绍一种利用MACD与30日均线配合起来寻找底部的办法,可剔除绝大多数的无效信号,留下最真最纯的买入信号。其使用法则:MACD指标中DIF线在0轴以下与MACD线金叉后没有上升至0轴以上,而是很快又与MACD线死叉,此时投资者可等待两线何时再重新金叉,若两线再度金叉(在0轴以下)前后,30日平均线亦拐头上行,这表明底部构筑成功,随后出现一波行情的可能性较大。
    三、MACD背驰深探
    MACD指标是最著名的趋势性指标,其主要特点是稳健性,这种指标不过度灵敏的特性对短线而言固然有过于缓慢的缺点,但正如此也决定其能在周期较长、数据数目较多行情中给出相对稳妥的趋势指向。若以此类推,将MACD在周期对较长的分时图如15分钟以上中尤其是在交易日午市运用,则可化长为短,成为几个交易日内做短线的极佳工具。值得注意的是,在现在的钱龙系统里,快速参数多取12日,慢速参数多取26日,这是因为中国股市在早期是一周6个交易日、一月平均26个交易日而如此沿袭下来,投资者可改为10和22。但基本差别不大,所以,之后也没引起重视而一直沿袭至今。指标背离原则是整个MACD运用的精髓所在,也是这个指标准确性较高的地方。其中细分为顶背弛和底背弛。其基础要点如下:
   (一)、背弛形成原理:往往是在市场多空中一方运行出现较长时期后出现的(图象上即为DIF和DEA交叉开口后呈近平行同向运行一段时间),因为这代表一方的力量较强,在此情况下往往容易走过了头,这种股价和指标的不对称就形成了背弛!
    在股市投资中,MACD指标作为一种技术分析的手段,得到了投资者的认知。但如何使用MACD指标,才能使投资收益达到最佳境界,却是知者甚微。技术分析作为股市一种投资分析的工具,有两大功能。首先是发现股市的投资机会,其次则是保护股市中的投资收益不受损失。
    1、当DIF,MACD两数值位于0轴上方时,说明大势处于多头市场,投资者应当以持股为主要策略。若DIF由下向上与MACD产生交叉,并不代表是一种买入信号,而此时的大盘走势,已是一个短期高点,应当采用高抛低吸的策略。一般情况下,在交叉信号产生后的第二天或第三天,会有一个回调低点,此刻可以再行买入,达到摊低成本的目的。若DIF由上向下交叉MACD时,说明该波段上升行情已经结束,通常行情会在交叉信号产生后,有波象样的反弹,已确认短期顶部的形成,此时投资者可以借机平仓出局。在之后的调整中,利用随机指标KDJ,强弱指标RSI再伺机介入,摊低操作成本。若DIF第二次由下向上与MACD交叉,预示着将产生一波力度较大的上升行情,在交叉信号产生后,投资者应当一路持股,直到DIF再次由上向下交叉MACD时,再将所有的股票清仓,就可以扛着钱袋回家休息了。由于股市行情的变化多端,MACD指标常会与K线走势图呈背离的走势,通常称为熊背离。既K线走势图创出近期的第二个或第三个高点,MACD指标并不配合出现相应的高点,却出现相反的走势,顶点在逐步降低。次种现象应引起投资者的警觉,因为它预示着今后将有大跌行情产生,所以投资者宜采用清仓离场的策略,使自己的股票避免被套,资金避免受到损失。
    2、当DIF与MACD两指标位于0轴的下方时,说明目前的大势属于空头市场,投资者应当以持币为主要策略。若DIF由上向下交叉MACD时,会产生一个调整低点。一般情况下,在此之后由一波反弹行情产生,这是投资者一次很好的平仓机会。在中国股市中,目前还没有建立作空机制,因此股市一旦进入空头市场,投资者最好的策略就是离场观望。投资者可以在股票贬值的同时,使手中的资金得到增值。若DIF由下向上交叉MACD时,会产生近期的一个高点,投资者应当果断平仓。这种信号的产生,一般以反弹的性质居多。在空头市场中,每次反弹都应当视为出货的最佳良机。尤其需要引起注意的是,若DIF第二次由上向下交叉MACD时,预示着今后会有一波较大的下跌行情产生。投资者应当在交叉信号产生后,坚决清仓出局。通常产生的这段下跌,属于波浪理论中的C浪下跌,是最具杀伤力的一波下跌。只有躲过C浪下跌,才可以说真正在股市中赚到了钱。在空头市场经过C浪下跌以后,偶尔也会发生MACD指标与K线走势图产生背离的现象,通常称为牛背离。既K线走势图出现第二或第三个近期的低点,MACD指标并没有相应的低点产生,却出现一底高过一底的相反走势,这种现象的产生,预示着行情在今后会发生反转走势,投资者应当积极介入,因为目前的市场根本没有风险。
    3、背弛原点取值十分重要,强调要具有明显的高(低)点性!注意要在同一上升(下降)趋势里中取值,且在最高(低)点之后运行一段(一般在下跌末段、股价与指标出现第三浪低点)后才出现原点;
   (三)、连续性原则。注意:1、必须在复权价位下运用指标;2、停牌阶段指标运动失效;3、涨跌停板指标失效。背弛是一种能量积累过程,只有震荡交易才能利于能量的积累与转换!故此,停牌期间MACD指标容易失灵!就形成方式看,只有以股价震荡盘升(跌)方式形成的背弛具有较高的判顶(底)信号,那种指标暴涨(跌)后形成的背弛往往是反弹(回调)行情。因为只有逐步震荡的方式才能是能量完全释放完毕而确立顶(底)部,但暴动的方式却使市场一方扩大了发挥的范围,其之后至少还会出现多次背弛才能真正反转。
     四、MACD背弛抄底法
     一、事不过三。在大跌行情中,底背弛低点后连续出现2次顺次的背弛时,基本可以确定下跌行情已快结束。但此时往往由于空头力量的顽强而向下假突破,指标也随其突破,虽然有可能打穿前两次背弛的底部,也即相对前两次没有形成背弛,但其和最初的背弛原点仍是形成了背弛,而且是第三次背弛,操作上反而可大胆反手操作抄底。三背弛后的反转行情幅度往往较大且安全性高,其中暴涨后期需要连续的大量支持。近期的ST板块个股在下跌过程中的60分钟图就形成了明显的三背弛,从而也支持其反弹行情的展开。
    二、对称原理。在股市中,对称原理的存在面很广,MACD背弛也不例外。一般而言,出现底背弛尤其是多次背弛之后的行情见顶多以成交或者股价顶背弛结束。因为底背弛代表能量的过分集中,在反弹行情展开后压抑的能量容易产生报复行情,而强大的惯性作用也就往往容易造成顶背弛。
    三、形态分析。MACD属于趋势性指标,而传统形态分析中绝大部分也都是根据趋势理论逐步总结出来的,故此从原理上看两者有较大的共通性,这也决定了MACD底背弛也可用一般的形态理论进行分析,如头肩底、双底、三底、圆弧底、平台扎底等,此类形态分析中常用的量度幅度、阻力或支持位等评判理论也可适用,顶背弛则反之运用。
    五、大盘背离所发出的买卖信号
    MACD主要用于对大势中长期的上涨或下跌趋势进行判断.当股价处于盘局或指数波动不明显时,MACD发出的买卖信号不是很明显,当股价在短时间内上下波动较大时,因MACD移动相当缓慢,所以不会立即对股价的变动产生买卖信号.现实当中笔者运用最多的是利用其与大盘背离所发出的买卖信号,对大盘的未来趋势作出判断.现以本次行情的见顶和近期所发出的底背离信号作一简要分析.
    首先,我们来看MACD在本次行情见顶时,它是何时发出第一次卖出信号的.以上证指数为例,2001年4月23日,当天MACD明显在高位向下交叉,第一次发出卖出信号.如果留意基本面的朋友可能知道,今年一季度央行招开的全国金融工作会议中的一个主要议题就是整顿金融秩序,规范资本市场.作为投资者,如果对高层发出的规范市场信号反应迟钝的话,那是相当危险的.因此,笔者结合基本面对技术指标发出的危险信号作了果断处理,抛出所有股票离场观望.之后的大盘走势也印证了这一点,不同的是,经过短期震荡后,大盘还在爬高.那么如何解释这种现象。
    其实这个问题不难理解,大家可以观察图中对应大盘上涨时的MACD走势.将光标移动到2001-05-28日,大盘当天的收盘超过了2001-04-23日,然而MACD没有创出新高,相反出现了二次向下死叉,出现了顶背离,市场又一次发出了卖出信号.根据MACD的应用原则,高位出现二次向下死叉,其后都将有一波较大的跌势.抛开基本面不说,如果对这个重要的卖出信号也视而不见的话,那么市场留给你的将是无尽的痛苦和折磨了.
    六、用MACD就能赚钱
    大盘日线MACD金叉且周线KDJ的J小于0!每年做2-3次,出货在日线MACD死叉!
    MACD背弛抄底法:背弛陷阱,任何技术工具都有其独特优势之处,但优势有时也容易转化为缺陷,而这经常也成为庄家骗线制造陷阱的入手点!
    MACD背弛在应用中虽然成功率比较高,但同样存在背弛陷阱的可能。其中主要表现在:在连续暴跌后形成底背弛原点后,指标开始斜向上形成底背弛,但股价并没有因此而反弹,只是盘平甚至盘跌,而且在指标盘升到压力位后却继续向下突破,底背弛陷阱显现!值得注意的是,背弛陷阱之后再次出现的指标高级别底背弛,这往往就是真正的底部出现。最明显的例子就是去年8月到9月大盘暴跌后在市场一片企稳反弹呼声中,指数仍盘滑且MACD指标也开始盘升,但最终仍是继续暴跌到今年年初指标再次出现高级别底背弛时,中期底部才真正出现!同理,股价在连续暴涨后也容易出现类似的顶背弛陷阱。究其原理,主要还是能量级别与指标反映程度难以配比有关。MACD运行主要特点就在于稳健性,但这恰恰暴露其在暴涨暴跌行情中的缺陷,即其对此类行情中蕴藏的能量无法靠一次性背弛就释放完毕,进而需要多次背弛或者形成更高级别背弛后,才能给出真正的反转点信号。有鉴于此,投资者在股价连续暴跌暴涨同时MACD出现大开口突破之际,仍不适宜马上应用一般背弛原理进行反转操作,最好是等待出现多次背弛并重回低点形成高级别背弛后,再动手的安全性才较高!
    七、MACD的“买小卖小”原则。
    买小卖小说白了就是买在小绿柱,卖在小红柱,前大后小,即前面是大绿柱或大红柱,后面往往为小绿柱或小红柱。参考原则如下,否则可能不成立:
    1、股价经历了一段较长时间阴跌后,一般会有一个急跌的过程,此时MACD上形成一个大绿柱,此时可以关注,但不是进场的时机。
    2、股价急跌后开始反弹突破30周线,一般是庄家在建仓,也没必要参与,保持观望。
    3、当股价再次突破30周线时,很可能意味着洗盘结束,即将进入拉升期,后市将有较大的升幅。此时应密切注意该股的动向,一旦其日线系统MACD出现买点,即形成的小绿柱买点,应该毫不犹豫进场。
    4、尽量使用多周期买点,多周期是指月,周,日,60分钟,30分钟,15分钟,5分钟这7个周期。月,周可划为一个周期,60分钟,30分钟可划为一个周期。多周期共振的含义就是指任何一个买点或卖点都必须有两个周期或两个以上的周期发出买点或卖点(当然越多越好),方能考虑进场买入或卖出,一个周期发出的买卖点是不予考虑的。
    5、卖小的原则跟买小刚好相反,即不要卖在大红柱而应该卖在小红柱。
    MACD二次翻红
    首先说说MACD,MACD是一个中线指标,用它不仅可判断大盘的中级走势,实践显示,在选股尤其是选强势股方面,MACD也有着十分重要的作用,如果运用得好,可以成功地相对低位捕捉到个股的起涨点。特别是“MACD二次翻红”这种形态出现后,股价企稳回升的概率较大,具有较大的实战价值,又有“MACD二次翻红”有黄金之说。
    其次说说使用法则:满足“MACD连续二次翻红”的个股往往会有非常好的上涨行情,所谓MACD连续二次翻红是指MACD第一次出现红柱后,还没有等红柱缩短变绿便再次放大其红柱,这是利用MACD选强势股的关键,也是介入的最佳买点。特别是前期下跌时间长、下跌幅度大的个股,一旦出现“MACD连续二次翻红”形态,股价企稳回升的概率较大。如某只股票的股价开始缓慢回升,MACD由绿变红,一段时间后股价再度下探,红柱又开始缩短至零轴附近,红柱又翻红并逐渐伸长,这便是“MACD连续二次翻红”,也是最佳的买点。
    最后依据上面的法则以及“MACD二次翻红”的形态,从MACD二次翻红找起涨点入手编写指标如下:
    {二次翻红}
     DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
     DEA:=EMA(DIFF,9);
     MACD:=2*(DIFF-DEA);
     FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND
     REF(MACD,3)<REF(MACD,4);
     FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
     FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
     FH4:=FH1 AND FH2 AND ABS((DIFF-DEA)/C)<0.018;
     FH5:=FH1 AND FH2 AND MACD<0.10;
     FH3 OR FH4 OR FH5;
     这个由原来设计的三个指标组合成一个的指标,“二次翻红”需要同时满足四个条件,一是MACD在零轴以上并且第二次收红柱;二是MACD红柱大于等于零轴并且红柱缩短小于0.10以下;三是DIFF与DEA两线的粘合度小于0.018;四是红柱连续缩短三天以上。在指标中设计了三个“二次翻红”起涨点,只要符合其中的任意一个起涨点就能选出股票。
     如今,网上只有MACD二次翻红的形态描述,但还没有查看到比较系统的此类选股指标。应用该指标选股时尽可能选择调整基本到位,MACD柱线短的股票来介入,力争获取上涨幅度比较大的那部分空间。
     需要注意的是:不是所有符合“二次翻红”形态的股票都能上涨,同样需要大环境的配合,只要美股、港股及亚太周边股市上涨,再有Z*F的政策支持,我们的A股才能有所表现,个股才有机会,不然,有的股票当天红柱伸长,次日就来个大缩短,套你没商量。
     再说说“二次翻红”的作用,有网文对“二次翻红”的作用是这样描述的:
     如果某走势符合““MACD连续二次翻红”的个股往往会有非常好的上涨行情,所谓MACD连续二次翻红,是指MACD第一次出现红柱后,还没有等红柱缩短变绿便再次放大其红柱,这是利用MACD选强势股的关键,也是介入的最佳买点。”这个总的原则,同时又符合以下的四个条件,该股短期出现大幅上升的概率非常大:
    1、30日移动平均线由下跌变为走平或翘头向上,5日、10、30日移动平均线刚刚形成多头排列;
    2、日K线刚刚上穿30日移动平均线或在30日移动平均线上方运行;
    3、DIF在零轴下方与MACD金叉后可靠意义将会更大,在第一次翻红后,红柱开始缩短,越短越好,最好不要超过0轴的第一横线;
    4、成交量由萎缩逐渐放大,特别是在二次翻红后,若能得到成交量的配合,该股后市向上冲击的力量会更大。
    既然如此,根据上面描述的四个条件又编写了下面的指标,也供大家选用:
    {多头二次翻红}
     DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
     DEA:=EMA(DIFF,9);
     MACD:=2*(DIFF-DEA);
     FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND
     REF(MACD,3)<REF(MACD,4);
     FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
     FH3:=EMA(C,30)>=REF(EMA(C,30),1) AND COUNT(EMA(C,5)>EMA(C,10)
     AND EMA(C,10)>EMA(C,30),1)=1;
     FH4:=CROSS(C,EMA(C,30)) OR C>EMA(C,30);
     FH5:=FH1 AND FH2 AND FH3 AND FH4;
     FH6:=FH1 AND FH2 AND FH3 AND FH4 AND ABS((DIFF-DEA)/C)<0.018;
     FH7:=FH1 AND FH2 AND FH3 AND FH4 AND MACD<0.10;
     FH5 OR FH6 OR FH7;
     这个“二次翻红”指标除了满足原有的四个条件外(即:一是MACD在零轴以上并且第二次收红柱;二是MACD红柱大于等于零轴并且红柱缩短小于0.10以下;三是DIFF与DEA两线的粘合度小于0.018;四是红柱连续缩短三天以上。),还基本满足了所描述的四个条件(即:1、30日移动平均线由下跌变为走平或翘头向上,5日、10、30日移动平均线刚刚形成多头排列;2、日K线刚刚上穿30日移动平均线或在30日移动平均线上方运行;3、DIF在零轴下方与MACD金叉后可靠意义将会更大,在第一次翻红后,红柱开始缩短,越短越好,最好不要超过0轴的第一横线;4、成交量由萎缩逐渐放大,特别是在二次翻红后,若能得到成交量的配合,该股后市向上冲击的力量会更大。),该指标没有设计成交量这个条件。只要符合所涉及到的条件,就能在“二次翻红”起涨点选出股票。
    上述两类指标即可以作技术指标使用,也可以作选股指标使用,又能用于预警。
 
 

CCI指标的原理和用法,附背离公式
一、CCI指标的原理
CCI指标是唐纳德·蓝伯特于上世纪80年代提出的,是一种比较新颖的技术指标。它最早是用于期货市场的判断,后运用于股票市场的研判,并被广泛使用。与大多数单一利用股票的收盘价、开盘价、最高价或最低价而发明出的各种技术分析指标不同,CCI指标是根据统计学原理,引进价格与固定期间的股价平均区间的偏离程度的概念,强调股价平均绝对偏差在股市技术分析中的重要性,是一种比较独特的技术分析指标。
CCI指标是专门衡量股价是否超出常态分布范围,属于超买超卖类指标的一种,但它与其他超买超卖型指标又有自己比较独特之处。象KDJ、WR%、CCI等大多数超买超卖型指标都有“0—100”上下界限,因此,它们对待一般常态行情的研判比较适用,而对于那些短期内暴涨暴跌的股票的价格走势时,就可能会发生指标钝化的现象。而CCI指标却是波动于正无穷大到负无穷大之间,因此不会出现指标钝化现象,这样就有利于投资者更好地研判行情,特别是那些短期内暴涨暴跌的非常态行情。
一、CCI指标的背离
CCI指标的背离是指CCI指标的曲线的走势正好和股价K线图的走势方向正好相反。CCI指标的背离分为顶背离和底背离两种。
1、顶背离
当CCI曲线处于远离﹢100线的高位,但它在创出近期新高后,CCI曲线反而形成一峰比一峰低的走势,而此时K线图上的股价却再次创出新高,形成一峰比一峰高的走势,这就是顶背离。顶背离现象一般是股价在高位即将反转的信号,表明股价短期内即将下跌,是卖出信号。
在实际走势中,CCI指标出现顶背离是指股价在进入拉升过程中,先创出一个高点,CCI指标也相应在﹢100线以上创出新的高点,之后,股价出现一定幅度的回落调整,CCI曲线也随着股价回落走势出现调整。但是,如果股价再度向上并超越前期高点创出新的高点时,而CCI曲线随着股价上扬也反身向上但没有冲过前期高点就开始回落,这就形成CCI指标的顶背离。CCI指标出现顶背离后,股价见顶回落的可能性较大,是比较强烈的卖出信号。
2、底背离
CCI的底背离一般是出现在远离﹣100线以下的低位区。当K线图上的股价一路下跌,形成一波比一波低的走势,而CCI曲线在低位却率先止跌企稳,并形成一底比一底高的走势,这就是底背离。底背离现象一般预示着股价短期内可能将反弹,是短期买入的信号。
与MACD、KDJ等指标的背离现象研判一样,CCI的背离中,顶背离的研判准确性要高于底背离。当股价在高位,CCI在远离﹢100线以上出现顶背离时,可以认为股价即将反转向下,投资者可以及时卖出股票;而股价在低位,CCI也在远离﹣100线以下低位区出现底背离时,一般要反复出现几次底背离才能确认,并且投资者只能做战略建仓或做短期投资。
 
 
用法提示:
1)选好股票;
2)用1分钟K线图;
3)按照CCI指标的用法,15分钟线看走势、看范围(-100至+100为正常区,>100为强势区,
   <-100为弱势区),根据走势和范围决定买或卖;
4)1分钟线配合15分钟线定买卖点.
买点1:15'和1'都在-100的弱势区,是较理想的低买点,效益最大.
买点2:15'在-100至+100的正常区,1'在<-100的弱势区,效益较好.
买点3:15'在>100的强势区,1'在正常区,有一定效益.
点,看1'线和15'线的位置,不看上穿-100或+100线时,因为此处不是买点!
附背离公式
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORRED,LINETHICK1;
STICKLINE(CCI>REF(CCI,1),HHV(CCI,3),LLV(CCI,3),0,0),COLORYELLOW;
STICKLINE(CCI
DRAWTEXT(((LLV(LOW,21) = LOW) AND NOT((LLV(CCI,21) =CCI))),LLV(CCI,21),'▲'),COLORRED;
DRAWTEXT(((HHV(HIGH,34) = HIGH) AND (MA(CCI,3)
 

显示1分钟CCI的同时显示15分钟CCI.
N:=14;
M:=210;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
TYP15:=(HHV(HIGH,15)+LLV(LOW,15)+CLOSE)/3;
CCI15:(TYP15-MA(TYP15,M))/(0.015*AVEDEV(TYP15,M)),COLORRED;
用法提示:
1)选好股票;
2)用1分钟K线图;
3)按照CCI指标的用法,15分钟线看走势、看范围(-100至+100为正常区,>100为强势区,
<-100为弱势区),根据走势和范围决定买或卖;
4)1分钟线配合15分钟线定买卖点.

买点1:15'和1'都在-100的弱势区,是较理想的低买点,效益最大.
买点2:15'在-100至+100的正常区,1'在<-100的弱势区,效益较好.
买点3:15'在>100的强势区,1'在正常区,有一定效益.
点,看1'线和15'线的位置,不看上穿-100或+100线时,因为此处不是买点!
优化了一下.加了一个顶底背离.
N:=14;
M:=210;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
TYP15:=(HHV(HIGH,15)+LLV(LOW,15)+CLOSE)/3;
CCI15:(TYP15-MA(TYP15,M))/(0.015*AVEDEV(TYP15,M)),COLORRED;
AA:=REF(CCI,3)=HHV(CCI,2*3+1);
BB:=BACKSET(AA,3+1);
CC:=FILTER(BB,3) AND CCI=HHV(CCI,3+1);
A1:=BARSLAST(REF(CC,1));
顶背离:=REF(CLOSE,A1+1)CCI AND CC;
DRAWLINE(CC,CCI,FILTER(顶背离>0,5),CCI,0),COLORRED,LINETHICK3;
AA2:=REF(CCI,3)=LLV(CCI,2*3+1);
BB2:=BACKSET(AA2,3+1);
CC2:=FILTER(BB2,3) AND CCI=LLV(CCI,3+1);
AA2A:=BARSLAST(REF(CC2,1));
底背离:=REF(C,AA2A+1)>CLOSE AND REF(CCI,AA2A+1)
DRAWLINE(CC2,CCI,FILTER(底背离>0,5),CCI,0),COLORRED,LINETHICK4;
DRAWLINE(CC2,CCI,FILTER(底背离>0,5),CCI,0),COLORRED,LINETHICK4;
-100;0;100;

卖点的掌握:
1) 15'线和1'线都在CCI>100的强势区;
2) 卖点应以15'线的顶拐点为准,1'线的顶拐点有时与15'线的顶拐点谐振而同时出现,大多是先于15'线出现,
但此处不是卖点,须等15'线拐点出现才是卖点;
 
自选股线上翘}走平8跟量柱,在第八根量柱画立着的三个红箭头!!!
下面是公式:
         VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
AA:=VOL>REF(V,1)*1.9;
AA1:=VOL<REF(LLV(VOL,13),1);
AA2:=VOL<REF(LLV(VOL,55),1);
STICKLINE(AA,0,V,1,0),COLORYELLOW;
STICKLINE(AA1,0,V,1,0),COLORGREEN;
STICKLINE(AA2,0,V,1,0),COLORMAGENTA;
TJ1:=COUNT(V>REF(V,1)*1.9,4)=1;
TJ2:=COUNT(V<REF(V,1) AND L>MIN(L,4) AND L>REF(L,1),3)=3 ;
TJ3:=TJ1 AND TJ2;
STICKLINE(TJ3,0,V,1,0),COLORRED;
MV5:MA(V,5);
MV135:MA(V,135); 选股:HHV(VOL,13);
本盘亿股: CAPITAL/1000000,;
 
 
本人自编布林指标选股公式交流
   说明:1.本人是用大通证券行情接受软件编写,其它软件一般都有编写选股公式功能。
           2.进入大通证券行情接受软件---->点:功能(菜单)---->点:专家系统---->点:公式管理器---->点:用户---->技术指标公式---->点:新建
           你就可以通过插入函数来编写修改自定义公式
          3.本自编公式与一般查询到的公式相比多了以下功能:收盘在布林线中的位置以及所在位置的时间选股、布林线带宽选股、缩口时间长短选股、今收与最近布林最小收口的时间选股,另外,布林线是以每日成交平均价为基础计算出来的,而一般通用的是以收盘价为基础计算出来的,因此本公式更能反映市场状态。
         4.使用说明:A.指标B%是用来指示股价在布林线图形中的相对位置,在本公式中,若今收等于中轴价,指标B%为10;带宽(WIDTH),一般来说带宽指标小于10的股票随时有可能发生突破;B.公式中:“收在上轨上:收在上轨中轴间,收在中轴下轨间,收在下轨下,带宽连缩,前最小收口距今”这几项都是通过设置时间周期来选股。
 
以下是自编布林指标选股公式:
 
中轴:MA(AMOUNT/(100*VOL),M);
上轨:中轴+2*STD(AMOUNT/(100*VOL),M);
下轨:中轴-2*STD(AMOUNT/(100*VOL),M);
今收:CLOSE;
B%:10* (今收-下轨)/(上轨-下轨);
带宽:100*(上轨-下轨)/中轴;
收在上轨上:BARSLASTCOUNT(B%>10);
收在上轨中轴间:IFF( 5<B%,BARSLASTCOUNT(B%<10) ,0);
收在中轴下轨间:IFF( B%<5,BARSLASTCOUNT(0<B%) ,0);
收在下轨下:BARSLASTCOUNT(B%<0);
带宽连缩日:BARSLASTCOUNT(带宽<REF(带宽,1));
前最小收口距今: LLVBARS(带宽,N);
 

{底背离,柱背离}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
QM:=LLVBARS(MACD,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);
XG1:=MACD<0 AND MACD>MQDZ
AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0;
XG:REF(XG1,1)=1 AND MACD>REF(MACD,1);
{双底背离,柱加线}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
QM:=LLVBARS(MACD,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);
QF:=LLVBARS(DIFF,QZQ+20);
DQDZ:=IF(QF>QZQ,REF(DIFF,QF),0);
XG1:=MACD<0 AND MACD>MQDZ AND DIFF<0 AND DIFF>DQDZ
AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0 AND DQDZ<0;
XG:REF(XG1,1)=1 AND MACD>REF(MACD,1);
 
{量价共振选股}
J0:=(HIGH+LOW)/2;
QJ:=EMA(J0,3);
J1:=IF(CLOSE>QJ,VOL,0);
J2:=IF(CLOSE<QJ,VOL,0);
RV:=(QJ-LLV(QJ,144))/(HHV(QJ,144)-LLV(QJ,144))*100;
统计:=SUM(J1-J2,5);
差:=EMA(统计,7)-EMA(统计,340);
趋势:=EMA(差,7);
GZ:=CROSS(差,趋势);
GG:=CROSS(趋势,差);
KZ:=COUNT(RV<15,3)>=1 AND CROSS(RV,3);
KD:=COUNT(RV>80,3)>=1 AND CROSS(98.5,RV);
底:GZ AND KZ;
 
 
变动速率和威廉指标综合优化
WR1:=100*(HHV(HIGH,20)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20));
WR2:=100*(HHV(HIGH,20)-HIGH)/(HHV(HIGH,20)-LLV(LOW,20));
偏离:=(CLOSE/MA(CLOSE,120)-1)*100,;
ROC:(CLOSE-REF(CLOSE,N))/REF(CLOSE,N)*100,COLORWHITE;
ROCeMA:=EMA(CLOSE,13);
S_ROC:(ROCeMA-REF(ROCeMA,21))/REF(ROCeMA,21)*100,COLORYELLOW;
MTM : (CLOSE-REF(CLOSE,7))*0.07,COLORMAGENTA;
FILLRGN(MTM <ROC,ROC,MTM ),COLORWHITE;
FILLRGN(MTM >ROC,ROC,MTM ),COLORred;
ROCV:S_ROC;
红1升:PARTLINE(ROCV>REF(ROCV,1),ROCV),COLORMAGENTA,linethick2;
绿1降:PARTLINE(ROCV<REF(ROCV,1),ROCV),COLORWHITE,linethick2;
反弹:IF(WR1>97 ,偏离,0),STICK,LINETHICK3;
调整:IF(WR1<3 ,偏离,0),STICK,LINETHICK3;
0,LINEDOT,COLORGREEN

威廉指标是LARRY WILLIAM 于1973年所发表的。
  原名为"威廉氏超买指标",简称"WMS%R"或"%R"。
  计算公式:
  首先要确定周期次数,此日数乃买卖循环的半数。在欧美,技术分析专家认 为一买卖循环为28日。但扣除周六与周日,实际交易为20日。而一较长的买卖循 环有56日,交易日为40日。因而%R 的周期取前面20日与40日之半数。
  即使用10日%R或者20日%R,也有取更小周期日数如5日%R者。
  以10日%R为例:
  C10-L10
  WMS%R=-------------------×100%
  H10-L10
  H10:10日内最高价
  L10:10日内最低价
  C10:第10日收盘价
  应用法则:
  计算出的%R数值与RSI一样介于0至100间。其功能为:
  1、当"%R"低于20,即处于超卖状态,行情即将见底,20这一横线,称之 为"买进线"。
  2、当"%R"高于80,即处于超买状态,行情即将见顶,80这一横线,称之 为"卖出线"。
  3、当"%R"由超卖区向上爬升,只是表示行情趋势转向,若是突破50中轴 线,便是涨势转向强,可以买进。
  4、当"%R"由超买区向下滑落,跌破50中轴线, 可以确认跌势转强,应予 卖出。
  5、当"%R"进入超买区,并表示行情会立刻下跌,在超买区内的波动,只 是表示行情是价格仍然属于强势中。直至%R回头跌破"卖出线"时,才 是卖出讯号。反之亦然。

ROC指标
① 当ROC向上则表示强势,以100为中心线,由中心线下上穿大于100时为买入信号。 
② 当ROC向下则表示弱势,以100为中心线,由中心线上下穿小于100时为卖出信号。
③ 当股价创新高时,ROC未能创新高,出现背离,表示头部形成。
④ 当股价创新低时,ROC未能创新低,出现背离,表示底部形成。
[变动率ROC(Rate of Change)]
ROC是由当天的股价与一定的天数之前的某一天股价比较,其变动速度
的大小,来反映股票市变动的快慢程度。大多数的书籍上把ROC叫做变
动速度指标或变化速率指标。从英文原文直译应该是变化率。
1. ROC的参数 ROC中只含一个参数,那就是究竟是同多少天之前的股价
进行比较,这个天数N就是参数。
参数的含义其实反映了相比较的股价离现在时间上的远近。N越大,距
现在越远。N选得太大,离得太远,对于股价的预测可能没有什么指导意
义。N选得太小,离得太近,对预测也可能没有什么指导意义。参数N应
该选多少,这与个人的习惯有关,不能一概而论。目前,市场上流行的
是N=5和N=10等几种。

2. ROC的特性
(1) ROC表示股价上升或下降的速率大小。
如果是上升趋势,并且ROC为正值,另外ROC步步上扬,则意味着上升趋
势正在加速,若ROC开始走平,这就意味着,现在股价的涨幅与数天前的
股价涨幅相近,尽管还处于上升趋势,但速度已经放慢;若ROC开始回落,
虽然股价还在上升,但上升的力量已经衰落;若ROC开始延伸到0之下,则
近期的下降趋势已开始露头,ROC进一步向下,则下降动力正在加强。
ROC是显示一定时间间隔的两头的股价的相对差价。ROC上升,则股价比
数天前的股价有所上升。ROC走平,则当前股价涨幅仅仅同数天前一
样。ROC向下,则股价已经比数天数的涨幅小了。ROC就是这样显示当
前股价趋势的加速和减速状态的。
对于下降趋势和ROC下降,且为负值的情况,可以类似地叙述。
(2) ROC的变化超前于股票价格的变化
因为ROC的构造特点,ROC的变化总是领先于股价的变化,比价格提前
几天上升或下降。股价还在上升时,ROC可能已走平,而股价走平时,
ROC可能已经下降了。这一点也是背离思想的基本依据。
(3)ROC折变化有一定的范围
ROC可正可负,可大可小,但是ROC的变化基本上是有一个范围的。换
句话说,我们可以找到一个正数和一个负数,使得ROC曲线绝大部分落
在这两个数构成的范围内,即比这个正数小,比那个负数大。这样,就
好像给ROC加上了上下边界一样。这两条边界对我们今后预测股价的上
升高度和下降深度很有帮助。我们可以利用这两条边界通过反向运算的
方法,计算出未来的上升高度和下降高度。

3. ROC的应用法则:
根据ROC的特性,我们可以按以下的法则正确地应用ROC。为了更好地应
用ROC,我们还引入了另一个技术指标——ROCAVG(ROCR的移动平均)。
(1) 从ROC的取值方面
ROC自上而下跌破0,是卖出信号。反之,ROC自下而上穿过0,是买进信
号。这是由ROC描述股价变动速度的特性而定的。
(2) 从ROC与ROCAVG的相对取值方面
后者是前者的移动平均,这两个指标的关系就如股价与MA的关系一样,
正是由于这个原因,ROC上穿ROCAVG并且ROC为正值时,是买入信号。同
理,ROC下穿ROCAVG并且ROC为负值时,是卖出信号。
(3) 从ROC与股价的背离方面
ROC有领先于股价的特性,所以有如下的法则。
如果从高向低ROC曲线出现两个依次下降的峰,而此时,股价却出现新
的高峰。这就是背离,是卖出的信号。同理,ROC从低向高形成依次上
升的两个谷,而此时,股价却出现了新的低谷。这是买入信号。

ROC(Price Rate of Change)乃以今天之价格比较其N天前之价格,以比率表示之,此指标经由Gerald Apple And Fred Hitschler 两人于"Stock Market Tra Systems"一书中介绍,采用12天及25天周期可达到相当的效果。
买卖原则:
1. ROC具有超买超卖的原则。
2. 个股经价格比率之不同,其超买超卖范围也略有不同,但一般介于正负6.5之间。
3. ROC抵达超卖水准时,作买;抵达超买水准时,作买。
4. ROC对于股价也能产生背离作用。

一.用途:
该指标用来测量价位动量,可以同时监视常态性和极端性两种行情。ROC以0为中轴线,可以上升至正无限大,也可以下跌至负无限小。以0轴到第一条超买或超卖线的距离,往上和往下拉一倍、两倍的距离,再画出第二条、第三条超买超卖线,则图形上就会出现上下各三条的天地线。
二.使用方法:
1、 ROC波动于“常态范围”内,而上升至第一条超买线时,应卖出股票。
2、 ROC波动于“常态范围”内,而下降至第一条超卖线时,应买进股票。
3、 ROC向上突破第一条超买线后,指标继续朝第二条超买线涨升的可能性很大,指标碰触第二条超买线时,涨势多半将结束。
4、 ROC向下跌破第一条超卖线后,指标继续朝第二条超卖线下跌的可能性很大,指标碰触第二条超卖线时,跌热多半将停止。
5、 ROC向上穿越第三条超买线时,属于疯狂性多头行情,涨涨涨!涨不停,回档之后还要涨,应尽量不轻易卖出持股。
6、 ROC向上穿越第三条超卖线时,属于崩溃性空头行情,跌跌跌!跌不休,反弹之后还要跌,应克制不轻易买进股票。
三.使用心得:
1.界定某一只股票的超买超卖值时,可以在画面上显示至少一年的走势,观察一年来ROC在常态行情中,大约上升至什么地方就下跌?下跌至什么地方就上涨?这个距离就是第一条超买超卖线的位置,再以此等距离向上和向下 ,画第二条、第三条超买超卖线。
2.判断是否处于“常态行情”?可以参考BR、CR、VR等指标,如果上述指标没有异常上扬,大致上都属于“常态行情”。
3.指标有时候会超出超买超卖线一点点,这是正常的。这一方面,不仅须靠个个的判断能力,你可参考布林线的说明,可以帮助你提高过滤误差的能力。
4.当ROC指标穿越第三条超买超卖线时,将股票交给SAR管理,成果相当令人满意!
四.计算公式:
1、 AX=今天的收盘价—12天前的收盘价
2、 BX=12天前的收盘价
3、 ROC=AX/BX
 
变速率指标ROC
① 当ROC向上则表示强势,以100为中心线,由中心线下上穿大于100时为买入信号。
② 当ROC向下则表示弱势,以100为中心线,由中心线上下穿小于100时为卖出信号。
③ 当股价创新高时,ROC未能创新高,出现背离,表示头部形成。
④ 当股价创新低时,ROC未能创新低,出现背离,表示底部形成。

用ROC指标狙击牛股
  在弱市中,独立牛股是短线炒家的狙击目标。而变动率指标ROC在这方面则具有较高的实战价值。该指标是通过计算股价某一段时间内收盘价变动的比例,并结合价格的移动比较来测量其价位动量,以达到事先探测股价买卖供需力量强弱的目的。该指标对于常态行情可以设置两条常态超买线,针对不同个股的盘子大小、股价波动的活跃性、个人操作周期的长短等等,设定相应的参考线。
  一般而言,对于只能达到超买线一(参数值5-10)的个股,投资者要见利就跑;而对于能达到超买线二(参数值12-17)的个股,应相应地进行波段的高抛低吸。而一旦个股能够摆脱这两条常态超买线,挑战第三条超买线(参数值18-35),行情往往就会向狂热的极端行情演变。
  我发现具备以下特征的个股出现黑马的概率较高: 1.先于大盘启动,底部放量换手吸筹充分的,第一波ROC上攻至第三超买线的个股。在这部分个股中,有75%的黑马出现概率。
  2.上攻日换手率3.5%-6%,第一波上攻月升幅在25%以上。股价回调后,仍能总体保持45度以上的攻击性角度的个股。一旦第一波峰ROC指标达到第三超买线,其未来走势往往十分出众,投资者自当乘中线回调时介入。
  3.对于达到第三超买线的领涨股,一旦遇到主力的快速洗盘,投资者可果断介入。其中ROC向上突破零线,进入强势区域时,表示多方力量强盛,这是辅助中短线的买入信号。
  4.股价在洗盘后启动第二波升浪时,中线20日或40日均线系统率先梳理完毕,并先于大盘呈多头排列的个股。对于这类有庄超跌股,第二波走势往往会呈现出“涨、涨、涨”,涨不停的超强趋势。
用ROC指标在30分钟K线上寻找强势股中继买点
在30分钟K线上用ROC指标来捕捉此类强势股的中继买点。
看2003.5的000066长城电脑近期的日K线图,从日线上可以看出该股在5月份放量脱离底部上涨,随后出现深幅回调,此时我们将图形调到30分钟K线,可以看出在7日左右ROC指标有一次明显回探0轴的走势,这个点就是我们今天要给大家讲解的买点。
使用这个方法时要注意以下几点:
1、 所关注的个股已经盘出底部,处于回调确认行情之中;
2、 个股上涨放量、下跌缩量,量价配合良好;
3、 这个方法要在30分钟K线上使用。
下面让我们再看一个实例:600037歌华有线在2003.6月底突破底部,之后回调,此时我们将图形转到30分钟K线上,在7月7日,ROC回调到0轴附近启稳,这个点就是我们要捕捉的买点,之后的行情大家可以看到在大盘不是很强的前提下有一波拉升行情。
................................................................................................................
变动率指标(ROC指标)的系统应用技术
实例为2003年。
ROC指标又叫变动率指标,是以当日的收盘价和N天前的收盘价比较,通过计算股价某一段时间内收盘价变动的比例,应用价格的移动比较来测量价位动量,达到事先探测股价买卖供需力量的强弱,进而分析股价的趋势及其是否有转势的意愿,属于反趋向的指标之一。N的参数一般采用12天及25天做为间隔周期,计算ROC的M日移动平均线ROCMA时,M的参数一般采用6天。ROC指标计算公式是:

  ROC=(今天的收盘价-N日前的收盘价)/N日前的收盘价*100

  ROCMA=ROC的M日移动平均价=ROC的M日累加/M

  ROC指标指标可以同时监视常态性和极端性两种行情,等于综合了RSI、W%R、KDJ、CCI四种指标的特性。

  ROC的应用原则及其缺陷:

  一,ROC的多空力量对比的强弱:

  ① ROC向上突破零线,进入强势区域,表示多方力量强盛是买入信号。

  ② ROC向下跌破零线,进入弱势区域,表示空方做空动力强大是卖出信号。

  缺点:ROC指标过于敏感,不仅如此,连ROCMA有时都会在零线附近象心电图般的跳动。

  二,ROC的超买超卖研判技巧:

  ① ROC上升到极高位置时,指标达到超买水平,产生卖出信号。

  ② ROC下降到极低位置时,指标达到超卖水平,产生买入信号。

  缺点: a,个股的股价波动特性不同,其超买超卖的极限值也各有不同。

  b,操作周期的不同决定了确认超买超卖的极限值也各有不同。

  c,行情属于短线脉冲行情,还是属于较大的波段行情等对于ROC超买超卖的极限值的设定也各有不同。

  三,ROC与股价同步研判技巧:

  ① 股价与ROC从低位同步上升,表示短期有望触底反弹或短期股价会有继续上涨趋势。

  ② 股价与ROC从高位同时下降,表示短期警惕做头回落或短期股价会有继续下跌趋势。

  缺点:不适宜对长期走势的预测。

  四,ROC与股价背离研判技巧:

  ① 当股价创新高时,ROC未配合上升,不能创新高,出现背离,表示上涨动能减弱,头部正在形成。

  ② 当股价创新低时,ROC未配合下降,不能创新低,出现背离,显示下跌动能减弱,底部正在形成。

  缺点:在趋势形成当中,该指标有时会过早出现超买或超卖讯号。这也是ROC的优点之一,由于该指标可测量价格涨跌力量的强弱,因而一旦价格走势出现反转, 变速率指标会提前发出信号,具有一般指标所没有的预测功能。关键是如何改进,扬长避短,既发挥它的预报效果,又要减少误报的概率。

  ROC指标的改进方案:

  ROC指标过于敏感,短期波动频率太快,当初的设计者使用了ROCMA做为平滑ROC指标的工具,这种设计思路是正确的,也起到了一定的作用,可惜,效果不明显。在K线图中,ROCMA常常围绕零线走出心电图,如果投资者依据它做为买卖信号,恐怕,那边卖单还未成交,这边就要填写买单了。改进方案是加入新设计的一条平滑ROC指标的移动平均线ROCEMA,ROCEMA是求ROC指标的X日指数平滑移动平均线,另外,还要将ROC的用收盘价比较方法改为用成交均价比较,这样可以有效排除股价在临收盘前被人为的突然拉高或打压所产生的影响,具体计算公式:

  成交均价=个股成交额/个股成交量

  ROC=(今天的成交均价-N日前的成交均价)/N日前的成交均价*100

  ROCMA=ROC的M日移动平均价=ROC的M日累加/M

  ROCEMA=[2*ROC+(X-1)*上一周期ROC]/(X+1)

  参数的设置分别是:N=12,M=6,X=9

  经过改进后的ROC指标明显的消除过去的敏感现象,使之可以精确的反映股价短期趋势。

  对于ROC的超买超卖研判技巧,几乎所有的教科书和理论分析文章,都把ROC的波动区间定格为正负6.5之间,超过+6.5以上的是超买,低于-6.5以下的是超卖,这是不对的。由于个股的盘子大小,股价波动特性的活跃和呆滞的不同,个人操作周期的长短,行情的大小不同等等,会造成超买之后还超买,超卖之后更超卖的结果,会造成任何人为的设定统一的ROC超买超卖极限值的做法都是徒劳无功的。解决问题的根本办法是放弃不准确的ROC超买超卖研判技巧,用新ROC指标带来的新的应用技巧替代落后的办法。新ROC指标应用技巧:

  1,指标交叉,当ROC,ROCMA,ROCEMA三条线均小于零轴时,ROC迅速同时上穿ROCMA和ROCEMA两条线,而且ROCMA和ROCEMA两条线也处于缓缓上行中,为短线黑马买入信号。如:

  600763 ST中燕在2001年2月份,股价从17元一带快速滑落到13.50元左右,2月23日,收盘价是13.99元,ROC=-11.936,ROCMA=-10.164,ROCEMA=-9.48,三线均小于零。2月26日股价仅微涨到14.10元,而ROC快速有力的上穿了ROCMA和ROCEMA两线,收盘时ROC=-4.666,ROCMA=-9.51,ROCEMA=-8.517,其后的两天中股价又回到14元附近,主力用两根低开小阳线掩饰其上攻欲望,但ROCMA和ROCEMA的缓缓上行已经暴露了庄家的企图。果然,随着3月1日的一根不大的阳线终于拉开波澜壮阔的黑马行情,股价以同2月份下跌时一样的速度快速上升,终于在4月19日股价冲到19.68元,2个月不到,涨幅达到41%。

  当ROC,ROCMA,ROCEMA三条线均大于零轴时,ROC迅速同时下穿ROCMA和ROCEMA两条线,而且ROCMA和ROCEMA两条线也处于缓缓下行中,为短线卖出信号。如:

  600769 祥龙电业 99年6月时只用了三周时间,股价就迅速从8.2元涨到6月23日的最高11.65元,6月24日,走出一根小阴线,由于下影线较长,很多持股人认为下档支撑强,还能涨。可是,当天的ROC以极强的力度向下刺穿了ROCMA和ROCEMA两条线,三条线不仅大于零轴,ROCMA和ROCEMA两条线甚至都超过20,而且处于缓缓下行中,一切均显示危险已经来临。果然,第二天,一根暴跌7.5%的大阴线拉开跳水的序幕,不久,股价就被打回原形到8.2元。

  指标的具体应用过程关键是要把握好指标交叉的有效性,有效性的判断标准是ROC穿越ROCMA和ROCEMA两条线的力度及多头排列或空头排列持续时间的长短。当空头排列时间较长,ROC上穿ROCMA和ROCEMA两条线时的力度较大,就可以确认为短线黑马。当多头排列时间较长,ROC下穿ROCMA和ROCEMA两条线时的力度较大,就可以确认为短线头部。

  2,指标排列的应用技巧:根据ROC指标ROC,ROCMA,ROCEMA三条线是处于多头排列中,还是处于空头排列中研判股价未来的发展趋势。

  当ROC,ROCMA,ROCEMA三条线是处于多头排列中,成交量处于间隙式放大或温和放大过程时,表明股价正运行于上升趋势中,仍有继续上涨趋势。

  当ROC,ROCMA,ROCEMA三条线是处于空头排列中,表明股价正运行于下行趋势中,仍有继续下跌趋势。

  指标交叉是用于判别股价的转折点,而指标排列是用于判别股价是否有沿原来的方向继续发展的动力。通俗的说就是用指标交叉骑上黑马后,用指标排列解决黑马还要骑多长时间的问题。

  如:600078澄星股份自从2000年3月22日ROC在零轴之下上穿ROCEMA后,股价也从10.15元一路盘升到16.5元,这期间虽然涨幅巨大,但ROC,ROCMA,ROCEMA三条线始终处于多头排列中并稳步上行,显示投资者仍可坚定持股。直到2000年4月中旬,ROC指标见顶回落时再卖出,投资者可以凭借该指标的特性拿下一段完整的行情。

  3,指标聚散的应用技巧:根据ROC,ROCMA,ROCEMA三条线的粘合和发散状态研判股价的蓄势及喷发力度。所谓:蓄之既久 其发必速,当ROC,ROCMA,ROCEMA三条线的粘合时间越长其发散时所产生的爆发力越大,不是一飞冲天就是飞流直下,由此也会产生极快的短线利润或极大的投资风险。关键是判别三条线粘合时股价是处于阶段性高位还是处于阶段性底位,以及三线迅速离散的瞬间是否伴随成交量的爆发。

  如:600071凤凰光学于今年5月15日至6月15日之间,ROC的三条线粘合在一起时间长达一个月。6月18日ROC,ROCMA,ROCEMA三条线突然迅速向上发散,成交量也有效爆发出来,当日成交量是20日平均成交量的5倍。这些因素完整的构成买入信号,如果以此信号出现的第二天的平均价7.55元买入,7个交易日后股价涨幅达30%。
 

资金指数:
主流资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORMAGENTA,LINETHICK2;
非主流资金:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLORGREEN,LINETHICK2;
弱势区:20,POINTDOT,COLORGREEN;
强弱分水岭:50,POINTDOT,COLORWHITE;
强势区:80,POINTDOT,COLORF00FF0;
选股公式:
主流资金:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
非主流资金:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
CROSS(主流资金,非主流资金);
 
 
 
 
 
 
 
 
 

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>