寂听夜竹 / 均线,指标 / [转载]量柱指标汇总(1)

0 0

   

[转载]量柱指标汇总(1)

2014-05-25  寂听夜竹

[转载]量柱指标汇总(1)

7天前出现黄金柱的选股公式,

黄金柱:=REF(C,1)>=REF(C,2) AND REF(V,1)>=REF(V,2)*2 AND C>=REF(C,1) AND V
T1:=COUNT(黄金柱,7)>=1;
XG:REF(T1,1);

个股在10天内出现2个黄金柱的选股预警公式.必须今天是黄金柱!谢谢!

count(v>=ref(v,1)*2,10)=2 and v>=ref(v,1)*2;

2个黄金柱中间夹个缩倍量柱的选股预警公式,

AA:=VOL>2*REF(VOL,1) AND C>O;
XG:AA AND REF(AA,2) AND REF(V*2
(给你定义的黄金柱:收阳,成交量大于昨日2倍)

 通达信主图源码:倍量柱其后三天价升量缩被确认为‘黄金柱’,遂在该量柱最低价画横线向右延伸


倍量柱:=V/REF(V,1)>2;
价升:=COUNT(C>REF(C,1),3);

量缩:=COUNT(VOL
黄金柱:=IF(价升 AND 量缩,倍量柱,DRAWNULL);
STICKLINE(黄金柱,H,L,1,0),COLORYELLOW;
DRAWTEXT(黄金柱,L*1.01,'___________________________'),COLORYELLOW;
 

追问
非常好,太谢谢你了。希望进一步求个通达信主图源码:
【只要涨停板满足‘成交量为上一交易日的3倍’,则在该涨停板最低价处画‘ ↖㊣ ’ 】,分一定给,诚谢。
 
回答
倍量:=V>REF(V,1)*3;
涨停:=C=H;
ZT&BL:IF(涨停 AND 倍量,涨停,DRAWNULL);
STICKLINE(涨停,H,L,1,0),COLORYELLOW;
DRAWTEXT(涨停,L*1.01,'↖㊣'),COLORYELLOW;
提问者评价
你真棒,学习了
 
个股昨天出现黄金柱的选股公式,谢谢!

黄金柱的定义是什么?
追问
(给你定义的黄金柱:收阳,成交量大于昨日2倍)
回答
a1:=c>o and v>=ref(v,1)*2;
xg:ref(a1,1);
提问者评价
谢谢老师
 
选股公式,个股满足条件:在最近的8个K线周期内,出现“先连续下跌5天,后连续上涨3天”的情况?


lxxd:=EVERY(c


lxsz:=EVERY(c>ref(c,1),3);


sdwz:=BARSLAST(lxxd);


szwz:=BARSLAST(lxsz);


sdwz=3 and szwz=0



统计7天内个股出现过5天连续上涨的选股公式
 

COUNT(LAST(C>REF(C,1)>=5,7)=1;

或者
COUNT(SUM(C>REF(C,1),5)=5,7)=1;


黄金柱是指通达信软件的黄色的倍量柱,
求:通达信软件,个股在n天内出现2个黄金柱的选股预警公式【包括今天当日出现的黄金柱

 请将黄金柱的具体定义给出来。
公式如下:
COUNT(V>=REF(V,1)*2,N)=2;

 

 

 

求通信达今天出现20和30天内最低量柱的选股公式

 

要求收盘后选出今天的成交量是20或30日的之内最低的选股公式

VOL=LLV(VOL,20);

求通信达13天或50天内有低量柱的选股公式

量13天最低:LLV(V,13)=L;

量50天最低:LLV(V,50)=L;


有谁帮我编写一个通信达的选股公式(四个交易日内成交量出现两个倍量柱),


 

v/ref(v,1)=2{----指“成交量倍量柱”}
count(v/ref(v,1)=2,4){----指“四个交易日内”
=2;---指“出现两个”}


整个公式的逻辑都很严密,且此时通过。不知楼主所说的“不行”是什么意思?
追问
通信达里动态翻译里也是楼主这个意思,可是就是选不出个股,是不是缺了啥?
回答
缺了大盘没有行情啊。有行情自然有信号出现。



求通信达三天成交量逐步放大的选股公式 


 A:vol>ref(vol,1) and ref(vol,1)>ref(vol,2);

提问者评价
对了噢 。。谢了。。选出的好多啊。。。

 

成交量比前一天放大2倍以上的选股公式

 

60交易日内 成交量比前一天放大2倍以上的选股公式
(只要60交易日内,成交量放大2倍的个股,都要选出来)

2009-07-16 18:53 提问者采纳

COUNT(V>REF(V,1)*2,60);



这一周成交量是上一周成交量的2倍的选股公式怎么写? 

b:v>=2*ref(v,1);{用在周线上}
 

 选出当天K线阳包阴(最好股价在低位)同时成交量较前一天放大的股票,谢谢!
 

v/ref(v,1)>1.5 and ref(c,1)o and c>ref(o,1) and o<=ref(c,1);

提问者评价
非常感谢!采用中.


5.10.20日均线多头且成交量小于20万且当日涨幅大于百分之五的通达信选股公式

ma(c,5)>ma(c,10) and ma(c,10)>ma(c,20) and v<200000 and c>ref(c,1)*10.5;


 
股票价格在一天之内突破5日均线、10日均线、20日均线通达信选股公式和指标如何编写呀?

cross(c,ma(c,5)) and cross(c,ma(c,10)) and cross(c,ma(c,20));
提问者评价
非常好
成交量5日 10日量均线走平 或多头向上怎么编 也就是要剔除空头向下的 谢谢! 通达信
{1.成交量5日 10日量均线走平
}
MA(V,5)=REF(MA(V,5),1);

{2.成交量5日 10日量均线走平 或多头向上
}
MA(V,5)>MA(V,10);

{二个均已测试,复制可直接引用,如果回答满意,请记得给采纳}
 
 
周k线成圆弧底图型的选股公式
 

{选股周期---周线;主图K线--周线}
AA:=(C*2+H+L+O)/5;
A1:=(EMA(AA,4)+MA(AA,8)+MA(AA,16))/3;
A2:=(EMA(AA,9)+MA(AA,18)+MA(AA,36))/3;
A3:=(EMA(AA,13)+MA(AA,26)+MA(AA,52))/3;
A4:=(EMA(AA,24)+MA(AA,48)+MA(AA,96))/3;
A10:=MAX(MAX(A1,A2),A3);
周圆弧底:LONGCROSS(A1,A3,30) AND (A4-A3)/A3<0.05 AND A10
 
追问
不像吆
回答
看图哪里不像?

 通达信10日20日均线粘合并且在60日均线以上的选股公式

 A10:=MA(C,10);
A20:=MA(C,20);
A60:=MA(C,60);
MAX(A10,A20)/MIN(A10,A20)<1.005 AND A10>REF(A10,1)AND A20>REF(A20,1) AND A10>A60 AND A20>A60 ;
 

 个股连涨三个K线周期(不管天,还是周),且成交量逐级递增,且停牌但合条件的股票也显示
下面这个简单的应该也能用的:
EVERY(C>REF(C,1),3) AND EVERY(V>REF(V,1),3);
提问者评价
公式简单直接,达到条件。最佳答案。谢谢!

 


 通达信5 10 20 30 60 均线粘合的条件选股公式,谢谢!就是即将上涨的那种。

MA1:=MA(CLOSE,5);

MA2:=MA(CLOSE,10);

MA3:=MA(CLOSE,20);

MA4:=MA(CLOSE,30);

MA5:=MA(CLOSE,60);

N5:=(MA1*5-REF(C,4)+C)/5;

最大:=MAX(MAX(MAX(MAX(MA1,MA2),MA3),MA4),MA5);

最小:=MIN(MIN(MIN(MIN(MA1,MA2),MA3),MA4),MA5);

比值:=(最大/最小-1)*100;

粘合:比值<2 AND MA1100;

这里我正在使用的均线粘合公式,按楼主的要求改成5、10、20、30、60五条均线粘合的。但这里提示一下楼主,均线粘合并不表示一定会涨哦。使用的时候还是加强人为判断为好。

 

 
 
 
 
5日均线向上运行,10日20日均线粘合(通达信选股公式)

均线粘合很少有百分百相等的情况,可以取1%振幅内粘合,并且一般是3条均线。

源码如下:
X1:=ABS(MA(C,10)/MA(C,20)-1)<0.01;
X2:=ABS(MA(C,5)/MA(C,10)-1)<0.01;
X3:=ABS(MA(C,5)/MA(C,20)-1)<0.01;
MA(C,5)>REF(MA(C,5),1) AND X1 AND X2 AND X3;
提问者评价
先试试看,谢谢。


通达信选股公式,5,10,20,30,四条均线粘合在一起

{5、10、20、30均线粘合}
ll:=MIN(MA(C,5),MIN(MA(C,10),MIN(MA(C,20),MA(C,30))));
HH:=MAX(MA(C,5),MAX(MA(C,10),MAX(MA(C,20),MA(C,30))));
均线接近度:=(HH-LL)/LL*100;
均线粘合:均线接近度<5;


 
所有均线近期粘合在一起的通达信选股公式

a5:=ma(c,5);
a10:=ma(c,10);
a30:=ma(c,30);
a60:=ma(c,60);
a120:=ma(c,120);
a240:=ma(c,240);
max(max(max(a5,a10),max(a30,a60)),max(a120,a240))/min(min(min(a5,a10),min(a30,a60)),min(a120,a240))<1.05 and a5>ref(a5,1)and a120>ref(a120,1);
追问
无限接近粘合
回答
只需把1.05改小,小到∞接近你的要求即可。
提问者评价
谢谢

 

 

成交量5日均量线上穿10日均量线并且上穿135均量线选股

  

 

指标源码:(TDX DZH)
VOLUME:=VOL;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
MAVOL3:=MA(VOLUME,135);
选股:CROSS(MAVOL1,MAVOL2)AND CROSS(MAVOL1,MAVOL3);

 

<成交量VOL>的5日均线.向上突破60日均线<成交量VOL的5日均线向上交叉60日均线>的选股公式.

1、这是一个非常不错的选股方式,一般是在庄家在低位横盘吸完货进行拉升的开始阶段,因此可以无风险的跟进,公式可以描述成以下代码:

 

CROSS(MA(V,5),MA(V,60))

 

 

 


2、从楼主的图形上我们不难发现,实现这一描述虽然较容易,但同时价量在突破60天均线后很容易形成二次或多次交叉,因此我们必须视情况进行二次判断,在下简单的给出附带代码:


CROSS(MA(V,5),MA(V,60)) AND V=HHV(V,20)
即条件是:5日量的均线上穿60日量的均线,并且当天的量是20天内最高的成交量。

成交量VOL的5日均线向上交叉10日均线>的选股公式

 

CROSS(MA(V,5),MA(V,10))AND V=HHV(V,10);

 

5日均量线上叉10日均量线且两线呈30度上行

 

CROSS(MA(C,5),MA(C,10)) AND ATAN(SLOPE(MA(C,5),4))*57.3>30

 

 

股价经过下跌以后成交量连续缩量,并且连续多天潜伏在60天均量线下面(这个潜伏的意思:就是成交量柱全部低于60天线),潜伏多日后,成交量某一天突然突破60天均量线.

 选股条件:

 1.选出潜伏期超过15天(就是前15天的成交量柱子都低于60天均量线),今天成交量放量突破了60天均量线.

2.要求潜伏期要大于15天,小于30天. 3.能选出近3天符合上面2条的选股. 谢谢!不胜感激

 

股旁网解答:

 

 QF:=EVERY(V

XG:REF(QF,1) AND CROSS(V,MA(V,60)) AND V/REF(V,1)>1.5 ;

 

 

4线金叉20日均量线选股公式 
 
 VOLUME:VOL,VOLSTICK;
  D1:MA(V,4);
  D2:MA(V,20);
  DRAWICON(CROSS(D1,D2),D1,1);
  DRAWICON(CROSS(D2,D1),D1,2);

  1、洗盘要洗到量芝麻点!大盘或个股下跌趋势的底部拐点,就在4、20日均量线粘合处


  2、当成交量连续低于4日均量线时,一旦4线金叉20线,就是介入良机!

 

5日、10日、20日、30日量均线多头排列选股公

 

 
MV5:=MA(V,5);
MV10:=MA(V,10);
MV20:=MA(V,20);
MV30:=MA(V,30);
TJ1:=MV5>MV10 AND MV10>MV20 AND MV20>MV30;
TJ2:=MV5>REF(MV5,1) AND MV10>REF(MV10,1) AND MV20>REF(MV20,1) AND MV30>REF(MV30,1);
XG:TJ1 AND TJ2;

追问
你好,我想要的是成交额的均量线而不是换手的均量线,能不能修改一下?  
回答
MV5:=MA(AMOUNT,5);
MV10:=MA(AMOUNT,10);
MV20:=MA(AMOUNT,20);
MV30:=MA(AMOUNT,30);
TJ1:=MV5>MV10 AND MV10>MV20 AND MV20>MV30;
TJ2:=MV5>REF(MV5,1) AND MV10>REF(MV10,1) AND MV20>REF(MV20,1) AND MV30>REF(MV30,1);
XG:TJ1 AND TJ2;

 

 

麻烦请注意一下,我要的是量均线而不是价格均线,还有我想要的是成交金额平均线而不是换手率平均线,因为成交额可以是无限的,而换手永远不能超过100%,谢谢。 
ma5:=ma(AMOUNT,5);
ma10:=ma(AMOUNT,10);
ma20:=ma(AMOUNT,20);
ma30:=ma(AMOUNT,30);
XG:ma5>ma10 and ma10>ma20 and ma20>ma30;

 

上升角度选股公式

 

公式源码:

C/REF(C,2)>=1.09 AND
ATAN(C/REF(C,2)*100-100)*56.3>=40;



“一阳穿三线”是指一根阳线上穿三根均线,是多头确立信号。

    1、这个图形发生的位置越低越好,把握会更大。
    2、阳线的长度倒不一定非要限制在多少涨幅之内,涨停也是可以的。只是,对三条短期均线的向上穿破是一定要出现的情况,属于一个必要条件。有时我们经常会看见“一阳上穿两线”的情况,但那不一定保靠,同时穿越三线的情况才是最理想的。
    3、这三条均线最好是在一个小的区域内密集或者是互缠状态,互相分散开的情况,即便穿过了,效果也不一定理想。
    4、这三条均线均指短期均线,即5日、10日和30日三条均线。(也可自己设置)
    5、自然,这个形态的判断结果也是对个股短期走势的判断,不能用作长线趋势的判断。
    6、该形态操作成功率:7成以上,即10次操作7次以上可获成功,具体情况可视当时细节而定。
选股公式如下:
MA5:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
低:=REF(C,1)
高:=CROSS(C,MA5) AND CROSS(C,MA10) AND CROSS(C,MA30);
选股:低 AND 高;
 
 
 
一阳穿四线(选股)

参数:Q   最大 20;  最小 0;  默认 0;   

M1:=MA(C,5);
M2:=MA(C,10);
M3:=MA(C,20);
M4:=MA(C,30);
最大值:=MAX(MAX(M1,M2),MAX(M3,M4)); 
最小值:=MIN(MIN(M1,M2),MIN(M3,M4)); 
BARSLAST(L<=最小值 AND C>=最大值)=Q;

原理:
当股价经过一段时间横盘整理,均线系统趋向闭合,
到达时间共振点,一根K线穿头破脚一举攻破5日;10日;
20日;30日均线的阻力,同时MACD形成金叉,这往往是
主力开始拉升的信号.

注意:
其后走势一般分三种:
1、一路轧空连续向上,成交量不断放大,及时跟进;
2、上冲遇到阻力回落整理,在未来走势中只要收盘不破
此K线的开盘价继续持股;
3、骗线,上冲后回落向下调整,如果跌破此K线开盘价立即止损;



 
出现一阳穿五线、同时MACD几乎0轴金叉特征的股票可以直接介入。盛情利用这项技术在7月19日成功捕获600263G路桥,在8月15日成功捕获000029G深深房,短线获利不错,窃喜。

    近日,盛情却高兴不起来了,因为望着600263G路桥、000029G深深房芝麻开花节节高的走势,心中的困惑有点难以言表。遂潜心研究一阳穿五线涨停股票的运行轨迹,有所斩获,特撰本文赠与有缘的朋友参考。

    一阳穿五线涨停股票的第一买点,我认为,在涨停当日4%—5%震荡期间突然启动的一刹那,或者在开盘就上冲4%—5%的期间。
 
       那么第二最佳买点在那里呢? 下面偶用几个实际例子说明。

    600263G路桥,在7月19日一阳穿五线涨停,同时出现均量线、MACD在0轴金叉的技术特征,我在7月25日出局后看到她下跌心中为自己的精彩操作而高兴,她在8月8日的涨停没敢追击,遂失去了8月21日的涨停和之后快速拉升的利润和快乐。经过认真反思,因祸得福,却得到了
 
     第二最佳买点。
 
     一阳穿五线的前提条件应该是股价震荡了很长时间,多条均线靠拢、汇聚,说明长短主力的建仓成本趋于一致, 一阳穿五线涨停的出现,是主力想快速脱离成本区,并得到了长短主力一致认可的结果,可以理解为中线启动的第一信号。
 
     这样,就明白了G路桥的第二最佳买点应该在8月7日,因为这天她受到了30日均线的支撑,30日均线是强弱分水岭,如果跌破30日均线,就说明她重新转入弱市区域,这是主力不想看到的,否则,主力想快速脱离成本区的计划就泡汤了。
    上述观点正确否?000029G深深房的近期表现得到了进一步的验证。
 
8月15日G深深房一阳穿五线涨停,同时出现均量线、MACD在0轴下方金叉技术特征。G深深房一阳穿五线涨停后的短线表现为什么不如G路桥强?
 
       主要原因是MACD所处位置的区别,G深深房的MACD在0轴下方,即处于较弱的区域。同理,她的第二最佳买点应该在8月21日,因为这天她受到了120日均线的支撑(牛熊分水岭),第三最佳买点应该在8月24日,这天她受到30日均线支撑,也是对120日均线支撑的确认。如果按这个思路操作,将享受到后面涨停和快速拉升的快乐。
    600800ST磁卡,在8月21日出现一阳穿五线涨停,其走势类似600263连续冲高后在8月29日受年线支撑止跌,出现第二最佳买点,之后走上连续涨停的道路。 
 
 付:

 
一阳穿五线(选股)


参数:Q   最大 20;  最小 0;  默认 0;  

MA1:=MA(CLOSE, 5); 
MA2:=MA(CLOSE, 10); 
MA3:=MA(CLOSE, 30); 
MA4:=MA(CLOSE, 60); 
MA5:=MA(CLOSE, 120);
A:=MAX(MAX(MAX(MA1,MA2),MAX(MA3,MA4)),MA5); 
B:=MIN(MIN(MIN(MA1,MA2),MIN(MA3,MA4)),MA5); 
BARSLAST(O<=B AND C>=A )=Q

黄金坑选股

 
 VAR312:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR412:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
洗盘调整完毕:(VAR312<-6 AND VAR412<-6 AND "KDJ.J"<-6)+0.5,COLORFF00FF;
DRAWICON(VAR312<-6 AND VAR412<-6 AND "KDJ.J"<-6,1.5,1);
 
开盘15分钟向上跳空缺口选股公式 
选出“当天 9:30分-9:45分 这根15分钟K线 向上产生跳空缺口”的所有股票

源码:

var0:=O>REF(h,1) and L>REF(H,1) andC>REF(h,1);
选:IF(TIME>092900 and TIME<095000,var0,0);

 


 


任何时间15分钟跳空向上选股

var0:=L>REF(H,1);
选:ref(var0=1,sumbars(time<94600,1)-1) 

 

涨幅大于4%选股预警公式


LS:=C/REF(C,1)>1.04 ANDBETWEEN(C,H,H*0.99) ANDBETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));拉升:FILTER(LS,28);

 

 

 

当天涨停板选股公式可做预警
LS:=C/REF(C,1)>1.048 AND C=H ANDBETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
 拉升:FILTER(LS,28);


 所有历史新高选股公式



MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
主力:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
选股:主力=HHV(主力,0); 

 
a:主力=hhv(主力,0);
括号内的0天可以按需求修改。.

 

使用说明:

黄色为立桩量,绿色长竖条为逃顶提示,蓝色与红箭头为突破,红色为牛,
紫色为立桩三天法则成立,笑脸为寻底,棕色与绿箭头为破位,淡红色黑中
线涨停,深绿色黑中线跌停,∠为45度上升,亮绿色为顶背离,紫色为底背离,
红绿点为筹码提示,红点表示获利筹75以上,绿点表示75以下。

源玛---

股价趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
底部警戒:=10,COLORRED,LINETHICK2;
底1:=CROSS(股价趋势,底部警戒);
A1:=(2*CLOSE+HIGH+LOW)/4;
A2:=LLV(LOW,27);
A3:=HHV(HIGH,27);
A4:=EMA((A1-A2)/(A3-A2)*100,13);
A5:=EMA(0.618*REF(A4,1)+0.382*A4,3);
底2:=CROSS(A4,A5) AND A4<16;
波底:=底1 AND 底2;
{奔牛}
VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)/28.57;
VAR4:=EMA(VAR3,5);
VAR5:=3*VAR3-2*VAR4;
牛:=CROSS(VAR5,VAR3) AND VAR3<2.1 ANDC>O;
{逃顶提示}
VARA2:=LLV(LOW,10);
VARA3:=HHV(HIGH,25);
动力线:= EMA((CLOSE-VARA2)/(VARA3-VARA2)*4,4);
{突破与破位}
N:=19;
VARB1:=HHV(HIGH,N);
VARB2:=LLV(LOW,N);
阻力线:=EMA((CLOSE-VARB2)/(VARB1-VARB2),21)-0.5;
操作线:=EMA((CLOSE-VARB2)/(VARB1-VARB2),5)-0.5;
突破:=CROSS(操作线,阻力线) AND 阻力线<0.1;
破位:=CROSS(阻力线,操作线) AND 阻力线>0.25;
{立桩成立判断}
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
T12:=V2>=1;
T0:=BARSLAST(T12);
L1:=REF(L,T0);
H1:=REF(H,T0);
L11:=MIN(REF(L,1),L);
L10:=MIN(L11,REF(L,2));
L21:=MAX(REF(L,1),L);
L20:=MAX(L21,REF(L,2));
T111:=(REF(V2>=1,3) OR REF(V2>=1,2)OR REF(V2>=1,1)) AND
((L10>L1 AND L20>H1) OR(L11>L1 AND L21>H1) OR(L>H1));
T11:=T111 AND REF(T111,1)=0;
{涨跌停}
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
{顶背离与底背离}
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) *100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
顶背离:=CROSS(88,RSI);
底背离:=CROSS(FF,MA15);
{45度攻击}
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
T1:=FILTER(BB13>1 ANDEMA(X1,13)>REF(EMA(X1,8),1),10);
{获利盘提示}
获利盘:=WINNER(C)*100;
{彩色成交量柱线}
VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,5),COLORWHITE;
MAVOL2:MA(VOLUME,35),COLORYELLOW;MAVOL3:MA(VOLUME,135),COLORGREEN;
{V2:IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1),NODRAW,COLORRED;}
STICKLINE(V2>=1,0,VOL*0.5,2,0),COLORYELLOW;
STICKLINE(动力线>=3.2,0,VOL,1,0),COLOR238E23;
STICKLINE(波底,0,VOL,2,0),COLORMAGENTA;
DRAWTEXT(波底,VOL*0.8,'底'),COLORWHITE;
DRAWICON(波底,VOL*1.1,5);
STICKLINE(牛,0,VOL,2,0),COLORRED;
DRAWTEXT(牛,VOL*1.15,'牛'),COLORWHITE;
STICKLINE(突破,0,VOL,1,0),COLORBLUE;
DRAWTEXT(突破,VOL*0.5,'突破'),COLORWHITE;
DRAWICON(突破,VOL*1.2,1);
STICKLINE(破位,0,VOL,0.5,0),COLORBROWN;
DRAWTEXT(破位,VOL*0.5,'破位'),COLORWHITE;
DRAWICON(破位,VOL*1.05,2);
STICKLINE(T11,O,VOL,2,0),COLORFF00FF;
STICKLINE(涨停,VOL*0.5,VOL,2.5,0),COLORLIRED;
STICKLINE(涨停,VOL*0.5,VOL,0,0),COLORRED;
STICKLINE(跌停,VOL*0.5,VOL,2.5,0),COLOR2F4F2F;
STICKLINE(跌停,VOL*0.5,VOL,0,0),COLORBLACK;
STICKLINE(顶背离,VOL*0.8,VOL,2.5,0),COLORGREEN;
STICKLINE(底背离,0,VOL*0.2,3,0),COLOR7F017F;
DRAWTEXT(T1,VOL*1.1,'∠'),COLOR007575;
DRAWTEXT(获利盘>=75 AND动力线>=3.2,VOL*1.1,'●'),COLORRED;
DRAWTEXT(获利盘<75 AND动力线>=3.2,VOL*1.1,'●'),COLORGREEN; 

 

 

倍量过左峰指标                                                                           

  (选股用)倍量过左峰有以下含义:
(1)过左峰是股价创新高;
(2)倍量暴露了主力真实意图;
(3)倍量过左峰符合最经典的道氏理论;
(4)是股价上涨的必经之路,是最佳的拦截位置。


源码                                                                                        

 SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
倍量:=VOL/REF(VOL,1)>=1.9;
突破前高:CROSS(C,前高);

 

 



    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多