魏源wy / 指标公式 / 13日乖离画图----公开源码

分享

   

13日乖离画图----公开源码

2015-04-28  魏源wy
 

近期有很多人认为A股到顶了,我也不知道对不对。
闲来无事,用乖离率做了一个图,仁者见仁智者见智,大家各取所需吧。不会发图,有心人请帮忙发一图。

乖离率(BIAS)是测量股价偏离均线大小程度的指标。当股价偏离市场平均成本太大时,都有一个回归的过程,即所谓的“物极必反”。
乖离率是指股价与平均移动线之间的偏离程度,通过百分比的形式来表示股价与平均移动线之间的差距。如果股价在均线之上,则为正值;如果股价在均线之下,则为负值。乖离率最早来源于葛兰维的平均线定律,它的理论基础主要从投资者心理角度来分析。因为均线可以代表平均持仓成本,利好利空的刺激,造成股价出现暴涨暴跌。
乖离率是一种简单而又有效的分析工具,但在使用过程中基期的选择十分重要。如果基期太短,反应过于敏感,如果基期太长,反应过于迟钝。

BIAS:MA((CLOSE-MA(CLOSE,13))/MA(CLOSE,13),3)*100,COLORWHITE,NODRAW;
DRAWBAND(0,RGB(0,224,224),BIAS,RGB(255,96,96));
VAR1:=MA((HIGH+LOW+2*CLOSE)/4,5);
VAR2:=EMA(VAR1,3)-EMA(VAR1,17);
VAR3:=EMA(VAR2,5);
VAR4:=(VAR2-VAR3)*5;
VAR5:=IF(VAR4<=VAR1,VAR1,VAR4);
回归:= FORCAST(FORCAST(VAR5,17),3),LINETHICK1;
回归一: IF(VAR5>回归,VAR5,VAR1),COLORYELLOW;
MA5: MA(VAR1,5),COLORWHITE;
DRAWKLINE(H,O,L,C);
STICKLINE(C#DAY/REF(C,1)#DAY>=1.099,O,C,1.5,0),COLORD200D2;
STICKLINE((C-REF(C,1))/REF(C,1)*100<=-9.8,O,C,0.5,0),COLORBLUE;
DRAWICON(CROSS(回归一,MA5),LOW*0.95,1);

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>