湖湘人家书馆 / 股票 / 学习量学 自创主图公式

0 0

   

学习量学 自创主图公式

2015-06-13  湖湘人家...
 学习量学近2个月,将部分量学概念写入该公式-----不断完善中,希望能和大家一起交流。

注意:N是个可变值,是当日价柱波动与价柱波动十日均线的比值,该值越大说明长阴短柱或长阳矮柱特征越明显。取值可根据大盘形势,通常取值1.5-2均可;
地量:=VOL=LLV(VOL,100),COLORBLUE;
缩量涨:=C>=REF(C,1) AND V<REF(V,1),NODRAW,COLORCYAN;
倍量:=VOL>=REF(VOL,1)*1.90,NODRAW,COLORYELLOW;
低量:=VOL=LLV(VOL,13),COLORGREEN;
缩梯:=COUNT(V<REF(VOL,1),2)=2,NODRAW,COLORBROWN;
倍缩:=VOL<=REF(VOL,1)*0.5,NODRAW,COLORRED;
平量:=ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.05,NODRAW,COLORWHITE;
梯量:=COUNT(V>REF(VOL,1),2)=2,NODRAW,COLORLIRED;
高量:=VOL=HHV(VOL,13),NODRAW,COLORLIMAGENTA;
天量:=VOL=HHV(VOL,100);
阴线:=C<=REF(C,1);  阴距:=BARSLAST(阴线),NODRAW;
阳线:=C>=REF(C,1);  阳距:=BARSLAST(阳线),NODRAW;
双阳:=COUNT(阳线,2)=2;
双阴:=COUNT(阴线,2)=2;
阳双胜:=阳线 AND VOL>REF(VOL,阴距)*0.9 AND C>REF(O,阴距);
阳量积阴胜:=双阳 AND (V+REF(V,1))>REF(V,2) AND C>REF(O,阴距);
阴双胜:=阴线 AND VOL>REF(VOL,阳距)*0.85 AND C<REF(O,阳距);
阴量积阳胜:=双阴 AND (V+REF(V,1))>REF(V,2) AND C<REF(O,阳距);
阳胜A:=阳双胜 OR 阳量积阴胜;
阴胜A:=阴双胜 OR 阴量积阳胜;
阳胜距:=BARSLAST(阳胜A),NODRAW;
阴胜距:=BARSLAST(阴胜A),NODRAW;
阳胜:=REF(阳胜距>阴胜距,1)=1 AND 阳胜A;
DRAWICON(阳胜,L-0.1,11);
阴胜:=REF(阴胜距>阳胜距,1)=1 AND 阴胜A;
DRAWICON(阴胜,H+0.1,12);
{以下为"将军柱和黄金柱"指标公式}
波幅:=(H-L+ABS(C-O))/2;
量价系数:=MA(VOL,240)/MA(波幅,240);
将军价角:=(((REFX(C,1)+REFX(C,2)+REFX(C,3))/3-O)/O)*100,NODRAW;
黄金价角:=(((REFX(C,1)+REFX(C,2)+REFX(C,3))/3-C)/C)*100,NODRAW;
量角:=(((REFX(V,1)+REFX(V,2)+REFX(V,3))/3-V)/V)*100,NODRAW;
将军价量角:=阳双胜 AND 将军价角>0 AND 0>量角,NODRAW;
黄金价量角:=阳双胜 AND 黄金价角>0 AND 0>量角,NODRAW;
将军柱:=阳双胜 AND 将军价量角>0;
STICKLINE(将军柱,O,C,2.5,0),COLORMAGENTA;
黄金柱:=阳双胜 AND 黄金价量角>0 AND C>O;
STICKLINE(黄金柱,O,C,2.5,0),COLORYELLOW;
{以下为"假阴真阳"指标公式,此指标复权后失真,可选"不复权"参考}
成交均价:AMOUNT/VOL/100,NODRAW;
假阴:=O>C AND 成交均价>REF(C,1);
DRAWTEXT(假阴,H+0.1,'↙假阴');
{以下为"长阴短柱"和"长阳短柱"指标公式}
振幅:=H-L+ABS(C-O);
价差:=ABS(C-REF(C,1));
量价比:=VOL/振幅;
量价比均线:=MA(量价比,10);
均线量价比:量价比均线/量价比,NODRAW;
DRAWTEXT(C>REF(C,1) AND 均线量价比>N,(O+C)/2,'←阳短'),COLORYELLOW;
DRAWTEXT(REF(C,1)>C AND 均线量价比>N,L-0.05,'↖阴短'),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,HYBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0,0.05,0,DYBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0,0.1,0,GNBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0,0.15,0,FGBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0,0.2,0,ZDBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0,0.2.5,0,ZHBLOCK);
补充内容 (2013-4-28 23:28):
今天看见老耐的帖子,觉得他阴阳胜的公式比我写的更好一些,特在此更正
真阴线:=C<=REF(C,1) AND C<O;假阳线:=C<=REF(C,1) AND C>=O;阴线:=真阴线 OR 假阳线;阴距:=BARSLAST(阴线);
补充内容 (2013-4-28 23:28):
阴线实体高:=MAX(REF(C,阴距),REF(O,阴距));   阴线成交量:=REF(V,阴距);
阳胜条件:=阴距>0 AND C>=阴线实体高 AND V>=阴线成交量;
阳双胜:=IF(阳胜条件 AND REF(阳胜条件,1)=0,1,0);
补充内容 (2013-4-28 23:29):
真阳线:=C>=REF(C,1) AND C>O;                假阴线:=C>=REF(C,1) AND C<=O;
阳线:=真阳线 OR 假阴线;                     阳距:=BARSLAST(阳线);
阳线实体低:=MIN(REF(C,阳距),REF(O,阳距));  
补充内容 (2013-4-28 23:29):
阳线成交量:=REF(V,阳距);
阴胜条件:=阳距>0 AND C<=阳线实体低 AND V>=阳线成交量*0.9;
阴双胜:=IF(阴胜条件 AND REF(阴胜条件,1)=0,1,0);
双阴:=COUNT(阴线,2)=2;
补充内容 (2013-4-28 23:29):
阴积胜阳:=双阴 AND (VOL+REF(VOL,1))>REF(VOL,阳距) AND C<=阳线实体低;
阴胜:=双阴 OR 阴积胜阳;
阳胜距:=BARSLAST(阳双胜);
阴胜距:=BARSLAST(阴胜);
补充内容 (2013-4-28 23:30):
阳胜利:=REF(阳胜距>阴胜距,1)=1 AND 阳双胜;
DRAWICON(阳胜利,L-0.1,1);
阴胜利:=REF(阴胜距>阳胜距,1)=1 AND 阴胜;
DRAWICON(阴胜利,H+0.1,2);
补充内容 (2013-4-28 23:32):
请参考的同学们将以上部分更换,另外欢迎大家对本公式提出建议和质疑。谢谢!

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多