分享

更多

   

【通达信】量能公式(全新思路,无未来)可选股

2016-08-21  cerocad
 

下面举例3个。有缘人会爱上这个指标的。




AAA1:49;
BBB2:52;
B1:=REF(CLOSE,1);
B2:=REF(CLOSE,2);
B3:=REF(CLOSE,3);
B4:=REF(CLOSE,4);
CMAX:=MAX(MAX(MAX(CLOSE,B1),B2),B3);
CMIN:=MIN(MIN(MIN(CLOSE,B1),B2),B3);

BT:=REF(VOL,1);
BB1:=IF(O=REF(C,1),O,REF(C,1));
多建:=IF((C>CMIN)*(VOL>BT) OR (C>CMAX)*(VOL>BT),VOL-BT,0);
空平:=IF((C>CMIN)*(VOL<BT) OR (C>CMAX)*(VOL<BT),VOL-BT,0);
空建:=IF((C<CMAX)*(VOL>BT) OR (C<CMIN)*(VOL>BT),VOL-BT,0);
多平:=IF((C<CMAX)*(VOL<BT) OR (C<CMIN)*(VOL<BT),VOL-BT,0);
AAA:=多建+多平;
BBB:=空建+空平;
多头持单:=SUM(AAA,0);
AAT1:=多头持单>REF(多头持单,1);
AAT2:=多头持单<REF(多头持单,1);
AAT3:=多头持单=REF(多头持单,1);
空头持单:=SUM(BBB,0);
BBT1:=空头持单>REF(空头持单,1);
BBT2:=空头持单<REF(空头持单,1);
BBT3:=空头持单=REF(空头持单,1);






当日主力买入量:=(BUYVOL*0.5+SELLVOL
*0.1)/2;
庄家持仓量:=SUM(VOL,100)*0.20;

HOLD:=庄家持仓量;

B5:=SUM(VOL,5)/5;
B6:=SUM(HOLD,5)/5;


VAR1:=(VOL/ (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
VAR2:=(HIGH-LOW);
VAR3:=ABS((OPEN-CLOSE));
VAR4:=(HIGH-IF((CLOSE>OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE>OPEN),OPEN,CLOSE)-LOW);
VAR6:=((VAR3/VAR2)*VOL);
VAR7:=((VAR4/VAR2)*VOL);
VAR8:=((VAR5/VAR2)*VOL);


多头:=((CLOSE=CMAX)*(B1=CMIN))*((HOLD>B6)*(VOL>B5)) OR ((CLOSE=CMAX)*(B1>=B2 OR B1>=B3)
OR ((B1=CMAX)*(B2=CMIN OR B3=CMIN)*(CLOSE>=B2)) OR (B2=CMAX)*(B3=CMIN)*(CLOSE>=B1)
 OR (B3=CMAX)*(CLOSE>=B1)*(CLOSE>=B2))*((HOLD>B6)*(VOL>B5)) OR ((B1=CMIN)*(CLOSE>=B2)
 OR (B2=CMIN)*(B1<=B3) OR (B3=CMIN)*(B1<=B2)*(B2<B4)*(CLOSE>=B1))*((HOLD>B6)*(VOL>B5));
多头3:=((CLOSE=CMAX)*(B1=CMIN))*((HOLD>B6)*(VOL<B5)) OR ((CLOSE=CMAX)*(B1>=B2 OR B1>=B3)
OR ((B1=CMAX)*(B2=CMIN OR B3=CMIN)*(CLOSE>=B2)) OR (B2=CMAX)*(B3=CMIN)*(CLOSE>=B1)
 OR (B3=CMAX)*(CLOSE>=B1)*(CLOSE>=B2))*((HOLD>B6)*(VOL<B5)) OR ((B1=CMIN)*(CLOSE>=B2)
 OR (B2=CMIN)*(B1<=B3) OR (B3=CMIN)*(B1<=B2)*(B2<B4)*(CLOSE>=B1))*((HOLD>B6)*(VOL<B5));


多衰:=((CLOSE=CMAX)*(B1=CMIN))*((HOLD<B6)*(VOL<B5)) OR ((CLOSE=CMAX)*(B1>=B2 OR B1>=B3)
OR ((B1=CMAX)*(B2=CMIN OR B3=CMIN)*(CLOSE>=B2)) OR (B2=CMAX)*(B3=CMIN)*(CLOSE>=B1)
 OR (B3=CMAX)*(CLOSE>=B1)*(CLOSE>=B2))*((HOLD<B6)*(VOL<B5)) OR ((B1=CMIN)*(CLOSE>=B2)
 OR (B2=CMIN)*(B1<=B3) OR (B3=CMIN)*(B1<=B2)*(B2<B4)*(CLOSE>=B1))*((HOLD<B6)*(VOL<B5));

多平1:=((HOLD<B6)*(VOL>B5))*((B1=CMAX)*(CLOSE=CMIN)) OR ((HOLD<B6)*(VOL>B5))*
((CLOSE=CMIN)*(B1<B2 OR B1<B3) OR (B1=CMIN)*(B2=CMAX OR B3=CMAX)*(CLOSE<B2) OR
(B2=CMIN)*(B3=CMAX)*(CLOSE<B1) OR (B3=CMIN)*(CLOSE<B1)*(CLOSE<B2));

空头:=((HOLD>B6)*(VOL>B5))*((B1=CMAX)*(CLOSE=CMIN)) OR ((HOLD>B6)*(VOL>B5))*
((CLOSE=CMIN)*(B1<B2 OR B1<B3) OR (B1=CMIN)*(B2=CMAX OR B3=CMAX)*(CLOSE<B2) OR
(B2=CMIN)*(B3=CMAX)*(CLOSE<B1) OR (B3=CMIN)*(CLOSE<B1)*(CLOSE<B2));
空头3:=((HOLD>B6)*(VOL<B5))*((B1=CMAX)*(CLOSE=CMIN)) OR ((HOLD>B6)*(VOL<B5))*
((CLOSE=CMIN)*(B1<B2 OR B1<B3) OR (B1=CMIN)*(B2=CMAX OR B3=CMAX)*(CLOSE<B2) OR
(B2=CMIN)*(B3=CMAX)*(CLOSE<B1) OR (B3=CMIN)*(CLOSE<B1)*(CLOSE<B2));

空衰:=((HOLD<B6)*(VOL<B5))*((B1=CMAX)*(CLOSE=CMIN)) OR ((HOLD<B6)*(VOL<B5))*
((CLOSE=CMIN)*(B1<B2 OR B1<B3) OR (B1=CMIN)*(B2=CMAX OR B3=CMAX)*(CLOSE<B2) OR
(B2=CMIN)*(B3=CMAX)*(CLOSE<B1) OR (B3=CMIN)*(CLOSE<B1)*(CLOSE<B2));

空平1:=((CLOSE=CMAX)*(B1=CMIN))*((HOLD<B6)*(VOL>B5)) OR ((CLOSE=CMAX)*(B1>=B2 OR B1>=B3)
OR ((B1=CMAX)*(B2=CMIN OR B3=CMIN)*(CLOSE>=B2)) OR (B2=CMAX)*(B3=CMIN)*(CLOSE>=B1)
 OR (B3=CMAX)*(CLOSE>=B1)*(CLOSE>=B2))*((HOLD<B6)*(VOL>B5)) OR ((B1=CMIN)*(CLOSE>=B2)
 OR (B2=CMIN)*(B1<=B3) OR (B3=CMIN)*(B1<=B2)*(B2<B4)*(CLOSE>=B1))*((HOLD<B6)*(VOL>B5));


STICKLINE(多头 OR 多头3,0,ABS(HOLD-REF(HOLD,1)),2,0),COLORRED;
STICKLINE(多衰,0,ABS(HOLD-REF(HOLD,1)),2,0),COLORWHITE;
STICKLINE(多平1,0,ABS(HOLD-REF(HOLD,1)),2,1),COLORRED;

STICKLINE(空头 OR 空头3,0,-ABS(HOLD-REF(HOLD,1)),2,0),COLORGREEN;
STICKLINE(空衰,0,-ABS(HOLD-REF(HOLD,1)),2,0),COLORWHITE;
STICKLINE(空平1,0,-ABS(HOLD-REF(HOLD,1)),2,1),COLORGREEN;



5188.com

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    类似文章 更多
    喜欢该文的人也喜欢 更多