空灵道bss2px8t / ww / 【通达信】高手老师“祝你有收获”将殷保...

分享

   

【通达信】高手老师“祝你有收获”将殷保华公式源码转为通达信版的指标

2017-10-03  空灵道bss...
感谢高手老师“祝你有收获”将殷保华公式源码转成通达信版的指标:
{殷宝华变色MA}
MA5:EMA(C,5),COLORWHITE;
工作线:EMA(C,14),COLORF00FF0,LINETHICK1;
二号线:EMA(C,25),COLOR00FF00,LINETHICK1;
九号线:EMA(CLOSE,99),LINETHICK1;
MA120:EMA(CLOSE,120),LINETHICK1;
生命线:EMA(CLOSE,453),LINETHICK1,COLORRED;
DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19));
DEA:=EMA(DIFF,9);
MACD:=0.90*(DIFF-DEA);
TJ:=(DIFF>=DEA);
TJ1:=(DIFF>=0);
STICKLINE(TJ,H,L,0.5,0),COLORYELLOW;
STICKLINE(TJ,O,C,4,0),COLORYELLOW;
STICKLINE(TJ1 AND TJ,H,L,0.5,0),COLORF00FF0;
STICKLINE(TJ1 AND TJ,O,C,4,1),COLORF00FF0;
STICKLINE(DIFFSTICKLINE(DIFFVAR1:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(VAR1,13)-EMA(VAR1,73);
SD:= EMA(SK,2);
DRAWTEXT((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) ,L*0.99,'短线'),COLORGREEN;
STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),H,L,0.5,0),COLORRED;
STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),O,C,10,1),LINETHICK3,COLORRED;

{公称名称: 保华均线}
MA25:EMA(CLOSE,25);
牛熊分水岭:EMA(CLOSE,905);
STICKLINE((MA25 > 牛熊分水岭),MA25,牛熊分水岭,1,0),COLORRED;
STICKLINE((MA25 < 牛熊分水岭),MA25,牛熊分水岭,1,0),COLORGREEN;
DRAWICON(CROSS(MA25,牛熊分水岭),(牛熊分水岭 * 0.98),6);

{公称名称: 保华提醒}
VAR1:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR2:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
VAR3:=REF(CLOSE,1);
VAR4:=((SMA(MAX((CLOSE - VAR3),0),6,1) / SMA(ABS((CLOSE - VAR3)),6,1)) * 100);
买入:(VAR1 AND VAR2),STICK,COLORFFFFFF;
卖出:CROSS(80,VAR4),STICK,COLORFF0000;

{公称名称: 江恩八线}
一号线:EMA(CLOSE,144);
工作线:EMA(CLOSE,14),colorFFffff;
二号线:EMA(CLOSE,25);
三号线:EMA(CLOSE,318);
生命线:EMA(CLOSE,453),LINETHICK2,colorFF00ff;
五号线:EMA(CLOSE,550);
六号线:EMA(CLOSE,610);
七号线:EMA(CLOSE,730);
八号线:EMA(CLOSE,888);
九号线:EMA(CLOSE,99),colorFF0000;

{公称名称: 买卖奇准}
你:=MA(CLOSE,1);
老:=(((LOW + HIGH) + CLOSE) / 3);
板:=MA(老,5);
好:=HHV(板,10);
老板:=MA(老,5);
买卖:=LLV(老板,10);
急买奇准:IF(LLV((你 < 买卖),5),50,0),colorFF2222;
急卖奇准:IF(HHV((你 < 好),5),100,50),colorFF0000;
短买奇准:IF(LLV((你 < 买卖),10),50,0),colorFFFFFF;
短卖奇准:IF(HHV((你 < 好),10),100,50),colorFF00ff;

{公称名称: 四号箱体}
HEPG:(EMA(CLOSE,450) * 2.14),COLORFFFFFF;
MA03:(EMA(CLOSE,450) * 2.01),COLORFF00FF;
MA02:(EMA(CLOSE,450) * 1.88),COLORFF0033;
MA01:(EMA(CLOSE,450) * 1.75),COLORFFFFFF;
MA1:(EMA(CLOSE,450) * 1.66),COLORFF0000;
MA2:(EMA(CLOSE,450) * 1.5),COLORFF00FF;
MA3:(EMA(CLOSE,450) * 1.37),COLORFFFF66;
MA4:(EMA(CLOSE,450) * 1.33),COLORFF00FF;
MA5:(EMA(CLOSE,450) * 1.25),COLORFF0088;
MA6:(EMA(CLOSE,450) * 1.14),COLORFFFFFF;
MA7:(EMA(CLOSE,450) * 0.99),COLORFFFFFF;
MA8:(EMA(CLOSE,450) * 0.84),COLORFFFFFF;
工作线:EMA(CLOSE,14),COLORFFFFFF;
生命线:EMA(CLOSE,47),COLORFFFFFF;

{公称名称: 准备买入}
N:=5;
VAR1:4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2:8,COLORGREEN,LINETHICK0;
上升在即: IF(CROSS(VAR1,VAR2),80,0),STICK,COLOR0000CC,LINETHICK2;
专吸庄血: IF(VAR1<=8,25,0),STICK,COLORWHITE,LINETHICK2;
DRAWTEXT(CROSS(VAR1,VAR2),80,'准备买入'),COLOR00FFFF;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓区: IF((VARO7<10),80,100) ,COLOR00CCFF,LINETHICK1;
0,LINETHICK2 ,COLORFFCC00;
感觉有用的朋友,使用要感恩“祝你有收获“老师。

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>