情系故乡 / 指标 选股公式 / 通达信控盘动力线副图指标公式

分享

   

通达信控盘动力线副图指标公式

2017-11-03  情系故乡


A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-VOL/CAPITAL*100,0)),0);
成交额:=V*C/100,NODRAW;
A2:=SUM((IF(((成交额/8>18) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)) ,0); {股票公式网(www.gpgsw.com)为您整理}
A3:=SUM((IF(((成交额/8>18) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<18) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<18) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
RATE:=A2/A6*100,COLORWHITE,LINETHICK1;
VOLA:=SUM(VOL,4)/CAPITAL*100>0.22;
HH1:=IF(CAPITAL>5000000 AND REF(V,3)/CAPITAL*100>0.45,0,1);
HH2:=IF(CAPITAL<5000000 AND CAPITAL>3000000 AND REF(V,3)/CAPITAL*100>0.6,0,1);
HH3:=IF(CAPITAL<3000000 AND CAPITAL>1000000 AND REF(V,3)/CAPITAL*100>0.75,0,1);
HH4:=IF(CAPITAL<1000000 AND REF(V,3)/CAPITAL*100>0.9,0,1);
SUMVOL:=HH1 AND HH2 AND HH3 AND HH4;
MM3:=IF(REF(VOL,3)/REF(VOL,2)>3.5 OR (REF(VOL,3)/REF(VOL,2)>2.8 OR REF(V,3)/CAPITAL*100>0.09 AND REF(C,3)<DYNAINFO(4)),0,1);
MM4:=IF(REF(VOL,4)/REF(VOL,3)>3.5 OR (REF(VOL,4)/REF(VOL,3)>2.8 AND REF(C,4)<DYNAINFO(4)),0,1);
MM5:=IF(REF(VOL,5)/REF(VOL,4)>3.5 OR (REF(VOL,5)/REF(VOL,4)>2.8 AND REF(C,5)<DYNAINFO(4)),0,1);
NN3:=COUNT(RATE=100,3)=3 AND BARSCOUNT(FROMOPEN)=3 AND MM3; 
NN4:=COUNT(RATE=100,3)=3 AND BARSCOUNT(FROMOPEN)=4 AND MM4; 
NN5:=COUNT(RATE=100,3)=3 AND BARSCOUNT(FROMOPEN)=5 AND MM5;
量形限制:=IF(VOL/REF(HHV(VOL,3),1)>1.56 OR VOL/REF(VOL,1)>1.6 OR VOL/REF(VOL,1)<0.5 OR REF(VOL,1)/REF(VOL,2)>1.8,0,1);
NN:=(NN3 OR NN4 OR NN5) AND VOLA AND SUMVOL AND 量形限制;
涨幅%:=DYNAINFO(14)*100,NODRAW;
SHOU:=IF(DATE<=1150520,1,0);
SHI:=BETWEEN((DCLOSE*SHOU)/(SUM(AMOUNT,BARSCOUNT((DCLOSE*SHOU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*SHOU)))),1.05,0.95);
TOU:=IF(SHI=0,MA((DCLOSE*SHOU),BARSCOUNT((DCLOSE*SHOU))),(SUM(AMOUNT,BARSCOUNT((DCLOSE*SHOU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*SHOU)))));
动力线:=EXPMA((DCLOSE/TOU),13),COLORFFFF00,LINETHICK1;
趋势线:=EXPMA((DCLOSE/TOU),88),COLOR0080FF,LINETHICK2;
NOTEXT1:=1.003,COLORLIGREEN,LINETHICK2;
NOTEXT2:=1.03,COLORLIRED,LINETHICK2;
IF(动力线>1.003,动力线,DRAWNULL),COLORMAGENTA;
IF(动力线>1.03,动力线,DRAWNULL),COLORRED;
DRAWICON(CROSS(动力线,1.03),1,13);
DRAWTEXT(CROSS(动力线,1.03),0,'板动力'),COLORRED;
VAR18:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR18-REF(VAR18,1))/REF(VAR18,1)*1000;
STICKLINE(控盘<0,控盘,0,1,1),COLOR00FF00;
STICKLINE(控盘>REF(控盘,1) AND 控盘<0,控盘,0,1,1),COLORFF00FF;
无庄控盘:=控盘<0;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLOR0000FF;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
VAR288:=100*WINNER(CLOSE*0.95);
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLORFFFF00;
主力出货:=控盘<REF(控盘,1) AND 控盘>0;
STICKLINE(VAR288>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,1),COLOR00FFFF;
高度控盘:VAR288>50 AND COST(85)<CLOSE AND 控盘>0,COLOR00FFFF,LINETHICK2;
A10:=CROSS(控盘,0);
控盘B:FILTER(IF(A10,1,0),5)*0.5;



    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>