自由翱翔-zyax / 股票公式教程 / 通达信指标公式编写教程[完整版]

0 0

   

通达信指标公式编写教程[完整版]

2018-07-21  自由翱翔...

 

注意事项

   在编公式中所运用的标点符号均是在英语状态下的符号。

 

   在编制公式中,有要显示的句子和不显示的句子,要显示用:”不要显示用“:=

 

1、15天跌幅大于20%,并且今天出现长下影线

 (REF(C,15)-C)/REF(C,15)*100>20 AND

(MIN(C,O)-L)/MIN(C,O)*100>4 ;

 

2、创新高:H=HHV(H,60);

   创新低:L=LLV(L,60);

 

3、涨幅:=(C-REF(C,1))/REF(C,1)*100;

振幅:=(H-L)/L*100;

均价1:(H+L+O+C)/4;

均价2:AMOUNT/(V*100);

 

4、换手率1:V*100/FINANCE(7)*100;

换手率2:V/CAPITAL*100;

 

5、宽幅震荡:(H-L)/L*100>12;

是否在某个范围1:RANGE(C,8,10);{X>A AND A

是否在某个范围2:BETWEEN(C,10,13);{X>=A AND X<=B};

 

6、上穿:CROSS(MA(C,5),MA(C,10));

{持续}一段时间后上穿:LONGCROSS(MA(C,5),MA(C,10),10);

 

7、存在:EXIST(C>REF(C,1)*1.099,10);

一直存在:EVERY(C>O,5);

持续存在:LAST(C>O,10,5);

并非:NOT(C>O);

 

8、跨周期写法 周J:"KDJ.J#WEEK";

D:"KDJ.D#WEEK";

金叉:CROSS(周J,周D);

 

9、{K线形态}

 

阴线:C

阳线:C>O;

 

上涨:C>REF(C,1);

下跌:C

平盘:C=REF(C,1);

 

大阳线:C/REF(C,1)>1.05;

大阴线:C/REF(C,1)<0.95;

 

高开:O>REF(C,1);

低开:O

 

高开高走:O>REF(C,1) AND C>O;

高开低走:O>REF(C,1) AND C

 

低开低走:O

低开高走:OO;

 

上跳空:L>REF(H,1);

下跳空:H

 

长上影:H/MAX(O,C)>1.03;

长下影:MIN(O,C)/L>1.03;

 

十字星:MAX(O,C)/MIN(O,C)<1.02 AND H/MAX(O,C)>1.01 AND MIN(O,C)/L>1.01;

 

T字:O=C AND C=H AND L

T字:O=C AND C=L AND H>L;

 

一字涨停:O=C AND C=H AND L=H AND C>REF(C,1);

一字跌停:O=C AND C=L AND L=H AND C

 

横盘:HHV(H,20)/LLV(L,20)<1.15;

 

    均线状况——金叉和死叉。

 

MA1:MA(C,5);

MA2:MA(C,10);

金叉:CROSS(MA1,MA2);

死叉:CROSS(MA2,MA1);

 

    均线上拐、下拐、将死未死。

 

MA1:MA(C,5);

MA2:MA(C,10);

上拐:=REF(MA1,1)REF(MA1,1);

下拐:=REF(MA1,1)>REF(MA1,2) AND MA1

 

多头排列、空头排列。

 

MA1:MA(C,5);

MA2:MA(C,10);

MA3:MA(C,20);

多头排列:=MA1>MA2 AND MA2>MA3;

空头排列:=MA1

STICKLINE(多头排列,MA1,MA3,0,0),COLORRED;

STICKLINE(空头排列,MA1,MA3,0,0),COLORGREEN;

 

    均线粘合、粘合一段时间。

 

MA1:MA(C,5);

MA2:MA(C,10);

MA3:MA(C,20);

粘合:=MAX(MAX(MA1,MA2),MA3)/MIN(MIN(MA1,MA2),MA3)<1.02;

粘合一段时间:=COUNT(粘合,10)=10;

 

 

成交量状况——主要观察成交量之间、成交量与均量线之间以及换手率之间的关系。放量、历史天量。

 

放量1:V>REF(V,1)*2;

放量2:V>MA(V,60);

历史天量:V=HHV(V,0);

 

连续放量。

 

连续放量1:COUNT(V>REF(V,1),5)=5;

连续放量2:(COUNT(V>MA(V,60),5)=5)*2;

连续放量3:(COUNT(V*100/FINANCE(7)*100>8,5)=5)*3;

 

    缩量、历史地量。

 

缩量1:V

缩量2:V

历史地量:V=LLV(V,0);

 

    连续缩量。

 

连续缩量1:COUNT(V

连续缩量2:(COUNT(V

 

筹码低位密集。

 

筹码密集:=(WINNER(C*1.1)-WINNER(C*0.9))*100>50;

相对低位:=(C-COST(0.01))/(COST(99.99)-COST(0.01))*100<10;

低位密集:筹码密集 AND 相对低位;

 

 

 

10、编一个十字星公式  要求涨幅小于百分之一,跌幅小于百分之零点五,振幅小于百分之四


ZDF:=C>REF(C,1)*0.995 AND C
ZZF:=H
ST:=MAX(O,C)/MIN(O,C)<1.01;
ZDF AND ZZF AND ST;

 

11、放量上攻

AA:=VOL/REF(VOL,1)>2;BB:=CLOSE/REF(CLOSE,1)>1.07;AA AND BB;

 

12、高开高走

AA:=OPEN>REF(CLOSE,1);BB:=CLOSE>OPEN;

AA AND BB;

 

13 涨停板的写法

X:=CLOSE/REF(CLOSE,1)>1.0999;

 

14、均线多头排列下的kdj 的j值在零轴以下的选股公式

 

均线多头:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND  MA(C,20)>MA(C,30);   

J值:=KDJ.J<0;   均线多头 AND  J值;

 

15、 83与288日均线第一次金叉回踩288日线

 

ZQ:=BARSLAST(CROSS(MA(C,83),MA(C,288)));

HCJX:=LMA(C,288);

HCJX AND ZQ>3  AND ZQ<20  AND COUNT(HCJX,ZQ)=1;

 

16、16、2016年9月9曰到9月26日这时间里最高价

 

ZQ:=BARSLAST(DATE=1160926);
GD:REF(HHV(H,10),ZQ);

 

17、refdate(c,1160929); 意思是16年9月29号的收盘价

 

18、最近20个交易日内,10日均线连续下跌的公式编写

 

    count(ma(c,10)

19、5日量柱金叉60日量柱选股

CROSS(MA(V,5),MA(V,60));

 

20、横盘整理

 

 (HHV(CLOSE,10)-LLV(CLOSE,10))/CLOSE<0.05

 

21、取得200221日到20021230日间的最低价

 

LL:=IF(YEAR=2002 AND MONTH>=2 AND MONTH<=12,LOW0)

 

225日均线上升角度

 

aa:=ma(c,5);{这是5日均线}

bb:=ref(ma(c,5),1);{这是昨日5日均线}

cc:(aa-bb)/bb>n/100;{这是5日均线增长比率,比率越大,其上长的斜率就越大}

n是参数,n%5日均线的增长比率,因此n5以上可能其的斜率就越大,你可试试。)

 

23、引用个股数据时使用下列格式:”股票代码$数据” 比如

"000002$C";

 

24引用指标公式

可以引用其他技术指标的指标线,写法是"公式名称.指标线名称"(参数表),请注意,参数表中的参数个数应该与该公式的实际参数数量一致,若不写参数表,则表示使用缺省参数。例如:"KDJ.K966",表示引用根据(966)参数计算出KDJ指标中的K指标线数值。

 

25、跨周期引用公式

 

  可以引用其他周期的数据,写法为"公式名称.指标线名称#周期"(参数表),跨周期引用只能从较短周期引用较长周期,反方向的引用不允许。例如"KDJ.K#WEEK"(966),表示引用根据(966)参数计算周线周期的KDJ指标公式K指标线的数值。

其中周期包括MIN1MIN5MIN15MIN30MIN60DAYWEEKMONTH,分别表示15153060分钟线,以及日线、周线、月线。

 

 

26走势形态特征指标编制的基础。

1)、放量、缩量(成交量函数为VOL

  A、放量

   a.今天成交量较昨天增加了1倍,表示如下:

   VOL/REF(VOL,1)>2

   b.今天成交量较10个交易日平均成交量放大了1倍,表示如下:

a:=ma(vol,10);

Vol/a>2

     或者直接用如下公式表示:

vol/ma(vol,10)>2;

   c.今日的5日均量较10个交易日平均成交量放大了1倍,表示如下:

   a:=ma(vol,10);

     b:=ma(vol,5);

     b/a>2;

   d.今日的成交量超过了整个流通盘的5%,表示如下:

   vol/capital>0.05;其中capital代表流通盘。

B、缩量

  a.今日成交量较昨日减少了一半,表示如下:

     vol/ref(vol,1)<0.5;

   b.今日成交量较10个交易日平均成交量减少一倍,表示如下:

   a:=ma(vol,10);

     vol/a<2;

     或者直接用如下公式表示:

   vol/ma(vol,10)<2;

   c.今日的5日均量较10个交易日平均成交量减少1倍,表示如下:

     a:=ma(vol,10);

     b:=ref(a,5);

     a/b<2;

   d.今日的成交量低于了整个流通盘的5%,表示如下:

     vol/capital<0.05;

2)、上涨、下跌

上涨

今天的涨幅达到5%以上,表示如下:

close>ref(close,1)>1.05;

5日均价连续上涨,表示如下:

a:=ma(close,5);

b:=ref(a,1);

b;

下跌

今天的跌幅达到5%以上,表示如下:

close/ref(close,1)<0.95;

5日均价连续下跌,表示如下:

a:=ma(close,5);

b:=ref(a,1);

a

 

27、今天出现涨停,同时从今天往前面数10天日有6天5日均量线小于120日均量线

 

ZT:=C/REF(C,1)>1.095 AND C=H;

AA:=COUNT(MA(V,5)

ZT AND REF(AA,1);

 

28、均线多头排列,价格在10日均线和5日线之间

 

多头排列:= MA(C,5)>MA(C,10) AND  MA(C,10)>MA(C,20)  AND  MA(C,20)>MA(C,30) ;

 

HCJX:=RANGE(C,MA(C,10),MA(C,5));

多头排列 AND HCJX;

 

29、n日内阴线多于阳线

    count(open>close,n)/n<0.5;注:n为指标参数,可在参数设定范围内设定参数范围。

30 n日内上涨多于下跌(第二天盘高于前一天收盘)

      count(c>ref(c,1),n)/n>0.5;

31连续n天上涨

   count(close>ref(close,1),n)=n;

注:count(x,n),统计n周期中满足x条件的周期数,若n=0则从第一个有效值开始。N为指标参数,可在参数设定范围内设定参数范围

 

32、 26,72,178,370日线 股价突破4线后首次回踩26日均线

 

AA:=C>REF(C,26) AND C>REF(C,72) AND  C>REF(C,178) AND  C>REF(C,370) AND C>REF(C,540) ;

 

ZQ:=BARSLAST(AA);

 

HC:=LMA(C,26);

 

HC AND ZQ>3 AND ZQ<20 AND COUNT(HC,ZQ)=1;

 

33、四日二次缩倍量的选股公式

 

COUNT(REF(V,1)>V*2,4)=2;

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多