pharl / macd / 成功率极高的macd指标0轴上二次金叉选股方...

分享

   

成功率极高的macd指标0轴上二次金叉选股方法,屡试不爽,附源码

2019-03-03  pharl

什么是MACD二次金叉买入法?

研究“MACD二次金叉”是因为这种情况下出现暴涨的概率很高,把握也会更大一些,经过“第一次金叉”之后,空头虽然再度小幅进攻、造成又一次死叉,但是,空头的进攻在多方的“二次金叉”面前,遭遇溃败。从而造成多头力量的喷发,这种方法分为两种情况,第一种情况是0轴上方二次金叉买入,第二种是0轴下方二次金叉买入;今天重点说一下0轴上方二次金叉买入与选股。

0轴上二次金叉

成功率极高的macd指标0轴上二次金叉选股方法,屡试不爽,附源码

二次金叉选股指标

成功率极高的macd指标0轴上二次金叉选股方法,屡试不爽,附源码

选出来的股票配合使用二次金叉幅图指标公式,准确率很高

如图:

成功率极高的macd指标0轴上二次金叉选股方法,屡试不爽,附源码

龙回头选股指标

成功率极高的macd指标0轴上二次金叉选股方法,屡试不爽,附源码

状元龙头幅图如图:

成功率极高的macd指标0轴上二次金叉选股方法,屡试不爽,附源码

提刀踏浪幅图指标

成功率极高的macd指标0轴上二次金叉选股方法,屡试不爽,附源码

提刀踏浪指标

源码:

VAR1:=REF(CLOSE,1);

标尺: SMA(MAX(CLOSE-VAR1,0),5,1)/SMA(ABS(CLOSE-VAR1),5,1)*100,COLOR00FF00,LINETHICK2;

VAR2:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;

VAR3:=SMA(VAR2,5,1);

VAR4:=SMA(VAR3,3,1);

VAR5:=SMA(VAR4,3,1);

浪:VAR3,COLORMAGENTA,LINETHICK2;

波:VAR4,COLORRED,LINETHICK2;

段:VAR5,COLORYELLOW,LINETHICK2;

VAR6:=CROSS(VAR3,VAR4) AND VAR4<25;

VAR61:=CROSS(VAR4,VAR5) AND VAR4<50;

STICKLINE(VAR6,0,VAR4+6,1,0),COLORFF00FF,LINETHICK4;

STICKLINE(VAR61,0,VAR4+6,1,0),COLORFFFFFF,LINETHICK4;

DRAWTEXT(FILTER(VAR61,7),VAR5-5,'-短线买入'),COLORFFFFFF;

VAR7:=CROSS(VAR4,VAR5) AND VAR4<50;

VAR8:=VAR7 AND VOL>=REF(VOL,1)*2 AND VOL>=REF(MA(VOL,5),1)*2;

STICKLINE(VAR8,0,VAR4+10,1,0),COLORRED,LINETHICK4;

DRAWTEXT(VAR8 AND COUNT(VAR8,10)=1,VAR4-1,'放量'),COLORRED;

VAR9:=CROSS(VAR3,VAR4) AND VAR4>80 AND VAR4>VAR5;

STICKLINE(VAR9 AND COUNT(VAR9,5)=1,VAR4-5,100,1,0),COLOR00FF00,LINETHICK2;

VARA:=CROSS(VAR5,VAR4) AND VAR5>=70;

STICKLINE(VARA,VAR4-6,100,1,0),COLORYELLOW,LINETHICK4;

{STICKLINE(FILTER(CROSS(VAR3,VAR4),10) AND

VAR5>80,VAR4-5,100,1,0),COLOR00FF00,LINETHICK2;}

DRAWTEXT(VARA AND COUNT(VARA,10)=1,VAR4+20,'牛市震荡'), COLORYELLOW;

DRAWTEXT(VARA AND COUNT(VARA,10)=1,VAR4+10,'熊市抛股'), COLORYELLOW;

VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);

VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

VAR1D:=SMA(VAR1C,4,1);

VAR1E:=SMA(VAR1D,3,1);

VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

VARE:=REF(LOW,1)*0.9;

VARF:=LOW*0.9;

VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;

VAR11:=EMA(VAR10,30);

VAR12:=CLOSE-REF(CLOSE,1);

VAR13:=MAX(VAR12,0);

VAR14:=ABS(VAR12);

VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;

VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;

VAR17:=BARSCOUNT(CLOSE);

VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;

VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;

VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30

AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;

STICKLINE(VAR20,0,50,10,0),LINETHICK2,COLOR888800;

DRAWTEXT(FILTER(VAR20,5),60,''),COLOR00FF00;

Y:-2,COLORFF0000,LINETHICK2;

B:99,POINTDOT,COLOR00FFFF,LINETHICK1;

T:81,POINTDOT,COLOR0000FF,LINETHICK1;

X:15,POINTDOT,COLOR00FF00,LINETHICK1;

YY:0,LINETHICK2,COLOR0000FF;

HH:90,POINTDOT,COLOR0000FF,LINETHICK1;

成功率极高的macd指标0轴上二次金叉选股方法,屡试不爽,附源码

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    来自: pharl > 《macd》

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>