福树 / 实战经典战法 / 深度MACD战法使用技巧

   

深度MACD战法使用技巧

2019-07-21  福树

在股市投资中,我们无依无靠,研究指标,能找到一套易学易用的交易系统是我们的梦寐以求。个人也曾经痴迷指标,但只能说徒劳而已。阅遍指标无数,KDJ、RSI、DMI、BOLL,归根还是大道至简MACD。不说指标无用论,只能说指标中最管用还MACD。对绝大多数股民来说,MACD是很熟悉的指标,但是真正的内涵是什么,真正用MACD线来指导操作又有几分胜算?如果看见MACD发生金叉就买,死叉就卖的话,或许早被市场消灭了。机械的运用金叉/死叉信号来买卖还不如用投硬币来决定买卖会更省力些,而效果也不会差很多,只有在符合一定规则之下采用MACD发出的金叉/死叉信号,才可以大大提高信号的成功率。为提高指标准确率,我重新设置了指标参数,综合了各自优点,把她分为短期和中期部分,并融洽贯通,起到看长炒短的效果。其使用要点如下:

一、  买入

第一,当MACD线上穿0轴,短DIFF0线上穿短DEA0线,并或同时出现底背离信号或突破信号时,预示有较大行情,果断满仓买入。

第二,当MACD线上穿0轴,短DIFF0线上穿短DEA0线时,预示有行情,可半仓买入。

二、  卖出

第一,当短DIFF0线下穿短DEA0线时,应注意减仓,密切观察。

第二,当短DIFF0线下穿短DEA0线或同时出现顶背信号后,随后再出现中DIFF0线下穿中DEA0线时,预示行情结束,应及时清仓出局。

以上是本人独有的MACD指标使用方法,与自带软件有非常不同之处。如果配合我的2599战法使用,成功率更高。 具体用法因为用语言表达太复杂,就供志合者朋友琢磨吧,只有经过自己深入研究,相信你会用的比我更好。

副图

{MACD短线}

0.00,DOTLINE,COLORWHITE;

短DIFF:EMA(DCLOSE,12)-EMA(CLOSE,26)COLORRED,LINETHICK3;

IF(短DIFF<REF(短DIFF,1),短DIFF,DRAWNULL),COLORGREEN, LINETHICK3;

短DEA:EMA(短DIFF,9)COLORYELLOW,LINETHICK3;

MACD:(短DIFF-短DEA)*2,COLORMAGENTA,LINETHICK2;

IF(MACD<REF(MACD,1),MACD,DRAWNULL),COLORBLUE, LINETHICK2;

低位金:CROSS(短DIFF,短DEA) AND 短DIFF<-0.1,COLORYELLOW,LINETHICK2;

JCCOUNT:=COUNT(CROSS(短DIFF,短DEA),BARSLAST(短DEA>=0));

二次金:CROSS(短DIFF,短DEA) AND 短DEA<0 AND COUNT(JCCOUNT=2,34)=1,COLORMAGENTA,LINETHICK2;

A1:=BARSLAST(REF(CROSS(短DIFF,短DEA),1));

底背离:REF(CLOSE,A1+1)>CLOSE AND 短DIFF>REF(短DIFF,A1+1) AND CROSS(短DIFF,短DEA),COLORRED,LINETHICK2;

A2:=BARSLAST(REF(CROSS(短DEA,短DIFF),1));

顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(短DIFF,A2+1)>短DIFF AND CROSS(短DEA,短DIFF),COLORCYAN,LINETHICK2;

强:IF(短DIFF>=短DEA,短DIFF,DRAWNULL),COLORRED,LINETHICK2;

DRAWICON(CROSS(短DEA,短DIFF),短DEA,2);

DRAWICON(CROSS(短DIFF,短DEA),短DIFF,1);

DRAWICON(CROSS(MACD,0),MACD,34);

{MACD中线}

SHORT:=6;

LONG:=13;

MID:=5;

 DIF2:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORGREEN,LINETHICK2;

 DEA2:=EMA(DIF2,MID)COLORGREEN,LINETHICK2;

MACD2:=(DIF2-DEA2)*2,COLORSTICK;

中DIFF0:EMA(CLOSE,12)-EMA(CLOSE,27)COLORGRAY,DOTLINE;

中DEA0:EMA(中DIFF0,9)COLORLIBLUE,DOTLINE;

DRAWICON(CROSS(中DIFF0,中DEA0),中DIFF0,9);

 DRAWICON(CROSS(中DEA0,中DIFF0),中DEA0,15);

T:=BARSLAST(CROSS(DEA2,DIF2));

HT:=BARSLAST( HHV(DEA2,15)=DEA2);

GT:=BARSLAST(T=0 AND REF(HT,1)=0 AND 中DEA0>0);

GM:=REF(DEA2,GT);

EXT:DRAWLINE(GT=0,DEA2,T=0 AND (REF(GM,1)-DEA2)>0.75 AND DEA2>0,REF(DEA2,T),1)COLORBROWN;

XG:=CROSS(DEA2,EXT);

DRAWICON(XG,DEA2-0.05,23);

选股

{当股价0轴上金叉时,DIFF线大于0轴线,DEA线大于0轴线。}

{MACD0轴上金叉}

G:=0.00,COLORWHITE,LINETHICK3;

DIFF:=EMA(DCLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MA1:=EMA(DCLOSE,12)-EMA(CLOSE,26);

MA2:=EMA(DIFF,9);

MA3:=0.00,COLORWHITE,LINETHICK3;

MA4:=CROSS(DIFF,DEA);

MA5:=MA3<MA2;

MA6:=MA2>MA3;

MA7:=MA1>MA3;

MA4 AND MA5 AND MA6 AND MA7;

 图示

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    《个图VIP服务协议》

    全部>>