风信子d0w17xnr / 指标3 / MACD底背离通达信选股公式

分享

   

MACD底背离通达信选股公式

2019-08-31  风信子d0w...

    MACD底背离在实战中有重要的参考价值,值得广大投资者认真研究。但MACD底背离本身形态变化多端,因此其公式编制较为困难,要根据不同的形态编制不同的选股公式。

一、MACD底背离的主要形态

第一种:回拉靠近0轴型

    存在一个下跌趋势AD,跌至B点反弹到C点时,MACD黄白线回拉到d,靠近而不上穿0轴。D低于B,但e不低于c,背离形成。

第二种:回升升破0轴型

    存在一个下跌趋势AD,跌至B点反弹到C点时,MACD黄白线回拉到c,上穿0轴。D低于B,但d不低于b,背离形成。

第三种:反复纠缠型

    存在一个下跌趋势AD,跌至B点时,BC之间形成箱体震荡,MACD黄白线反复上穿和跌破0轴。D低于B,但h不低于b,背离形成。

第四种:背了又背型

    存在一个下跌趋势AJ,下跌过程中多次反弹,屡创新低。MACD黄白线反复回拉至0轴附近但不升破。股价BDFHJ屡创新低,黄白线低点dfhj逐渐提高,背了又背,最终j点背离形成。

    鉴于MACD底背离形态多变,想编制一个公式涵盖所有的底背离形态是很困难的。实战中,底背离出现后并不能保证马上止跌,底背离后趋势继续下跌的例子屡见不鲜。上面四种形态中,成功率最高的是第四种“背了又背型”,虽然出现次数不如其他三种频繁,但一旦出现的话,成为长线大牛股的概率较高。因此,下面就以第四种为例,编制“背了又背型”底背离选股公式。

二、公式编制要求

    股价处于长期下跌趋势,近日内股价创新低,MACD黄白线波谷低点f、h、j逐渐提高。当下MACD为红柱,白线在黄线上方。

三、编制思路

    用股价60日均线斜率判断下跌趋势。寻找MACD近期3个谷底低点f、h、j,比较3个点DEA(黄线)的高低。寻找f、h、j三个低点对应的股价F、H、J,比较其股价的高低。

四、公式内容

    新建一个选股指标,名称为“MACD底背离”。输入以下代码:

A1:=SLOPE(MA(C,60),5);{60日均线的5日斜率}

A2:=SLOPE(MACD.DEA,5);{MACD黄线线的5日斜率}

B1:=BARSLAST(CROSS(A2,0));{最近1次MACD黄线线拐头向上到现在的周期数}

B2:=BARSLAST(CROSS(0,A2));{最近1次MACD黄线线拐头向下到现在的周期数}

B3:=B2+REF(B1,B2);{最近第2次MACD黄线线拐头向上到现在的周期数}

B4:=B3+REF(B2,B3);{最近第2次MACD黄线线拐头向下到现在的周期数}

B5:=B4+REF(B1,B4);{最近第3次MACD黄线线拐头向上到现在的周期数}

B6:=B5+REF(B2,B5);{最近第3次MACD黄线线拐头向下到现在的周期数}

C1:=REF(MACD.DEA,B1);{最近1次MACD黄线线拐头向上时的DEA值}

C3:=REF(MACD.DEA,B3);{最近第2次MACD黄线线拐头向上时的DEA值}

C5:=REF(MACD.DEA,B5);{最近第3次MACD黄线线拐头向上时的DEA值}

D1:=REF(C,B1);{最近1次MACD黄线线拐头向上时的收盘价}

D3:=REF(C,B3);{最近第2次MACD黄线线拐头向上时的收盘价}

D5:=REF(C,B5);{最近第3次MACD黄线线拐头向上时的收盘价}

D6:=LLV(C,B2);{最近1次MACD黄线线拐头向下到现在的最低收盘价}

D7:=LLV(C,B6);{最近3次MACD黄线线拐头向下到现在的最低收盘价}

E1:=A1<0;{60日均线向下}

E2:=MACD.MACD>0;{当前MACD是红柱}

E3:=B1<B2;{最近1次MACD黄线拐头向上迟于拐头向下}

E4:=C1>C3 ANDC3>C5;{MACD黄线低点逐波提高}

E5:=D1<D3 AND D3<D5;{股价低点逐波降低};

E6:=D6=D7;{最近1、3次MACD黄线线拐头向下到现在的最低收盘价相同}

E1 AND E2 AND E3 AND E4 ANDE5 AND E6;{选股条件};

    见下图:

五、公式说明:

1、SLOPE函数的作用是求均线斜率,斜率小于0时,均线向下;

2、BARSLAST函数的作用是最近一次条件成立到当下的周期数;

3、用“.”引用MACD指标的各项参数,MACD指红绿柱,DEA指黄线;

4CROSS函数的作用是金叉;

5REF函数是引用若干周期前的数据;

6LLV函数的作用是求最低值。

六、使用效果

    首先补充下载完整的日线数据,要保证近3年的数据是完整的,数据不完整则选股不准确。见下图:

    然后条件选股窗口内执行“MACD底背离”选股公式,由于这种形态的股票并不多见,因此我们扩大选股区间,勾选“时间段内满足条件”,将时间锁定为2019年3月1日至4月22日,只要是3月1日以来任一天出现的底背离都能被选出来。执行选股,共选出25只符合要求的股票:

   试举其中2例如下:

七、补充说明

    该公式选出的只是背离2次的股票,还可以选出背离3次、4次的,编制思路是一样的。所选的股票中有些形态太过勉强,要手工予以剔除。实战中,背离点并不是买入的最佳位置,最佳买入位置还要继续观察,直到有一天黄白线冲上0轴并在0轴以上再一次出现金叉时,买入最佳。还有,基本面才是最重要的。

    其他三种形态的底背离在这儿就不再编写了,感兴趣的话朋友们可以自行完成,原理是一样的。

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>