一漂--文摘 / 指标源码 / 如何将画线指标改为选股公式,怎么从源码...

0 0

   

如何将画线指标改为选股公式,怎么从源码中提取,附黑牛战法指标

2019-09-21  一漂--文摘

很多朋友之前也找过我需要按自己的要求将主图指标改编为选股公式的一些情况,今天简单的说一下如何从源码中提取选股公式:举例说明

要点:从后往前找,删除没用条,去掉修饰符,个别加等号。

例一、买入信号:以《跟庄建仓》为例

如何将画线指标改为选股公式,怎么从源码中提取,附黑牛战法指标

效果图如下:

如何将画线指标改为选股公式,怎么从源码中提取,附黑牛战法指标

分析:这个公式输出语句非常多,但多数都是用于趋势判断的。所以不用管它。仍按我们既定的思路进行。

第一步{从后往前找},先删除发出信号关键语句之后的(红色为输出语句,它以下的语句已经删去,蓝色为等待下步删除的)

A01:=DYNAINFO(7);

A03:=BARSCOUNT(CLOSE);

A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);

A05:=IF((A03 》 20),A04,0);

A06:=IF((LOW 》 A01),0,IF((HIGH 《 A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));

A07:=DMA(A06,(VOL / CAPITAL)) * 60;

A09:=IF((((A07 》 0) AND (A07 》 REF(A07,1))) AND (A05 《= 88)),A07,0);

Var1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

Var2:=EMA(Var1,8);

Var3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);

趋势:=EMA(Var3,3)-10;

FILLRGN(趋势》80,趋势,80);(南方财富网SOUTHMONEY.COM)

DRAWICON(CROSS(趋势,0),0,1);

第二步{删除没用条}后

趋势:=EMA(Var3,3)-10;

DRAWICON(CROSS(趋势,0),0,1);

第三步{去掉修饰符后}:

趋势:=EMA(Var3,3)-10;

CROSS(趋势,0);

Var5;

第四步{个别加等号}本公式中的“条件”语句都是不输出的,所以此项省略,但因是要笑脸和买入两个信号,所以还必须把它们连结起来:

趋势:=EMA(Var3,3)-10;

CROSS(趋势,0)or Var5;

这些东西都是需要不断的去测试,去反复的实践,才能做到熟能生巧。

黑牛战法

一般使用配套的指标准确率会高一些,因此很多也都是想要把画线指标改成选股的,今天给大家分享的这套黑牛战法就是一套从选股、到主图、幅图的配套指标。

如何将画线指标改为选股公式,怎么从源码中提取,附黑牛战法指标

主副图效果图如下:

如何将画线指标改为选股公式,怎么从源码中提取,附黑牛战法指标

选股指标:

如何将画线指标改为选股公式,怎么从源码中提取,附黑牛战法指标

欢迎关注!后期会定期的更显更多的股票交易干货,有兴趣的可以相互交流,想要研究一下指标的可以留言或者评论分享给大家!

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多