lgbxdg / 待分类 / 通达信数显宝塔线威廉CCI顶底买卖组合主图...

分享

   

通达信数显宝塔线威廉CCI顶底买卖组合主图指标 源码 简单说明

2019-09-28  lgbxdg
OZ:=DYNAINFO(3)*1,COLOR0000FF;
STICKLINE(1,50/200+OZ,50/200+OZ,2,0),COLOR00AA00;
RTYP:=(HIGH+LOW+CLOSE)/3;
CCI14:=(RTYP-MA(RTYP,14))/(0.015*AVEDEV(RTYP,14))/2;
CCI84:=(RTYP-MA(RTYP,84))/(0.015*AVEDEV(RTYP,84))/2;
MMCCI84:=OZ+CCI84 /200,COLOR00FFFF,LINETHICK1;
STICKLINE(1,-50/200+OZ,-50/200+OZ,6,0),COLOR00AAAA;
DRAWBAND(MMCCI84,RGB(150,0,150),50/200+OZ,RGB(0,100,100));
WLFX:=IF(100-(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))*100>95,(50/200+OZ)-(50/200+OZ)*0.02,50/200+OZ),COLOR00FFFF,LINETHICK0;
WLDB:=IF(100-(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))*100<5,(-50>
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=ref(close,2);>
VAR4:=REF(VAR3,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=ref(close,2);>
VAR6:=REF(VAR5,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=ref(close,2);>
VAR8:=REF(VAR7,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=ref(close,2);>
VARA:=REF(VAR9,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=ref(close,2);>
VARC:=REF(VARB,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);
VARCC:=STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3.2,0),COLORRED;
VARD:=CLOSE
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=ref(close,2);>
VARF:=REF(VARE,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=ref(close,2);>
VAR11:=REF(VAR10,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=ref(close,2);>
VAR13:=REF(VAR12,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=ref(close,2);>
VAR15:=REF(VAR14,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=ref(close,2);>
VAR17:=REF(VAR16,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=ref(close,2);>
VARBB:=STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3.20,1),COLORCYAN;{ 收阴}
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
DRAWBAND(MMCCI84,RGB(150,0,150),50/200+OZ,RGB(0,100,100));
DRAWICON(VAR19,LOW*0.99,13);
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
DRAWICON(VAR1A,HIGH*1.01,14);
DRAWKLINE(H,O,L,C);
DRAWBAND(WLDB,RGB(250,0,2500),-50/200+OZ,RGB(0,0,0));
DRAWBAND(50/200+OZ,RGB(255,255,0),WLFX,RGB(0,0,0));
买卖CCI84:MMCCI84,COLOR00FFFF,LINETHICK1;
判顶底CCI14:OZ+CCI14 /200,COLORDDCCCC,LINETHICK1;
MA5:MA(CLOSE,5),COLOR0000FF,LINETHICK2;
MA10:MA(CLOSE,10),COLORFF00FF,LINETHICK1;
DRAWRECTREL(0,580,100,960,RGB(150,0,0));
DRAWRECTREL(100,580,200,960,RGB(0,150,150));
DRAWRECTREL(200,725,300,960,RGB(150,0,150));
日K:='KD.K'(9,3,3);
日D:='KD.D'(9,3,3);
月K:='KDJ.K#MONTH'(9,3,3);
月D:='KDJ.D#MONTH'(9,3,3);
周K:='KDJ.K#WEEK'(9,3,3);
周D:='KDJ.D#WEEK'(9,3,3);
DRAWTEXT_FIX(ISLASTBAR,0.04,0.60,0,'KDJ '),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.65,0,'日K='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.65,0,日K),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.7,0,'日D='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.7,0,日D),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.75,0,'周K='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.75,0,周K),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.8,0,'周D='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.8,0,周D),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.85,0,'月K= '),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.85,0, 月K),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.9,0,'月D='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.9,0,月D),COLORFFFFFF;
日DIF:='MACD.DIF'(12,26,9);
日DEA:='MACD.DEA'(12,26,9);
周DIF:='MACD.DIF#WEEK'(12,26,9);
周DEA:='MACD.DEA#WEEK'(12,26,9);
月DIF:='MACD.DIF#MONTH'(12,26,9);
月DEA:='MACD.DEA#MONTH'(12,26,9);
DRAWTEXT_FIX(ISLASTBAR,0.13,0.60,0,'MACD '),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.65,0,'日DIF='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.65,0,日DIF),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.7,0,'日DEA='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.7,0,日DEA),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.75,0,'周DIF='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.75,0,周DIF),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.8,0,'周DEA='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.8,0,周DEA),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.85,0,'月DIF= '),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.85,0, 月DIF),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.9,0,'月DEA='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.155,0.9,0,月DEA),COLORFFFFFF;
TYP:=(HIGH+LOW+CLOSE)/3;
日CCI:=(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84));
周CCI:=(TYP-MA(TYP,21))/(0.015*AVEDEV(TYP,21));
月CCI:=(TYP-MA(TYP,9))/(0.015*AVEDEV(TYP,9));
DRAWTEXT_FIX(ISLASTBAR,0.235,0.75,0,'CCI'),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.206,0.80,0,'日CCI='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.250,0.80,0,日CCI),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.206,0.85,0,'周CCI='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.250,0.85,0,周CCI),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.206,0.90,0,'月CC='),COLORFFFFFF;
DRAWNUMBER_FIX(ISLASTBAR,0.250,0.90,0,月CCI),COLORFFFFFF;
DRAWTEXT_FIX(1,0.05,0.02,0,'★★【红绿色球--宝塔线买卖标识】★【黄色粉色小三角--威廉买卖提示】★★'),COLOR00FFFF;
 

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多