喜欢素描的日子 / 股市评论 / 通达信价值趋势副图源码 多种指标整合指标...

0 0

   

通达信价值趋势副图源码 多种指标整合指标表达出是否值得跟踪

2019-11-20  喜欢素描...

DRAWTEXT(CURRBARSCOUNT=38,10,'价值发现'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=38,32,'安全边界'),COLORFF00FF;
DRAWTEXT(CURRBARSCOUNT=38,62,'价值中枢'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=38,92,'风险警界'),COLOR00FF00;
最低成本:=COST(0.99);
最高成本:=COST(99.9);
相对价位:=(C-最低成本)/(最高成本-最低成本)*100;
K:SMA(相对价位,3,1),COLORWHITE;
D:SMA(K,3,1),COLORYELLOW;
J:3*K-2*D,COLORFF00FF;
DRAWICON( CROSS(J,K) AND J<80,J,1);
0,COLORLIBLUE;
20,COLORBLUE;
50,COLORBLUE;
100,COLORLICYAN;
85,DOTLINE;
M3:=MA(CLOSE,3);
M13:=MA(CLOSE,13);
M34:=MA(CLOSE,34);
STICKLINE(M3>=M13 AND M34>=REF(M34,1),98,101,2,0 ),COLORRED;
STICKLINE(M3<M13 AND M34>=REF(M34,1),98,101,2,0 ),COLORYELLOW;
STICKLINE(M3<M13 AND M34<REF(M34,1),98,101,2,0 ),COLORGREEN;
STICKLINE(M3>=M13 AND M34<REF(M34,1),98,101,2,0 ),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,97,'---四色图'),COLORGRAY;
JJJ:=(CLOSE+HIGH+LOW)/3;
A1:=EMA(JJJ,5);
B1:=REF(A1,1);
IF(A1>B1,0,DRAWNULL),COLORYELLOW,LINETHICK2;
DRAWTEXT(ISLASTBAR,2,'---蓝黄线'),COLORGRAY;
VHF:=(HHV(CLOSE,28)-LLV(CLOSE,28))/SUM(ABS(CLOSE-REF(CLOSE,1)),28);
VHFMA:=MA(VHF,10);
短趋:=VHFMA>REF(VHFMA,1);
箱型:=VHFMA<REF(VHFMA,1);
中趋:=VHF>0.3 {AND VHFMA>REF(VHFMA,1) AND VHF>VHFMA};
IF(短趋,85,DRAWNULL),COLORYELLOW,LINETHICK2;
IF(箱型,85,DRAWNULL),COLORGRAY,LINETHICK2;
IF(中趋,85,DRAWNULL),COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,85,'--趋势过滤'),COLORGRAY;
MTM:=CLOSE-REF(CLOSE,24);
MTMMA:=MA(MTM,24);
XGTJ:=MTM>0 AND MTM>MTMMA;
IF(XGTJ,50,DRAWNULL),COLORRED,LINETHICK2;
IF(XGTJ<1,50,DRAWNULL),COLORBLUE,LINETHICK2;
DRAWTEXT(ISLASTBAR,51,'---动能MTM'),COLORGRAY;
MTM金叉:=(XGTJ AND CROSS(MTM,MTMMA));
DRAWTEXT(CROSS(MTM,MTMMA),53,'×'),COLORYELLOW;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:=MA(OBV,30);
IF(OBV>MAOBV,20,DRAWNULL),COLORRED,LINETHICK2;
IF(OBV<=MAOBV,20,DRAWNULL),COLORBLUE,LINETHICK2;
DRAWTEXT(ISLASTBAR,21,'----OBV'),COLORGRAY;
MA5 :=EMA(CLOSE,5);
趋势:=MA5-EMA(MA5,2);
JCSJ1:=BARSLAST(CROSS(趋势,0))+1;
JCSJ2:=JCSJ1+REF(JCSJ1,JCSJ1);
双底:(IF(JCSJ1=1 AND MA5>REF(MA5,JCSJ2) AND COUNT(趋势<0,4)>=2,1,0))*50,STICK;

通达信价值趋势副图源码 多种指标整合指标表达出是否值得跟踪

通达信价值趋势副图源码 多种指标整合指标表达出是否值得跟踪

通达信价值趋势副图源码 多种指标整合指标表达出是否值得跟踪

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多