耕鑫不了情 / 待分类 / 把这个副图指标里的 小牛起程和超牛全仓出...

分享

   

把这个副图指标里的 小牛起程和超牛全仓出击,这个两指标分别做成选股公式

2020-01-12  耕鑫不了情
2019-10-21 11:23
请老师帮把这个副图指标里的 小牛起程 和 超牛全仓出击 这个两指标做分别做成选股公式





XA_1:=REF(CLOSE,1)*1.1-CLOSE<0.01 AND HIGH=CLOSE;


XA_2:=5;

XA_3:=3;

XA_4:=(EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10;

XA_5:=IF(YEAR>=2025,0,1);

XA_6:=EMA(EMA(LOW,21)+6.8*STD(LOW,2),55);

XA_7:=EMA(CLOSE/XA_6*(1.88*CLOSE+LOW+OPEN)/2.75,3);

XA_8:=(XA_7-XA_6)/XA_6/2;

XA_9:=EMA(XA_7-XA_8*XA_7,5)*XA_5;

XA_10:=EMA(CLOSE,34)-3*STD(CLOSE,34);




喇叭上轨:=IF(XA_4>XA_9,XA_4,XA_9)*XA_5,COLORRED,LINETHICK3;


喇叭下轨:=IF(XA_9<XA_4 AND XA_9<CLOSE*0.15,EMA(CLOSE,34)-3*STD(CLOSE,34),XA_9),COLORFF0080,LINETHICK3;


开口选股:=BARSLASTCOUNT(喇叭上轨>喇叭下轨)=1,NODRAW;




价量:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

主力活跃力度:=(((价量-LLV(价量,27))/(HHV(价量,27)-LLV(价量,27)))*(4))*(25);

RSV:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
K1:=SMA(RSV,10,1);
D1:=SMA(K1,5,1);
KK:=INTPART(K1);
DD:=INTPART(D1);
TFXXS:=KK+DD;{//变异KD风险系数}
TGLD:=MOD(TFXXS,10);{//踏浪涨停概率点}
TGLXS:=(TFXXS-REF(TFXXS,1))*10;
{//变异KD乖离系数}
TYCFX:=TFXXS+TGLXS;
{//变异KD预测风险}


ZLCM:=EMA(WINNER(CLOSE)*70,3);

{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
{//小筹码估算}


主力控盘系数:=ZLCM/(ZLCM+SHCM)*100;


主力筹码:=EMA(WINNER(CLOSE)*40,3);


散户筹码:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);


散户套牢筹码:=散户筹码/(主力筹码+散户筹码)*100;


主升浪波段:=主力筹码/(主力筹码+散户筹码)*100;


散户主导行情:=EMA(散户套牢筹码,55);

主力主导行情:=EMA(主升浪波段,55);


疯牛压力平台:=HHV((H+L)/2,120);


金叉疯牛:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2);

界:=MA(CLOSE,27);

ER:=V/FINANCE(7)*100;
A0:=TMA(ER,(1-ER),1);

MAXCYC:=DMA((C+O)/2,ER/TMA(ER,(1-ER),1));

T1:=BARSLAST(C>MAXCYC*POW(1.1,0.9));

T2:=BARSLAST(C<MAXCYC*POW(1.1,-0.9));
T3:=CROSS(T1,T2) OR CROSS(T2,T1) OR BARSSINCE(T1+1)=0 OR BARSSINCE(T2+1)=0 OR BARSCOUNT(C)=0;

T4:=REF(MAXCYC,BARSLAST(T3));

主力最大盈利:=LN(C/T4)/LN(1.1)*10;

换手率:=VOL/CAPITAL*100;

获利盘:=WINNER(C/1.10)*100; 


牛股出现预警:=WINNER(C/1.20)*100; 

主力赢利25持仓:=WINNER(C/1.25)*100;

主线:=EMA(EMA(C,1),5);

本:=EMA(HHV(主线,5),1);

急:=EMA(HHV(本,21),1);

稳:=EMA(HHV(急,21),2);

投:=EMA(HHV(稳,21),3); 

散:=EMA(HHV(投,21),4); 

集:=EMA(HHV(散,21),5); 

日线:=CLOSE;

VAR3:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

疯牛强势分界线:=IF(C>200,C,DMA(VAR3,VOL/CAPITAL))*1.1;


疯牛马线:=EMA(HHV(集,21),6); 


VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;


主力做空能量线:=SMA(VAR1,3,1);
VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

主力做多能量线:=SMA(VAR2,5,1)-8;



狂飙临界能量:=(主力做多能量线-主力做空能量线);

Y:=(H+O+L+3*C)/6;

净资金流向:=EMA(100-(100/(1+SUM(IF(Y>REF(Y,1),Y*VOL,0),14)/SUM(IF(Y<REF(Y,1),Y*VOL,0),14))),5);



AA:=CROSS(日线,疯牛马线);
TT:=(2*CLOSE+OPEN+HIGH+LOW);

主导动能:=(TT/EMA(TT,4)-1)*100;


FF:=主导动能*5;



乖离系数:=TGLXS,,NODRAW,COLORRED;


角度1:=ATAN((净资金流向/REF(净资金流向,1)-1)*100)*180/3.1416;

角度2:=ATAN((FF/REF(FF,1)-1)*100)*180/3.1416;
放量2:=(FF-REF(FF,1))*100/REF(FF,1);


当日涨幅:=(C-REF(C,1))*100/REF(C,1);

七日涨幅:=SUM((C-REF(C,1))/REF(C,1)*100,15);


停牌:=(DYNAINFO(4)=0);


持股时段:=IF((金叉疯牛>界)AND(散户筹码<主力筹码) AND((主力活跃力度>50)OR(主力活跃力度>REF(主力活跃力度,1))),-40,0);



金牛:=IF((COUNT(AA,20))AND(主力筹码>散户筹码)AND(主升浪波段>主力主导行情)AND(主力赢利25持仓>30)AND(主力活跃力度>主升浪波段)AND(主力活跃力度>60)AND(当日涨幅>=0.5)AND(MAX(CLOSE,金叉疯牛))AND(COUNT(CLOSE>金叉疯牛,10)),18,0);



金牛起航:=IF((金牛>10)AND(当日涨幅>=0.5)AND(持股时段=-40),88,0),COLORYELLOW,NODRAW;



VARA:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;


主升浪:=EMA((CLOSE-REF(CLOSE,21))/REF(CLOSE,21)*100,4)*2,COLOR1E90FF,NODRAW;


B1:=MA(C,1);


持币阶段:=SMA(SMA(SMA(B1,2,1),2,1),2,1);


主升持股波段:=HHV(MA(持币阶段,1),13);



主力疯狂做多:=IF((主力最大盈利>0)AND(主力最大盈利<150)AND(主力活跃力度>50)AND(C>疯牛强势分界线)AND(日线>疯牛马线)AND(换手率<20)AND(放量2>10)AND(角度1>2)AND(主力筹码>散户筹码),208,0),COLORRED,NODRAW;



VAR11:=3*SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))*100,5,1)
-2*SMA(SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))*100,180,1),15,1);


超级主升:=EMA(VAR11,5);
主升1:=超级主升-100;

DH:=EMA(C,5);
D2:=(EMA(C,1)+EMA(C,5)+EMA(C,10)+EMA(C,15)+EMA(C,20)+EMA(C,25)+EMA(C,30)+EMA(C,35)+EMA(C,40)+EMA(C,45)+
EMA(C,50)+EMA(C,55)+EMA(C,60)+EMA(C,65)+EMA(C,70)+EMA(C,75)+EMA(C,80)+EMA(C,85)+EMA(C,90)+EMA(C,95)+
EMA(C,100)+EMA(C,105)+EMA(C,110)+EMA(C,115)+EMA(C,120)+EMA(C,125)+EMA(C,130)+EMA(C,135)+EMA(C,140)+EMA(C,150))/30;
DDE:=(DH/D2)*100;
主升2:=DDE-110;

A:=(H+L+2*C)/4;
A1:=(A-REF(A,3))/3+A;
MA5:=EMA(A1,7);
J:=EMA(HHV(A1,20),60),LINETHICK3;
CB5:=EMA(COST(80),30),CIRCLEDOT;

HMX:=EMA(1.4*EMA(FORCAST(A1,20),40),20),LINETHICK2;

金牛线:=(J+CB5+HMX)/3,LINETHICK2;

UP:=EMA(EMA(C*1.38,50),50),DOTLINE,COLOR0000FF;

白色:=SMA(HIGH,21,2)*1.05;
黄色:=SMA(LOW,21,2)*0.95;

中线:=(白色+黄色)/2;
UP1:=中线+2*STD(中线,20);
UP2:=REF(UP1,0);
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(A1,20))/MA(A1,20);
DN:=DMA(CLOSE,CC);

通道3:=(1+9/100)*DN;
通道4:=(1-7/100)*DN;

界限:=(REF((金牛线+UP+EMA(UP1*1.04,40)+通道3)/4,10)+MA(C,20)*1.04)/2;

AHC1:=H*VOL;

AHC24:=EMA((EXPMA(AHC1,180)/EXPMA(VOL,180)+EXPMA(AHC1,360)/EXPMA(VOL,360)+EXPMA(AHC1,720)/EXPMA(VOL,720)+EXPMA(AHC1,1440)/EXPMA(VOL,1440))/4,34);

C上X:=1.06*AHC24;
C下X:=AHC24*0.94;

AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);

上X:=1.06*AHC22;
下X:=AHC22*0.94;

AHC23:=EMA((EXPMA(AHC1,5)/EXPMA(VOL,5)+EXPMA(AHC1,10)/EXPMA(VOL,10)+EXPMA(AHC1,20)/EXPMA(VOL,20)+EXPMA(AHC1,40)/EXPMA(VOL,40))/4,34);


D上X:=1.06*AHC23;
D下X:=AHC23*0.94;
T:=(C上X+D上X+上X)/3*1.05;

主升3:=(MA5*2/(界限+T)-1)*100;
CBX80:=MA(COST(80),20);

主升4:=(MA5/CBX80-1)*100;
FT:=((HHV(H,42)-LLV(L,42)))/2+LLV(L,42);
FT1:=ABS(HHV(H,40)-LLV(L,40)-LLV(L,40))+FT*0.5;

主升5:=(FT/FT1-1)*100;
P:=EMA(EMA(C*1.14,55),20);

主升6:=(MA5/P-1)*100;
金K线:=(EMA(HHV(H,60),60)+EMA(FT,453)*1.62)/2;

主升7:=(MA5/金K线-1)*100;

超牛拉升:=(主升1+主升2+主升3+主升4+主升5+主升6+主升7)/2,LINETHICK2;



V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);

换手:=V*100/CAPITAL;
主力:=MA(换手,4);


大户:=MA(换手,9);


中户:=MA(换手,17);

散户:=MA(换手,34);


均量:=(主力+大户+中户+散户)/4;


成交量:=V;


机构主力拉升:=(主力-均量),COLORRED,NODRAW;


大户主力拉升:=(大户-均量),COLORFF0080,NODRAW;



阻击牛股:=IF(((持股时段<0)AND(REF(机构主力拉升,1)>0)AND((CLOSE/REF(CLOSE,4)-1)*100<15)AND(日线>疯牛马线)AND(日线>疯牛压力平台)AND(当日涨幅>0)AND(机构主力拉升>REF(机构主力拉升,1)*1.5)AND(大户主力拉升>REF(大户主力拉升,1))AND(机构主力拉升>0)AND(主力活跃力度>主升浪波段)),80,0);


MA7:=MA(CLOSE,7);
MA14:=MA(CLOSE,14);
MA21:=MA(CLOSE,21);
MA34:=MA(CLOSE,34);

MA8:=MA(CLOSE,55);

均线金叉:=CROSS(MA7,MA34);
均线多头排列:=MA7>MA14>MA21>MA34;
VOL1:=MA(VOL,5);
VOL2:=MA(VOL,10);

量能金叉:=CROSS(VOL1,VOL2);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;

MACD金叉:=CROSS(DIF,DEA);

三线金叉:=均线金叉 AND 量能金叉 AND MACD金叉;






VAR80:=3*SMA((C-LLV(L,180))/(HHV(H,180)-LLV(L,180))*100,5,1)-2*SMA(SMA((C-LLV(L,180))/(HHV(H,180)-LLV(L,180))*100,180,1),15,1);

横盘:=BARSLASTCOUNT(100*(HHV(H,20)-LLV(L,20))/LLV(L,20)<30 AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1) AND MA(C,20)>REF(MA(C,20),1))>=5 AND BARSLASTCOUNT(100*(HHV(H,14)-LLV(L,20))/LLV(L,20)<15 AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1) AND MA(C,20)>REF(MA(C,20),1))<=30;
横盘突破:=COUNT((REF(横盘,1)<=0.25)AND(C>O)AND(C>=REF(HHV(C,15),1))AND((C-REF(C,1))/REF(C,1)>=0.04),15)=1;
  


超牛横盘突破:=IF(((横盘突破)AND(主力赢利25持仓>30)AND((C-REF(C,1))/REF(C,1)>=0.04)AND(CLOSE>=疯牛马线)AND((C-REF(C,20))/REF(C,20)>0)AND((C-REF(C,20))/REF(C,20)<0.25)),218,0);



涨幅:=(C-REF(C,1))*100/REF(C,1);
涨幅5:=(REF(C,1)-REF(C,5))*100/REF(C,5);

涨幅10:=(REF(C,1)-REF(C,10))*100/REF(C,10);


超牛潜力:=-EMA(VAR80,5)/4, COLOR6600FF;


涨幅20:=(C-REF(C,20))*100/REF(C,20);


三合一:=IF(((金牛起航>18)AND(主力疯狂做多>10)AND(涨幅10<10)),218,0);


超牛:=IF(((COUNT((超牛拉升>超牛潜力),5)>=1)AND(涨幅5>1)AND(持股时段<0)AND(持币阶段=主升持股波段)AND(日线>疯牛马线*0.95)AND(涨幅>=3)AND(涨幅10<20))OR((超牛横盘突破>18)AND(COUNT(CROSS(超牛拉升,超牛潜力),5)=1))OR((阻击牛股>18)AND(涨幅10<20))OR((三合一>8)),18,0),COLORYELLOW,NODRAW;

金叉:=(COUNT(CROSS(超牛拉升,超牛潜力),5)=1)AND(涨幅20>4)AND(持币阶段=主升持股波段)AND(涨幅10<20)AND(日线>疯牛马线*1.05);

金叉超牛:=FILTER(金叉,30),COLORRED,LINETHICK2;

超牛高:=H=HHV(超牛拉升,10);

日振幅:=(H-L)/REF(C,1)*100;

振幅15:=HHV(日振幅,15);

涨幅1:=(REF(C,1)-REF(C,2))/REF(C,2)*100;

涨幅2:=(REF(C,2)-REF(C,3))/REF(C,3)*100;


涨幅50:=(C-REF(C,50))/REF(C,50)*100;


振幅:=(C-O)/O*100;
跌幅:=(REF(C,1)-C)/REF(C,1)*100;
低开阳线:=((O>REF(H,1) AND L>REF(H,1) AND C>O AND (O-REF(C,1))/REF(C,1)*100>1.5));


低开大阳线:=(O-REF(C,1))/REF(C,1)*100>2;


连阳1:=COUNT(O>REF(C,1),2)>=2;



跳空1:=COUNT(O>REF(H,1) AND L>REF(H,1),10);

跳空2:=COUNT(O>REF(C,1) AND L>REF(C,1),10) AND L<O;
跳空3:=COUNT(O>REF(C,1) AND (O-REF(C,1))/REF(C,1)*100>0.1 AND C>REF(H,1),10);


VAR21:=SMA(ABS(HIGH-VAR1),13,1)/SMA(MIN(HIGH-VAR1,0),10,1);

VAR31:=EMA(VAR21,10);
VAR41:=HHV(HIGH,33);
VAR51:=EMA(IF(HIGH>=VAR41,VAR31,0),3);

{强势反包阳线}
ZF:=(C/REF(C,1)-1)*100;
AZ:=RANGE(ZF,1.07,1.1) OR C=H;
AR:=REF(AZ,2);
AA2:=REF(C,1)<REF(O,1);
AA3:=C>(REF(C,1)+REF(C,1))/1.9;
AA4:=(C*FINANCE(7)/100000000)<60;{流通市值}

强势反包阳线:=IF((AR AND AA2 AND AA3 AND AA4),18,0),COLORRED,NODRAW;


主力推升股价:=IF(VAR51<REF(VAR51,1)AND(跌幅<3),18,0),COLORRED,NODRAW;
{低开阳线}



老鼠仓:=(REF(C,1)-O)/REF(C,1)*100>2.5 AND (C-O)/O*100>2 AND 涨幅5<30 AND 涨幅10<40 AND 超牛拉升>=REF(超牛拉升,1),COLORFF00FF;



{快马加鞭}
快马加鞭:=FILTER((涨幅>5)AND(涨幅1>5)AND(超牛拉升>=REF(超牛拉升,1)AND(C>疯牛马线)AND(涨幅10<40)AND(超牛拉升>=REF(超牛拉升,10))),3);



超强洗筹:=REF(涨幅>5,1)AND(REF(涨幅1,1))AND(振幅<2)AND(涨幅<2)AND(跌幅<2)AND(涨幅10<28)AND(主升持股波段=持币阶段),COLORFF6100;



大黑马:=((COUNT(低开大阳线,10)=1)AND(连阳1))OR(强势反包阳线)OR((振幅15<20)AND(跳空3)AND(COUNT(MA(C,34)>=LLV(MA(C,34),30),15)>1))AND(涨幅>5)AND(涨幅1<5)AND(涨幅20<20)AND(涨幅50<40)AND(主升持股波段=持币阶段)AND(MA8>=REF(MA8,1))AND(BARSCOUNT(C)>20)AND(超牛拉升>=REF(超牛拉升,1)),COLORFF00FF;





牛刀1:=IF((乖离系数>0)AND(持币阶段>=主升持股波段),28,0),COLORRED,LINETHICK2;



牛刀2:=IF(((EXIST(乖离系数>0,3))AND(主力控盘系数>=50)),28,0),COLORRED,LINETHICK2;



喇叭大牛股:=(开口选股)AND((REF(涨幅,1)>5)OR(涨幅>1)OR(强势反包阳线));


超强转势:=IF(XA_1 AND 涨幅>7 AND CROSS(日线,喇叭上轨),18,0);



小试牛刀:FILTER(((主力控盘系数>REF(主力控盘系数,5)AND(涨幅20<30)AND(主力控盘系数>=HHV(主力控盘系数,50)))AND((牛刀1>5)OR(牛刀2>5)AND(涨幅20<30))AND((COUNT(CROSS(持币阶段,疯牛马线),10)=1)AND(涨幅20<30)AND(主力控盘系数>REF(主力控盘系数,10)AND(主力控盘系数>=HHV(主力控盘系数,50))))OR((持币阶段<疯牛马线)AND(涨幅20<30)AND(涨幅>1.5)AND(主力控盘系数>REF(主力控盘系数,10))AND(涨幅20<30)AND(日线>疯牛马线))AND(主力赢利25持仓>20))OR((快马加鞭)AND(涨幅20<30))OR((大黑马)AND(涨幅20<50))OR(喇叭大牛股)AND(主力推升股价>0)AND(MA8>=REF(MA8,1)),6),COLORFF00FF,LINETHICK2;



小牛启程:FILTER(((超牛>5)AND(主力活跃力度>主升浪波段)OR(金叉超牛))AND(机构主力拉升>0)AND(主力赢利25持仓>20)OR(涨幅20<30)AND(大黑马)OR(快马加鞭)OR(喇叭大牛股)OR(强势反包阳线)OR((COUNT(CROSS(超强转势,0.8),5)=1)AND(涨幅>1.5))AND(主力推升股价>0)AND(MA8>=REF(MA8,1)),6),COLORFF0080,LINETHICK2;





{重点自选}


自选:=IF(((COUNT(开口选股,5)=1 AND 涨幅>0.5 AND 主力赢利25持仓>30 AND 主升持股波段=持币阶段 AND 涨幅10<50 AND 乖离系数>=REF(乖离系数,1))),18,0),COLORRED,LINETHICK2;


共振:=IF(((COUNT(CROSS(小牛启程,0.8),6)=1)AND(小试牛刀>0))OR((COUNT(CROSS(小试牛刀,0.8),6)=1)AND(小牛启程>0))OR((COUNT(CROSS(自选,0.8),6)=1)AND(小牛启程>0))OR((COUNT(CROSS(小牛启程,0.8),6)=1)AND(自选>0))OR((COUNT(CROSS(小试牛刀,0.8),6)=1)AND(自选>0))OR((COUNT(CROSS(自选,0.8),6)=1)AND(小试牛刀>0))AND(主力推升股价>0)AND(BARSCOUNT(C)>20)AND(MA8>=REF(MA8,1)),18,0);
共振乾坤1:=IF((共振>5)OR(强势反包阳线>5),6,0),COLORFFFF00,LINETHICK2;



超牛全仓:=IF(((COUNT(CROSS(共振乾坤1,0.8),6)=1)AND(开口选股 AND((REF(涨幅,1)>5)OR(涨幅>1)))OR((COUNT(开口选股,6)=1)AND (共振乾坤1)AND((REF(涨幅,1)>5)OR(涨幅>1)))),8,0),COLORYELLOW,LINETHICK2;



重点自选:FILTER((自选>1),20),COLORRED,LINETHICK2;


共振乾坤:FILTER((共振>5)OR(强势反包阳线>5)OR(自选>5),6),COLORFFFF00,LINETHICK2;



超牛全仓出击:FILTER((自选>1),20),COLORYELLOW,LINETHICK2;




STICKLINE(重点自选,0,118,0.18,0),COLORRED,LINETHICK3;
STICKLINE(超牛全仓出击,0,88,3,0),COLORYELLOW,LINETHICK3;

STICKLINE(小牛启程,0,68,3,0),COLORFF0080,LINETHICK3;

STICKLINE(小试牛刀,0,48,6,0),COLORFF00FF,LINETHICK3;


STICKLINE(共振乾坤,0,28,10,0),COLORFFFF00,LINETHICK3;

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多