asasww / 龙虎榜 / 【新提醒】【图】两个竞价打板必备公式,...

0 0

   

【新提醒】【图】两个竞价打板必备公式,命中率100%

2020-03-12  asasww
不好意思,昨天有事下线了,没来得及仔细看留言。这个指标要分两步:
首先把
Var1:=AMOUNT/VOL/100;
Var2:=REF(ASKPRICE(1),1);
Var3:=REF(BIDPRICE(1),1);
Var4:=(Var2-Var3)*0.35;
Var5:=IF(Var1>=Var2-Var4,VOL,IF(Var1<Var2-Var4 AND Var1>Var3+Var4,BUYVOL,0));
Var6:=IF(Var1<=Var3+Var4,VOL,IF(Var1<Var2-Var4 AND Var1>Var3+Var4,SELLVOL,0));
买一:=if(BARSTATUS=1 and DYNAINFO(4)>=DYNAINFO(3),vol,if(c=DYNAINFO(55),0,if(c=DYNAINFO(54),vol,var5)));
卖一:=if(BARSTATUS=1 and DYNAINFO(4)<DYNAINFO(3),vol,if(c=DYNAINFO(54),0,if(c=DYNAINFO(55),vol,var6)));
主动买单:=if(买一>0 and AMOUNT>=500000 ,买一,0);
主动卖单:=if(卖一>0 and AMOUNT>=500000 ,卖一,0);
大买量:=sum(主动买单,0);
大卖量:=sum(主动卖单,0);
买卖差:大买量-大卖量;
五十万增仓率:买卖差/capital*100;
这部分建立一个公式,一定要把指标命名为竞价增仓,副图指标。然后把下面的部分,做成第二个公式,名字可以是50分时,别的也可以,但要做成主图叠加指标:
五十万增仓:="竞价增仓.五十万增仓率#tick";
DRAWTEXTREL(220 ,660,STRRIGHT(NUMTOSTRN(五十万增仓,2),10)),COLOR00FFFF,LINETHICK3;
DRAWTEXTREL(5,850,'9:15-9:29'),COLORFFFFFF,LINETHICK1;
DRAWTEXTREL(70,850,'9:30-10:00'),COLORFFFFFF,LINETHICK1;
DRAWTEXTREL(185,850,'10:00-10:30'),COLORFFFFFF,LINETHICK1;
DRAWTEXTREL(310,850,'10:30-11:00'),COLORFFFFFF,LINETHICK1;
DRAWTEXTREL(445,850,'11:00-11:30'),COLORFFFFFF,LINETHICK1;
DRAWTEXTREL(570,850,'13:00-13:30'),COLORFFFFFF,LINETHICK1;
DRAWTEXTREL(695,850,'13:30-14:00'),COLORFFFFFF,LINETHICK1;
DRAWTEXTREL(810,850,'14:00-14:30'),COLORFFFFFF,LINETHICK1;
DRAWTEXTREL(940,850,'14:30-15:00'),COLORFFFFFF,LINETHICK1;
{9点30分}                                                                                                                                                                                                                                       
ZL9D:=REF(五十万增仓,BARSLAST(TIME>=091500 AND TIME<=092600));
DRAWTEXTREL(5,925,STRRIGHT(NUMTOSTRN(ZL9D,2),9)),COLOR00FFFF,LINETHICK2;
{10点}
ZL10D:=REF(五十万增仓,BARSLAST(TIME<=100000));
DRAWTEXTREL(75,925,STRRIGHT(NUMTOSTRN(ZL10D,2),9)),COLOR00FFFF,LINETHICK2;
{10点半}
ZL10DB:=REF(五十万增仓,BARSLAST(TIME>100000 AND TIME<=103000));
DRAWTEXTREL(189,925,STRRIGHT(NUMTOSTRN(ZL10DB-ZL10D,2),9)),COLOR00FFFF,LINETHICK2;
{11点}
ZL11D:=REF(五十万增仓,BARSLAST(TIME>103000 AND TIME<=110000));
DRAWTEXTREL(318,925,STRRIGHT(NUMTOSTRN(ZL11D-ZL10DB,2),9)),COLOR00FFFF,LINETHICK2;
{11点半}
ZL11DB:=REF(五十万增仓,BARSLAST(TIME>110000 AND TIME<=113000));
DRAWTEXTREL(465,925,STRRIGHT(NUMTOSTRN(ZL11DB-ZL11D,2),9)),COLOR00FFFF,LINETHICK2;
{13点半}
ZL13DB:=REF(五十万增仓,BARSLAST(TIME>130000 AND TIME<=133000));
DRAWTEXTREL(578,925,STRRIGHT(NUMTOSTRN(ZL13DB-ZL11DB,2),10)),COLOR00FFFF,LINETHICK2;
{14点}
ZL14D:=REF(五十万增仓,BARSLAST(TIME>133000 AND TIME<=140000));
DRAWTEXTREL(709,925,STRRIGHT(NUMTOSTRN(ZL14D-ZL13DB,2),10)),COLOR00FFFF,LINETHICK2;
{14点半}
ZL14DB:=REF(五十万增仓,BARSLAST(TIME>140000 AND TIME<=143000));
DRAWTEXTREL(819,925,STRRIGHT(NUMTOSTRN(ZL14DB-ZL14D,2),10)),COLOR00FFFF,LINETHICK2;
{15点}
ZL15D:=REF(五十万增仓,BARSLAST(TIME>143000 AND TIME<=150000));
DRAWTEXTREL(959,925,STRRIGHT(NUMTOSTRN(ZL15D-ZL14DB,2),10)),COLOR00FFFF,LINETHICK2;
这两个指标只能在分笔中使用,一个是主图、一个副图,配套用。你直接粘贴我的代码就行了!
查看全部打赏

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多