xiaoyin1206 / 指标 / 技术指标-BOLL改良版

0 0

   

技术指标-BOLL改良版

2020-03-14  xiaoyin12...

布林线(Boll)指标是股市技术分析的常用工具之一,通过计算股价的“标准差”,再求股价的“信赖区间”。

该指标在图形上画出三条线,其中上下两条线可以分别看成是股价的压力线和支撑线,而在两条线之间还有一条股价平均线,布林线指标的参数最好设为20。一般来说,股价会运行在压力线和支撑线所形成的通道中。

与MACD、RSI、KDJ等指标一样,BOLL指标也是股票市场最实用的技术分析参考指标。

本版改良中加入了缠论分型的判断,转绿是顶分型,转红是底分型,简单包含关系已经处理了,但有时会遇到复杂包含关系暂时标记为黄色。信号加入了先前文章的二次突破信号,用于抓住主升浪的起点,注意此信号有可能会有些假突破信号,需结合其他指标和K线形态综合判断。

技术指标-BOLL改良版

BOLL改良版

BOLL:MA(CLOSE,20);UB:BOLL+2*STD(CLOSE,20);LB:BOLL-2*STD(CLOSE,20);TJ1:=CROSS(C>UB,0.5);TJ2:=H=HHV(H,20);TJ3:=CROSS(C<LB,0.5);TJ4:=L=LLV(L,20);AA:=SUMBARS(CROSS(C>UB,0.5),2),NODRAW;BB:=SUMBARS(CROSS(C<UB,0.5),2),NODRAW;UBB:AA<60 && TJ1 && TJ2 && AA>1 && EXIST(C<UB,AA) && C>MA(C,60),NODRAW;LBS:BB<60 && TJ3 && TJ4 && AA>1 && EXIST(C>LB,AA) && C<MA(C,60),NODRAW;DRAWICON(UBB,UB,3);DRAWICON(LBS,LB,4);A1:=H>REF(H,1) AND L>REF(L,1);B1:=H<REF(H,1) AND L<REF(L,1);UP:=BARSLAST(A1)-BARSLAST(B1)<0;DW:=BARSLAST(A1)-BARSLAST(B1)>0;D1:=H>=REF(H,1) AND L<=REF(L,1);D2:=H<=REF(H,1) AND L>=REF(L,1);D3:=D1 OR D2;D:=COUNT(D3,2);A3:=D3 AND UP;B3:=D3 AND DW;STICKLINE(B1 OR B3,H,L,0,0),COLORGREEN;STICKLINE(A1 OR A3,H,L,0,0),COLORRED;STICKLINE(D=2,H,L,0,0),COLORYELLOW;

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多