2195969 / 选股公式 / 怎样发现均线粘合的股票?

0 0

   

怎样发现均线粘合的股票?

2020-05-13  2195969

很简单,有两种电脑编程自动化筛选方式,一种是编写一个选股公式,另一种是编写一个排序指标,两种方式,任选其一都可以实现。

我给大家举个例子,以排序指标筛选均线粘合的股票为例,公式可以这样写:

MA10:=MA(CLOSE,10);

MA30:=MA(CLOSE,30);

MA60:=MA(CLOSE,60);

X1:=ABS(MA10-MA60)/MA60;

X2:=ABS(MA30-MA60)/MA60;

X3:=ABS(MA10-MA30)/MA30;

NHPX:X1+X2+X3;

当然,也可以将均线的范围放大一些,譬如将均线MA60换成MA120甚至MA250,若两线周期相差太大,周期之间可以增加几条线。以通达信为例,将源码拷贝指标公式编辑器,填入公式名称,点击确认即可。

进入“报价-历史行情.指标排序”,进行排序。

通常需要更换排序指标,选择刚才新建的“均线粘合”排序指标,对沪深A股进行排序

因为是均线粘合排序,所以,应该选择倒序排序,数值越小,说明均线越粘合。

筛选结果,选择一组图示如下:

如果想要筛选均线既粘合,又呈现多头排列形态的目标股,可以在公式中增加多头排列的条件,如下:

MA10:=MA(CLOSE,10);

MA30:=MA(CLOSE,30);

MA60:=MA(CLOSE,60);

X1:=ABS(MA10-MA60)/MA60;

X2:=ABS(MA30-MA60)/MA60;

X3:=ABS(MA10-MA30)/MA30;

TJ:=MA10>=MA30 AND MA30>=MA60;

NHPX:IF(TJ,X1+X2+X3,DRAWNULL);


如有不同意见,欢迎大家留言交流。

如果有什么想法需要通过指标公式实现的,而你又不会编程,可以先把问题提出来,然后关注我,再邀请我来回答。

文/股票问答

如何寻找 均线粘合的股票,虽说均线粘合的形态挺好找的,但在股市3000多只股票中,要一个个股票往过找这工作量太大了。今天我给大家讲一下我是如何筛选均线粘合的股票。

1.Ctrl+F 打开公式管理器 选择其他 点击新建

2.复制选股公式源代码,一定要记得个这个指标命名。

以下是我常用的均线粘合的公式源代码

MA5:MA(CLOSE,5); MA10:MA(CLOSE,10); MA20:MA(CLOSE,20); MA60:MA(CLOSE,60),COLORGREEN,DOTLINE; MA120:MA(CLOSE,120),COLORRED,DOTLINE; MA250:MA(CLOSE,250),COLORBLUE,DOTLINE; STICKLINE(C/REF(C,1)>1.099 AND C=H,O,C,-1,1),COLORWHITE;三合:(MAX(MAX(MA(C,5),MA(C,10)),MA(C,20))/MIN(MIN(MA(C,5),MA(C,10)),MA(C,20))-1)*100,NODRAW;四合:(MAX(MAX(MAX(MA(C,5),MA(C,10)),MA(C,20)),MA(C,60))/MIN(MIN(MIN(MA(C,5),MA(C,10)),MA(C,20)),MA(C,60))-1)*100,NODRAW;五合:(MAX(MAX(MAX(MAX(MA(C,5),MA(C,10)),MA(C,20)),MA(C,60)),MA(C,120))/MIN(MIN(MIN(MIN(MA(C,5),MA(C,10)),MA(C,20)),MA(C,60)),MA(C,120))-1)*100,NODRAW;六合:(MAX(MAX(MAX(MAX(MAX(MA(C,5),MA(C,10)),MA(C,20)),MA(C,60)),MA(C,120)),MA(C,250))/MIN(MIN(MIN(MIN(MIN(MA(C,5),MA(C,10)),MA(C,20)),MA(C,60)),MA(C,120)),MA(C,250))-1)*100,NODRAW;A:=C>REF(HHV(H,2),1);B:=C<REF(LLV(L,2),1);ENTERLONG:=TFILTER(A,B,1);EXITLONG:=TFILTER(A,B,2);DRAWICON(ENTERLONG,L*0.98,1),COLORRED;DRAWICON(EXITLONG,H/0.998,2),COLORGREEN;

导入指标后 就可以通过它进行选股了。

所有符合均线粘合的股票都会被挑选出来,你直接根据你的做票习惯去挑选适合自己的均线粘合的股票即可。

我是小散学习ing,欢迎关注、点赞。也欢迎各位大神指点哦! ღ( ´・ᴗ・` )比心

展开全部

在实际操作中,均线粘合虽然并不一定代表股价涨势的开启或是行情的反转,但均线粘合往往意味着底部或者说是阶段底部的到来,投资者只有时刻关注着均线粘合的个股,才能在一定程度上提高投资获利。

那么,在3000多只个股中,我们如何才能准确捕捉均线粘合的股票呢?

以通达信系统为例:

在条件选股中输入下方的选股源码,我们就可以得到相应的均线粘合股票。

N:=10;

MA5:=MA(CLOSE,5);

MA10:=MA(CLOSE,10);

MA20:=MA(CLOSE,20);

MA30:=MA(CLOSE,30);

MA60:=MA(CLOSE,60);

MA90:=MA(CLOSE,90);

MA120:=MA(CLOSE,120);

MA250:=MA(CLOSE,250);

DTPL:=MA10>MA30ANDMA30>REF(MA30,1);

DG:=MAX(MAX(MA5,MA10),MAX(MA20,MA30));

ZG:=MAX(MAX(DG,MA60),MAX(MA90,MA120));

DD:=MIN(MIN(MA5,MA10),MIN(MA20,MA30));

ZD:=MIN(MIN(DD,MA60),MIN(MA90,MA120));

粘合:=(ZG/ZD-1)*100<N,POINTDOT,LINETHICK0;

高粘:=(ZG/ZD-1)*100<N AND ZD>MA250,POINTDOT,LINETHICK0;

穿5:(粘合 AND CROSS(C,MA5))*0.5;

穿10:(粘合 AND CROSS(C,MA10))*1;

穿20:(粘合 AND CROSS(C,MA20))*2;

穿30:(粘合 AND CROSS(C,MA30))*3;

FLSZ:=(C/REF(C,1)-1)*100>=2 AND V>REF(V,1);

DXTP:=((穿5/0.5)+穿10+(穿20/2)+(穿30/3))>=2;

优选:(FLSZ AND DXTP AND MA30>REF(MA30,1))*3,COLOR00FFFF,LINETHICK2;

选优:(FLSZ AND DXTP AND MA30>REF(MA30,1) AND COUNT(高粘,20)>=15)*3,COLOR0000FF,LINETHICK2;

JXDT:=MA5>MA10 AND MA10>MA20 AND MA20>MA30;

发散:(JXDT AND NOT(REF(JXDT,1)))*1,COLOR00FF00,LINETHICK2;

起飞:(NOT(粘合) AND REF(粘合,1) AND COUNT(粘合,20)>=15 AND DTPL)*3,COLORFF00FF,LINETHICK2;

具体的做法如下:

点击软件上方的“功能”,选择下列表中的“公示系统”——“公式管理器”。

在“公式管理器”中选择“条件选股公式”,然后点击“条件选股公式”下方的“其他类型”,再点击“新建”,窗口会弹出“条件选股公式编辑器”。

在“编辑器”中填入公式名称,公式描述,然后将上述的源代码复制到代码框里面,点击“确定”即可。

之后再在“选股器”中筛选出符合条件的个股即可。

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×