梵哥 / 待分类 / 通达信MACD精确背离指标公式

分享

   

通达信MACD精确背离指标公式

2020-09-20  梵哥
SHORT:=12;
LONG:=26;
MID:=9;
DIFF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIFF,MID);
MACD:(DIFF-DEA)*2,COLORFFFF00,COLORSTICK;
A1:=BARSLAST(REF(CROSS(0, DEA),1));
A2:= BARSLAST(REF(COUNT(DEA<=0,A1+1)=A1+1 AND LLV(DIFF,5)=LLV(DIFF,A1+1) AND CROSS(DIFF,DEA),1));
A3:= BARSLAST(REF(CROSS(DIFF,DEA),1));
金叉:=IF(CROSS(DIFF,DEA) AND DEA<=0,0,DEA),COLORYELLOW;
低位多次金叉:IF(CROSS(DIFF,DEA) AND COUNT(A2>=1,A2+1)>=1 AND COUNT(DEA <=0,A2+1)=A2+1,0,DEA),COLORYELLOW;
DIBL1:= LLV(CLOSE,A3+1)=LLV(CLOSE,A1+1) AND NOT(LLV(DIFF,A3+1)=LLV(DIFF,A1+1)) AND CROSS(DIFF,DEA) AND COUNT(A2>=1,A2+1)>=1 AND COUNT(DEA <=0,A2+1)=A2+1;
背离:=IF(DIBL1,0,DEA);
DRAWLINE(A2=0,DEA,DIBL1=1,DEA,0),COLORRED,LINETHICK3;
B1:=BARSLAST(REF(CROSS(DEA,0),1));
B2:=BARSLAST(REF(COUNT(DEA>=0,B1+1)=B1+1 AND HHV(DIFF,5)=HHV(DIFF,A1+1) AND CROSS(DEA,DIFF),1));
B3:=BARSLAST(REF(CROSS(DEA,DIFF),1));
死叉:=IF(CROSS(DEA,DIFF) AND DEA>=0,0,DEA),COLORFFFF00;
高位多次死叉:IF(CROSS(DEA,DIFF) AND COUNT(B2>=1,B2+1)>=1 AND REF(COUNT(DEA >=0,B2+1)=B2+1,1),0,DEA),COLORFFFF00;
DINGBL1:= HHV(CLOSE,B3+1)=HHV(CLOSE,B1+1) AND NOT(HHV(DIFF,B3+1)=HHV(DIFF,B1+1)) AND CROSS(DEA,DIFF) AND COUNT(B2>=1,B2+1)>=1 AND COUNT(DEA >=0,B2+1)=B2+1;
顶背离:=IF(DINGBL1,0,DEA);
DRAWLINE(B2=0,DEA,DINGBL1,DEA,0),COLOR00FF00,LINETHICK3;
STICKLINE(DIFF>DEA,MACD,0,1,0),COLORRED;
STICKLINE(DEA>DIFF,MACD,0,1,0),COLORFFFF00;

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>