自由翱翔-zyax / 股票公式 / 通达信九转趋势主图指标公式

分享

   

通达信九转趋势主图指标公式

2020-09-28  自由翱翔...

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
ZK1:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),DOTLINE,COLORBLUE;
ZD1:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK3,COLORRED;
ZD2:EMA(ZD1,25),LINETHICK3,COLORGREEN;
DRAWBAND(ZD1,RGB(55,0,0),ZD2,RGB(0,91,0));
DRAWKLINE(H,O,L,C);
STICKLINE(ZD1>LOW AND ZD1<HIGH,ZD1,MIN(MIN(OPEN,CLOSE),ZD1),2,0),COLORYELLOW;
STICKLINE(ZD1>MIN(C,O) AND ZD1<MAX(C,O),ZD1,MIN(OPEN,CLOSE),2,0),COLORYELLOW;
STICKLINE(ZD1>HIGH,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(ZD1>HIGH,HIGH,LOW,0,0),COLORYELLOW;
VAR23:=100*XMA(XMA((C-REF(C,1)),6),6)/XMA(XMA(ABS((C-REF(C,1))),6),6);
回调买:=LLV(VAR23,2)=LLV(VAR23,7) AND COUNT(VAR23<0,2) AND CROSS(VAR23,MA(VAR23,2));
XG:=ZD1>HIGH AND 回调买 AND L<=ZD1;
DRAWTEXT(XG,L,'▲买入'),COLORRED;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
XG2:=C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 AND H<ZK1;
{DRAWTEXT(XG2,L,'▲抓牛'),COLORYELLOW;}
DRAWTEXT(XG2 AND L<ZD1,L,'↖黑马暴涨'),COLORRED;
高1:=REF(HHV(3,80),3);
低1:=REF(LLV(L,3),3);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
高:REFDATE(高1,DATE);
低:REFDATE(低1,DATE);
一:REFDATE(H1,DATE);
二:REFDATE(H2,DATE);
三:REFDATE(H3,DATE);
四:REFDATE(H4,DATE),COLORRED;
五:REFDATE(H5,DATE);
{DRAWTEXT(CURRBARSCOUNT=1.00,一,'一(0.191)'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1.00,二,'二(0.382)'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1.00,三,'三(0.50)'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1.00,四,'四(0.618'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1.00,五,'五(0.809)'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1.00,高,'高'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1.00,低,'低'),COLORYELLOW;
DRAWKLINE(H,O,L,C);}
日:=150;昨前:=3;
Z高1:=REF(HHV(H,日),昨前);
Z低1:=REF(LLV(L,日),昨前);
ZH1:=Z高1-(Z高1-Z低1)*0.191;
ZH2:=Z高1-(Z高1-Z低1)*0.382;
ZH3:=Z高1-(Z高1-Z低1)*0.5;
ZH4:=Z高1-(Z高1-Z低1)*0.618;
ZH5:=Z高1-(Z高1-Z低1)*0.809;
顶:REFDATE(Z高1,DATE),DOTLINE,COLORRED;
Z一:REFDATE(ZH1,DATE),DOTLINE,COLORYELLOW;
Z二:REFDATE(ZH2,DATE),DOTLINE,COLORMAGENTA;
Z三:REFDATE(ZH3,DATE),DOTLINE,COLORWHITE;
Z四:REFDATE(ZH4,DATE),DOTLINE,COLORGREEN;
Z五:REFDATE(ZH5,DATE),DOTLINE,COLORYELLOW;
Z低:REFDATE(Z低1,DATE),DOTLINE,COLORRED;
VAR1P:=ZIG(3,13);
STICKLINE((REF(VAR1P,2) < REF(VAR1P,1)) AND (VAR1P < REF(VAR1P,1)),CLOSE,OPEN,5,0),COLORBLUE;
DRAWICON(CROSS(REF(ZIG(3,12),1),ZIG(3,12)),HIGH*1.02,15);
DRAWTEXT(CROSS(REF(ZIG(3,12),1),ZIG(3,12)),LOW-0.05,'绝对清'),COLOR00FF00;
STICKLINE((REF(VAR1P,2) > REF(VAR1P,1)) AND (VAR1P >REF(VAR1P,1)),CLOSE,OPEN,5,0),COLORRED;
A1:=C>=REF(C,4);
A:=C<REF(C,4);
AA:=C<REF(C,4) AND REF(A1,1);
T:=BARSLAST(AA)NODRAW;
M:=(T=0 AND REFX(T=1 AND NOT(A),1)) OR (REFX(T=2 AND NOT(A),2)) OR (REFX(T=3 AND NOT(A),3)) OR (REFX(T=4 AND NOT(A),4)) OR (REFX(T=5 AND NOT(A),5))
OR (REFX(T=6 AND NOT(A),6)) OR (REFX(T=7 AND NOT(A),7)) OR (REFX(T=8 AND NOT(A),8));
M1:=T=1 AND REFX(T=2 AND NOT(A),1) OR (REFX(T=3 AND NOT(A),2)) OR (REFX(T=4 AND NOT(A),3)) OR (REFX(T=5 AND NOT(A),4)) OR (REFX(T=6 AND NOT(A),5))
OR (REFX(T=7 AND NOT(A),6)) OR (REFX(T=8 AND NOT(A),7));
M2:=T=2 AND REFX(T=3 AND NOT(A),1) OR (REFX(T=4 AND NOT(A),2)) OR (REFX(T=5 AND NOT(A),3)) OR (REFX(T=6 AND NOT(A),4)) OR (REFX(T=7 AND NOT(A),5)) OR (REFX(T=8 AND NOT(A),6));
M3:=T=3 AND REFX(T=4 AND NOT(A),1)OR (REFX(T=5 AND NOT(A),2)) OR (REFX(T=6 AND NOT(A),3)) OR (REFX(T=7 AND NOT(A),4)) OR (REFX(T=8 AND NOT(A),5));
M4:=T=4 AND REFX(T=5 AND NOT(A),1) OR (REFX(T=6 AND NOT(A),2)) OR (REFX(T=7 AND NOT(A),3)) OR (REFX(T=8 AND NOT(A),4));
M5:=T=5 AND REFX(T=6 AND NOT(A),1) OR (REFX(T=7 AND NOT(A),2)) OR (REFX(T=8 AND NOT(A),3));
M6:=T=6 AND REFX(T=7 AND NOT(A),1) OR (REFX(T=8 AND NOT(A),2));
M7:=T=7 AND REFX(T=8 AND NOT(A),1);
N:=T=1 AND REF(T=0 AND AA,1) AND A;
N1:=T=2 AND REF(N,1) AND A;
N2:=T=3 AND REF(N1,1) AND A;
N3:=T=4 AND REF(N2,1) AND A;
N4:=T=5 AND REF(N3,1) AND A;
N5:=T=6 AND REF(N4,1) AND A;
N6:=T=7 AND REF(N5,1) AND A;
N7:=T=8 AND REF(N6,1) AND A;
DRAWTEXT(T=0,H*1.008,'1')COLORGREEN;
DRAWTEXT(N,H*1.008,'2')COLORGREEN;
DRAWTEXT(N1,H*1.008,'3')COLORGREEN;
DRAWTEXT(N2,H*1.008,'4')COLORGREEN;
DRAWTEXT(N3,H*1.008,'5')COLORGREEN;
DRAWTEXT(N4,H*1.008,'6')COLORGREEN;
DRAWTEXT(N5,H*1.008,'7')COLORGREEN;
DRAWTEXT(N6,H*1.008,'8')COLORGREEN;
DRAWTEXT(N7,H*1.008,'9')COLORGREEN;
DRAWICON(N7,H*1.01,1)COLORGREEN;
DRAWTEXT(M,H*1.008,'1')COLORBLACK;
DRAWTEXT(M1,H*1.008,'2')COLORBLACK;
DRAWTEXT(M2,H*1.002,'3')COLORBLACK;
DRAWTEXT(M3,H*1.002,'4')COLORBLACK;
DRAWTEXT(M4,H*1.002,'5')COLORBLACK;
DRAWTEXT(M5,H*1.02,'6')COLORBLACK;
DRAWTEXT(M6,H*1.002,'7')COLORBLACK;
DRAWTEXT(M7,H*1.002,'8')COLORBLACK;
B1:=C<=REF(C,4);
B:=C>REF(C,4);
BB:=C>REF(C,4) AND REF(B1,1);
T1:=BARSLAST(BB)NODRAW;
M111:=(T1=0 AND REFX(T1=1 AND NOT(B),1)) OR (REFX(T1=2 AND NOT(B),2)) OR (REFX(T1=3 AND NOT(B),3)) OR (REFX(T1=4 AND NOT(B),4)) OR (REFX(T1=5 AND NOT(B),5))
OR (REFX(T1=6 AND NOT(B),6)) OR (REFX(T1=7 AND NOT(B),7)) OR (REFX(T1=8 AND NOT(B),8));
M11:=T1=1 AND REFX(T1=2 AND NOT(B),1) OR (REFX(T1=3 AND NOT(B),2)) OR (REFX(T1=4 AND NOT(B),3)) OR (REFX(T1=5 AND NOT(B),4)) OR (REFX(T1=6 AND NOT(B),5))
OR (REFX(T1=7 AND NOT(B),6)) OR (REFX(T1=8 AND NOT(B),7));
M22:=T1=2 AND REFX(T1=3 AND NOT(B),1) OR (REFX(T1=4 AND NOT(B),2)) OR (REFX(T1=5 AND NOT(B),3)) OR (REFX(T1=6 AND NOT(B),4)) OR (REFX(T1=7 AND NOT(B),5)) OR (REFX(T1=8 AND NOT(B),6));
M33:=T1=3 AND REFX(T1=4 AND NOT(B),1)OR (REFX(T1=5 AND NOT(B),2)) OR (REFX(T1=6 AND NOT(B),3)) OR (REFX(T1=7 AND NOT(B),4)) OR (REFX(T1=8 AND NOT(B),5));
M44:=T1=4 AND REFX(T1=5 AND NOT(B),1) OR (REFX(T1=6 AND NOT(B),2)) OR (REFX(T1=7 AND NOT(B),7)) OR (REFX(T1=8 AND NOT(B),4));
M55:=T1=5 AND REFX(T1=6 AND NOT(B),1) OR (REFX(T1=7 AND NOT(B),2)) OR (REFX(T1=8 AND NOT(B),3));
M66:=T1=6 AND REFX(T1=7 AND NOT(B),1) OR (REFX(T1=8 AND NOT(B),2));
M77:=T1=7 AND REFX(T1=8 AND NOT(B),1);
N111:=T1=1 AND REF(T1=0 AND BB,1) AND B;
N11:=T1=2 AND REF(N111,1) AND B;
N22:=T1=3 AND REF(N11,1) AND B;
N33:=T1=4 AND REF(N22,1) AND B;
N44:=T1=5 AND REF(N33,1) AND B;
N55:=T1=6 AND REF(N44,1) AND B;
N66:=T1=7 AND REF(N55,1) AND B;
N77:=T1=8 AND REF(N66,1) AND B;
DRAWTEXT(T1=0,H*1.002,'1')COLORLIRED;
DRAWTEXT(N111,H*1.002,'2')COLORLIRED;
DRAWTEXT(N11,H*1.002,'3')COLORLIRED;
DRAWTEXT(N22,H*1.002,'4')COLORLIRED;
DRAWTEXT(N33,H*1.002,'5')COLORLIRED;
DRAWTEXT(N44,H*1.002,'6')COLORLIRED;
DRAWTEXT(N55,H*1.002,'7')COLORLIRED;
DRAWTEXT(N66,H*1.002,'8')COLORLIRED;
DRAWTEXT(N77,H*1.002,'9')COLORLIRED;
DRAWICON(N77,H*1.004,2);
DRAWTEXT(M111,H*1.002,'1')COLORBLACK;
DRAWTEXT(M11,H*1.002,'2')COLORBLACK;
DRAWTEXT(M22,H*1.002,'3')COLORBLACK;
DRAWTEXT(M33,H*1.002,'4')COLORBLACK;
DRAWTEXT(M44,H*1.002,'5')COLORBLACK;
DRAWTEXT(M55,H*1.002,'6')COLORBLACK;
DRAWTEXT(M66,H*1.002,'7')COLORBLACK;
DRAWTEXT(M77,H*1.002,'8')COLORBLACK;
HM:=30;HN1:=12;HN2:=10;
LC:=REF(C,1);
SSMA:=SMA(MAX(C-LC,0),6,1)/SMA(ABS(C-LC),6,1)*100;
HA:=MA(C,HM);
HB:=(HA-C)/HA>=0.23 AND V>REF(V,1) AND C>L AND (REF(C,1)-C)/REF(C,1)>=0.04;
海底捕鱼:CROSS(SSMA,HN1) AND EXIST(HB,HN2);
DRAWTEXT(海底捕鱼,L*0.96,'海底捕鱼'),COLORRED;
STICKLINE(海底捕鱼,C,O,0,0),COLORCYAN;
STICKLINE(海底捕鱼,C,O,0.6,0),COLORCYAN;

通达信九转趋势主图指标公式

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>