红牛2008 / 副图公式 / 高人整理优化的MACD王牌指标。  最牛...

分享

   

高人整理优化的MACD王牌指标。  最牛MACD

2020-11-01  红牛2008

高人整理优化的MACD王牌指标,自认为还可以,MACD的钝化,高低位背离等都很简洁美观,如果有优化的高人也可以在此基础上优化,公式感觉不错,大家互相讨论学习

ss      1    50    12

LL     1   50   26

MM   1   50    9

N       5    50     10

{DIF1:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL));
DEA1:=EMA(DIF1,MM);
DRAWBAND(DIF1,RGB(155,50,50),DEA1,RGB(0,100,50));}

DIF:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL)),COLORWHITE;
DEA:=EMA(DIF,MM),COLORYELLOW;
DRAWBAND(DIF,RGB(155,50,50),DEA,RGB(0,100,50));
{DRAWBAND(DIF,RGB(255,0,0),DEA,RGB(0,100,50));}
MACD:(DIF-DEA)*2,COLORSTICK;

MACD120:=REF(MACD/2,BARSLAST(MACD=HHV(MACD,120))),COLORRED,LINETHICK1;
MACD250:=REF(MACD/2,BARSLAST(MACD=HHV(MACD,250))),COLORGREEN,LINETHICK1;
XG:=NOT(REF(MACD120,1)=MACD120);
STICKLINE(XG,0,MACD,1,0),COLORYELLOW;
STICKLINE(MACD>=MACD250,MACD250,MACD,1,0),COLORMAGENTA;
大行情:=NOT(REF(MACD120,1)=REF(MACD250,1)) AND MACD120=MACD250;
{DRAWTEXT(XG,0,'↖金柱'),COLORYELLOW;}
DRAWTEXT(大行情,0,'↖大牛启动'),COLORYELLOW;

{_抄底:ABS((CROSS("MACD.DIF","MACD.DEA") &&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.50,COLORLIMAGENTA;
_DIF:"MACD.DIF",COLORWHITE;
_DEA:"MACD.DEA",COLORYELLOW;
__强度:IF(DIF>DEA,DIF,DRAWNULL),COLORRED,LINETHICK2;
_强度:IF(DEA<>
DRAWTEXT(ABS(_抄底)>0,_抄底*1.20,' 抄底'),COLORYELLOW;
DRAWICON(ABS(_抄底)>0,_抄底*1.10,4);
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);}

死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=(直接底背离 OR 隔峰底背离);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1));
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);

STICKLINE(B OR BG,DIF,DEA,1,0),COLORRED;
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.1),'钝化'),COLORYELLOW;
DRAWTEXT(FILTER(BG,10),(DIF*1.1),'结构形成'),COLORMAGENTA;
DRAWTEXT(FILTER(底背离消失,10),DIF*1.1,'消失'),COLORGREEN;
STICKLINE(BG,0,DIF,1,0), COLORRED;


金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT20 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT30 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=(直接顶背离 OR 隔峰顶背离);
TG:=((MDIFT2<>顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,DIF,1,0), COLORGREEN;
STICKLINE(T OR TG,DIF,DEA,1,0),COLORGREEN;
DRAWTEXT(FILTER(TG,20),(DIF*1.1),'结构形成'),COLORMAGENTA;
DRAWTEXT(FILTER(顶背离消失,20),DIF*1.1,'消失'),COLORGREEN;

MACDDIF:=IF(ABS(MACD)>ABS(DIF),MACD,DIF);
DRAWICON(REF(DIF,1)>REF(DIF,2) AND DIF0 AND DIF>DEA,MACDDIF*1.1,39),COLORGREEN;
DRAWICON(REF(DIF,1)REF(DIF,1) AND DIF<0 AND DIF<>

{精选金叉}
X_1:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_2:=EMA(X_1,9);
DDD:100*(X_1-X_2)*2,COLORFF00FF,LINETHICK2;
DDD2:EMA(DDD,N),COLORGREEN,LINETHICK2;
X_3:=CROSS(DDD,DDD2) AND DDD2>=0 AND DDD2<1.5 AND CLOSE/REF(CLOSE,1)>1 AND CLOSE>MA(CLOSE,5) AND CROSS(CLOSE,REF(HHV(HIGH,15),1));
DRAWICON(X_3,0,38);
STICKLINE(X_3,0,10,1,0),COLORBLUE;




前辈高人整理优化的MACD王牌指标 通达信 贴图 无加密

前辈高人整理优化的MACD王牌指标 通达信 贴图 无加密


    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>