pananbaba / 指标公式 / 通达信选股公式:移动筹码3合1移动筹码神线...

分享

   

通达信选股公式:移动筹码3合1移动筹码神线移动筹码峰最长筹码峰

2020-11-21  pananbaba

指标三合一,把3个不错的公式合并:移动筹码神线,移动筹码峰及最长筹码峰,这样方便看盘

HB:=COST(99.9);

LB:=COST(0.1);

B3:=(HB-LB)/50;

B31:=HB-B3;

B32:=HB-2*B3;

B33:=HB-3*B3;

B34:=HB-4*B3;

B35:=HB-5*B3;

B36:=HB-6*B3;

B37:=HB-7*B3;

B38:=HB-8*B3;

B39:=HB-9*B3;

B310:=HB-10*B3;

B311:=HB-11*B3;

B312:=HB-12*B3;

B313:=HB-13*B3;

B314:=HB-14*B3;

B315:=HB-15*B3;

B316:=HB-16*B3;

B317:=HB-17*B3;

B318:=HB-18*B3;

B319:=HB-19*B3;

B320:=HB-20*B3;

B321:=HB-21*B3;

B322:=HB-22*B3;

B323:=HB-23*B3;

B324:=HB-24*B3;

B325:=HB-25*B3;

B326:=HB-26*B3;

B327:=HB-27*B3;

B328:=HB-28*B3;

B329:=HB-29*B3;

B330:=HB-30*B3;

B331:=HB-31*B3;

B332:=HB-32*B3;

B333:=HB-33*B3;

B334:=HB-34*B3;

B335:=HB-35*B3;

B336:=HB-36*B3;

B337:=HB-37*B3;

B338:=HB-38*B3;

B339:=HB-39*B3;

B340:=HB-40*B3;

B341:=HB-41*B3;

B342:=HB-42*B3;

B343:=HB-43*B3;

B344:=HB-44*B3;

B345:=HB-45*B3;

B346:=HB-46*B3;

B347:=HB-47*B3;

B348:=HB-48*B3;

B349:=HB-49*B3;

A1:=WINNER(HB)*100-WINNER(B31)*100;

A2:=WINNER(B31)*100-WINNER(B32)*100;

A3:=WINNER(B32)*100-WINNER(B33)*100;

A4:=WINNER(B33)*100-WINNER(B34)*100;

A5:=WINNER(B34)*100-WINNER(B35)*100;

A6:=WINNER(B35)*100-WINNER(B36)*100;

A7:=WINNER(B36)*100-WINNER(B37)*100;

A8:=WINNER(B37)*100-WINNER(B38)*100;

A9:=WINNER(B38)*100-WINNER(B39)*100;

A10:=WINNER(B39)*100-WINNER(B310)*100;

A11:=WINNER(B310)*100-WINNER(B311)*100;

A12:=WINNER(B311)*100-WINNER(B312)*100;

A13:=WINNER(B312)*100-WINNER(B313)*100;

A14:=WINNER(B313)*100-WINNER(B314)*100;

A15:=WINNER(B314)*100-WINNER(B315)*100;

A16:=WINNER(B315)*100-WINNER(B316)*100;

A17:=WINNER(B316)*100-WINNER(B317)*100;

A18:=WINNER(B317)*100-WINNER(B318)*100;

A19:=WINNER(B318)*100-WINNER(B319)*100;

A20:=WINNER(B319)*100-WINNER(B320)*100;

A21:=WINNER(B320)*100-WINNER(B321)*100;

A22:=WINNER(B321)*100-WINNER(B322)*100;

A23:=WINNER(B322)*100-WINNER(B323)*100;

A24:=WINNER(B323)*100-WINNER(B324)*100;

A25:=WINNER(B324)*100-WINNER(B325)*100;

A26:=WINNER(B325)*100-WINNER(B326)*100;

A27:=WINNER(B326)*100-WINNER(B327)*100;

A28:=WINNER(B327)*100-WINNER(B328)*100;

A29:=WINNER(B328)*100-WINNER(B329)*100;

A30:=WINNER(B329)*100-WINNER(B330)*100;

A31:=WINNER(B330)*100-WINNER(B331)*100;

A32:=WINNER(B331)*100-WINNER(B332)*100;

A33:=WINNER(B332)*100-WINNER(B333)*100;

A34:=WINNER(B333)*100-WINNER(B334)*100;

A35:=WINNER(B334)*100-WINNER(B335)*100;

A36:=WINNER(B335)*100-WINNER(B336)*100;

A37:=WINNER(B336)*100-WINNER(B337)*100;

A38:=WINNER(B337)*100-WINNER(B338)*100;

A39:=WINNER(B338)*100-WINNER(B339)*100;

A40:=WINNER(B339)*100-WINNER(B340)*100;

A41:=WINNER(B340)*100-WINNER(B341)*100;

A42:=WINNER(B341)*100-WINNER(B342)*100;

A43:=WINNER(B342)*100-WINNER(B343)*100;

A44:=WINNER(B343)*100-WINNER(B344)*100;

A45:=WINNER(B344)*100-WINNER(B345)*100;

A46:=WINNER(B345)*100-WINNER(B346)*100;

A47:=WINNER(B346)*100-WINNER(B347)*100;

A48:=WINNER(B347)*100-WINNER(B348)*100;

A49:=WINNER(B348)*100-WINNER(B349)*100;

A50:=WINNER(B349)*100-WINNER(LB)*100;

MAX1:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(A1,A2),A3),A4),A5),A6),A7),A8),A9),A10);

MAX2:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(A11,A12),A13),A14),A15),A16),A17),A18),A19),A20);

MAX3:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(A21,A22),A23),A24),A25),A26),A27),A28),A29),A30);

MAX4:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(A31,A32),A33),A34),A35),A36),A37),A38),A39),A40);

MAX5:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(A41,A42),A43),A44),A45),A46),A47),A48),A49),A50);

最大值:=MAX(MAX(MAX(MAX(MAX1,MAX2),MAX3),MAX4),MAX5),NODRAW;

筹码线:=IF(最大值=A1,HB,IF(最大值=A2,B31,IF(最大值=A3,B32,IF(最大值=A4,B33,IF(最大值=A5,B34,IF(最大值=A6,B35,IF(最大值=A7,B36,IF(最大值=A8,B37,IF(最大值=A9,B38,IF(最大值=A10,B39,

IF(最大值=A11,B310,IF(最大值=A12,B311,IF(最大值=A13,B312,IF(最大值=A14,B313,IF(最大值=A15,B314,IF(最大值=A16,B315,IF(最大值=A17,B316,IF(最大值=A18,B317,IF(最大值=A19,B318,IF(最大值=A20,B319,

IF(最大值=A21,B320,IF(最大值=A22,B321,IF(最大值=A23,B322,IF(最大值=A24,B323,IF(最大值=A25,B324,IF(最大值=A26,B325,IF(最大值=A27,B326,IF(最大值=A28,B327,IF(最大值=A29,B328,IF(最大值=A30,B329,

IF(最大值=A31,B330,IF(最大值=A32,B331,IF(最大值=A33,B332,IF(最大值=A34,B333,IF(最大值=A35,B334,IF(最大值=A36,B335,IF(最大值=A37,B336,IF(最大值=A38,B337,IF(最大值=A39,B338,IF(最大值=A40,B339,

IF(最大值=A41,B340,IF(最大值=A42,B341,IF(最大值=A43,B342,IF(最大值=A44,B343,IF(最大值=A45,B344,IF(最大值=A46,B345,IF(最大值=A47,B346,IF(最大值=A48,B347,IF(最大值=A49,B348,IF(最大值=A50,B349,LB)))))))))))))))))))))))))))))))))))))))))))))))))),LINETHICK2,COLORFF00FF;

最高筹峰:筹码线,LINETHICK1,COLORFF0000;

IF(C>筹码线,筹码线,DRAWNULL),LINETHICK2,COLORFF00FF;

最高筹峰密集度%:(WINNER(筹码线*1.1)-WINNER(筹码线*0.9))*100,NODRAW;

MA10:=MA(CLOSE,10),COLORYELLOW,LINETHICK0;

MA54:=MA(CLOSE,54),COLORFFCCCC,LINETHICK0;

PL1:=(((CLOSE - MA54) / MA54) < 0.1);

PL2:=(((CLOSE - MA10) / MA10) < 0.3);

偏离率:=(((PL1 = 1) AND (PL2 = 1)) * 0.2);

平台突破:=((((偏离率 = 0) AND (REF(偏离率,1) = 0.2)) AND (REF((COUNT((偏离率 = 0.2),10) = 10),1) = 1)) * 1);

DRAWTEXT(平台突破,L,'=================='),COLORWHITE;

底: HHV(HIGH,70)*0.83,DOTLINE,COLORGREEN;

IF(C>底,底,DRAWNULL),LINETHICK2,COLORRED;

DRAWTEXT(ISLASTBAR,底,'===底'),COLORGREEN;

{筹码峰长}

STICKLINE(ISLASTBAR,HB ,HB ,A1*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B31 ,B31 ,A1*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B32 ,B32 ,A2*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B33 ,B33 ,A3*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B34 ,B34 ,A4*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B35 ,B35 ,A5*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B36 ,B36 ,A6*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B37 ,B37 ,A7*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B38 ,B38 ,A8*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B39 ,B39 ,A9*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B310 ,B310 ,A10*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B311 ,B311 ,A11*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B312 ,B312 ,A12*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B313 ,B313 ,A13*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B314 ,B314 ,A14*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B315 ,B315 ,A15*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B316 ,B316 ,A16*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B317 ,B317 ,A17*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B318 ,B318 ,A18*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B319 ,B319 ,A19*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B320 ,B320 ,A20*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B321 ,B321 ,A21*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B322 ,B322 ,A22*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B323 ,B323 ,A23*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B324 ,B324 ,A24*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B325 ,B325 ,A25*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B326 ,B326 ,A26*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B327 ,B327 ,A27*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B328 ,B328 ,A28*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B329 ,B329 ,A29*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B330 ,B330 ,A30*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B331 ,B331 ,A31*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B332 ,B332 ,A32*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B333 ,B333 ,A33*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B334 ,B334 ,A34*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B335 ,B335 ,A35*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B336 ,B336 ,A36*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B337 ,B337 ,A37*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B338 ,B338 ,A38*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B339 ,B339 ,A39*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B340 ,B340 ,A40*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B341 ,B341 ,A41*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B342 ,B342 ,A42*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B343 ,B343 ,A43*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B344 ,B344 ,A44*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B345 ,B345 ,A45*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B346 ,B346 ,A46*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B347 ,B347 ,A47*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,B348 ,B348 ,A48*50 ,0 ),COLORGRAY;

STICKLINE(ISLASTBAR,LB ,LB ,A50*50 ,0 ),COLORGRAY;

{分组最长筹码}

{公式}

STICKLINE(ISLASTBAR AND A1 =MAX(MAX1,MAX2),HB ,HB ,A1*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A1 =MAX(MAX1,MAX2),B31 ,B31 ,A1*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A2 =MAX(MAX1,MAX2),B32 ,B32 ,A2*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A3 =MAX(MAX1,MAX2),B33 ,B33 ,A3*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A4 =MAX(MAX1,MAX2),B34 ,B34 ,A4*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A5 =MAX(MAX1,MAX2),B35 ,B35 ,A5*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A6 =MAX(MAX1,MAX2),B36 ,B36 ,A6*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A7 =MAX(MAX1,MAX2),B37 ,B37 ,A7*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A8 =MAX(MAX1,MAX2),B38 ,B38 ,A8*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A9 =MAX(MAX1,MAX2),B39 ,B39 ,A9*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A10 =MAX(MAX1,MAX2),B310 ,B310 ,A10*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A11 =MAX(MAX1,MAX2),B311 ,B311 ,A11*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A12 =MAX(MAX1,MAX2),B312 ,B312 ,A12*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A13 =MAX(MAX1,MAX2),B313 ,B313 ,A13*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A14 =MAX(MAX1,MAX2),B314 ,B314 ,A14*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A15 =MAX(MAX1,MAX2),B315 ,B315 ,A15*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A16 =MAX(MAX1,MAX2),B316 ,B316 ,A16*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A17 =MAX(MAX1,MAX2),B317 ,B317 ,A17*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A18 =MAX(MAX1,MAX2),B318 ,B318 ,A18*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A19 =MAX(MAX1,MAX2),B319 ,B319 ,A19*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A20 =MAX(MAX1,MAX2),B320 ,B320 ,A20*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A21 =MAX3,B321 ,B321 ,A21*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A22 =MAX3,B322 ,B322 ,A22*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A23 =MAX3,B323 ,B323 ,A23*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A24 =MAX3,B324 ,B324 ,A24*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A25 =MAX3,B325 ,B325 ,A25*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A26 =MAX3,B326 ,B326 ,A26*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A27 =MAX3,B327 ,B327 ,A27*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A28 =MAX3,B328 ,B328 ,A28*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A29 =MAX3,B329 ,B329 ,A29*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A30 =MAX3,B330 ,B330 ,A30*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A31 =MAX(MAX4,MAX5),B331 ,B331 ,A31*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A32 =MAX(MAX4,MAX5),B332 ,B332 ,A32*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A33 =MAX(MAX4,MAX5),B333 ,B333 ,A33*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A34 =MAX(MAX4,MAX5),B334 ,B334 ,A34*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A35 =MAX(MAX4,MAX5),B335 ,B335 ,A35*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A36 =MAX(MAX4,MAX5),B336 ,B336 ,A36*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A37 =MAX(MAX4,MAX5),B337 ,B337 ,A37*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A38 =MAX(MAX4,MAX5),B338 ,B338 ,A38*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A39 =MAX(MAX4,MAX5),B339 ,B339 ,A39*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A40 =MAX(MAX4,MAX5),B340 ,B340 ,A40*50 ,0 ),COLORYELLOW;

STICKLINE(ISLASTBAR AND A41 =MAX(MAX4,MAX5),B341 ,B341 ,A41*50 ,0 ),COLORYELLOW;

Tags:筹码最长测试通达信

本文仅代表作者观点,不代表财富炒股学习网立场。

本文系作者授权炒股学习网发表。

炒股学习网(www.cf7.com.cn)提醒您:股市有风险,投资需谨慎。

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>