分享

“月线反转”6.0版本的选股公式

 沐阳flells1leu 2022-06-27 发表于上海

2022年6月27日

交易时复盘、非交易时干货分享

本复盘仅为鄙人的股市思考历程,非荐股!请勿未经思考盲目跟票。本人有中长线和短线两个账户分开操作,仅供大家探讨学习。

      请要使用这一公式的学友们去陶博士的公众号付费阅读,昨天我已经被好几位学友给批评教育了,说我不该这么早就把公式给公布出来。

      无奈后台咨询的人实在太多,有的是刚学“欧奈尔技术”不久不知道怎么设置公式?有的是进去博士的公众号后说看不懂?发现不能复制粘贴被难住了?还有的是说年纪大了压根儿就不会弄?仍是要我快点给写个流程给贴出来,我也是架不住这么多热情学友的学习精神就给贴出了。

      我知道因各种原因还不会弄而又想快点使用起来的学友们的着急的心,也理解他们的心情,因为我自己就是这样过来的,为了让不懂技术和设置的人能够快点使用上陶博士的这一利器,争取不落后大神们太多,我考虑再三:决定在页首提示大家去陶博士公众号付费阅读一下,再来我这里就可以简单的复制下载安装公式了。我想博士要是知道这个事情应该也不会反感,毕竟这是将他的技术发扬光大,福泽众学友们。而且我已经在文首和留言置顶贴里分别号召大家去付费阅读并打赏,还望意见的学友们能够海涵!

安装步数:

1、通达信系统按CTRL+F

图片

2、进到这个界面后点“条件选股公式”,然后鼠标双击“其它类型”。

图片

3、进到这个界面后鼠标点击“新建”

图片

4、按照以上示意图设置好公式名称及参数,然后在编写程序的空白处复制我下面发的源代码,最后点击确定保存就可以使用了。

公式源码:

Z:=EXTDATA_USER(3,0);{50天的}

RPS50:=Z/10;

FYX11:=IF(RPS50<=87,0,1);{RPS50大于87}

RPS5090:=IF(RPS50>=90,1,0);{RPS50大于90}

FYX120:=COUNT(RPS5090,60);

FYX121:=HHV(C,5)>=HHV(C,80) OR HHV(H,5)>=HHV(H,80);{80日最高收盘价,或者创80日最高价}

FYX12:=FYX120>12 AND FYX121;{60天内RPS50大于90的天数多于12天,且创80日新高}

FYX13:=FYX120>18 AND FYX121 AND RPS50>=90;{60天内RPS50大于90的天数多于18天,且创80日新高,且当天RPS50大于90。在后面被FYX62FYX72引用}

FYX1:=FYX11 OR FYX12;

FYX21:=LLV(L,50)>LLV(L,250) AND RPS50>=90;{50日内最低价大于250日内最低价,RPS50大于90}

FYX22:=LLV(L,50)>LLV(L,200);{50日内最低价大于200日内最低价}

FYX23:=LLV(L,30)>LLV(L,200) AND HHV(H,5)>=HHV(H,200);{30日内最低价大于200日内最低价,且创200日新高}

FYX24:=LLV(L,30)>LLV(L,120) AND FYX12;{30日内最低价大于120日内最低价,且60天内RPS50大于90的天数多于12}

FYX25:=LLV(L,20)>LLV(L,50);{20日内最低价大于50日内最低价}

FYX2:=(FYX21 OR FYX22 OR FYX23 OR FYX24) AND FYX25;{结构紧凑的重要条件}

NH80:=IF(H<HHV(H,80),0,1);

FYX31:=COUNT(NH80,10);{10天内曾创80日新高}

FYX32:=(C>=HHV(C,50) OR H>=HHV(H,50)) AND RPS50>=90;{当天创50日最高收盘价或50日最高价,RPS50大于90}

FYX3:=FYX31 OR FYX32;

FYX4:=C>MA(C,200) AND MA(C,120)/MA(C,200)>0.85;{当天收盘价必须站上200天线}

NN200:=IF(C>MA(C,200),1,0);{当天收盘价大于200天线}

AA200:=COUNT(NN200,45);

FYX51:=AA200>2 AND AA200<45;{45天内,收盘价站上200天线的天数大于2,小于45}

LNN200:=IF(L<MA(C,200),1,0);

LAA200:=COUNT(LNN200,45);

FYX52:=LAA200>0 AND AA200>2;{45天内,至少有一天的最低价低于200天线;且至少站上200天线3天以上}

FYX5:=FYX51 OR FYX52;

FYX61:=HHV(H,30)/LLV(L,150)<1.55;{30天内最高价与150日内最低价之比小于1.55}

FYX62:=HHV(H,30)/LLV(L,150)<1.75 AND FYX13;{30天内最高价与150日内最低价之比小于1.75,且满足FYX13}

FYX6:=FYX61 OR FYX62;

FYX71:=HHV(H,5)/HHV(H,120)>0.85;{5天内最高价距离120日内的最高价不到15%}

FYX72:=HHV(H,5)/HHV(H,120)>0.8 AND FYX13;{5天内最高价距离120日内的最高价不到20%,且满足FYX13}

FYX7:=FYX71 OR FYX72;

YXFZ:=FYX1 AND FYX2 AND FYX3 AND FYX4 AND FYX5 AND FYX6 AND FYX7;

BARSSINCEN(YXFZ,15)=0;

友情提醒:今天在复制拷贝陶博士的公式至通达信时多次提示有误不能成功,后经仔细检查,发现是倒数第二行的源码后面有个“?”,去掉就好了,但返回检查时发现复制下来的源码又没有这个符号,不知是什么原因?可能是转换导致的问题,如果大家和我遇到一样的问题可以同样处理。

到这一步公式就安装完毕了,接下来就进入选股的流程了:

1、通达信系统按CTRL+T,选择好刚刚建立的“月反6.0”的公式----点加入条件----选股范围选择“基金持股3%北上资金1千万”----再点“选股入板块”

图片

2、进到这个界面后选择自定义板块里“月反6.0”,再点“确定”,

图片

图片

3、下面就是今天选出来的4只个股,千万不能当成买卖依据,任何股票的买入都必须结合1基本面、2板块效应、3资金介入的程度。

图片

扫地僧2008只是自己的投资日记,立此存照,激励自己,坚定前行。所述的分析、个股提示仅供参考,不构成任何投资建议!据此操作,风险自负。

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。
    转藏 分享 献花(0

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多