分享

通达信自用操盘优化成交量实战操作控盘强度新庄杀手未加密选股指标公式源码编程思路破译

 发现探索 2022-08-09 发表于黑龙江

编程思路:

输出多:收盘价的3日指数移动平均,画蓝色

输出空:收盘价的5日指数移动平均,COLOR00FF00

输出均衡:空的5日指数移动平均,画红色,

VARF1赋值:统计2日中满足多上穿均衡的天数=1

VARF2赋值:统计2日中满足空上穿均衡的天数=1

ZAI赋值:VARF1ANDVARF2的2日过滤

当满足条件ZAI时,在均衡位置书写文字,COLORFF00FF

VV2赋值:1日前的收盘价

VV3赋值:(收盘价-VV2)的6日[1日权重]移动平均/收盘价-VV2的绝对值的6日[1日权重]移动平均*100

当满足条件1日前的VV3>81ANDVV3<80时,在最高价位置画2号图标

当满足条件1日前的VV3>81ANDVV3<80时,在最高价*1.03位置书写文字

'),画蓝色

VF1赋值:收盘价的60日简单移动平均-收盘价的5日简单移动平均/3.2

当满足条件如果收盘价<VF1ANDVOL/240>成交量(手)的5日简单移动平均/240ANDCLOSE>=1日前的收盘价*1.08ANDCLOSE<收盘价的13日简单移动平均*1.3,返回1,否则返回0时,在最低价位置书写文字,画白色

VARA赋值:(收盘价-29日前的开盘价)/29日前的开盘价*100

VARB赋值:0.667*1日前的VARA+0.333*VARA的5日指数移动平均

当满足条件如果成交量(手)>=1.3*成交量(手)的5日简单移动平均ANDCOUNT(VARA>=VARBANDVARA<-17,3)ANDREF(最低价,1)=120日内最低价的最低值,返回1,否则返回0时,在最低价位置书写文字

VARR1赋值:收盘价-1日前的收盘价和0的较大值的6日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的6日[1日权重]移动平均*100

当满足条件82上穿VARR1时,在最高价位置画2号图标

当满足条件82上穿VARR1时,在最高价位置书写文字

'),画蓝色

VAR1赋值:(最高价+最低价+开盘价+2*收盘价)/5

VAR2赋值:1日前的VAR1

VAR3赋值:VAR1-VAR2和0的较大值的10日[1日权重]移动平均/VAR1-VAR2的绝对值的10日[1日权重]移动平均*100

HY3赋值:如果统计5日中满足VAR3<20的天数>=1ANDCOUNT(VAR1=10日内VAR1的最低值,10)>=1ANDCLOSE>=开盘价*1.038ANDVOL>成交量(手)的5日简单移动平均*1.2,返回1,否则返回0

当满足条件HY3时,在最低价位置书写文字,画白色

S赋值:成交量(手)的5日简单移动平均/成交量(手)的60日简单移动平均,画白色,,线宽为2

A赋值:S的5日简单移动平均,画青色,,线宽为2

BIAS赋值:(收盘价-收盘价的5日简单移动平均)/收盘价的5日简单移动平均*100

F赋值:S的121日简单移动平均

RSV赋值:(收盘价-45日内最低价的最低值)/(45日内最高价的最高值-45日内最低价的最低值)*100

K赋值:RSV的15日[1日权重]移动平均

D赋值:K的15日[1日权重]移动平均

J赋值:3*K-2*D

LC赋值:1日前的收盘价

RSI赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100

当满足条件84上穿RSI时,在最高价*1.06位置书写文字,画蓝色

S1赋值:如果(J<11ANDBIAS>-11ANDCROSS(S,F)AND(S-F)>0.010),返回2,否则返回0,STICK,线宽为3,画青色

当满足条件S1=2时,在最低价位置书写文字, 画青色

输出中轨:13日内最高价的13日简单移动平均的最高值,画白色,线宽为2

公式源码:

多:Ema(C,3),COLORBLUE;

空:ema(C,5),COLOR00FF00;

均衡:EMA(空,5),COLORRED,;

VARF1:=COUNT(crOSS(多,均衡),2)=1;

VARF2:=COUNT(CROSS(空,均衡),2)=1;

ZAI:=FILTER(VARF1 AND VARF2,2);

DRAWTEXT(ZAI,均衡,'主升↑'),COLORFF00FF;

VV2:=REF(CLOSE,1);

VV3:=SMA((CLOSE-VV2),6,1)/SMA(Abs(CLOSE-VV2),6,1)*100;

DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2);

DRAWTEXT(REF(VV3,1)>81 AND VV3<80,HIGH*1.03,'沽空&darr;'),COLORBLUE;

VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;

DRAWTEXT(IF(CLOSE<VF1 AND vol/240>MA(VOL,5)/240 AND CLOSE>=REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'☆'),COLORWHITE;

VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);

DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VARA>=VARB AND VARA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入');

VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;

DRAWICON(CROSS(82,VARR1),HIGH,2);

DRAWTEXT(CROSS(82,VARR1),HIGH,'短空&darr;'),COLORBLUE;

VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;

VAR2:=REF(VAR1,1);

VAR3:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;

HY3:=IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);

DRAWTEXT(HY3,LOW,'注意买入'),COLORWHITE;

S:=MA(VOL,5)/MA(VOL,60),COLORWHITE,,LINETHICK2;

A:=MA(S,5),COLORCYAN,,LINETHICK2;

bias:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;

F:=MA(S,121);

RSV:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;

K:=SMA(RSV,15,1);

D:=SMA(K,15,1);

J:=3*K-2*D;

LC:=REF(CLOSE,1);

rsi:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

DRAWTEXT(CROSS(84,RSI) , HIGH*1.06,'逃顶!'),COLORBLUE ;

S1:=IF((J<11 AND BIAS>-11 AND CROSS( S,F) AND (S-F)>0.010),2,0),STICK,LINETHICK3,COLORCYAN;

DRAWTEXT(S1=2,LOW,'关注'), COLORCYAN;

中轨:HHV(MA(H,13),13),COLORWHITE,LINETHICK2;

趋势:LLV(MA(H,13),1),COLORCYAN,LINETHICK2;

    转藏 全屏 打印 分享 献花(0

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多