分享

通达信有大资金就关注副图未加密选股指标公式源码编程思路破译

 发现探索 2022-08-09 发表于黑龙江

编程思路:

VA1赋值:100-3*(收盘价-65日内最低价的最低值)/(80日内最高价的最高值-65日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-65日内最低价的最低值)/(80日内最高价的最高值-65日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均

VA2赋值:100-3*(开盘价-65日内最低价的最低值)/(80日内最高价的最高值-65日内最低价的最低值)*100的20日[1日权重]移动平均+2*(开盘价-65日内最低价的最低值)/(80日内最高价的最高值-65日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均

VA3赋值:VA1<1日前的VA2 AND 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的收盘价

当满足条件VA3ANDCOUNT(VA3,30)=1时,在15位置书写文字,线宽为1,COLORFF00FF

A赋值:以收盘价+收盘价*15/100计算的获利盘比例*100

B赋值:以收盘价+收盘价*0/100计算的获利盘比例*100

CC赋值:A-B

D赋值:(以收盘价-收盘价*0.1/100计算的获利盘比例-以收盘价-收盘价*15/100计算的获利盘比例)*100

E赋值:CC<3 AND D<0.5 AND 开盘价不等于最低价

A1赋值:最低价

A2赋值:如果最低价>A1,返回0,否则返回如果最高价<A1,返回1,否则返回(A1-最低价+0.01)/(最高价-最低价+0.01)

A3赋值:成交量(手)/以最低价计算的获利盘比例

A4赋值:1日前的120日内收盘价的最高值

A5赋值:1日前的120日内收盘价的最低值

A6赋值:100*(收盘价-A5)/(A4-A5)

A7赋值:A2>0 OR A2=1

A8赋值:A7 AND A3/3日前的A3>=3 AND A6<80

A9赋值:1日前的A8 OR 2日前的A8 OR 3日前的A8 OR 4日前的A8

A10赋值:A8 AND A9

A11赋值:如果A8的3日过滤,返回5,否则返回0

A12赋值:如果A10的3日过滤ORE,返回10,否则返回0

输出资金进场日:如果A11>0,返回8,否则返回无效数,COLOR00FFFF,线宽为3,STICK

输出资金加仓日:如果A12>0,返回15,否则返回无效数,COLORFF00FF,线宽为4,STICK

当满足条件A11时,在8位置书写文字

当满足条件A12时,在17位置书写文字

VAR1赋值:(收盘价*2+最高价+最低价)/4*10

VAR2赋值:VAR1的13日指数移动平均-VAR1的34日指数移动平均

VAR3赋值:VAR2的5日指数移动平均

VAR4赋值:2*(VAR2-VAR3)*5.5

输出主力:VAR4,画白色,线宽为2

公式源码:

VA1:=100-3*Sma((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);


VA2:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);


VA3:=VA1<REF(VA2,1) AND vol>REF(VOL,1) AND CLOSE>REF(CLOSE,1);


DRAWTEXT(VA3 AND COUNT(VA3,30)=1,15,'有大资金进 关注'),LINETHICK1,COLORFF00FF;


A:=WINNER(CLOSE+CLOSE*15/100)*100;


B:=WINNER(CLOSE+CLOSE*0/100)*100;


CC:=A-B;


D:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;


E:=CC<3 AND D<0.5 AND OPEN!=LOW;


A1:=DYnaINFO(6);


A2:=IF(LOW>A1,0,IF(HIGH<A1,1,(A1-LOW+0.01)/(HIGH-LOW+0.01)));


A3:=VOL/WINNER(LOW);


A4:=REF(HHV(CLOSE,120),1);


A5:=REF(LLV(CLOSE,120),1);


A6:=100*(CLOSE-A5)/(A4-A5);


A7:=A2>0 OR A2=1;


A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80;


A9:=REF(A8,1) OR REF(A8,2) OR REF(A8,3) OR REF(A8,4);


A10:=A8 AND A9;


A11:=IF(FILTER(A8,3),5,0);


A12:=IF(FILTER(A10,3) OR E,10,0);


资金进场日:IF(A11>0,8,DRAWNULL),COLOR00FFFF,LINETHICK3,STICK;


资金加仓日:IF(A12>0,15,DRAWNULL),COLORFF00FF,LINETHICK4,STICK;


DRAWTEXT(A11,8,'资金进场');


DRAWTEXT(A12,17,'资金加仓');


VAR1:=(CLOSE*2+HIGH+LOW)/4*10;


VAR2:=ema(VAR1,13)-EMA(VAR1,34);


VAR3:=EMA(VAR2,5);VAR4:=2*(VAR2-VAR3)*5.5;


主力:VAR4,COLORWHITE,LINETHICK2;

    转藏 全屏 打印 分享 献花(0

    0条评论

    发表

    请遵守用户 评论公约

    类似文章