分享

狙击下影线之狙击选股公式源码编程思路破译及成功率回测数据

 发现探索 2022-08-09 发表于黑龙江

​编程思路破译:

CS赋值:(最高价-收盘价和开盘价的较大值)/(收盘价和开盘价的较小值-最低价)<=0.03

PP赋值:最高价/最低价>=1.03

TT赋值:收盘价和开盘价的较大值/收盘价和开盘价的较小值<=1.02

AA赋值:(CS AND PP AND TT)*0.3

JJJ赋值:(最低价-收盘价和开盘价的较小值)/开盘价<0.99

FFF赋值:收盘价和开盘价的较小值-最低价>最高价-收盘价和开盘价的较大值

DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均

DEA赋值:DIF的9日指数移动平均

SS赋值:DIF>DEA

小李探花1赋值: AA AND 收盘价>收盘价的60日简单移动平均 AND SS AND 收盘价>收盘价的20日简单移动平均 AND JJJ AND FFF

输出选股:小李探花1 AND 1日前的小李探花1<1 AND 6日前的小李探花1<1 AND 2日前的小李探花1<1 AND 3日前的小李探花1<1 AND 4日前的小李探花1<1 AND 5日前的小李探花1<1

条件选股:狙击[日线]成功率测试

测试股票数:4597

共发出信号:37839成功信号:18681失败信号:18989未完成信号:169

信号发出率:83.71%平均成功率:49.59%成功率达到50%的股票数有:54.26%

利润1总平均:13.74%最大平均利润1:  133.56%  最小平均利润1: 0.00%

利润2总平均:0.48%最大平均利润2:  98.34%  最小平均利润2:  -41.74%

公式源码:

CS:=(H-MAX(C,O))/(MIN(C,O)-L)<=0.03;
PP:=H/L>=1.03;
TT:=MAX(C,O)/MIN(C,O)<=1.02;
AA:=(CS AND PP AND TT)*0.3;
JJJ:=(L-MIN(C,O))/O<0.99;
FFF:=MIN(C,O)-L>H-MAX(C,O);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
SS:=DIF>DEA;
小李探花1:= AA AND C>MA(C,60) AND SS AND C>MA(C,20) AND JJJ AND FFF;
狙击下影线之狙击:小李探花1 AND REF(小李探花1,1)<1 AND REF(小李探花1,6)<1 AND REF(小李探花1,2)<1 AND REF(小李探花1,3)<1 AND REF(小李探花1,4)<1 AND REF(小李探花1,5)<1;

    转藏 全屏 打印 分享 献花(0

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多