分享

通达信个股强弱指标公式

 pharl 2022-08-12 发表于福建
N:=13;M:=5;{移动平均参数}
SCCD:=stR2CON(DPZSCODE);
LC:=REF(CLOSE,1);
HYC:=HY_INDEXC;{行业收盘价}
HYLC:=REF(HYC,1);
Srsi:=SMA(maX(CLOSE-LC,0),N,1)/(SMA(Abs(CLOSE-LC),N,1))*100;{个股相对强弱}
HYRSI:=SMA(MAX(HYC-HYLC,0),N,1)/(SMA(ABS(HYC-HYLC),N,1))*100;{行业相对强弱}
DPRSI:=SMA(MAX(INDEXC-REF(INDEXC,1),0),N,1)/(SMA(ABS(INDEXC-REF(INDEXC,1)),N,1))*100;{大盘相对强弱}
个股:MA(SRSI,M),LINETHICK2,COLORRED;{个股相对强弱均线}
行业:MA(HYRSI,M),COLORYELLOW;{行业相对强弱均线}
大盘:MA(DPRSI,M),COLORCYAN;{大盘相对强弱均线};
DRAWTEXT_FIX(1,0,0,0, STRCAT(HYBLOCK,STRCAT(' + ', STRCAT(GNBLOCK,STRCAT('+ ', EXTERNSTR(0,1)))))),COLORWHITE;
Z1:=STRCAT(HYBLOCK,'----');
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,'----');
沪A涨家数:="999999$ADVANCE",COLORRED,NODRAW;
沪A跌家数:="999999$DECLINE",COLORGREEN,NODRAW;
深A涨家数:="399107$ADVANCE",COLORRED,NODRAW;
深A跌家数:="399107$DECLINE",COLORGREEN,NODRAW;
上涨总家数:沪A涨家数+深A涨家数,COLORRED,NODRAW;
上涨总家数比:(沪A涨家数+深A涨家数)/(沪A涨家数+沪A跌家数+深A涨家数+深A跌家数)*100,COLORRED,NODRAW;
下跌总家数:沪A跌家数+深A跌家数,COLORGREEN,NODRAW;
下跌总家数比:(沪A跌家数+深A跌家数)/(沪A涨家数+沪A跌家数+深A涨家数+深A跌家数)*100,COLORGREEN,NODRAW;
涨停数:="880006$C",NODRAW;
E1:=CON2STR(涨停数,0);
E2:=STRCAT(E1,' 家');
E3:=STRCAT('大盘涨停数: ',E2);
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ISLASTBAR,0.001,0.9,0,E3),COLORRED;
跌停数:="880006$O",NODRAW;
F1:=CON2STR(跌停数,0);
F2:=STRCAT(F1,' 家');
F3:=STRCAT('大盘跌停数: ',F2);
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND ISLASTBAR,0.075,0.9,0,F3),COLORGREEN;
X1:=个股,NODRAW;
BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;
DRAWTEXT(FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10) AND 大盘>REF(大盘,1) AND UPNDAY(行业,2) AND 个股<45 ,X1*0.99,'★∠45'),COLORFFFFFF;
STICKLINE(个股<30 AND 行业<30 AND 大盘<30 ,23,30,2,0),COLOR008888;
30,DOTLINE,COLORYELLOW;
60,DOTLINE,COLORLIRED;

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。
    转藏 全屏 打印 分享 献花(0

    0条评论

    发表

    请遵守用户 评论公约

    类似文章