分享

通达信-寻龙诀-精选指标

 通达信指标合集 2022-10-17 发表于江苏

  

副图指标源码

X_1:=MA(CLOSE,10);
X_2:=MA(CLOSE,55);
X_3:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
X_4:=FILTER(X_3,10);
X_5:=BARSLAST(X_4);
X_6:=REF(HIGH,X_5+2);
X_7:=REF(HIGH,X_5+1);
X_8:=REF(HIGH,X_5);
X_9:=MAX(X_6,X_7);
X_10:=MAX(X_9,X_8);
X_11:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
X_12:=X_5<150;
X_13:=(OPEN-X_10)/X_10*100<30;
X_14:=(CLOSE-LLV(LOW,X_5))/LLV(LOW,X_5)*100<50;
X_15:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
X_16:=VOL/MA(VOL,5)<3.5;
X_17:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
X_18:=X_11 AND X_12 AND X_13 AND X_14 AND X_15 AND X_16 AND X_17;
X_19:=FILTER(X_18,15);
X_20:=(CLOSE-X_2)/X_2<0.1;
X_21:=(CLOSE-X_1)/X_1<0.3;
X_22:=(X_20=1 AND X_21=1)*0.2;
X_23:=(X_22=0 AND REF(X_22,1)=0.2 AND REF(COUNT(X_22=0.2,10)=10,1)=1)*(-0.1);
X_24:=X_23=(-0.1);
X_25:=X_19 OR X_24;
X_26:=DYNAINFO(7)/REF(CLOSE,1)>1.05 AND DYNAINFO(7)/OPEN>1.05;
X_27:=VOL/REF(VOL,1)>1.2 AND CLOSE>OPEN OR (LOW>REF(HIGH,1) AND OPEN>CLOSE AND VOL/REF(VOL,1)>1.2);
X_28:=IF(CODELIKE(3) OR (CODELIKE(4) AND DATE>=1200824),CLOSE>=ZTPRICE(REF(CLOSE,1),0.2) AND CLOSE=HIGH,CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND CLOSE=HIGH);
X_29:=X_25 AND X_26 AND X_27 AND X_28 AND REF(NOT(X_28),1);
STICKLINE(X_29,0,1,2,0),COLORRED;
公:DRAWNULL,COLORCCCCCC;众:DRAWNULL,COLORCCCCCC;号:DRAWNULL,COLORCCCCCC;
指标公式合集:DRAWNULL,COLORCCCCCC;
选股指标源码
X_1:=MA(CLOSE,10);
X_2:=MA(CLOSE,55);
X_3:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
X_4:=FILTER(X_3,10);
X_5:=BARSLAST(X_4);
X_6:=REF(HIGH,X_5+2);
X_7:=REF(HIGH,X_5+1);
X_8:=REF(HIGH,X_5);
X_9:=MAX(X_6,X_7);
X_10:=MAX(X_9,X_8);
X_11:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
X_12:=X_5<150;
X_13:=(OPEN-X_10)/X_10*100<30;
X_14:=(CLOSE-LLV(LOW,X_5))/LLV(LOW,X_5)*100<50;
X_15:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
X_16:=VOL/MA(VOL,5)<3.5;
X_17:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
X_18:=X_11 AND X_12 AND X_13 AND X_14 AND X_15 AND X_16 AND X_17;
X_19:=FILTER(X_18,15);
X_20:=(CLOSE-X_2)/X_2<0.1;
X_21:=(CLOSE-X_1)/X_1<0.3;
X_22:=(X_20=1 AND X_21=1)*0.2;
X_23:=(X_22=0 AND REF(X_22,1)=0.2 AND REF(COUNT(X_22=0.2,10)=10,1)=1)*(-0.1);
X_24:=X_23=(-0.1);
X_25:=X_19 OR X_24;
X_26:=DYNAINFO(7)/REF(CLOSE,1)>1.05 AND DYNAINFO(7)/OPEN>1.05;
X_27:=VOL/REF(VOL,1)>1.2 AND CLOSE>OPEN OR (LOW>REF(HIGH,1) AND OPEN>CLOSE AND VOL/REF(VOL,1)>1.2);
X_28:=IF(CODELIKE(3) OR (CODELIKE(4) AND DATE>=1200824),CLOSE>=ZTPRICE(REF(CLOSE,1),0.2) AND CLOSE=HIGH,CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND CLOSE=HIGH);
X_29:X_25 AND X_26 AND X_27 AND X_28 AND REF(NOT(X_28),1);

    转藏 分享 献花(0

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多