黑白马2010 / 指标公式 / 波段高低点公式

分享

   

波段高低点公式

2020-09-12  黑白马2010

 

 

A1:=REF(HIGH,3)=HHV(HIGH,2*3+1); B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1); D1:=FILTER(C1,3);{高点}
A2:=REF(LOW,3)=LLV(LOW,2*3+1); B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1); D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR barstatus=2  OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR barstatus=2  OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点}
DRAWLINE(LD,L,HD,H,0),COLORWHITE{,LINETHICK3},POINTDOT;
DRAWLINE(HD,H,LD,L,0),COLORWHITE{,PLINETHICK3},POINTDOT;
J1:=BACKSET(barstatus=2 ,MIN(BARSLAST(HD),BARSLAST(LD))+1); J2:=J1>REF(J1,1);
DRAWLINE(J2,IF(HD,H,L),barstatus=2 ,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),COLORWHITE,POINTDOT;

{以下是两条趋势线原码}
UU:=BACKSET(barstatus=2 ,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
DRAWLINE(XX,L,VV,L,1),COLORFF00FF{,LINETHICK2};
UU2:=BACKSET(barstatus=2 ,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);

前一低:=REF(L,BARSLAST(VV)){,COLOR99FF66,POINTDOT,LINETHICK1};
前二低:=REF(L,BARSLAST(XX)){,COLORFF66FF,POINTDOT,LINETHICK1};
前一高:=REF(H,BARSLAST(VV2)){,COLOR99FF66,POINTDOT,LINETHICK1};
前二高:=REF(H,BARSLAST(XX2)){,COLORFF66FF,POINTDOT,LINETHICK1};
求4看空:h*前一低/if(前一高=h,前二高,前一高);
求4看多:l*前一高/if(前一低=l,前二低,前一低);

〖以上公式在大智慧软件中提示“barstatus 未定义标识符”此问题无法解决,推荐采用下面的公式〗

 

 

{源代码}
High1:=PEAK(1,5,1);
Low1:=TROUGH(2,3 ,1);
High2:=PEAK(1,5,2);
Low2:=TROUGH(2,3 ,2);
DRAWLINE(H=High1,HIGH,L=Low1,LOW,0),COLORblue,LINETHICK2;
DRAWLINE(L=Low1,LOW,H=High1,HIGH,0),COLORRED,LINETHICK2;
波段低点:High1*Low1/high2;
波段高点:High1*Low1/low2;



注释:

HIGH              取得该周期最高价

LOW              取得该周期最低价

PEAK             PEAK(K,N,M,ABS)表示之字转向ZIG(K,N,ABS)的前M个波峰的数值,M必须大于等于1。
                      若ABS为0或省略,则表示相对ZIG转向,否则为绝对ZIG转向


ZIG                ZIG(K,N,ABS),当价格变化量超过N%时转向,
                      K表示 0:开盘价,1:最高价2:最低价,3:收盘价,4:低点采用最低价、高点采用最高价。
                      若ABS为0或省略,则表示相对之字转向,否则为绝对之字转向


TROUGH       TROUGH(K,N,M,ABS)表示之字转向ZIG(K,N,ABS)的前M个波谷的数值,M必须大于等于1。
                      若ABS为0或省略,则表示相对ZIG转向,否则为绝对ZIG转向


DRAWLINE    在图形上绘制直线段。DRAWLINE(COND1,PRICE1,COND2,PRICE2,EXPAND),
                      当COND1条件满足时,在PRICE1位置画直线起点,当COND2条件满足时,
                      COND2条件满足时,在PRICE2位置画直线终点,EXPAND为延长类型。

 

 

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>