梵哥 / 待分类 / 通达信多种背离指标公式

分享

   

通达信多种背离指标公式

2020-09-19  梵哥
X_1:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_2:=EMA(X_1,9);
X_3:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-X_3,0),6,1)/SMA(ABS(CLOSE-X_3),6,1)*100,COLORWHITE;
RSI2:SMA(MAX(CLOSE-X_3,0),12,1)/SMA(ABS(CLOSE-X_3),12,1)*100,COLORYELLOW;
RSI3:SMA(MAX(CLOSE-X_3,0),24,1)/SMA(ABS(CLOSE-X_3),24,1)*100,COLORMAGENTA;
RSI:RSI1-RSI3,COLORSTICK,LINETHICK2;
X_4:=BARSLAST(REF(CROSS(X_1,X_2),1));
X_5:=REF(CLOSE,X_4+1)>CLOSE AND REF(X_1,X_4+1)<X_1 AND CROSS(X_1,X_2);
X_6:=BARSLAST(REF(CROSS(KDJ.K(9,3,3),KDJ.D(9,3,3)),1));
X_7:=REF(CLOSE,X_6+1)>CLOSE AND REF(KDJ.K(9,3,3),X_6+1)<KDJ.K(9,3,3) AND CROSS(KDJ.K(9,3,3),KDJ.D(9,3,3));
X_8:=BARSLAST(REF(CROSS(RSI.RSI1(6,12,24),RSI.RSI2(6,12,24)),1));
X_9:=REF(CLOSE,X_8+1)>CLOSE AND REF(RSI.RSI1(6,12,24),X_8+1)<RSI.RSI1(6,12,24) AND CROSS(RSI.RSI1(6,12,24),RSI.RSI2(6,12,24));
X_10:=BARSLAST(REF(CROSS(X_2,X_1),1));
X_11:=REF(CLOSE,X_10+1)<CLOSE AND REF(X_1,X_10+1)>X_1 AND CROSS(X_2,X_1);
X_12:=BARSLAST(REF(CROSS(KDJ.D(9,3,3),KDJ.K(9,3,3)),1));
X_13:=REF(CLOSE,X_12+1)<CLOSE AND REF(KDJ.K(9,3,3),X_12+1)>KDJ.K(9,3,3) AND CROSS(KDJ.D(9,3,3),KDJ.K(9,3,3));
X_14:=BARSLAST(REF(CROSS(RSI.RSI2(6,12,24),RSI.RSI1(6,12,24)),1));
X_15:=REF(CLOSE,X_14+1)<CLOSE AND REF(RSI.RSI1(6,12,24),X_14+1)>RSI.RSI1(6,12,24) AND CROSS(RSI.RSI2(6,12,24),RSI.RSI1(6,12,24));
MACD底背:IF(X_5>0,(-0.1),0),POINTDOT,COLORRED;
KDJ底背:IF(X_7>0,(-0.1),0),POINTDOT,COLORMAGENTA;
RSI底背:IF(X_9>0,(-0.1),0),POINTDOT,COLORYELLOW;
MACD顶背:IF(X_11>0,0.1,0),POINTDOT,COLORGREEN;
KDJ顶背:IF(X_13>0,0.1,0),POINTDOT,COLORFFCC66;
RSI顶背:IF(X_15>0,0.1,0),POINTDOT,COLORWHITE;
STICKLINE(X_5>0,(-25),0,2,0),COLORRED;
STICKLINE(X_7>0,(-25),0,2,0),COLORMAGENTA;
STICKLINE(X_9>0,(-25),0,2,0),COLORYELLOW;
STICKLINE(X_11>0,25,0,2,0),COLORGREEN;
STICKLINE(X_13>0,25,0,2,0),COLORFFCC66;
STICKLINE(X_15>0,25,0,2,0),COLORWHITE;

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>