分享

0621指标

 凡人sypls 2022-06-23 发表于江苏

涨停回马枪主图

均价线:=AMOUNT/V/100;

C2:=REF(C,1);

涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);

STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;

STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;

STICKLINE(涨停,H,L,0,0),COLORRED;

B1:='';

DRAWTEXT(均价线 AND 涨停,均价线,B1),COLORGREEN;

B3:='';

DRAWTEXT((O+C)/2 AND 涨停,(O+C)/2 ,B3),COLORMAGENTA;

B2:='';

DRAWTEXT(涨停,L,B2),COLORGRAY;

MA13:MA(C,13),COLORGRAY;

MA21:MA(C,21),COLORWHITE;

支撑线:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

LC:=REF(CLOSE,1);

操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;

趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;

震仓线:=45;

震仓线2:=50;

逃命线:=80;

抄底线:=20;

绝底线:=5;

PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;

PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;

PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;

HH:=COUNT(涨停,13)>=1;

STICKLINE(PP2 AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;

STICKLINE(PP AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;

STICKLINE(PP3 AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;

A:=SMA(L,4,3) ;

STICKLINE(A AND REF(PP,1) AND HH ,A*0.9999,A*0.9979,5,0);

DRAWICON(A AND REF(PP,1) AND HH,L*0.98,1);

STICKLINE(A AND REF(PP3,1) AND HH ,A*0.9999,A*0.9979,5,0);

DRAWICON(A AND REF(PP3,1) AND HH,L*0.98,1);

STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;

STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;

DRAWTEXT(涨停,L-0.1,'涨停'),COLORRED;

C3:=REF(C,1);

跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);

STICKLINE(跌停,OPEN,CLOSE,4,0),COLORBLUE;

STICKLINE(跌停,OPEN,CLOSE,3,0),COLORBLUE;

DRAWTEXT(跌停,H+0.3,'跌停'),COLORBLUE;


操盘手主图

MA10:MA(CLOSE,10),LINETHICK1,COLORYELLOW;

MA20:MA(CLOSE,20),LINETHICK1,COLORMAGENTA;

MA62:MA(CLOSE,62),LINETHICK1,COLORGREEN;

{VAR444:=C;

操作:=MA(VAR444,5);

生命线:HHV(操作,13),LINETHICK2,COLORYELLOW;收盘破此线短逃}

愚公:IF(1>10,HIGH*1.03,DRAWNULL),POINTDOT,LINETHICK9,COLORYELLOW;

买线:=EMA(C,4); 

卖线:=EMA(SLOPE(C,20)*10+C,35); 

DRAWICON(CROSS(买线,卖线),LOW*0.98,7);

DRAWICON(CROSS(卖线,买线),HIGH*1.02,8);

STICKLINE(买线>=卖线,LOW,HIGH,0,0),COLORLIRED; 

STICKLINE(买线>=卖线,CLOSE,OPEN,3,2),COLORLIRED; 

STICKLINE(买线<卖线,LOW,HIGH,0,0),COLORCYAN; 

STICKLINE(买线<卖线,CLOSE,OPEN,3,2),COLORCYAN; 

STICKLINE(OPEN>CLOSE,CLOSE,OPEN,2.5,0),COLORCYAN;

涨停:=IF(REF(C,1)*1.095-C<0.01 ,1,0);

STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;

STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;

DRAWTEXT(涨停,L-0.1,'涨停'),COLORRED;

C3:=REF(C,1);

跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);

STICKLINE(跌停,OPEN,CLOSE,4,0),COLORBLUE;

STICKLINE(跌停,OPEN,CLOSE,3,0),COLORBLUE;

DRAWTEXT(跌停,H+0.3,'跌停'),COLORBLUE;

伏击活跃股副图

XN:=3;

上市天数:=BARSCOUNT(C)+1;

MA5:=MA(CLOSE,5);

MA10:=MA(CLOSE,10);

MA20:=MA(CLOSE,20);

MA60:=EMA(CLOSE,60);

MAXX:=IF((上市天数 > 100),MA60,MA20);

均线乖离:=((MA10 - MA60) / MA60);

低吸条件:=((((CLOSE / REF(CLOSE,20)) < 1.20) && (MA10 > REF(MA10,1))) && (CLOSE < (LLV(L,80) * 1.5)));

BIAS10:=((CLOSE - MA10) / MA10);

BIAS20:=((CLOSE - MA20) / MA20);

BIAS60:=((CLOSE - MA60) / MA60);

均价:=((0.01 * AMOUNT) / VOL);

换手率:=(VOL / CAPITAL);

MVOL5:=MA(换手率,5);

MVOL20:=MA(换手率,20);

MVOL60:=EMA(换手率,60);

大阳线:=((CLOSE / REF(CLOSE,1)) > 1.060);

涨停板:=((((CLOSE / REF(CLOSE,1)) > 1.099) && (CLOSE = HIGH)) && (L < C));

一字涨停:=(((CLOSE / REF(CLOSE,1)) > 1.099) && (LOW = HIGH));

冲涨停:=((((((HIGH / REF(CLOSE,1)) > 1.099) || ((CLOSE / REF(CLOSE,1)) > 1.09)) && ((CLOSE / REF(CLOSE,1)) > 1.065)) && ((CLOSE / REF(CLOSE,1)) < 1.0992)) && (CLOSE > 均价));

放量长阳线:=(((((CLOSE / REF(CLOSE,1)) > 1.050) && ((换手率 > REF(换手率,1)) || (换手率 > MAX(MVOL5,MVOL60)))) && (CLOSE > 均价)) && (BIAS10 < 0.12));

标志性阳线:=((涨停板 || 冲涨停) || 放量长阳线);

涨停间隔:=BARSLAST(标志性阳线);

前均价:=REF(均价,涨停间隔);

均线条件:=((REF(LOW,1) < MAX(REF(MA10,1),REF(MA20,1))) && (CLOSE > MA10));

大盘指数:=INDEXC;

大盘均线乖离:=((INDEXC - MA(INDEXC,10)) / MA(INDEXC,10));

相对强弱:=(3 * (BIAS10 - 大盘均线乖离));

相对强弱条件:=((相对强弱 > 0) || ((相对强弱 > -(0.1)) && (相对强弱 > REF(相对强弱,1))));

累积强弱:=SUM(相对强弱,10);

N:=10;

P:=3;

BBI:=((((MA(CLOSE,3) + MA(CLOSE,6)) + MA(CLOSE,12)) + MA(CLOSE,24)) / 4);

UPR:=(BBI + (P * STD(BBI,N)));

DWN:=(BBI - (P * STD(BBI,N)));

布林宽度:=((UPR - DWN) / 10);

布林条件:=(((布林宽度 < 0.40) && (LLV(布林宽度,5) < (3 * LLV(布林宽度,100)))) || (布林宽度 < 0.20));

当日涨幅:=((((CLOSE / REF(CLOSE,1)) > 1.03) && ((CLOSE / REF(CLOSE,1)) < 1.110)) && ((CLOSE / MA10) < 1.13));

内外盘差:=DYNAINFO(22)  - DYNAINFO(23) / CAPITAL;

A1:=MIN(COUNT(AVGOFFERPX,0),30);

缩量:=(换手率 < MAX(MVOL5,MVOL20));

缩量条件:=(COUNT(缩量,7) >= 4);

换手率条件:=(((((换手率 > (1.35 * REF(换手率,1))) && (换手率 < (7 * REF(换手率,1)))) && (换手率 > 1.5)) && (换手率 > MVOL5)) && REF(缩量条件,1));

波段启动:=((((均线条件 && 换手率条件) && 当日涨幅) && 相对强弱条件) && 布林条件);

双强模式:=(0.6 * ((((MA10 > MA20) || (MA10 > REF(MA10,1))) || (均价 > MA10)) && (相对强弱 > -(0.02))));

股性活跃:=(0.5 * ((((COUNT(大阳线,60) >= 6) || (COUNT(涨停板,60) >= 2)) || (COUNT((涨停板 || 放量长阳线),30) >= 1)) || (COUNT((相对强弱 > 0.1),120) > 20)));

放量:=0.2 * (换手率 > MAX(MVOL60,MVOL5) || (MVOL5 > MVOL60) || 涨停板) || 涨停板 || 放量长阳线 && (换手率 > MIN(MVOL60,MVOL5) && (CLOSE > MA10) || (相对强弱 > 0)) || MVOL5 >= REF(MVOL5,1) && CLOSE > REF(CLOSE,1);

活跃股:=(0.5 * ((放量 || 双强模式) && 股性活跃));

激活1:=((((((涨停板 || 放量长阳线) && 活跃股) && (相对强弱 > 0)) && (均线乖离 < 0.23)) && (BIAS60 < 0.25)) && 低吸条件);

激活时间1:=BARSLAST(激活1);

活跃区间:活跃股 AND EVERY(活跃股,激活时间1+1),COLORRED;

计数:=COUNT(激活1,0);

激活2:=((激活1 && 活跃区间) && (COUNT(激活1,0) = 1));

激活:=(((激活1 && 活跃区间) && REF((活跃区间 <> 1),1)) && (COUNT(激活1,0) > 1));

激活3:=(((激活1 && 活跃区间) && REF((活跃股 = 0),1)) && (COUNT(激活1,0) <= 1));

启动:IF((COUNT(激活1,0) > 1),激活,(激活2 || (激活3 && 低吸条件))),LINETHICK0;

激活时间:=BARSLAST(激活);

激活均价:=REF(均价,激活时间);

激活点开盘价:=REF(OPEN,激活时间);

激活点最低价:=REF(LOW,激活时间);

激活点均线价:=REF(MA10,激活时间);

最低止损价:=(激活均价 * 0.95);

建仓区间底价:=IF((激活点开盘价 < (激活均价 * 0.98)),MAX(激活点最低价,最低止损价),最低止损价);

回调:=(0.2 * (((((((HHV(CLOSE,5) / CLOSE) > 1.06) && (HHV(BIAS10,6) > 0.08)) && (CLOSE > (0.95 * MA10))) && (CLOSE < (1.09 * MA10))) && ((LOW / MA10) < 1.01)) && 活跃区间));

关注区间:(0.6 * (((活跃区间 && ((CLOSE >= 建仓区间底价) || (CLOSE > MA10))) && (激活时间 <= 6)) && (激活时间 > 0))),LINETHICK0;

关注:=(0.3 * (放量 && (相对强弱 > 0)));

选股:=FILTER((0.6 * (((活跃区间 && ((CLOSE >= 建仓区间底价) || (CLOSE > MA10))) && (激活时间 <= 6)) && (激活时间 > 0))),6);

STICKLINE(启动,0,2,2,0),COLORYELLOW;

STICKLINE((关注区间 > 0),0,2,2,0),COLOR9B85E5;

波段王副图

VAR1:=(CLOSE+HIGH+LOW+OPEN)/4; 

VAR2:=SUMBARS(VOL,CAPITAL); 

VAR3:=HHV(VAR1,VAR2); 

VAR4:=LLV(VAR1,VAR2); 

VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4); 

VAR6:=(VAR1-VAR4)/(VAR3-VAR4); 

VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60); 

VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30); 

VAR9:=EMA(VAR8,7); 

VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100; 

VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5; 

VARC:=HHV(HIGH,9)-LLV(LOW,9); 

VARD:=HHV(HIGH,9)-CLOSE; 

VARE:=CLOSE-LLV(LOW,9); 

VARF:=VARD/VARC*100-70; 

VAR10:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100; 

VAR11:=(2*CLOSE+HIGH+LOW)/4; 

VAR12:=SMA(VARE/VARC*100,3,1); 

VAR13:=LLV(LOW,34); 

VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1); 

VAR15:=IF(VAR14>100,VAR14-100,0); 

VAR16:=HHV(HIGH,34); 

VAR17:=EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8); 

VAR18:=EMA(VAR17,5); 

STICKLINE(VAR17-VAR18>0,VAR17,VAR18,8,1), ,COLORRED ; 

STICKLINE(VAR17-VAR18<0,VAR17,VAR18,8,1), ,COLORGREEN ; 

逃顶王副图

VAR2:=LLV(LOW,10);

VAR3:=HHV(HIGH,25);

阶段卖出: 3.2,COLORC6C600;

3.5,COLOR0088FF;

清仓卖出: 3.5,COLORFF75FF;

动力线:= EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);

STICKLINE(动力线>REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLORRED; 

STICKLINE(动力线<=REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLOR00FF00; 

底部:0.2,COLOR70DB93;

关注:0.5,COLORYELLOW;

DRAWICON( FILTER(CROSS(动力线,关注),20),动力线+0.02 ,1);

DRAWICON( FILTER(CROSS(清仓卖出,动力线),20),动力线+0.02,2);

DRAWICON( FILTER(CROSS(动力线,底部),20),动力线+0.02 ,1);

DRAWICON( FILTER(CROSS(阶段卖出,动力线),20),动力线+0.02,2);

强弱分界线:1.75,POINTDOT,LINETHICK2,COLOR70DB93;

数值:动力线,COLORA8A8A8;

资金趋势副图

A:=VOL*CLOSE;

B:=SUM(A,1)/SUM(VOL,1); 

B1:=EMA(B,8); 

敢死队:(B-B1)*100/B,NODRAW,COLORRED;

DRAWBAND(敢死队+35,RGB(250,0,00),35,RGB(0,255,0));

DRAWTEXT(ISLASTBAR,35.5,' 敢死队'),COLORRED;

资金趋势:3*(EMA(C,3)-EMA(C,8)-EMA(EMA(C,3)-EMA(C,8),20))*5,NODRAW,COLORMAGENTA;

涨停回马枪副图

均价线:=AMOUNT/V/100;

C2:=REF(C,1);

涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);

STICKLINE(涨停,0,5,6,0),COLORYELLOW;

DRAWTEXT(涨停,8,'涨停'),COLORYELLOW;

MA13:=MA(C,13),COLORGRAY;

MA21:=MA(C,21),COLORWHITE;

支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

LC:=REF(CLOSE,1);

操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;

趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;

震仓线:=45;

震仓线2:=50;

逃命线:=80;

抄底线:=20;

绝底线:=5;

PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;

PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;

PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;

HH:=COUNT(涨停,13)>=1;

STICKLINE(PP2 AND HH,0,5,3,0),COLORRED;

STICKLINE(PP AND HH,0,5,3,0),COLORRED;

STICKLINE(PP3 AND HH,0,5,3,0),COLORRED;

DRAWTEXT(PP2 AND HH,8,'预警'),COLORRED;

DRAWTEXT(PP AND HH,8,'预警'),COLORRED;

DRAWTEXT(PP3 AND HH,8,'预警'),COLORRED;

A:=SMA(L,4,3) ;

绿色买入:IF (((A AND REF(PP,1) AND HH) OR (A AND REF(PP3,1) AND HH)),1,0 );

STICKLINE(A AND REF(PP,1) AND HH ,0,10,1,0),COLORGREEN;

DRAWICON(A AND REF(PP,1) AND HH,12,1);

STICKLINE(A AND REF(PP3,1) AND HH ,0,10,1,0)COLORGREEN;

DRAWICON(A AND REF(PP3,1) AND HH,12,1);   

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。
    转藏 全屏 打印 分享 献花(0

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多