分享

通达信极阴弱转强选股指标公式源码编程思路破译及成功率回测数据

 发现探索 2022-09-30 发表于天津

编程思路破译

去ST赋值:如果模糊匹配品种名称ORNAMELIKE('*ST'),返回0,否则返回1

去退市赋值:如果模糊匹配品种名称ORNAMELIKE('退市*'),返回0,否则返回1

去KCB赋值:如果模糊匹配品种代码,返回0,否则返回1

去CYB赋值:如果模糊匹配品种代码,返回0,否则返回1

去BJS赋值:如果模糊匹配品种代码,返回0,否则返回1

去新股赋值:如果模糊匹配品种名称,返回0,否则返回1

去除停牌赋值:取反=0

一字板赋值:取反

流通市值赋值:流通市值/100000000[取日线数据]

QZ赋值:去除停牌 AND 去退市 AND 去新股 AND 去ST AND 去KCB AND 去CYB AND 去BJS AND 一字板 AND 流通市值<150 

开幅赋值:(开盘价/1日前的收盘价-1)*100

开换手Z赋值:开盘金额/开盘价/自由流通股本(股)*100

跌幅赋值:1日前的(开盘价-收盘价)/1日前的收盘价*100>4.5

输出XG:QZ AND 开幅>0 AND 开换手Z>0.1 AND 跌幅

条件选股:通达信极阴弱转强[日线]成功率测试

测试股票数:5042

共发出信号:0 成功信号:0 失败信号:0 未完成信号:0

信号发出率:0.00% 平均成功率:0.00% 成功率达到50%的股票数有:0.00%

利润1总平均:0.00% 最大平均利润1: 0.00%  最小平均利润1: 0.00%

利润2总平均:0.00% 最大平均利润2: 0.00%  最小平均利润2: 0.00%

程序源码

去ST:=IF(NAMELIKE('退市') OR NAMELIKE('*ST'),0,1 );

去退市:=IF(NAMELIKE('ST') OR NAMELIKE('退市*'),0,1 );

去KCB:=IF(CODELIKE('68'),0,1);

去CYB:=IF(CODELIKE('30'),0,1);

去BJS:=IF(CODELIKE('8'),0,1);

去新股:=IF(NAMELIKE('N'),0,1);

去除停牌:=NOT(DYNAINFO(7))=0;

一字板:=NOT(O/REF(C,1)>1.095 AND O=C);

流通市值:=FINANCE(40)/100000000#DAY;

QZ:=去除停牌 AND 去退市 AND 去新股 AND 去ST AND 去KCB AND 去CYB AND 去BJS AND 一字板 AND 流通市值<150 ;

开幅:=(O/REF(C,1)-1)*100;

开换手Z:=DYNAINFO(15)/OPEN/FINANCE(46)*100;

跌幅:=REF((O-C)/REF(C,1)*100,1)>4.5;

XG:QZ AND 开幅>0 AND 开换手Z>0.1 AND 跌幅;

该公式包含未来函数:DYNAINFO
该公式包含未来函数:FINANCE

    转藏 分享 献花(0

    0条评论

    发表

    请遵守用户 评论公约