zhoufan879 / 程序 / 顺势指标

分享

   

顺势指标

2014-07-03  zhoufan879
C:=CLOSE; H:=HIGH; L:=LOW; O:=OPEN; V:=VOL; MA5:EMA(C,5),COLORWHITE; WORK:EMA(C,14),COLORYELLOW; TWO:EMA(C,25),COLORRED; NINE:EMA(CLOSE,99); MA120:EMA(CLOSE,120); LIFE:EMA(CLOSE,453),COLORRED; DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19)); DEA:=EMA(DIFF,9); MACD:=0.90*(DIFF-DEA); TJ:=(DIFF>=DEA); TJ1:=(DIFF>=0); DRAWLINE(TJ,H,TJ,L,COLORYELLOW); STICKLINE(TJ,O,C,COLORYELLOW,0); DRAWLINE(TJ1 && TJ,H,TJ1 && TJ,L,COLORMAGENTA); STICKLINE(TJ1 && TJ,O,C,COLORMAGENTA,1); DRAWLINE(DIFF<DEA,H,DIFF<DEA,L,COLORGREEN); STICKLINE(DIFF<DEA,O,C,COLORGREEN,0); VAR1:=(CLOSE*2+HIGH+LOW)/4; SC:= EMA(VAR1,13)-EMA(VAR1,73); SD:= EMA(SC,2); DRAWLINE((CROSS(SC,SD) && SC<-0.04 && (C-REF(C,1))/REF(C,1)>=0.03) || (CROSS(SC,SD) && SC<=-0.14 ) || (CROSS(SC,SD) && SC<=0.05 && (V/MA(V,5)>2 ||C/REF(C,1)>0.035)),H,(CROSS(SC,SD) && SC<-0.04 && (C-REF(C,1))/REF(C,1)>=0.03) || (CROSS(SC,SD) && SC<=-0.14 ) || (CROSS(SC,SD) && SC<=0.05 && (V/MA(V,5)>2 ||C/REF(C,1)>0.035)),L,COLORRED); STICKLINE((CROSS(SC,SD) && SC<-0.04 && (C-REF(C,1))/REF(C,1)>=0.03) || (CROSS(SC,SD) && SC<=-0.14 ) || (CROSS(SC,SD) && SC<=0.05 && (V/MA(V,5)>2 || C/REF(C,1)>0.035)),O,C,COLORRED,0);

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多

    ×
    ×

    ¥.00

    微信或支付宝扫码支付:

    开通即同意《个图VIP服务协议》

    全部>>