pananbaba / 指标公式 / [指标]文华指标大集合[文华财经公式]

0 0

   

[指标]文华指标大集合[文华财经公式]

2018-09-17  pananbaba

 用眼6
RSV:=((HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13)))*(100);
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,5,1);
DRAWLINE((LWR1>=LWR2),HIGH,(LWR1>=LWR2),LOW,COLORBLUE);
STICKLINE((LWR1>=LWR2),OPEN,CLOSE,COLORBLUE,0);
DRAWLINE((LWR1
STICKLINE((LWR1

 


用眼5
C:=CLOSE;
L:=LOW;
MX:EMA(C,3);
SX:EMA(SLOPE(C,21)*20+C,55);
X:EMA(SLOPE(C,34)*20+C,89);
DRAWLINE(MX
DRAWLINE(MX>SX,MX,MX>SX,SX,COLORRED);
PARTLINE(MX
PARTLINE(MX>=REF(MX,1),MX,COLORRED);
STICKLINE((SX-X)>=0,(SX-(SX-X)*0.05),(SX-(SX-X)*0.15),COLORYELLOW,0);
STICKLINE((SX-X)>=0,(SX-(SX-X)*0.2),(SX-(SX-X)*0.35),COLORYELLOW,0);
STICKLINE((SX-X)>=0,(SX-(SX-X)*0.4),(SX-(SX-X)*0.55),COLORYELLOW,0);
STICKLINE((SX-X)>=0,(SX-(SX-X)*0.6),(SX-(SX-X)*0.75),COLORYELLOW,0);
STICKLINE((SX-X)>=0,(SX-(SX-X)*0.8),(SX-(SX-X)*0.95),COLORYELLOW,0);
STICKLINE((SX-X)<0,(X+(SX-X)*0.05),(X+(SX-X)*0.15),COLORRED,0);
STICKLINE((SX-X)<0,(X+(SX-X)*0.2),(X+(SX-X)*0.35),COLORRED,0);
STICKLINE((SX-X)<0,(X+(SX-X)*0.4),(X+(SX-X)*0.55),COLORRED,0);
STICKLINE((SX-X)<0,(X+(SX-X)*0.6),(X+(SX-X)*0.75),COLORRED,0);
STICKLINE((SX-X)<0,(X+(SX-X)*0.8),(X+(SX-X)*0.95),COLORRED,0);
STICKLINE(CROSS(MA(SX,1),MA(X,1)),MA(X,1),MA(X,1)+0.8, COLORWHITE,0);
DRAWTEXT(CROSS(SX,X),X+1.2,'骑龙');
DRAWLINE(CLOSE>OPEN||CLOSE=OPEN && CLOSE>REF(CLOSE,1),LOW,CLOSE>OPEN||CLOSE=OPEN && CLOSE>REF(CLOSE,1),HIGH,COLORRED);
STICKLINE(CLOSE>OPEN||CLOSE=OPEN && CLOSE>REF(CLOSE,1),OPEN,CLOSE,COLORRED,0);
DRAWLINE(CLOSE<=REF(CLOSE,1),LOW,CLOSE<=REF(CLOSE,1),HIGH,COLORCYAN);
STICKLINE(CLOSE<=REF(CLOSE,1),OPEN,CLOSE,COLORCYAN,0);
 

 

 

 

用眼4
CHANG:=(((CLOSE - LLV(CLOSE,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
CHANGK:=SMA(CHANG,5,1);
CHANGD:=SMA(CHANGK,5,1);
ZHONG:=(((CLOSE - LLV(CLOSE,21)) / (HHV(HIGH,21) - LLV(LOW,21))) * 100);
ZHONGK:=SMA(ZHONG,5,1);
ZHONGD:=SMA(ZHONGK,5,1);
DUAN:=(((CLOSE - LLV(CLOSE,5)) / (HHV(HIGH,5) - LLV(LOW,5))) * 100);
DUANK:SMA(DUAN,3,1);
DUAND:SMA(DUANK,3,1);
STICKLINE((DUANK >= DUAND),DUANK,DUAND,COLORWHITE,0);
STICKLINE((DUANK < DUAND),DUANK,DUAND,COLORMAGENTA,0);
 

 

 

用眼3
DIFELSEF: EMA(CLOSE,24) - EMA(CLOSE,60),COLORWHITE;
DEA: EMA(DIFELSEF,12),COLORYELLOW;
MACD2:=2*(DIFELSEF-DEA);
DIFELSEF1: EMA(CLOSE,10) - EMA(CLOSE,22),COLORGREEN;
DEA1: EMA(DIFELSEF1,9),COLORRED;
MACD1:= 2*(DIFELSEF1-DEA1);
MACD:=(MACD2+MACD1)/2;
STICKLINE(DIFELSEF-DEA>0,DIFELSEF,DEA,COLORRED,0);
STICKLINE(DIFELSEF-DEA<0,DIFELSEF,DEA,COLORBLUE,0);
STICKLINE(DIFELSEF1-DEA1>0,DIFELSEF1,DEA1,COLORMAGENTA,0);
STICKLINE(DIFELSEF1-DEA1<0,DIFELSEF1,DEA1,COLORCYAN,0);

 


用眼2
CHANG:=(((CLOSE - LLV(CLOSE,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
CHANGK:=SMA(CHANG,5,1);
CHANGD:=SMA(CHANGK,5,1);
ZHONG:=(((CLOSE - LLV(CLOSE,21)) / (HHV(HIGH,21) - LLV(LOW,21))) * 100);
ZHONGK:SMA(ZHONG,5,1);
ZHONGD:SMA(ZHONGK,5,1);
DUAN:=(((CLOSE - LLV(CLOSE,5)) / (HHV(HIGH,5) - LLV(LOW,5))) * 100);
DUANK:=SMA(DUAN,3,1);
DUAND:=SMA(DUANK,3,1);
STICKLINE((ZHONGK >= ZHONGD),ZHONGK,ZHONGD,COLORGREEN,0);
STICKLINE((ZHONGK < ZHONGD),ZHONGK,ZHONGD,COLORBLUE ,0);

 


用眼1飞狐
MA1:EMA(CLOSE,6),COLORWHITE;
MA2:EMA(CLOSE,25),COLORRED ;
STICKLINE(MA1>MA2,MA1,MA2,COLORMAGENTA,0) ;
STICKLINE(MA2>MA1,MA1,MA2,COLORGREEN,0);
DRAWTEXT(MA2-MA1>0&&MA1/LOW>1.15,LOW,'');
DRAWTEXT(MA1-MA2>0&&HIGH/MA1>1.15,HIGH,'');


用眼 1
FXQ:80,COLORWHITE;
PHQ:50,COLORCYAN;
AQQ:20,COLORYELLOW;
CHANG:=(((CLOSE - LLV(CLOSE,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
CHANGK:SMA(CHANG,5,1);
CHANGD:SMA(CHANGK,5,1);
ZHONG:=(((CLOSE - LLV(CLOSE,21)) / (HHV(HIGH,21) - LLV(LOW,21))) * 100);
ZHONGK:=SMA(ZHONG,5,1);
ZHONGD:=SMA(ZHONGK,5,1);
DUAN:=(((CLOSE - LLV(CLOSE,5)) / (HHV(HIGH,5) - LLV(LOW,5))) * 100);
DUANK:=SMA(DUAN,3,1);
DUAND:=SMA(DUANK,3,1);
STICKLINE((CHANGK >= CHANGD),CHANGK,CHANGD,COLORRED,0);
STICKLINE((CHANGK < CHANGD),CHANGK,CHANGD,COLORYELLOW,0);


隐形缚龙索
A1:EMA((EMA(CLOSE,1)+EMA(CLOSE,3)+EMA(CLOSE,5))/3,3),COLORRED;
A2:EMA((EMA(CLOSE,3)+EMA(CLOSE,5)+EMA( CLOSE,7))/3,3),COLORRED;
A3:EMA((EMA(CLOSE,5)+EMA(CLOSE,7)+EMA( CLOSE,9))/3,3),COLORRED;
A4:EMA((EMA(CLOSE,7)+EMA(CLOSE,9)+EMA( CLOSE,11))/3,3),COLORRED;
A5:EMA((EMA(CLOSE,9)+EMA(CLOSE,11)+EMA( CLOSE,13))/3,3),COLORRED;
A6:EMA((EMA(CLOSE,11)+EMA(CLOSE,13)+EMA( CLOSE,15))/3,3),COLORRED;
A7:EMA((EMA(CLOSE,13)+EMA(CLOSE,15)+EMA( CLOSE,17))/3,3),COLORRED;
A8:EMA((EMA(CLOSE,15)+EMA(CLOSE,17)+EMA( CLOSE,19))/3,3),COLORRED;
A9:EMA((EMA(CLOSE,17)+EMA(CLOSE,19)+EMA( CLOSE,21))/3,3),COLORYELLOW;
A10:EMA((EMA(CLOSE,19)+EMA(CLOSE,21)+EMA( CLOSE,23))/3,3),COLORYELLOW;
A11:EMA((EMA(CLOSE,21)+EMA(CLOSE,23)+EMA( CLOSE,25))/3,3),COLORYELLOW;
A:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW;
B:=REF(A,1);
DRAWTEXT(A>B,(A+B)/2,'');
DRAWTEXT(A<=B,(A+B)/2,'');
STICKLINE(A>B,A,B,COLORYELLOW,0);
STICKLINE(A<=B,A,B,COLORWHITE,1);
A15:A-(A1-A*0.997),COLORGREEN;
A16:A-(A2-A),COLORGREEN;
A17:A-(A3-A),COLORGREEN;
A18:A-(A4-A),COLORGREEN;
A19:A-(A5-A),COLORGREEN;
A20:A-(A6-A),COLORGREEN;
A21:A-(A7-A),COLORGREEN;
A22:A-(A8-A),COLORGREEN;
A23:A-(A9-A),COLORGREEN;
A24:A-(A10-A),COLORGREEN;
A25:A-(A11-A*0.997),COLORGREEN;
STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,COLORBLUE,0 );
STICKLINE(CLOSE>OPEN,OPEN,CLOSE,COLORMAGENTA,0 );
DRAWLINE(CLOSE>OPEN,OPEN,CLOSE>OPEN,LOW,COLORMAGENTA);
DRAWLINE(CLOSE>OPEN,CLOSE,CLOSE>OPEN,HIGH,COLORMAGENTA);
DRAWLINE(OPEN>=CLOSE,CLOSE,OPEN>=CLOSE,LOW,COLORBLUE);
DRAWLINE(OPEN>=CLOSE,OPEN,OPEN>=CLOSE,HIGH,COLORBLUE);

 


阴阳瀑布线
AA:=(OPEN+HIGH+LOW)/3;
PB1:PUBU(OPEN,0),COLORRED;
PB2:PUBU(OPEN,1),COLORGREEN;
PB3:PUBU(OPEN,2),COLORWHITE;
PB4:PUBU(OPEN,3),COLORYELLOW;
PB5:PUBU(OPEN,4),COLORMAGENTA;
PB6:PUBU(OPEN,5),COLORBLUE;
TMP:=PUBU(AA,3)-PUBU(AA,0);
DRAWLINE(TMP>0.00001,HIGH,TMP>0.00001,OPEN,COLORCYAN);
DRAWLINE(TMP>0.00001,LOW,TMP>0.00001,CLOSE,COLORCYAN);
DRAWLINE(TMP<-0.00001,HIGH,TMP<-0.00001,CLOSE,COLORRED);
DRAWLINE(TMP<-0.00001,LOW,TMP<-0.00001,OPEN,COLORRED);
DRAWLINE(ABS(TMP)<0.00001,LOW,ABS(TMP)<0.00001,OPEN,COLORWHITE);
DRAWLINE(ABS(TMP)<0.00001,HIGH,ABS(TMP)<0.00001,OPEN,COLORWHITE);
STICKLINE(TMP>0.00001,OPEN,CLOSE,COLORCYAN,1);
STICKLINE(TMP<-0.00001,OPEN,CLOSE,COLORRED,1);


倚天波段王
VAR1:=REF(CLOSE,1);
VAR2:=SUM(VOL,2)/((HHV(HIGH,2)-LLV(LOW,2))*100);
VAR3:=(CLOSE-VAR1)*VAR2;
VAR4:=SUM(VAR3,0);
VAR5:=SMA(VAR4,5,1);
VAR6:=SMA(VAR4,13,1);
DB:VAR5-VAR6,COLORWHITE;
CB:MA(DB,4),COLORRED;
STICKLINE(DB>0,0,DB,COLORRED,1);
STICKLINE(VAR5-VAR6<0,0,VAR5-VAR6,COLORGREEN,1);
STICKLINE(DB>CB,DB,CB,COLORRED,0);
STICKLINE(DB
QS:CROSS(DB,CB),COLORRED;
RS:CROSS(CB,DB),COLORGREEN;
BJ:0,COLORBLUE;
 

一笑趋势K线
QS0:=((CLOSE - LLV(LOW,120)) / (HHV(HIGH,120) - LLV(LOW,120)));
QS1:=((QS0 / 1) * EMA(CLOSE,20));
QS:=SMA(QS1,3,1);
QD0:=((CLOSE - LLV(LOW,119)) / (HHV(HIGH,119) - LLV(LOW,119)));
QD1:=((QD0 / 1) * EMA(CLOSE,20));
QD:=SMA(QD1,5,1);
QF0:=((CLOSE - LLV(LOW,118)) / (HHV(HIGH,118) - LLV(LOW,118)));
QF1:=((QF0 / 1) * EMA(CLOSE,20));
QF:=SMA(QF1,5,1);
PX1:=((((QS + QD) + QF) / 3) + EMA(CLOSE,20));
PX2:=MA(PX1,2);
PX3:=MA(PX1,3);
YY:=((((2 * CLOSE) + HIGH) + LOW) / 4);
MA1:=MA(YY,45);
C:=(PX1 - MA1);
M:=(PX2 - MA1);
O:=(PX3 - MA1);
MA2:MA(C,8);
DRAWLINE((C >= M),C,(C >= M),(O - 0.03),COLORRED);
STICKLINE((C >= M),M,(O - 0.03),COLORRED,0);
DRAWLINE((C <= M),C,(C <= M),(O + 0.03),COLORBLUE);
STICKLINE((C <= M),M,(O + 0.03),COLORBLUE,0);
LIFELSEE:MA(C,13),COLORGREEN;


一线定输赢
XDKX0:=DATE=20051228;
XDKX1:=EMA(REF(CLOSE,1),10);
XDKX2:=SMA(SUM(CLOSE,1),3,1);
DRAWLINE(XDKX2<=XDKX1,HIGH,XDKX2<=XDKX1,OPEN,COLORCYAN);
DRAWLINE(XDKX2<=XDKX1,LOW,XDKX2<=XDKX1,CLOSE,COLORCYAN);
DRAWLINE(XDKX2>XDKX1,HIGH,XDKX2>XDKX1,CLOSE,COLORRED);
DRAWLINE(XDKX2>XDKX1,LOW,XDKX2>XDKX1,OPEN,COLORRED);
STICKLINE(XDKX2<=XDKX1,OPEN,CLOSE,COLORCYAN,0);
STICKLINE(XDKX2>XDKX1,OPEN,CLOSE,COLORRED,1);


一线定乾坤
C:CLOSE;
O:=OPEN;
H:=HIGH;
L:=LOW;
TR:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
A:=EMA(TR,13)*1.2;
B:=HHV(C-A,21);
IFELSE((C>B|| C=B),C,B),COLORRED;
IFELSE(C
AA:C,COLORYELLOW;
STICKLINE(C>=O,C,O,COLORRED,0);
DRAWLINE(C>=O,H,C>=O,L,COLORYELLOW);
STICKLINE(C<=O,C,O,COLORBLUE,0);
DRAWLINE(C<=O,H,C<=O,L,COLORWHITE);


一个很好的指标
VAR1:=MA(LOW,1);
VAR2:=MA(HIGH,2);
VAR3:=MA(CLOSE,2);
VAR4:=(VAR3-LLV(VAR1,9))/(HHV(VAR2,9)-LLV(VAR1,9))*100;
VAR5:=SMA(VAR4,3,1);
Y:SMA(VAR5,3,1),COLORRED;
Y1:=SMA(Y,3,1);
VAR6:=(HHV(VAR2,9)-VAR3)/(HHV(VAR2,9)-LLV(VAR1,9))*100;
YI: SMA(VAR6,3,1),COLORYELLOW;
Y2:=SMA(YI,3,1);
VAR7:=REF(VAR3,1);
VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100;
VARB:=MA(CLOSE,3)*100/MA(CLOSE,10)-100;
VARC:=MA(CLOSE,3)*100/MA(CLOSE,10)-100;
VARD:=CLOSE*100/MA(CLOSE,10)-100;
VARE:=IFELSE(VARB>10,10,VARB);
VARF:=IFELSE(VARE<-10,-10,VARE);
VAR10:=IFELSE(VARC>10,10,VARC);
VAR11:=IFELSE(VAR10<-10,-10,VAR10);
VAR12:=REF(VARB,1);
VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1);
VAR15:=REF(CLOSE,1);
VAR16:=100*(CLOSE-VAR15)/CLOSE;
VAR17:=MA(VAR13,3);
VAR18:=MA(VAR16,3);
VAR19:=(3*CLOSE+VAR1+OPEN+HIGH)/6;
VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF(VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10)+9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF(VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210;
VAR1B:=MA(VAR1A,12);
VAR1C:=EMA(VAR1A,5);
VAR1D:=ABS(VAR1A-VAR1B);
VAR1E:=REF(VAR3,1)*0.015;
VAR1F:=REF(CLOSE,1);
VAR26:=MA(CLOSE,26);
VAR27:=VAR26+2*STD(VAR3,26);
VAR28:=VAR26-2*STD(VAR3,26);
VAR29:=VAR26+2*STD(REF(VAR3,1),26);
VAR2A:=VAR26-2*STD(REF(VAR3,1),26);
D1:=EMA(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),5);
D2:=REF(D1,1);
STICKLINE(D1>=REF(D1,1),D1,D2,COLORBLUE,0);
STICKLINE(D1
QR:SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100,COLORLIGHTGREEN;
A:20,COLORCYAN;
B:80,COLORLIGHTBLUE;
 

 

一个不错的指标
H:=HIGH;
L:=LOW;
HH1:=IFELSE(H
LL1:=IFELSE(L>REF(L,2)&&REF(L,1)>REF(L,2),REF(L,2),0);
HH2:=VALUEWHEN(HH1>0,HH1);
LL2:=VALUEWHEN(LL1>0,LL1);
K1:=IFELSE(CLOSE>HH2,-3,IFELSE(CLOSE
K2:=VALUEWHEN(K1<>0,K1);
G:=IFELSE(K2=1,HH2,LL2);
G1:=VALUEWHEN(ISLASTBAR,G);
DRAWNUMBER(L>0,G1,G1,0,COLORCYAN);
W1:=K2;
W2:=OPEN-CLOSE;
HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);
LT:=IFELSE(OPEN
DRAWLINE(W1=1,HIGH,W1=1,HT,COLORCYAN);
DRAWLINE(W1=1,LOW,W1=1,LT,COLORCYAN);
DRAWLINE(W1=-3,HIGH,W1=-3,HT,COLORRED);
DRAWLINE(W1=-3,LOW,W1=-3,LT,COLORRED);
STICKLINE(W1>0,OPEN,CLOSE,COLORCYAN,1);
STICKLINE(W1<=0,OPEN,CLOSE,COLORRED,1);
STICKLINE(W2>0&&W1<=0,OPEN,CLOSE,COLORRED,0);
STICKLINE(W2>0&&W1>0,OPEN,CLOSE,COLORCYAN,0);
DRAWLINE(W1=1&&REF(W1,1)=1,G,W1=1&&REF(W1,1)=1,REF(G,1),COLORGREEN);
DRAWLINE(W1=-3&&REF(W1,1)=-3,G,W1=-3&&REF(W1,1)=-3,REF(G,1),COLORYELLOW);
DRAWSL(K2=1,G,0,1,0,COLORGREEN);
DRAWSL(K2=-3,G,0,1,0,COLORYELLOW);
HH:=IFELSE(H>REF(H,1)&&H>REF(H,2)&&H>REF(H,3)&&H>REF(H,4)&&L
LL:=IFELSE(H>REF(H,1)&&H>REF(H,2)&&H>REF(H,3)&&H>REF(H,4)&&L
H1:=IFELSE(H>=REF(H,1)&&H>=REF(H,2)&&H>=REF(H,3)&&H>=REF(H,4)&& H>REFX(H,1)&&H>REFX(H,2)&&H>REFX(H,3)&&H>REFX(H,4),HH,0);
L1:=IFELSE(L<=REF(L,1)&&L<=REF(L,2)&&L<=REF(L,3)&&L<=REF(L,4)&& L
H2:=BARSLAST(H1);
L2:=BARSLAST(L1);
H3:=REFX(REF(H1,H2),2);
L3:=REFX(REF(L1,L2),2);
H4:=ZIGZAG(H3,0,0);
L4:=ZIGZAG(L3,0,0);
H5:=VALUEWHEN(H4REF(H4,2),HH);
L5:=VALUEWHEN(L4>REF(L4,1)&&REF(L4,1)
POLYLINE(H5>0,H5,COLORRED);
POLYLINE(L5>0,L5,COLORWHITE);
DRAWNUMBER(H5<>REF(H5,1),H5,H5-L5,0,COLORMAGENTA);
DRAWNUMBER(L5<>REF(L5,1),L5,H5-L5,0,COLORMAGENTA);
D:=VALUEWHEN(ISLASTBAR,H5);
E:=VALUEWHEN(ISLASTBAR,L5);
DRAWNUMBER(LOW>0,D,D,0,COLORWHITE);
DRAWNUMBER(LOW>0,E,E,0,COLORWHITE);
DRAWTEXT(CROSS(CLOSE,H5)||CROSS(CLOSE,L5),L,'');
DRAWTEXT(CROSS(H5,CLOSE)||CROSS(L5,CLOSE),H,'');
阳光心情
MA1:EMA(CLOSE,6),COLORWHITE;
MA2:EMA(CLOSE,25),COLORRED ;
STICKLINE(MA1>MA2,MA1,MA2,COLORMAGENTA,0) ;
STICKLINE(MA2>MA1,MA1,MA2,COLORGREEN,0);
DRAWTEXT(MA2-MA1>0&&MA1/LOW>1.15,LOW,'');
DRAWTEXT(MA1-MA2>0&&HIGH/MA1>1.15,HIGH,'');


颜色的变化
STICKLINE(CLOSEOPEN,OPEN,CLOSE,COLORCYAN,1);
STICKLINE(CLOSE<=OPEN,OPEN,CLOSE,COLORCYAN,0);
DRAWLINE(CLOSEOPEN,CLOSE,COLORCYAN);
DRAWLINE(CLOSEOPEN,OPEN,COLORCYAN);
DRAWLINE(CLOSE<=OPEN,LOW,COLORCYAN);
STICKLINE(CLOSE>EMA(CLOSE,49)&&CLOSE>=OPEN,OPEN,CLOSE,COLORYELLOW,1);
STICKLINE(CLOSE>EMA(CLOSE,49)&&CLOSE
DRAWLINE(CLOSE>EMA(CLOSE,49),HIGH,CLOSE>=OPEN,CLOSE,COLORYELLOW);
DRAWLINE(CLOSE>EMA(CLOSE,49),LOW,CLOSE>=OPEN,OPEN,COLORYELLOW);
DRAWLINE(CLOSE>EMA(CLOSE,49),LOW,CLOSE
DRAWLINE(CLOSE>EMA(CLOSE,49),HIGH,CLOSE
STICKLINE(HIGH>=HHV(CLOSE,24)&&CLOSE>OPEN,OPEN,CLOSE,COLORRED,1);
STICKLINE(HIGH>=HHV(CLOSE,24)&&CLOSE<=OPEN,OPEN,CLOSE,COLORRED,0);
STICKLINE(LOW<=LLV(CLOSE,24)&&CLOSE>OPEN,OPEN,CLOSE,COLORGREEN,1);
STICKLINE(LOW<=LLV(CLOSE,24)&&CLOSE<=OPEN,OPEN,CLOSE,COLORGREEN,0);
DRAWLINE(HIGH>=HHV(CLOSE,24),HIGH,CLOSE>=OPEN,CLOSE,COLORRED);
DRAWLINE(HIGH>=HHV(CLOSE,24),LOW,CLOSE>=OPEN,OPEN,COLORRED);
DRAWLINE(HIGH>=HHV(CLOSE,24),HIGH,CLOSE
DRAWLINE(LOW<=LLV(CLOSE,24),HIGH,CLOSE<=OPEN,LOW,COLORGREEN);
DRAWLINE(LOW<=LLV(CLOSE,24),HIGH,CLOSE>OPEN,CLOSE,COLORGREEN);
DRAWLINE(LOW<=LLV(CLOSE,24),LOW,CLOSE>OPEN,OPEN,COLORGREEN);

 


{烟雨斜阳豆油}
[V,1.000000,10.000000,3.000000]
[B,1.000000,10.000000,1.000000]
[N,1.000000,10.000000,4.000000]
[M,1.000000,10.000000,3.000000]
A:=ABS(SAR(2,V,B));D:=EMA(CLOSE,N);F:=SMA(D,M,1);CROSS(CLOSE,A )&&D>F,BPK;CROSS(A ,CLOSE )&&F>D,SPK;
[{RTF}]
{rtf1ansiansicpg936deff0deflang1033deflangfe2052{fonttbl{f0fnilfprq2fcharset134 FixedSys;}}{colortbl ;red0green0blue0;red255green0blue202;red0green0blue255;}viewkind4uc1pardcf1lang2052f0fs24 Acf2 :=cf3 ABScf2 (cf3 SARcf2 (cf1 2cf2 ,cf1 Vcf2 ,cf1 Bcf2 ));par cf1 Dcf2 :=cf3 EMAcf2 (cf3 CLOSEcf2 ,cf1 Ncf2 );par cf1 Fcf2 :=cf3 SMAcf2 (cf1 Dcf2 ,cf1 Mcf2 ,cf1 1cf2 );par cf3 CROSScf2 (cf3 CLOSEcf2 ,cf1 Acf2)cf0lang1033kerning2 &cf2 &cf1 Dcf2lang2052kerning0 >cf1 F,BPKcf2 ;par cf3 CROSScf2 (cf1 Acf2,cf3 CLOSEcf2)cf0lang1033kerning2 &cf2 &cf1 Fcf2 >cf1 D,SPKcf2lang2052kerning0 ;cf0 par }
[{INDEXPARAM}]
PINGJIN=0,NOTVALIDSTOPLOST=0,DEALTYPE=2,STOPLOST=0,STOPLOSTADJUST=3,VOLUME=1,STOPWIN=0,STOPWINADJUST=3,NOTVALIDSTOPWIN=0,REVERSECLOSE=0
 

原码:心在山林
[N,0.000000,30.000000,2.000000]
[M,0.000000,30.000000,5.000000]
K1:=(CLOSE-REF(CLOSE,3))/REF(CLOSE,3)*100;
K2:=(CLOSE-REF(CLOSE,4))/REF(CLOSE,4)*100;
K3:=(CLOSE-REF(CLOSE,5))/REF(CLOSE,5)*100;
K4:=(CLOSE-REF(CLOSE,6))/REF(CLOSE,6)*100;
KK1:=EMA(K1,2);
KK2:=EMA(K2,3);
KK3:=EMA(K3,4);
KK4:=EMA(K4,5);
KBQ:=(KK1+KK2+KK3+KK4)/4;
KB1:=EMA2(KBQ,N);
KB2:=EMA(KB1,M);
CROSS(KB1,KB2),BPK;
CROSS(KB2,KB1),SPK;
 

飓风水手
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
STICKLINE(VAR9>VARA,VAR9,VARA,COLORRED,0);
STICKLINE(VAR9<=VARA,VAR9,VARA,COLORGREEN,0);
飓风水手更改后:
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
STICKLINE(VAR9>VARA,VAR9,VARA,2,0),COLORRED;
STICKLINE(VAR9<=VARA,VAR9,VARA,2,0),COLORGREEN;
 

天途源码
DIFELSEF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:= EMA(DIFELSEF,9);
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
K2:EMA(CLOSE,6),COLORCYAN;
K3:EMA(CLOSE,9),COLORCYAN;
K5:EMA(CLOSE,12),COLORCYAN;
K7:EMA(CLOSE,15),COLORCYAN;
K10:EMA(CLOSE,18),COLORCYAN;
K13:EMA(CLOSE,21),COLORCYAN;
K16:EMA(CLOSE,24),COLORCYAN;
IFELSE (K2>REF(K2,1),K2,K2),COLORRED;
IFELSE (K3>REF(K3,1),K3,K2),COLORRED;
IFELSE (K5>REF(K5,1),K5,K2),COLORRED;
IFELSE (K7>REF(K7,1),K7,K2),COLORRED;
IFELSE (K10>REF(K10,1),K10,K2),COLORRED;
IFELSE (K13>REF(K13,1),K13,K2),COLORRED;
IFELSE (K16>REF(K16,1),K16,K2),COLORRED;
HHV(HIGH,20),COLORYELLOW;
LLV(LOW,20),COLORYELLOW;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,COLORRED,0);
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,COLORGREEN,0);
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,COLORYELLOW,0);
STICKLINE(CLOSE>=OPEN,HIGH,LOW,COLORYELLOW,0);
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,COLORBLUE,0);
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,COLORMAGENTA,0);
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,COLORLIGHTGREEN,0);
STICKLINE(CLOSE<=OPEN,HIGH,LOW,COLORLIGHTGREEN,0);
TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IFELSE(HD>0 && HD>LD,HD,0),14);
MDM:= SUM(IFELSE(LD>0 && LD>HD,LD,0),14);
PDI:= PDM*100/TR;
MDI:= MDM*100/TR;
A1:=BARSLAST(REF(CROSS(DIFELSEF,DEA),1));
B1:=REF(CLOSE,A1+1)>CLOSE && REF(DIFELSEF,A1+1)

A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(CLOSE,A2+1)>CLOSE && REF(K,A2+1)
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(CLOSE,A3+1)>CLOSE && REF(RSI1,A3+1)

C1:=BARSLAST(REF(CROSS(DEA,DIFELSEF),1));
D1:=REF(CLOSE,C1+1)
>DIFELSEF && CROSS(DEA,DIFELSEF);
C2:=BARSLAST(REF(CROSS(D,K),1));
D2:=REF(CLOSE,C2+1)K && CROSS(D,K);
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(CLOSE,C3+1)
>RSI1 && CROSS(RSI2,RSI1);
C4:=BARSLAST(REF(CROSS(MDI,PDI),1));
D4:=REF(CLOSE,C4+1)MDI && CROSS(MDI,PDI);
A4:=BARSLAST(REF(CROSS(PDI,MDI),1));
B4:=REF(CLOSE,A4+1)>CLOSE && REF(PDI,A4+1)
STICKLINE(B4,LOW,LOW-0.06,COLORBLUE,0);
DRAWTEXT(B4,LOW-0.09,'DMI底背');
STICKLINE(D4,HIGH,HIGH+0.06,COLORWHITE,0);
DRAWTEXT(D4,HIGH+0.09,'DMI顶背');
STICKLINE(B1,LOW,LOW-0.06,COLORGREEN,0);
DRAWTEXT(B1,LOW-0.09,'MACD底背');
STICKLINE(B2,LOW,LOW-0.06,COLORYELLOW,0);
DRAWTEXT(B2,LOW-0.09,'KDJ底背');
STICKLINE(B3,LOW,LOW-0.04,COLORRED,0);
DRAWTEXT(B3,LOW-0.09,'RSI底背');
STICKLINE(D1,HIGH,HIGH+0.06,COLORMAGENTA,0);
DRAWTEXT(D1,HIGH+0.09,'MACD顶背');
STICKLINE(D2,HIGH,HIGH+0.06,COLORLIGHTRED,0);
DRAWTEXT(D2,HIGH+0.09,'KDJ顶背');
STICKLINE(D3,HIGH,HIGH+0.06,COLORLIGHTGREEN,0);
DRAWTEXT(D3,HIGH+0.09,'RSI顶背');
MA13:=MA(CLOSE,13),COLORWHITE;
VLL:=CROSS(MA(CLOSE,13),MA(CLOSE,21));
DRAWTEXT(VLL,MA13,'');
DRAWTEXT(VLL,MA13-0.09,'圆弧底');


 

顺势有为-最棒源码
PARTLINE(CLOSE>0,MA(CLOSE,5),COLORWHITE);
PARTLINE(CLOSE>0,MA(CLOSE,6),COLORWHITE);
PARTLINE(CLOSE>0,MA(CLOSE,7),COLORWHITE);
PARTLINE(CLOSE>0,MA(CLOSE,8),COLORWHITE);
PARTLINE(CLOSE>0,MA(CLOSE,9),COLORWHITE);
PARTLINE(CLOSE>0,MA(CLOSE,10),COLORWHITE);
PARTLINE(CLOSE>0,MA(CLOSE,25),COLORRED);
PARTLINE(CLOSE>0,MA(CLOSE,26),COLORRED);
PARTLINE(CLOSE>0,MA(CLOSE,27),COLORRED);
PARTLINE(CLOSE>0,MA(CLOSE,28),COLORRED);
PARTLINE(CLOSE>0,MA(CLOSE,29),COLORRED);
PARTLINE(CLOSE>0,MA(CLOSE,30),COLORRED);
 

谁持彩绸当空舞源码
DRAWLINE((CLOSE > OPEN),OPEN,(CLOSE > OPEN),LOW,COLORRED);
DRAWLINE((CLOSE > OPEN),CLOSE,(CLOSE > OPEN),HIGH,COLORRED);
DRAWLINE((OPEN > CLOSE),OPEN,(OPEN > CLOSE),HIGH,COLORCYAN);
DRAWLINE((OPEN > CLOSE),CLOSE,(OPEN > CLOSE),LOW,COLORCYAN);
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,COLORCYAN,0);
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,COLORRED,0);
A1:=(3 * CLOSE + LOW+ OPEN+ HIGH) / 6;
MA1:=MA(A1,1);
MA2:=MA(A1,3);
MA3:=MA(A1,5);
MA4:=MA(A1,7);
MA5:=MA(A1,9);
MA6:=MA(A1,12);
MA7:=MA(A1,15);
MA8:=MA(A1,17);
MA9:=MA(CLOSE,20);
MA10:=MA(CLOSE,30);
MA11:=MA(CLOSE,35);
MA12:=MA(CLOSE,40);
MA13:=MA(CLOSE,45);
MA14:=MA(CLOSE,50);
MA15:=MA(CLOSE,55);
MA16:=MA(CLOSE,60);
B01:=EMA(((((MA1 + MA2) + MA3) + MA4) / 4),3);
B02:=EMA(B01,3);
B03:=EMA(B02,3);
B04:=EMA(B03,3);
B05:=EMA(((((MA5 + MA6) + MA7) + MA8) / 4),3);
B06:=EMA(B05,3);
B07:=EMA(B06,3);
B08:=EMA(B07,3);
B09:=EMA(((((MA9 + MA10) + MA11) + MA12) / 4),3);
B10:=EMA(B09,3);
B11:=EMA(B10,3);
B12:=EMA(B11,3);
B13:=EMA(((((MA13 + MA14) + MA15) + MA16) / 4),3);
B14:=EMA(B13,3);
B15:=EMA(B14,3);
PARTLINE(CLOSE>0,EMA(((((MA1 + MA2) + MA3) + MA4) / 4),3),COLORLIGHTGREEN);
PARTLINE(CLOSE>0,EMA(B01,3),COLORLIGHTGREEN);
PARTLINE(CLOSE>0,EMA(B02,3),COLORLIGHTGREEN);
PARTLINE(CLOSE>0,EMA(B03,3),COLORLIGHTGREEN);
PARTLINE(CLOSE>0,EMA(((((MA5 + MA6) + MA7) + MA8) / 4),3),COLORGREEN);
PARTLINE(CLOSE>0,EMA(B05,3),COLORGREEN);
PARTLINE(CLOSE>0,EMA(B06,3),COLORGREEN);
PARTLINE(CLOSE>0,EMA(B07,3),COLORGREEN);
PARTLINE(CLOSE>0,EMA(((((MA9 + MA10) + MA11) + MA12) / 4),3),COLORBLUE);
PARTLINE(CLOSE>0,EMA(B09,3),COLORBLUE);
PARTLINE(CLOSE>0,EMA(B10,3),COLORBLUE);
PARTLINE(CLOSE>0,EMA(B11,3),COLORBLUE);
PARTLINE(CLOSE>0,EMA(((((MA13 + MA14) + MA15) + MA16) / 4),3),COLORMAGENTA);
PARTLINE(CLOSE>0,EMA(B13,3),COLORMAGENTA);
PARTLINE(CLOSE>0,EMA(B14,3),COLORMAGENTA);
PARTLINE(CLOSE>0,EMA(B15,3),COLORMAGENTA);


 

拾金图源码
自定义n:10,n1:15)
STICKLINE((EMA(CLOSE,13) >= EMA(CLOSE,34)),LOW,HIGH,COLORRED,0);
STICKLINE((EMA(CLOSE,13) >= EMA(CLOSE,34)),OPEN,CLOSE,COLORRED,0);
STICKLINE((EMA(CLOSE,13) < EMA(CLOSE,34)),LOW,HIGH,COLORGREEN,0);
STICKLINE((EMA(CLOSE,13) < EMA(CLOSE,34)),OPEN,CLOSE,COLORGREEN,0);
LL1:=EMA(CLOSE,N);
HH1:=EMA(CLOSE,N1);
T:=IFELSE(HH1>LL1,1,-1);
G:=IFELSE(HH1>LL1,HH1,LL1);
DRAWLINE(T=1&&REF(T,1)=1,G,T=1&&REF(T,1)=1,REF(G,1),COLORGREEN);
DRAWLINE(T=-1&&REF(T,1)=-1,G,T=-1&&REF(T,1)=-1,REF(G,1),COLORRED);
DRAWSL(T=1,G,0,1,0,COLORGREEN);
DRAWSL(T=-1,G,0,1,0,COLORRED);
DRAWTEXT(CROSS(EMA(CLOSE,34),EMA(CLOSE,13)),HIGH,'S');
DRAWTEXT(CROSS(EMA(CLOSE,13),EMA(CLOSE,34)),LOW,'B');
DRAWNUMBER(CROSS(EMA(CLOSE,34),EMA(CLOSE,13)),LOW,CLOSE,0,COLORGREEN);
DRAWNUMBER(CROSS(EMA(CLOSE,13),EMA(CLOSE,34)),HIGH,CLOSE,0,COLORRED);
 

十线开花源码
MA3:MA(CLOSE,5),COLORRED;
MA4:MA(CLOSE,6),COLORRED;
MA5:MA(CLOSE,7),COLORRED;
MA6:MA(CLOSE,8),COLORRED;
MA7:MA(CLOSE,9),COLORRED;
MA8:MA(CLOSE,10),COLORRED;
MA9:MA(CLOSE,11),COLORRED;
MA10:MA(CLOSE,12),COLORRED;
MA11:MA(CLOSE,13),COLORRED;
MA12:MA(CLOSE,14),COLORRED;
MA13:MA(CLOSE,15),COLORRED;
MA14:MA(CLOSE,N),COLORGREEN;
W: IFELSE(MA14>MA3,MA3,MA14),COLORYELLOW;
W1: IFELSE(MA14>MA4,MA4,MA14),COLORYELLOW;
W2: IFELSE(MA14>MA5,MA5,MA14),COLORYELLOW;
W3: IFELSE(MA14>MA6,MA6,MA14),COLORYELLOW;
W4: IFELSE(MA14>MA7,MA7,MA14),COLORYELLOW;
W5: IFELSE(MA14>MA8,MA8,MA14),COLORYELLOW;
W6: IFELSE(MA14>MA9,MA9,MA14),COLORYELLOW;
W7: IFELSE(MA14>MA10,MA10,MA14),COLORYELLOW;
W8: IFELSE(MA14>MA11,MA11,MA14),COLORYELLOW;
W9: IFELSE(MA14>MA12,MA12,MA14),COLORYELLOW;
W10: IFELSE(MA14>MA13,MA13,MA14),COLORYELLOW;用眼6
RSV:=((HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13)))*(100);
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,5,1);
DRAWLINE((LWR1>=LWR2),HIGH,(LWR1>=LWR2),LOW,COLORBLUE);
STICKLINE((LWR1>=LWR2),OPEN,CLOSE,COLORBLUE,0);
DRAWLINE((LWR1
STICKLINE((LWR1

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章 更多
    喜欢该文的人也喜欢 更多